Subject: [lp-wan] Options to progress SCHC/Sigfox and new Compound ACK concept

From: Juan Carlos Zuniga <[email-masked]>
Date: Tue, 15 Jun 2021 15:09:01 +0000

Hi all,

As discussed over the LPWAN interim meeting, we have a few options to progress the documents:

  1.  Include in the SCHC/Sigfox draft [1] a Yang Data Model extension of [2] to define the new SCHC Compound ACK as a Fragmentation parameter
  2.  Split the SCHC/Sigfox draft [1] in the following way:
     *   Write a new draft to define the SCHC Compound ACK and the associated extensions to the Data Model
     *   Standalone SCHC/Sigfox profile
  3.  Extend the existing Yang Data Model draft [2] to include the SCHC Compound ACK as a Fragmentation parameter

[1] https://datatracker.ietf.org/doc/html/draft-ietf-lpwan-schc-over-sigfox-06
[2] https://datatracker.ietf.org/doc/html/draft-ietf-lpwan-schc-yang-data-model-04

Please reply if you have any views.

Best,

Juan Carlos

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 16 Jun 2021 12:43:36 +0000

Many thanks Juan Carlos:

I believe now is a good time to experiment with SCHC extension. This pleads for 1 or 2.

I remember the discussion with Suresh who was AD at the time. I wanted 2 RFCs for SCHC fragmentation and SCHC compression. But that doubled the work at IESG and Suresh preferred we do one draft, which became RFC 8724.

Same here; since you are proposing a mechanism that appears valuable beyond your technology I'd rather you do 2) and we progress the 2 RFCs together. But it might be that this does not help Eric down the road.

Keep safe;

Pascal

From: lp-wan <[email-masked]> On Behalf Of Juan Carlos Zuniga
Sent: mardi 15 juin 2021 17:09
To: [email-masked]
Subject: [lp-wan] Options to progress SCHC/Sigfox and new Compound ACK concept

Hi all,

  1.  Extend the existing Yang Data Model draft [2] to include the SCHC Compound ACK as a Fragmentation parameter

Best,

Juan Carlos

---

From: Sandra Céspedes <[email-masked]>
Date: Thu, 17 Jun 2021 19:21:28 -0400

Hi all,

I support option 2. This will help if other technologies also want to adopt
the compound ACK, provided that the new draft uses a generic definition.

Best,
Sandra

*Aclaración:* Debido al trabajo remoto durante la pandemia de COVID-19,
este correo puede llegar fuera del horario normal de oficina. A pesar de
que el horario de envío me acomoda, no implica que esté esperando respuesta
alguna en horario fuera de oficina.
*Disclaimer:* Emailing you now suits me due to remote working during the
COVID-19 pandemic, so if this email arrives outside office hours, please do
not feel you have to reply until regular working hours.

On Tue, Jun 15, 2021 at 11:09 AM Juan Carlos Zuniga <
[email-masked]> wrote:

>    1. Include in the SCHC/Sigfox draft [1] a Yang Data Model extension of
>    [2] to define the new SCHC Compound ACK as a Fragmentation parameter
>       1. Write a new draft to define the SCHC Compound ACK and the
>       associated extensions to the Data Model
>       2. Standalone SCHC/Sigfox profile
>    3. Extend the existing Yang Data Model draft [2] to include the SCHC
>    Compound ACK as a Fragmentation parameter
>
>
>
> [1]
> https://datatracker.ietf.org/doc/html/draft-ietf-lpwan-schc-over-sigfox-06
>
> [2]
> https://datatracker.ietf.org/doc/html/draft-ietf-lpwan-schc-yang-data-model-04
>
>
>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>

---

From: Alexander Pelov <[email-masked]>
Date: Fri, 18 Jun 2021 10:22:46 +0200

Dear Juan Carlos,

Thanks for the proposal and for initiating the discussion on the mailing
list.

Option 3 is the one I like the least, for several reasons:
a) it may require having a normative reference from the Generic Data Model
to the technology-specific Sigfox RFC-to-be.
b) it is undefined how that would work on technology other than Sigfox (as
of today)

Both points could be solved, but the solutions seem to me to fall in your
options 1 and 2.

Therefore, I'd go with either 1 or 2.
Option 1 is the easiest for you and most straightforward.
Option 2 would require additional work so as to make it more generic.

*So, to sum up, I'm for Option 1 or Option 2.*
I would love to see Option 2, but this one requires more work and possibly
involvement from people from other technologies - which still remains to be
confirmed. If not, Option 1 seems the most straightforward.

Cheers,
Alexander

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 18 Jun 2021 13:26:24 +0200

On 2021-06-18, at 10:22, Alexander Pelov <[email-masked]> wrote:
> 
> I would love to see Option 2, but this one requires more work and possibly involvement from people from other technologies - which still remains to be confirmed. If not, Option 1 seems the most straightforward.

Option 1 and option 2 are somewhat equivalent, except that option 1 sets us up for a future where each technology mapping spec sets up its own tweaks to the base standard, which as a result turns from a base rock to a quarry (I’m slightly, but only slightly, exaggerating here).
So I’d indeed favor option 2.  A lot.

Grüße, Carsten

---

From: "Diego S. Wistuba La Torre" <[email-masked]>
Date: Fri, 18 Jun 2021 13:16:51 -0400

Hi all. I also favor option 2 as it allows the SCHC Compound ACK to be 
defined generally with no constraints to any SCHC Profile (and cleaner 
referencing to the document that defines it too). Then it should be 
extended and adapted to Profiles that want to implement it using their 
own parameters and algorithms.

Best,

/

*Diego S. Wistuba La Torre*

/
El 15-06-2021 a las 11:09, Juan Carlos Zuniga escribió:
>  1. Include in the SCHC/Sigfox draft [1] a Yang Data Model extension
>     of [2] to define the new SCHC Compound ACK as a Fragmentation
>     parameter
> <https://datatracker.ietf.org/doc/html/draft-ietf-lpwan-schc-over-sigfox-06>
>
> [2] 
> <https://datatracker.ietf.org/doc/html/draft-ietf-lpwan-schc-yang-data-model-04>
>

---

From: <[email-masked]>
Date: Sat, 19 Jun 2021 06:27:09 +0000

+1 for Option 2.
This is the cleanest way in the long run.
Best regards,

Dominique

From: lp-wan [mailto:[email-masked]] On Behalf Of Diego S. Wistuba La Torre
Sent: vendredi 18 juin 2021 19:17
To: [email-masked]
Subject: Re: [lp-wan] Options to progress SCHC/Sigfox and new Compound ACK concept

Hi all. I also favor option 2 as it allows the SCHC Compound ACK to be defined generally with no constraints to any SCHC Profile (and cleaner referencing to the document that defines it too). Then it should be extended and adapted to Profiles that want to implement it using their own parameters and algorithms.

Best,

Diego S. Wistuba La Torre
El 15-06-2021 a las 11:09, Juan Carlos Zuniga escribió:
Hi all,

Best,

Juan Carlos

lp-wan mailing list

[email-masked]<mailto:[email-masked]>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Sat, 19 Jun 2021 12:10:51 +0200

Hi everyone,

+1 (for Option 2) as well.

The Compound ACK extends the functionality defined in RFC 8724, and it may
be beneficial for several technologies. Therefore, it would be cleaner to
specify it in a generic, technology-independent way.

Cheers,

Carles

> extended and adapted to Profiles that want to implement it using their own
> parameters and algorithms.
>
> Best,
>
>   1.  Extend the existing Yang Data Model draft [2] to include the SCHC

---

From: Ana Minaburo <[email-masked]>
Date: Tue, 22 Jun 2021 09:56:32 +0200

Dear all,

+1 for Option 2.

Ana

On Sat, Jun 19, 2021 at 12:11 PM Carles Gomez Montenegro <
[email-masked]> wrote:

> > Subject: Re: [lp-wan] Options to progress SCHC/Sigfox and new Compound
> ACK
> > concept
> >
> >

---

From: Sergio Aguilar Romero <[email-masked]>
Date: Tue, 22 Jun 2021 10:33:56 +0200

Hello everyone,

+1 for Options 2.

The RFC8724 defines the generic SCHC messages, hence a new draft may define the generic Compound ACK and data model, and then, each profile can define the specific requirements (e.g., if mandatory or not, if some ruleIDs are used for compound ACK, how it is different from the receiver abort, examples, etc). Other new functionalities may have the same path, generic specification with its data model, and implementation specifics in each profile.

Cheers,

Sergio

> On Jun 22, 2021, at 9:56 AM, Ana Minaburo <[email-masked]> wrote:
> 
> Dear all,
> 
> +1 for Option 2.
> 
> Ana
> 
> On Sat, Jun 19, 2021 at 12:11 PM Carles Gomez Montenegro <[email-masked] <mailto:[email-masked]>> wrote:
> Hi everyone,
> 
> > From: lp-wan [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Diego S.
> > Wistuba La Torre
> > To: [email-masked] <mailto:[email-masked]>
> > https://datatracker.ietf.org/doc/html/draft-ietf-lpwan-schc-over-sigfox-06 <https://datatracker.ietf.org/doc/html/draft-ietf-lpwan-schc-over-sigfox-06>
> > [2]
> > https://datatracker.ietf.org/doc/html/draft-ietf-lpwan-schc-yang-data-model-04 <https://datatracker.ietf.org/doc/html/draft-ietf-lpwan-schc-yang-data-model-04>
> >
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Tue, 22 Jun 2021 04:48:50 -0400

Dear all,
             While I am for keeping a single draft per technology, I think
this time is worth the exception. +1 for option 2.
Regards,

    Diego

El mar., 22 de junio de 2021 04:34, Sergio Aguilar Romero <
[email-masked]> escribió:

> Hello everyone,
>
> +1 for Options 2.
>
> The RFC8724 defines the generic SCHC messages, hence a new draft may
> define the generic Compound ACK and data model, and then, each profile can
> define the specific requirements (e.g., if mandatory or not, if some
> ruleIDs are used for compound ACK, how it is different from the receiver
> abort, examples, etc). Other new functionalities may have the same path,
> generic specification with its data model, and implementation specifics in
> each profile.
>
> Cheers,
>
> Sergio
>
>
>> of