Subject: [lp-wan] RFC 8824 on Static Context Header Compression (SCHC) for the Constrained Application Protocol (CoAP)

From: [email-masked]
Date: Tue, 29 Jun 2021 23:23:47 -0700 (PDT)

A new Request for Comments is now available in online RFC libraries.

        RFC 8824

        Title:      Static Context Header Compression (SCHC) 
                    for the Constrained Application Protocol (CoAP) 
        Author:     A. Minaburo,
                    L. Toutain,
                    R. Andreasen
        Status:     Standards Track
        Stream:     IETF
        Date:       June 2021
        Mailbox:    [email-masked],
                    [email-masked],
                    [email-masked]
        Pages:      30
        Updates/Obsoletes/SeeAlso:   None

        I-D Tag:    draft-ietf-lpwan-coap-static-context-hc-19.txt

        URL:        https://www.rfc-editor.org/info/rfc8824

        DOI:        10.17487/RFC8824

This document defines how to compress Constrained Application
Protocol (CoAP) headers using the Static Context Header Compression
and fragmentation (SCHC) framework. SCHC defines a header compression
mechanism adapted for Constrained Devices. SCHC uses a static
description of the header to reduce the header's redundancy and size.
While RFC 8724 describes the SCHC compression and fragmentation
framework, and its application for IPv6/UDP headers, this document
applies SCHC to CoAP headers. The CoAP header structure differs from
IPv6 and UDP, since CoAP uses a flexible header with a variable
number of options, themselves of variable length. The CoAP message
format is asymmetric: the request messages have a header format
different from the format in the response messages. This
specification gives guidance on applying SCHC to flexible headers and
how to leverage the asymmetry for more efficient compression Rules.

This document is a product of the IPv6 over Low Power Wide-Area Networks Working Group of the IETF.

This is now a Proposed Standard.

STANDARDS TRACK: This document specifies an Internet Standards Track
protocol for the Internet community, and requests discussion and suggestions
for improvements.  Please refer to the current edition of the Official
Internet Protocol Standards (https://www.rfc-editor.org/standards) for the 
standardization state and status of this protocol.  Distribution of this 
memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  https://www.ietf.org/mailman/listinfo/ietf-announce
  https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist

For searching the RFC series, see https://www.rfc-editor.org/search
For downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk

Requests for special distribution should be addressed to either the
author of the RFC in question, or to [email-masked].  Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.

The RFC Editor Team
Association Management Solutions, LLC

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 30 Jun 2021 07:29:07 +0000

Congrats to the team and the whole group!

Now we have a whole stack for a node at least for one technology, more techs to follow soon with SigFox and NB IOT.

Next steps are the architecture and the data model, so we can deploy the infrastructure more automatically and scale to tons of various devices.

Keep the good time rollin'!

The chairs

-----Original Message-----
From: lp-wan <[email-masked]> On Behalf Of [email-masked]
Sent: mercredi 30 juin 2021 8:24
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [lp-wan] RFC 8824 on Static Context Header Compression (SCHC) for the Constrained Application Protocol (CoAP)

        RFC 8824

        DOI:        10.17487/RFC8824

This document defines how to compress Constrained Application Protocol (CoAP) headers using the Static Context Header Compression and fragmentation (SCHC) framework. SCHC defines a header compression mechanism adapted for Constrained Devices. SCHC uses a static description of the header to reduce the header's redundancy and size.
While RFC 8724 describes the SCHC compression and fragmentation framework, and its application for IPv6/UDP headers, this document applies SCHC to CoAP headers. The CoAP header structure differs from
IPv6 and UDP, since CoAP uses a flexible header with a variable number of options, themselves of variable length. The CoAP message format is asymmetric: the request messages have a header format different from the format in the response messages. This specification gives guidance on applying SCHC to flexible headers and how to leverage the asymmetry for more efficient compression Rules.

STANDARDS TRACK: This document specifies an Internet Standards Track protocol for the Internet community, and requests discussion and suggestions for improvements.  Please refer to the current edition of the Official Internet Protocol Standards (https://www.rfc-editor.org/standards) for the standardization state and status of this protocol.  Distribution of this memo is unlimited.

For searching the RFC series, see https://www.rfc-editor.org/search For downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk

Requests for special distribution should be addressed to either the author of the RFC in question, or to [email-masked].  Unless specifically noted otherwise on the RFC itself, all RFCs are for unlimited distribution.

The RFC Editor Team

_______________________________________________
lp-wan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: <[email-masked]>
Date: Wed, 30 Jun 2021 07:34:24 +0000

Congrats and thanks to all involved, indeed.
We're moving on!

Dominique

-----Original Message-----
From: lp-wan [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: mercredi 30 juin 2021 09:29
To: [email-masked]
Subject: [lp-wan] FW: RFC 8824 on Static Context Header Compression (SCHC) for the Constrained Application Protocol (CoAP)

The chairs

-----Original Message-----
From: lp-wan <[email-masked]> On Behalf Of [email-masked]
Sent: mercredi 30 juin 2021 8:24
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [lp-wan] RFC 8824 on Static Context Header Compression (SCHC) for the Constrained Application Protocol (CoAP)

        RFC 8824

        DOI:        10.17487/RFC8824

The RFC Editor Team

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Alexander Pelov <[email-masked]>
Date: Wed, 30 Jun 2021 16:17:53 +0200

Congratulations to the authors, everyone that contributed and the whole
working group!

Cheers,
Alexander

On Wed, Jun 30, 2021 at 9:34 AM <[email-masked]> wrote:

> Subject: [lp-wan] FW: RFC 8824 on Static Context Header Compression (SCHC)
> Now we have a whole stack for a node at least for one technology, more
> techs to follow soon with SigFox and NB IOT.
>
> Next steps are the architecture and the data model, so we can deploy the
> infrastructure more automatically and scale to tons of various devices.
>
> Subject: [lp-wan] RFC 8824 on Static Context Header Compression (SCHC) for
> the Constrained Application Protocol (CoAP)
>
> This document defines how to compress Constrained Application Protocol
> (CoAP) headers using the Static Context Header Compression and
> fragmentation (SCHC) framework. SCHC defines a header compression mechanism
> adapted for Constrained Devices. SCHC uses a static description of the
> header to reduce the header's redundancy and size.
> While RFC 8724 describes the SCHC compression and fragmentation framework,
> and its application for IPv6/UDP headers, this document applies SCHC to
> CoAP headers. The CoAP header structure differs from
> IPv6 and UDP, since CoAP uses a flexible header with a variable number of
> options, themselves of variable length. The CoAP message format is
> asymmetric: the request messages have a header format different from the
> format in the response messages. This specification gives guidance on
> applying SCHC to flexible headers and how to leverage the asymmetry for
> more efficient compression Rules.
>
> protocol for the Internet community, and requests discussion and
> suggestions for improvements.  Please refer to the current edition of the
> Official Internet Protocol Standards (https://www.rfc-editor.org/standards)
> for the standardization state and status of this protocol.  Distribution of
> this memo is unlimited.
>
> For searching the RFC series, see https://www.rfc-editor.org/search For
> downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk
>
> Requests for special distribution should be addressed to either the author
> of the RFC in question, or to [email-masked].  Unless
> specifically noted otherwise on the RFC itself, all RFCs are for unlimited
> distribution.
>
>
> The RFC Editor Team
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;