Subject: [lp-wan] augment coupond-ack

From: Laurent Toutain <[email-masked]>
Date: Mon, 15 Nov 2021 08:50:35 +0100

Dear lpwaners,

During the last IETF meeting, it was asked to detach the compound-ack from
the RFC8724 model. I see to ways of doing it.

1) ignore completely the compound-ack from the RFC8724 data model and
augment this model such as:

augment
"/schc:schc/schc:rule/schc:nature/schc:fragmentation/schc:mode/schc:ack-on-error"
{
leaf bitmap-format {
type compound-ack:bitmap-format-type;
when "derived-from(../schc:fragmentation-mode,
'schc:fragmentation-mode-ack-on-error')";
default "compound-ack:bitmap-RFC8724";
description
"How the bitmaps are included in the Ack message.";
}
}

Where we create the leaf and a specific identityref for compound-ack.

2) create the leaf in RFC8724 datamodel but just a default value and just
define the compound ack value in the compound ack model.

Personally, I prefer the first approach, since we cannot guess all the time
what will be extended, but I would like to have your point of view on the
subject.

Laurent

---

From: Alexander Pelov <[email-masked]>
Date: Mon, 15 Nov 2021 09:08:02 +0100

Dear Laurent,

Thanks for getting the ball rolling on this one so quickly after the IETF!

On 1) - when you say "ignore the compound-ack from RFC8724" - there is no
compound-ack in RFC8724.
Do you mean this to be - keep the Yang Data Model aligned with RFC8724 and
not include compound-ack in it?

(and thus -> define an extension in the SCHC-Compound-Ack draft ?)

Cheers,
Alex

On Mon, Nov 15, 2021 at 8:51 AM Laurent Toutain <
[email-masked]> wrote:

> Personally, I prefer the first approach, since we cannot guess all the
> time what will be extended, but I would like to have your point of view on
> the subject.
>
> Laurent
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>

---

From: Laurent Toutain <[email-masked]>
Date: Mon, 15 Nov 2021 09:29:46 +0100

yes

On Mon, Nov 15, 2021 at 9:08 AM Alexander Pelov <[email-masked]> wrote:

>> During the last IETF meeting, it was asked to detach the compound-ack
>> from the RFC8724 model. I see to ways of doing it.
>>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 15 Nov 2021 08:32:08 +0000

And without any hat except some familiarity with YANG, I also support the approach of having the data model pristine and let the YANG augmentation in the compound-ack I-D

-éric

From: lp-wan <[email-masked]> on behalf of Laurent Toutain <[email-masked]>
Date: Monday, 15 November 2021 at 09:30
To: Alexander Pelov <[email-masked]>
Cc: lp-wan <[email-masked]>
Subject: Re: [lp-wan] augment coupond-ack

yes

On Mon, Nov 15, 2021 at 9:08 AM Alexander Pelov <[email-masked]<mailto:[email-masked]>> wrote:
Dear Laurent,

On 1) - when you say "ignore the compound-ack from RFC8724" - there is no compound-ack in RFC8724.
Do you mean this to be - keep the Yang Data Model aligned with RFC8724 and not include compound-ack in it?

Cheers,
Alex

On Mon, Nov 15, 2021 at 8:51 AM Laurent Toutain <[email-masked]<mailto:[email-masked]>> wrote:
Dear lpwaners,

During the last IETF meeting, it was asked to detach the compound-ack from the RFC8724 model. I see to ways of doing it.

1) ignore completely the compound-ack from the RFC8724 data model and augment this model such as:

augment "/schc:schc/schc:rule/schc:nature/schc:fragmentation/schc:mode/schc:ack-on-error" {
leaf bitmap-format {
type compound-ack:bitmap-format-type;
when "derived-from(../schc:fragmentation-mode, 'schc:fragmentation-mode-ack-on-error')";
default "compound-ack:bitmap-RFC8724";
description
"How the bitmaps are included in the Ack message.";
}
}

2) create the leaf in RFC8724 datamodel but just a default value and just define the compound ack value in the compound ack model.

Personally, I prefer the first approach, since we cannot guess all the time what will be extended, but I would like to have your point of view on the subject.

Laurent
_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Alexander Pelov <[email-masked]>
Date: Mon, 15 Nov 2021 09:45:53 +0100

Thanks for the clarification,  Laurent !

(chair hat off)

+1 on Eric's position - option 1)

Cheers,
Alex

Le lun. 15 nov. 2021 à 09:32, Eric Vyncke (evyncke) <[email-masked]> a
écrit :

> And without any hat except some familiarity with YANG, I also support the
> approach of having the data model pristine and let the YANG augmentation in
> the compound-ack I-D
>
>
>
> -éric
>
>
>
> *From: *lp-wan <[email-masked]> on behalf of Laurent Toutain <
> [email-masked]>
> *Date: *Monday, 15 November 2021 at 09:30
> *To: *Alexander Pelov <[email-masked]>
> *Cc: *lp-wan <[email-masked]>
> *Subject: *Re: [lp-wan] augment coupond-ack
>
>
>
> yes
>
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 15 Nov 2021 09:55:43 +0000

Same here, that was in the intention.

From: lp-wan <[email-masked]> On Behalf Of Eric Vyncke (evyncke)
Sent: lundi 15 novembre 2021 9:32
To: Laurent Toutain <[email-masked]>; Alexander Pelov <[email-masked]>
Cc: lp-wan <[email-masked]>
Subject: Re: [lp-wan] augment coupond-ack

-éric

From: lp-wan <[email-masked]<mailto:[email-masked]>> on behalf of Laurent Toutain <[email-masked]<mailto:[email-masked]>>
Date: Monday, 15 November 2021 at 09:30
To: Alexander Pelov <[email-masked]<mailto:[email-masked]>>
Cc: lp-wan <[email-masked]<mailto:[email-masked]>>
Subject: Re: [lp-wan] augment coupond-ack

yes

Cheers,
Alex

Laurent

---

From: Laurent Toutain <[email-masked]>
Date: Tue, 16 Nov 2021 09:25:59 +0100

Perfect,

I will also move what is OAM related to a new module.
To avoid a risk of dispersion, may I suggest that the architecture document
lists the yang module related to SCHC?

Laurent

On Mon, Nov 15, 2021 at 10:56 AM Pascal Thubert (pthubert) <
[email-masked]> wrote:

> *From:* lp-wan <[email-masked]> *On Behalf Of *Eric Vyncke
> (evyncke)
> *Sent:* lundi 15 novembre 2021 9:32
> *To:* Laurent Toutain <[email-masked]>; Alexander
> Pelov <[email-masked]>
> *Cc:* lp-wan <[email-masked]>
> *Subject:* Re: [lp-wan] augment coupond-ack
>
>
>