Subject: Re: [lp-wan] I-D Action: draft-ietf-lpwan-architecture-01.txt

From: Olivier Gimenez <[email-masked]>
Date: Tue, 7 Dec 2021 12:16:54 +0000

Pascal, All

I wonder if the chapter "7.1. Device Development" should be in this architecture document, in its own document, or even an RFC8724 extension.
I might have misunderstood (and in this case my comment is irrelevant) but I thought that "lpwan-architecture" is a high level introduction of SCHC applied to lpwan for people to understand the main concepts, and not in-depth explanation of the possible solutions to manage the rules, which also create new requirements "like Each rule set should have its own Uniform Resource Names (URN) {{!RFC8141}} and a version."

Best regards
Olivier

-----Original Message-----
From: lp-wan <[email-masked]> On Behalf Of [email-masked]
Sent: 26 November 2021 17:12
To: [email-masked]
Cc: [email-masked]
Subject: [lp-wan] I-D Action: draft-ietf-lpwan-architecture-01.txt

Warning - External Email
________________________________

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 over Low Power Wide-Area Networks WG of the IETF.

        Title           : LPWAN Static Context Header Compression (SCHC) Architecture
        Authors         : Alexander Pelov
                          Pascal Thubert
                          Ana Minaburo
        Filename        : draft-ietf-lpwan-architecture-01.txt
        Pages           : 13
        Date            : 2021-11-26

To view our privacy policy, including the types of personal information we collect, process and share, and the rights and options you have in this respect, see www.semtech.com/legal.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 7 Dec 2021 12:51:02 +0000

Hello Olivier

The section is about the device lifecycle and creates a chain of causes and consequences that start at the device inception. It is not saying how you should code. It is presenting steps that are needed at the dev stage so the outcome is present at the next stage.

And yes, the rule management is the architecture around the data model. We produce a data model without saying how it is used in real life; What is obvious for big iron is a lot less for LPWAN devices.

Note that the requirement is a should lowercase. If the lifecycle of your devices is specified by an alliance, the alliance supersedes the architecture.

Let's talk at the WG interim today...

BTW thanks for your inline comments in the md doc, I applied what I could on the spot. If I missed stuff, please raise it at the interim as well. 

Keep safe

Pascal

> From: lp-wan <[email-masked]> On Behalf Of Olivier Gimenez
> Sent: mardi 7 décembre 2021 13:17
> To: [email-masked]; [email-masked]
> Subject: Re: [lp-wan] I-D Action: draft-ietf-lpwan-architecture-01.txt
> 
> Pascal, All
> 
> I wonder if the chapter "7.1. Device Development" should be in this
> architecture document, in its own document, or even an RFC8724 extension.
> I might have misunderstood (and in this case my comment is irrelevant) but
> I thought that "lpwan-architecture" is a high level introduction of SCHC
> applied to lpwan for people to understand the main concepts, and not in-
> depth explanation of the possible solutions to manage the rules, which
> also create new requirements "like Each rule set should have its own
> Uniform Resource Names (URN) {{!RFC8141}} and a version."
> 
> Best regards
> Olivier
> 
> To view our privacy policy, including the types of personal information we
> collect, process and share, and the rights and options you have in this
> respect, see www.semtech.com/legal.
> 
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan