Subject: [Lsr] Comments on draft-hu-lsr-isis-path-mtu

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 9 Jul 2018 04:52:00 +0000

(Changed the subject – was “RE: [Lsr] IETF 102 LSR Working Group Call for Agenda Items”)

Zhibo –

Following up on Acee’s comment…he is (of course) quite correct that there already is a per link MTU sub-TLV defined by RFC 7176 – it is sub-TLV 28 defined here: https://www.iana.org/assignments/isis-tlv-codepoints/isis-tlv-codepoints.xhtml#isis-tlv-codepoints-22-23-25-141-222-223

In reading your draft, it seems that what you want to advertise is a per link attribute – not a per node attribute – in which case the existing sub-TLV is a perfect fit.

Not at all clear why we would need a new TLV – nor how such a TLV would allow you to advertise a per-link attribute without repeating all of the context information (neighbor ID, link endpoint identifiers) already available in TLVs 22, etc.

Do you agree that IS-IS already has what is needed and therefore does not need any additional protocol extension?

   Les

From: Lsr <[email-masked]> On Behalf Of Acee Lindem (acee)
Sent: Friday, July 06, 2018 6:21 AM
To: Huzhibo <[email-masked]>; [email-masked]
Cc: Dailongfei (Larry, IP Research) <[email-masked]>; Lizhenbin <[email-masked]>; [email-masked]
Subject: Re: [Lsr] IETF 102 LSR Working Group Call for Agenda Items

Hi Zhibo,

I’m sorry but our agenda is already full for IETF 102. As LSR is one of the most popular WGs, you need to get your requests in early. With respect to this draft, there is already an IS-IS sub-TLV MTU advertisement defined in RFC 7176. While the RFC is specific to TRILL, I don’t see any reason why the sub-TLV couldn’t be used in non-TRILL deploymennts.

Thanks,
Acee

From: Huzhibo <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 6, 2018 at 3:08 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Robin Li <[email-masked]<mailto:[email-masked]>>, "Dailongfei (Larry, IP Research)" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Lsr] IETF 102 LSR Working Group Call for Agenda Items

Hi,

Request a slot to discuss ISIS extended for PathMTU:

Drafts:
https://datatracker.ietf.org/doc/draft-hu-lsr-isis-path-mtu/
Presenter: ZhiBo Hu

Duration: 10 mins

Thanks!
ZHiBo

From: Lsr [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Monday, June 18, 2018 9:45 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Lsr] IETF 102 LSR Working Group Call for Agenda Items

Hi Folks,

The LSR (link-state-routing) WG will be meeting on Monday, July 16, 2018 from 9:30 to 12:00 (the first WG slot of IETF 102).

Please send us ([email-masked]<mailto:[email-masked]>) any requests for presentation slots.

Thanks,
Acee

---

From: Huzhibo <[email-masked]>
Date: Mon, 9 Jul 2018 06:11:05 +0000

Hi Les & Acee:
Yes, I agree with you, we will merge ISIS & OSPF extensions for Path MTU, and isis will reference RFC 7176.

Ths
ZhiBo Hu

From: Les Ginsberg (ginsberg) [mailto:[email-masked]]
Sent: Monday, July 09, 2018 12:52 PM
To: Acee Lindem (acee) <acee=[email-masked]>; Huzhibo <[email-masked]>; [email-masked]
Cc: Dailongfei (Larry, IP Research) <[email-masked]>; Lizhenbin <[email-masked]>; [email-masked]
Subject: Comments on draft-hu-lsr-isis-path-mtu

Zhibo –

   Les

From: Lsr <[email-masked]<mailto:[email-masked]>> On Behalf Of Acee Lindem (acee)
Sent: Friday, July 06, 2018 6:21 AM
To: Huzhibo <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Dailongfei (Larry, IP Research) <[email-masked]<mailto:[email-masked]>>; Lizhenbin <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Lsr] IETF 102 LSR Working Group Call for Agenda Items

Hi Zhibo,

Thanks,
Acee

Hi,

Drafts:

Duration: 10 mins

Thanks!
ZHiBo

Hi Folks,

Thanks,
Acee