Subject: Re: [Lsr] LSR Flooding Reduction Drafts - Moving Forward

From: Huaimo Chen <[email-masked]>
Date: Tue, 4 Sep 2018 13:49:49 +0000

Hi John,

> I have reviewed both of the flood reduction drafts and the draft referenced below, draft-cc-ospf-flooding-reduction-02, seems to me to be a derivative document inferior in >quality to the draft, draft-li-dynamic-flooding-05, from which it is derived.  For example, the referenced draft fails to include a description of the message used to deliver the >flooding topology when using centralized mode, it neglects to include any analysis of error conditions, and it neglects to include any description of the interactions with down->level nodes.
It seems that your word “derivative” is not correct. Our draft originally focuses on distributed solution, Tony’s on centralized one. It is not reasonable to say that a distributed solution is a derivative from a centralized one.
Regarding to missing message for centralized mode in our draft as you mentioned, it is for new ones to be added. We will fill this gap.
Regarding to missing analysis of error conditions, we will consider and add it.
Regarding to interactions with down-level nodes, can you give more details?

>Yours Irrespectively,
>John

From: Lsr <[email-masked]<mailto:[email-masked]>> On Behalf Of Huaimo Chen
Sent: Thursday, August 30, 2018 11:01 AM
To: Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Acee Lindem (acee) <acee=[email-masked]<mailto:acee=[email-masked]>>; [email-masked]<mailto:[email-masked]>; Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; Tony Przygienda <[email-masked]<mailto:[email-masked]>>; Peter Psenak <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] LSR Flooding Reduction Drafts - Moving Forward

Hi Robert,

>> draft-cc-ospf-flooding-reduction-02 allows operators to select distributed mode, centralized one or static one smoothly.
>Aside from static approach can you summarize in purely technical points advantages your draft proposes over draft-li-dynamic-flooding-05 ?
Initially, our draft focused on distributed solution for flooding reduction, and Tony’s on centralized way. This should be one advantage. Distributed solution is more practical.
In addition, we proposed the followings during the progress of our draft:

1)    A method to allow flooding topology to be lean and to allow multiple failures in an area;

2)    A procedure for establishing a new adjacency between a (new) node and  an existing node supporting flooding reduction;

3)    A way in which one touch (or command) to enable flooding reduction in a whole area within a short time;

4)    A way in which one touch (or command) to rollback flooding reduction to normal flooding in a whole area smoothly;

5)    A TLV for distributing the priority of a node to become a leader;

6)    Three algorithms for building a flooding topology.
Distributed solution for flooding reduction is stable after we resolve the issues raised by other experts during the last few IETFs.
BTW, as a service provider, which mode/solution (distributed or centralized) will you select to use in an operational network?

Best Regards,
Huaimo
>Many thx,
>R.

On Mon, Aug 27, 2018 at 6:41 PM, Huaimo Chen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Robert,

>Leader election happens automatically and procedures for that are to be vastly similar to today's DR or DIS election. So with this in mind one may observe that both OSPF and ISIS are pretty centralized on multiaccess networks today :)

Today’s DR or DIS election is local to a special interface/network such as a broadcast interface. Leader election in a network is global. Every node in the network depends on it (its flooding topology). These two seems different.

>Btw I don't think there is any problem here ... The text added to -05 version allows very seamless choice of centralized vs distributed topology computation by signalling either zero or non zero value in the added to version -05 area leader sub-tlv.
>
>In other words I don't see any problem or room for debate .. adopting and implementing -05 allows use of centralized or distributed optimal flooding computation at the operator's discretion.

draft-cc-ospf-flooding-reduction-02 allows operators to select distributed mode, centralized one or static one smoothly.

Best Regards,
Huaimo

From: Robert Raszuk [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, August 27, 2018 11:31 AM
To: Huaimo Chen <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; Acee Lindem (acee) <acee=[email-masked]<mailto:[email-masked]>>; Peter Psenak <[email-masked]<mailto:[email-masked]>>; Tony Przygienda <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] LSR Flooding Reduction Drafts - Moving Forward

Hi Huaimo,

> Introducing centralized feature into IGP will break IGP's distributed nature

That clearly proves that word "centralized" has been significantly overloaded here.  To many indeed "centralized" means a controller (like OpenFlow or SDN) and that such device added to a network is to push information - typically 1RU linux blade -  here optimized flooding graph. But this never was the plan with this proposal from its start ie. -00 version.

Centralized means that optimized flooding graph comes from single redundant node.

Leader election happens automatically and procedures for that are to be vastly similar to today's DR or DIS election. So with this in mind one may observe that both OSPF and ISIS are pretty centralized on multiaccess networks today :)

To your point of multi-vendor networks true - and that is precisely why upgrade network wide to a release containing consistent algorithm from more then a single vendor (and even for single vendor) is practically a very time consuming and difficult process.

Btw I don't think there is any problem here ... The text added to -05 version allows very seamless choice of centralized vs distributed topology computation by signalling either zero or non zero value in the added to version -05 area leader sub-tlv.

In other words I don't see any problem or room for debate .. adopting and implementing -05 allows use of centralized or distributed optimal flooding computation at the operator's discretion.

Thx,
R.

On Mon, Aug 27, 2018 at 5:10 PM, Huaimo Chen <[email-masked]<mailto:[email-masked]>> wrote:
>> I think distributed is more practical too.
>I would appreciate more detailed insights as to why you (and others) feel this way.  It is not at all obvious to me.
IGP is distributed in nature. The distributed computation of flooding topology like distributed SPF will keep IGP still distributed in nature. Introducing centralized feature into IGP will break IGP's distributed nature, which may cause some issues/problems.

>> For computing routes, we have been using distributed SPF on every node for many years.
>True, but that algorithm is (and was) very well known and a fixed algorithm that would clearly solve the problem at the time. If we were in a similar situation, where we were ready to set an algorithm in >concrete, I might well agree, but it’s quite clear that we are NOT at that point yet.  We will need to experiment and modify algorithms, and as discussed, that’s easier with a centralized approach.
After flooding reduction is deployed in an operational (ISP) network, will we be allowed to do experiments on their network?
After an algorithm is determined/selected, will it be changed to another algorithm in a short time?

>> In fact, we may not need to run the exact algorithm on every node. As long as the algorithms running on different nodes generate the same result, that would work.
>Insuring a globally consistent result without running the exact same algorithm on the exact same data will be quite a trick.  Debugging distributed problems at scale is already a hard problem.  Having >different algorithms in different locations would add another order of magnitude in difficulty.  No thank you.
In some existing networks, some nodes run IGPs from one vendor, some other nodes run IGPs from another vendor, and so on. Some may use normal SPF, some others may use incremental SPF. It seems that we have had these cases for many years.
>Tony

Best Regards,
Huaimo
_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_lsr&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=dQNetSHGAsFGcKk3dMxdWF6zY3NJc1cUOiTIkr-KOMA&s=aj_vuMJsmKUm-qly2FE2m_7WtK2ra7w4ftfPz37zXB8&e=>

---

From: John E Drake <[email-masked]>
Date: Tue, 4 Sep 2018 14:31:03 +0000

Hi,

Comments inline

Yours Irrespectively,

John

From: Huaimo Chen <[email-masked]>
Sent: Tuesday, September 4, 2018 9:50 AM
To: John E Drake <[email-masked]>; Robert Raszuk <[email-masked]>
Cc: [email-masked]; Acee Lindem (acee) <acee=[email-masked]>; [email-masked]; Jeff Tantsura <[email-masked]>; Tony Przygienda <[email-masked]>; Peter Psenak <[email-masked]>
Subject: RE: [Lsr] LSR Flooding Reduction Drafts - Moving Forward

Hi John,

[JD]  Both discuss centralized and distributed

[JD] Please see:   https://tools.ietf.org/html/draft-li-dynamic-flooding-05#section-5

[JD] Please see:   https://tools.ietf.org/html/draft-li-dynamic-flooding-05#section-4.6

[JD]  Please see:   https://tools.ietf.org/html/draft-li-dynamic-flooding-05#section-4, https://tools.ietf.org/html/draft-li-dynamic-flooding-05#section-4.1

Hi Robert,

Best Regards,
Huaimo

Best Regards,
Huaimo

Hi Huaimo,

Thx,
R.

Best Regards,
Huaimo

---

From: Huaimo Chen <[email-masked]>
Date: Tue, 4 Sep 2018 15:24:07 +0000

Hi John,

    See my comments inline below.

Best Regards,
Huaimo
From: Huaimo Chen <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, September 4, 2018 9:50 AM
To: John E Drake <[email-masked]<mailto:[email-masked]>>; Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Acee Lindem (acee) <acee=[email-masked]<mailto:acee=[email-masked]>>; [email-masked]<mailto:[email-masked]>; Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; Tony Przygienda <[email-masked]<mailto:[email-masked]>>; Peter Psenak <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Lsr] LSR Flooding Reduction Drafts - Moving Forward

Hi John,

[JD]  Both discuss centralized and distributed
[HC] Both drafts talk about both now. It is not reasonable to say one is a derivative of another.

[JD] Please see:   https://tools.ietf.org/html/draft-li-dynamic-flooding-05#section-4.6
[HC] For this, our draft talks about it. We will add more in details.

[JD]  Please see:   https://tools.ietf.org/html/draft-li-dynamic-flooding-05#section-4, https://tools.ietf.org/html/draft-li-dynamic-flooding-05#section-4.1
[HC] For this, our draft talks about it.

Hi Robert,

Best Regards,
Huaimo

Best Regards,
Huaimo

Hi Huaimo,

Thx,
R.

Best Regards,
Huaimo

---

From: John E Drake <[email-masked]>
Date: Tue, 4 Sep 2018 16:01:53 +0000

Hi,

I think we have circled back to the implicit point of my original email, viz, why do we need two drafts that solve the same problem in more or less the same way, especially given that one is much more robust and complete than the other?

Yours Irrespectively,

John

Sent: Tuesday, September 4, 2018 11:24 AM

Hi John,

Best Regards,
Huaimo

Hi John,

[JD] Please see:   https://tools.ietf.org/html/draft-li-dynamic-flooding-05#section-5<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dli-2Ddynamic-2Dflooding-2D05-23section-2D5&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=OtsOoYoplgrllQAM3IzPelpEFY22UOyVbTeCEZVKvfs&s=G1nxMx0mq-ML451DGEvEZ_QClKB6lWjXE6LJrkmxnds&e=>

[JD] Please see:   https://tools.ietf.org/html/draft-li-dynamic-flooding-05#section-4.6<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dli-2Ddynamic-2Dflooding-2D05-23section-2D4.6&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=OtsOoYoplgrllQAM3IzPelpEFY22UOyVbTeCEZVKvfs&s=BXGDgpp4d36n9mToUIVYpJ1jK70LFDdWv_G35532MtU&e=>
[HC] For this, our draft talks about it. We will add more in details.

[JD]  Please see:   https://tools.ietf.org/html/draft-li-dynamic-flooding-05#section-4<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dli-2Ddynamic-2Dflooding-2D05-23section-2D4&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=OtsOoYoplgrllQAM3IzPelpEFY22UOyVbTeCEZVKvfs&s=cQTQjUmBdJJJXLwNJuuICHOYwE09AmYdvM3tdz6JP5A&e=>, https://tools.ietf.org/html/draft-li-dynamic-flooding-05#section-4.1<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dli-2Ddynamic-2Dflooding-2D05-23section-2D4.1&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=OtsOoYoplgrllQAM3IzPelpEFY22UOyVbTeCEZVKvfs&s=7XTcJB8R7BWKwA6Gf9ZszZwlQUuVxDqnE-VkGBX2PPs&e=>
[HC] For this, our draft talks about it.

Hi Robert,

Best Regards,
Huaimo

Best Regards,
Huaimo

Hi Huaimo,

Thx,
R.

Best Regards,
Huaimo

---

From: Huaimo Chen <[email-masked]>
Date: Tue, 4 Sep 2018 16:30:13 +0000

Hi John,

    Two drafts are presented in just two IETFs. For centralized mode and distributed one, one very important part is the their efficiency. It is better to give some time for others to propose some new or more efficient solutions. If one solution (say A) is much more efficient than another one (say B), which one (A or B) will you select?

Best Regards,
Huaimo
From: John E Drake [mailto:[email-masked]]
Sent: Tuesday, September 4, 2018 12:02 PM
To: Huaimo Chen <[email-masked]>; Robert Raszuk <[email-masked]>
Cc: [email-masked]; Acee Lindem (acee) <acee=[email-masked]>; [email-masked]; Jeff Tantsura <[email-masked]>; Tony Przygienda <[email-masked]>; Peter Psenak <[email-masked]>
Subject: RE: [Lsr] LSR Flooding Reduction Drafts - Moving Forward

Hi,

Yours Irrespectively,

John

Hi John,

Best Regards,
Huaimo

Hi John,

Hi Robert,

Best Regards,
Huaimo

Best Regards,
Huaimo

Hi Huaimo,

Thx,
R.

Best Regards,
Huaimo

---

From: John E Drake <[email-masked]>
Date: Tue, 4 Sep 2018 17:42:13 +0000

There is no virtually no difference between the two drafts in the way that distributed mode works and your draft currently has no description of how centralized mode works.

Yours Irrespectively,

John

Sent: Tuesday, September 4, 2018 12:30 PM

Hi John,

Best Regards,
Huaimo
To: Huaimo Chen <[email-masked]<mailto:[email-masked]>>; Robert Raszuk <[email-masked]<mailto:[email-masked]>>

Hi,

Yours Irrespectively,

John

Hi John,

Best Regards,
Huaimo

Hi John,

Hi Robert,

Best Regards,
Huaimo

Best Regards,
Huaimo

Hi Huaimo,

Thx,
R.

Best Regards,
Huaimo

---

From: Christian Hopps <[email-masked]>
Date: Mon, 10 Sep 2018 20:39:15 -0400

> [HC] Both drafts talk about both now. It is not reasonable to say one is a derivative of another.

I think calling the OSPF draft a derivative of the other was probably counter-productive here, and if we consider the earlier publications, it is technically wrong. As originally presented each draft seemed to focus on one type of solution. It's important that people are given credit for work they have done and ideas they have had.

That said, it's also important to consider the quality of the work, and when the distributed OSPF solution was first presented there were some obvious problems with the algorithm that were raised in the room during the meeting by people after having just seen the work for the first time.

Now I'm assuming John arrived at his conclusion of one being a derivative of the other based on reading the drafts as they stand now. So while the conclusion may have been historically incorrect, it also may be indicative of which document is of higher quality and better suited for use by the WG going forward.

Thanks,
Chris.

Huaimo Chen <[email-masked]> writes:

> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr