Subject: [Lsr] [Technical Errata Reported] RFC2328 (5611)

From: RFC Errata System <[email-masked]>
Date: Tue, 22 Jan 2019 12:09:10 -0800 (PST)

The following errata report has been submitted for RFC2328,
"OSPF Version 2".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5611

--------------------------------------
Type: Technical
Reported by: Anil Chaitanya Mandru <[email-masked]>

Section: 16.1 (4)

Original Text
-------------
In this case, the current routing table entry
            should be overwritten if and only if the newly found path is
            just as short and the current routing table entry's Link
            State Origin has a smaller Link State ID than the newly
            added vertex' LSA.

Corrected Text
--------------
In this case, if the newly found path is just as short, 
then both the paths should be added to the routing table. 

Notes
-----
If the newly found path is just as short then both the paths should be considered for ECMP. Why should the smaller Link State ID path overwrite the current one even if the paths are equi distant?

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC2328 (no draft string recorded)
--------------------------------------
Title               : OSPF Version 2
Publication Date    : April 1998
Author(s)           : J. Moy
Category            : INTERNET STANDARD
Source              : Open Shortest Path First IGP
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 22 Jan 2019 20:50:01 +0000

Hi Anil, 
This is the case where the transit network vertex corresponding to a network-LSA is newly added to the current intra-area graph and an intra-area route corresponding to the SPF in progress already exists. This implies that there was another network-LSA. So, either the network corresponding to the subnet is partitioned or there is a network configuration error with the same subnet configured for multiple multi-access networks. In either case, I don't really see the benefit of an ECMP route. In fact, it could make trouble-shooting the problem more difficult. 

Hence, I would advise Alvaro, the responsible AD, to reject this Errata. 

Thanks,
Acee 

On 1/22/19, 3:09 PM, "RFC Errata System" <[email-masked]> wrote:

    
    
    Section: 16.1 (4)
    
    Original Text
    -------------
    
    Corrected Text
    --------------
    
    Notes
    -----
    
    Instructions:
    -------------

---

From: Alvaro Retana <[email-masked]>
Date: Mon, 28 Jan 2019 08:52:51 -0800

[Took the RFC Editor off..and removed Abhay’s e-mail as it is out of date.
I’m pretty sure John’s e-mail is also not accurate anymore, I moved that to
bcc…. In short, everyone interested should be in the lsr list. :-)]

Hi!

I am marking this report as Rejected…both because of Acee’s explanation,
but also because the intent of the system is to correct mistakes, not
change the specification.  In this case, the proposed text would result in
a modification of the process to calculate the routing table.  A change
like that should be discussed in the WG/mailing list instead.

Thanks!

Alvaro.

On January 22, 2019 at 3:50:04 PM, Acee Lindem (acee) ([email-masked])
wrote:

Hi Anil,
This is the case where the transit network vertex corresponding to a
network-LSA is newly added to the current intra-area graph and an
intra-area route corresponding to the SPF in progress already exists. This
implies that there was another network-LSA. So, either the network
corresponding to the subnet is partitioned or there is a network
configuration error with the same subnet configured for multiple
multi-access networks. In either case, I don't really see the benefit of an
ECMP route. In fact, it could make trouble-shooting the problem more
difficult.

Thanks,
Acee

On 1/22/19, 3:09 PM, "RFC Errata System" <[email-masked]>
wrote:

Section: 16.1 (4)

Original Text
-------------

Corrected Text
--------------

Notes
-----
If the newly found path is just as short then both the paths should be
considered for ECMP. Why should the smaller Link State ID path overwrite
the current one even if the paths are equi distant?

Instructions:
-------------