Subject: [Lsr] draft-bashandy-isis-srv6-extensions: Locator Leaking

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Thu, 17 Jan 2019 02:07:23 +0000

Hi Authors,

In chapter 6.1 of draft-bashandy-isis-srv6-extensions-04,  it mentions that Locator TLV can be leaked from level-2 to level-1.(See D bit)

I am wondering that
1: Does the Locator can be imported another protocol? Like OSPF?
2: Will SRv6 End SID sub-TLV be carried when the locator TLV is leaked from level-2 to Level-1?

Thanks,
Cheng

---

From: Peter Psenak <[email-masked]>
Date: Thu, 17 Jan 2019 08:26:08 +0100

Hi Cheng,

On 17/01/2019 03:07 , Chengli (Cheng Li) wrote:
> Hi Authors,
>
>
>
> In chapter 6.1 of draft-bashandy-isis-srv6-extensions-04,  it mentions
> that Locator TLV can be leaked from level-2 to level-1.(See D bit)
>
>
>
> I am wondering that
>

what do you mean by "imported"?

> 2: Will SRv6 End SID sub-TLV be carried when the locator TLV is leaked

yes.

thanks,
Peter

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Fri, 18 Jan 2019 03:53:26 +0000

Hi Peter,

Thanks to your reply. Please see my reply inline [Cheng].

Thanks,
Cheng

-----Original Message-----
From: Peter Psenak [mailto:[email-masked]] 
Sent: Thursday, January 17, 2019 3:26 PM
To: Chengli (Cheng Li) <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: draft-bashandy-isis-srv6-extensions: Locator Leaking

Hi Cheng,

On 17/01/2019 03:07 , Chengli (Cheng Li) wrote:
> 1: Can the Locator be imported from another protocol? Like OSPF?

[Cheng] For example, a locator A::/64 is learned via OSPF, can it be imported to IS-IS? Maybe it  is called "copy"? or "leak"? Not sure about the term.

yes.

[Cheng]If SRv6 End SID sub-TLVs are carried when the locator TLV is leaked  from level-2 to Level-1, does it mean  the locator TLV can not be summary? (Route aggregation)? 

thanks,
Peter

---

From: Peter Psenak <[email-masked]>
Date: Fri, 18 Jan 2019 09:47:17 +0100

Hi Cheng,

please see inline:

> [Cheng] For example, a locator A::/64 is learned via OSPF, can it be imported to IS-IS? Maybe it  is called "copy"? or "leak"? Not sure about the term.

it's called "redistribution". Sure, nobody stops you to redistribute 
locators between protocols. Please note that it is not something that is 
specified by the IETF, because it's an internal implementation detail. 
 From protocol perspective, there is nothing specific needed to support 
that.

> [Cheng]If SRv6 End SID sub-TLVs are carried when the locator TLV is leaked  from level-2 to Level-1, does it mean  the locator TLV can not be summary? (Route aggregation)?

When you leak the locator TLV, you leak it as it is, including END SIDs.

When you summarize multiple locators, you would advertise only the 
summary prefix - in IP reachability TLV I would think.

This is the same as with SR MPLS. If you leak a prefix, you include 
SIDs. If you summarize at the area border, no SIDs are advertised with 
the summary itself.

thanks,
Peter

> .

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Fri, 18 Jan 2019 09:57:55 +0000

Hi Peter,

Please see inline.

-----Original Message-----
From: Peter Psenak [mailto:[email-masked]] 
Sent: Friday, January 18, 2019 4:47 PM
To: Chengli (Cheng Li) <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: draft-bashandy-isis-srv6-extensions: Locator Leaking

Hi Cheng,

please see inline:

On 18/01/2019 04:53 , Chengli (Cheng Li) wrote:
> To: Chengli (Cheng Li) <[email-masked]>; 
> [email-masked]
> Cc: [email-masked]
>> In chapter 6.1 of draft-bashandy-isis-srv6-extensions-04,  it 
>> mentions that Locator TLV can be leaked from level-2 to level-1.(See 
>> D bit)
>>
>>
>>
>> I am wondering that
>>

it's called "redistribution". Sure, nobody stops you to redistribute locators between protocols. Please note that it is not something that is specified by the IETF, because it's an internal implementation detail. 
 From protocol perspective, there is nothing specific needed to support that.

[Cheng] Cool. Get it.

When you summarize multiple locators, you would advertise only the summary prefix - in IP reachability TLV I would think.

This is the same as with SR MPLS. If you leak a prefix, you include SIDs. If you summarize at the area border, no SIDs are advertised with the summary itself.

[Cheng] Agree. That is what I thought. When we summarize at the are border, no SIDs are advertised with the summary itself. Thank you!

thanks,
Peter