Subject: [Lsr] FW: New Version Notification for draft-white-distoptflood-00.txt

From: <[email-masked]>
Date: Sun, 31 Mar 2019 16:25:27 -0400

FYI -- I've put just the flooding optimizations from the openfabric work into a separate draft and submitted it. I've also modified the wording a bit, as this is applicable far beyond data center fabrics.

😊 /r

> -----Original Message-----
> From: [email-masked] <[email-masked]>
> Sent: Sunday, March 31, 2019 4:24 PM
> To: Shawn Zandi <[email-masked]>; Russ White <[email-masked]>
> Subject: New Version Notification for draft-white-distoptflood-00.txt
> 
> 
> A new version of I-D, draft-white-distoptflood-00.txt has been successfully
> submitted by Russ White and posted to the IETF repository.
> 
> Name:		draft-white-distoptflood
> Revision:	00
> Title:		IS-IS Optimal Distributed Flooding for Dense Topologies
> Document date:	2019-03-31
> Group:		Individual Submission
> Pages:		13
> URL:            https://www.ietf.org/internet-drafts/draft-white-distoptflood-
> 00.txt
> Status:         https://datatracker.ietf.org/doc/draft-white-distoptflood/
> Htmlized:       https://tools.ietf.org/html/draft-white-distoptflood-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-white-distoptflood
> 
> 
> Abstract:
>    Dense topologies, such as data center fabrics based on the Clos and
>    butterfly fabric topologies.  Flooding mechanisms designed for sparse
>    topologies, when used in these dense topologies, can result in slower
>    convergence times and higher resource utilization.  The modifications
>    to the flooding mechanism in the Intermediate System to Intermediate
>    System (IS-IS) link state protocol described in this document reduce
>    resource utilization to a minimum, while increaseing convergence
>    performance in dense topologies.
> 
>    Note that a Clos fabric is used as the primary example of a desne
>    flooding topology throughout this document.  However, the flooding
>    optimizations described in this document apply to any dense topology.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Sun, 31 Mar 2019 23:47:29 +0000

Russ -

The WG just went through a lengthy consideration of multiple flooding optimization drafts and selected https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/ as the vehicle for the WG to use to move forward in this area.

It would be good if, in the context of the above, you articulated why it makes sense for the WG to do yet another round of such discussion. 

(Full disclosure: I am a co-author on draft-ietf-lsr-dynamic-flooding - but my question isn't coming from that perspective. )

   Les

> From: Lsr <[email-masked]> On Behalf Of [email-masked]
> Sent: Sunday, March 31, 2019 1:25 PM
> To: [email-masked]
> Subject: [Lsr] FW: New Version Notification for draft-white-distoptflood-
> 00.txt
> 
> 
> FYI -- I've put just the flooding optimizations from the openfabric work into a
> separate draft and submitted it. I've also modified the wording a bit, as this is
> applicable far beyond data center fabrics.
> 
> 😊 /r
> 
> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr

---

From: <[email-masked]>
Date: Sun, 31 Mar 2019 21:18:04 -0400

> The WG just went through a lengthy consideration of multiple flooding
> optimization drafts and selected https://datatracker.ietf.org/doc/draft-ietf-
> lsr-dynamic-flooding/ as the vehicle for the WG to use to move forward in
> this area.

Yep.

> It would be good if, in the context of the above, you articulated why it makes
> sense for the WG to do yet another round of such discussion.

==
In this idea, the flooding topology is computed within an IGP area
   with the dense topology either centrally on an elected node, termed
   the Area Leader, or in a distributed manner on all nodes that are
   supporting Dynamic Flooding.
==

Because this is only one way to solve the problem... The process outlined in the draft I just published is a different and simpler way that applies to a wider range of topologies than the dynamic flooding draft does, afaict. 

😊 /r

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 1 Apr 2019 01:55:49 +0000

Russ -

Please state explicitly whether you want:

a)This draft to be considered by the WG in addition to draft-ietf-lsr-dynamic-flooding (i.e., we should work on both drafts in parallel)

b)This draft to be considered as a replacement for draft-ietf-lsr-dynamic-flooding (i.e., we should abandon work on draft-ietf-lsr-dynamic-flooding and instead work on this draft)

c)You want the ideas articulated in this draft to be incorporated into draft-ietf-lsr-dynamic-flooding

(and please don't say "it doesn't matter" - because it certainly does matter :-) )

Thanx.

   Les

> Sent: Sunday, March 31, 2019 6:18 PM
> To: Les Ginsberg (ginsberg) <[email-masked]>; [email-masked]
> Subject: Re: [Lsr] FW: New Version Notification for draft-white-distoptflood-
> 00.txt
> 
> 
> Because this is only one way to solve the problem... The process outlined in
> the draft I just published is a different and simpler way that applies to a wider
> range of topologies than the dynamic flooding draft does, afaict.
> 
> 😊 /r
> 
>