Subject: Re: [Lsr] AD Review of draft-ietf-isis-yang-isis-cfg-35

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 5 Sep 2019 19:09:09 +0000

Hi Alvaro,
I see you approved for IESG review.  Stephane and I have some more updates in -36 version. See inline.

From: Alvaro Retana <[email-masked]>
Date: Tuesday, July 30, 2019 at 3:29 PM
To: "[email-masked]" <[email-masked]>, Stephane Litkowski <[email-masked]>
Cc: Yingzhen Qu <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: AD Review of draft-ietf-isis-yang-isis-cfg-35
Resent-From: <[email-masked]>
Resent-To: Yingzhen Qu <[email-masked]>, Christian Hopps <[email-masked]>, Acee Lindem <[email-masked]>
Resent-Date: Tuesday, July 30, 2019 at 3:29 PM

On June 27, 2019 at 8:36:46 AM, [email-masked]<mailto:[email-masked]> ([email-masked]<mailto:[email-masked]>) wrote:

Stephane:

Hi!

Sorry it took me while to get to your reply.

Thanks for your comments. We are working on updating the document accordingly.
Please find some replies inline that may require more discussion.
I have stripped the comments that will be fixed in the next revision.

Just leaving some text with answers.

Thanks!

Alvaro.

...

474         Some parameters like "overload bit" and "route preference" are not
475         modeled to support a per level configuration.  If an implementation
476         supports per level configuration for such parameter, this
477         implementation SHOULD augment the current model by adding both
478         level-1 and level-2 containers and SHOULD reuse existing
479         configuration groupings.

[major] "...SHOULD augment the current model by adding both level-1 and level-2 containers"  What other way would that be done?  I think that Normative language is not needed in this case.
[SLI] Using YANG there are multiple ways to do things. People may create new containers, use different namings… and we want to keep the modeling consistency even in the future augmentations.

Ok…why not use MUST then?  Are there cases where it would be ok to not be consistent?  IOW, the current wording doesn’t guarantee consistency…

This is a MUST in the -36 version.

...
978            sequence-number-skipped: This notification is sent when the system
979            receives a PDU with its own system ID and different contents.  The
980            system has to reissue the LSP with a higher sequence number.

[nit] That's the last thing I would have guessed that this action would have been called...  Maybe it's just me...
[SLI] This is inherited from RFC4444

I guess operators are familiar with this SNMP Trap misnomer.

982            authentication-type-failure: This notification is sent when the
983            system receives a PDU with the wrong authentication type field.

985            authentication-failure: This notification is sent when the system
986            receives a PDU with the wrong authentication information.

[minor] Why do we need both of these?  Given that they both provide the same information (including the raw PDU), and that authentication-type-failure is a specific case of receiving "a PDU with the wrong authentication information"
[SLI] This is inherited from RFC4444

You used this reply in several places.

Inheriting things from rfc4444 doesn’t mean it is ok…or the best solution…

In either case, most are minor comments, so no big deal.  I just want to make sure that some of the points were considered.

In one case the wrong type of authentication is used, e.g., none vs auth-trailer and in the other the neighbors agree on authentication type but authentication fails.

...

1239         feature nsr {
1240           description
1241             "Non-Stop-Routing (NSR) support.";
1242         }

[minor] Reference?
[SLI] NSR is a local well known and deployed mechanism. We may enhance the description if required, however we cannot really provide a reference.

Yes, please do.  See the description in draft-ietf-ospf-yang.

This is included in the -36 version.

...
3995         grouping tlv242-router-capabilities {
3996           container router-capabilities {
3997             list router-capability {
3998                 leaf flags {
3999                   type bits {
4000                     bit flooding {
4001                       position 0;
4002                       description
4003                         "If the S bit is set, the IS-IS Router CAPABILITY
4004                          TLV MUST be flooded across the entire routing
4005                          domain. If the S bit is clear, the TLV MUST NOT
4006                          be leaked between levels. This bit MUST NOT
4007                           be altered during the TLV leaking.";
4008                     }

[major] This is a description of the behavior (copied from rfc7981!), not a description of the field.
[SLI] Yes, but this provides an accurate description on the conditions of the flag setting.

But this document is not Normative in the behavior above…. If anything, Normative language should not be used unless making it clear that it is a direct quote.

This is represented as an RFC 7981 quote in the -36 version.

...
4540         notification lsp-too-large {
4541           uses notification-instance-hdr;
4542           uses notification-interface-hdr;

4544           leaf pdu-size {
4545             type uint32;
4546             description "Size of the LSP PDU";
4547           }
4548           leaf lsp-id {
4549             type lsp-id;
4550             description "LSP ID";

4552           }
4553           description
4554             "This notification is sent when we attempt to propagate
4555              an LSP that is larger than the dataLinkBlockSize for the
4556              circuit.  The notification generation must be throttled
4557              with at least 5 seconds between successive
4558              notifications.";
4559         }

...
[major] "must be throttled"  Why is this text not Normative?  It seems to me that throttling is a good practice...in fact, it may be a good idea to specify it for all notifications.  There are 12 total instances of the same text.
[SLI] The text is mirrored from RFC4444.

I think this was the only “major” point what you replied with rfc4444…. Just leaving it here…. No further comments. ;-)

We didn’t change this notification throttling from RFC 4444. I’m not sure if it should be specified in the YANG model or be something that an implementation provides via configuration for all notifications.

Thanks,

Acee and Stephane

---

From: Alvaro Retana <[email-masked]>
Date: Mon, 9 Sep 2019 13:43:30 -0700

On September 5, 2019 at 3:09:44 PM, Acee Lindem (acee) ([email-masked])
wrote:

Hi!

Stephane and I have some more updates in -36 version.

I’m ready to start the IETF LC, but there’s one small thing I need you to
fix before:  rfc2966 was Obsoleted by rfc5302; please update the reference.

It’s important that we make this update before the LC because rfc2966 was
Informational, so it would require a DownRef, but rfc5302 is in the
Standards Track.

Thanks!

Alvaro.

---

From: Alvaro Retana <[email-masked]>
Date: Mon, 9 Sep 2019 13:45:21 -0700

Hi!

I just found that rfc2966 is in the DownRef registry already, so I’m
starting the IETF LC now.

We will still need to update the reference, but that can be done with any
other LC comments.

Thanks!

Alvaro.

On September 9, 2019 at 4:43:30 PM, Alvaro Retana ([email-masked])
wrote:

Hi!

Thanks!

Alvaro.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 9 Sep 2019 21:19:05 +0000

Hi Alvaro,
I see you started the WG last call. I’ll update this tonight - although I believe this isn’t the only down-ref.
Thanks,
Acee

From: Alvaro Retana <[email-masked]>
Date: Monday, September 9, 2019 at 4:45 PM
To: Acee Lindem <[email-masked]>, "[email-masked]" <[email-masked]>, Stephane Litkowski <[email-masked]>
Cc: Yingzhen Qu <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: AD Review of draft-ietf-isis-yang-isis-cfg-35
Resent-From: <[email-masked]>
Resent-To: Stephane Litkowski <[email-masked]>, Derek Yeung <[email-masked]>, Acee Lindem <[email-masked]>, Jeffrey Zhang <[email-masked]>, Ladislav Lhotka <[email-masked]>
Resent-Date: Monday, September 9, 2019 at 4:45 PM

Hi!

I just found that rfc2966 is in the DownRef registry already, so I’m starting the IETF LC now.

We will still need to update the reference, but that can be done with any other LC comments.

Thanks!

Alvaro.

On September 9, 2019 at 4:43:30 PM, Alvaro Retana ([email-masked]<mailto:[email-masked]>) wrote:
On September 5, 2019 at 3:09:44 PM, Acee Lindem (acee) ([email-masked]<mailto:[email-masked]>) wrote:

Hi!

I’m ready to start the IETF LC, but there’s one small thing I need you to fix before:  rfc2966 was Obsoleted by rfc5302; please update the reference.

It’s important that we make this update before the LC because rfc2966 was Informational, so it would require a DownRef, but rfc5302 is in the Standards Track.

Thanks!

Alvaro.

---

From: Alvaro Retana <[email-masked]>
Date: Mon, 9 Sep 2019 14:54:25 -0700

On September 9, 2019 at 5:19:09 PM, Acee Lindem (acee) ([email-masked])
wrote:

Acee:

I see you started the WG last call. I’ll update this tonight
<http://airmail.calendar/2019-09-09 19:00:00 EDT> - although I believe this
isn’t the only down-ref.

Thanks for the update!

The other DownRef is in the registry already. :-)

Alvaro.