Subject: [Lsr] Martin Vigoureux's No Objection on draft-ietf-lsr-isis-rfc5306bis-05: (with COMMENT)

From: Martin Vigoureux via Datatracker <[email-masked]>
Date: Tue, 17 Sep 2019 01:18:24 -0700

Martin Vigoureux has entered the following ballot position for
draft-ietf-lsr-isis-rfc5306bis-05: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lsr-isis-rfc5306bis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Hello,

thank you for this document.
What is the expected behaviour, if any needing to be described, when the
neighbor of a router planning to restart decides to also plan a restart?

Thank you

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 18 Sep 2019 06:11:55 +0000

Martin -

Thanx for reviewing.
Inline.

> -----Original Message-----
> From: Martin Vigoureux via Datatracker <[email-masked]>
> Sent: Tuesday, September 17, 2019 1:18 AM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Uma Chunduri
> <[email-masked]>; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Martin Vigoureux's No Objection on draft-ietf-lsr-isis-rfc5306bis-05:
> (with COMMENT)
> 

[Les:] A restarting router depends upon the adjacency state preserved by its neighbors in order to gracefully restore state post-restart. Anything which compromises that will compromise the "gracefulness" of the restart.
If two routers who are neighbors restart at the "same time" then the state of the adjacency(s) between those two routers will not be preserved and this will cause some flapping.

GR is intended to be a planned activity - therefore the operator should be able to insure that only one router at a time is undergoing GR.

   Les