Subject: Re: [Lsr] draft-ietf-isis-mpls-elc-07

From: <[email-masked]>
Date: Wed, 4 Sep 2019 23:14:57 +0000

Hi Uma,

There was a discussion on this topic. I think this was agreed during Chicago's IETF if I remember correctly.
The outcome of the discussion was that if an implementation is able to read N labels, this does not mean that it is actually able to hash based on these N labels. So we needed something which combines the ability of reading + doing an action. That's why the ERLD has been defined instead of the base RLD which was foreseen at first stages of the draft.
This implies that there is a possibility to create additional RLDs that may have other applications than entropy.

Brgds,

From: Lsr [mailto:[email-masked]] On Behalf Of Uma Chunduri
Sent: Wednesday, August 28, 2019 20:38
To: [email-masked]
Subject: [Lsr] draft-ietf-isis-mpls-elc-07

Can anybody tell what was the conclusion (if any) in previous discussions in various WGs on why the readable label depth in an LSR has to be entropy label specific ?

IOW can we just modify this as "readable label depth" as opposed to "entropy readable label depth" ?
This would allow any other special purpose label inserted in the stack and would be at par with current MSD type "Base MPLS Imposition MSD" ( https://www.iana.org/assignments/igp-parameters/igp-parameters.xhtml ).

--
Uma C.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Uma Chunduri <[email-masked]>
Date: Tue, 10 Sep 2019 18:15:24 +0000

Hi Stephane,

>The outcome of the discussion was that if an implementation is able to read N labels, this does not mean that it is actually able to hash based on these N labels. So we needed something which combines the ability of reading + doing an action.

That's correct, both reading and associated functionality is encoded in one MSD type here.

>This implies that there is a possibility to create additional RLDs that may have other applications than entropy.

Sure, thanks for confirming this.

--
Uma C.