Subject: Re: [Lsr] Working Group Last Call for "Signaling Entropy Label Capability and Entropy Readable Label-stack Depth Using ISIS" - draft-ietf-isis-mpls-elc-07

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 2 Sep 2019 04:48:07 +0000

I support moving forward with these drafts.
There are clearly use cases for this functionality and the solution has been vetted with providers who intend to deploy this.

   Les

From: Lsr <[email-masked]> On Behalf Of Acee Lindem (acee)
Sent: Friday, August 30, 2019 12:44 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Lsr] Working Group Last Call for "Signaling Entropy Label Capability and Entropy Readable Label-stack Depth Using ISIS" - draft-ietf-isis-mpls-elc-07

We’ve gone through a number of iterations with these ELC drafts and I believe they are ready and meets all the use case requirements. Note that “Entropy Label for Spring tunnels” – draft-ietf-mpls-spring-entropy-label-12 is on the RFC editor’s queue.
This begins a two week last call for the subject draft. Please indicate your support or objection on this list prior to 12:00 AM UTC on Sept 14th, 2014. Also, review comments are certainly welcome.
Thanks,
Acee

---

From: Jeff Tantsura <[email-masked]>
Date: Sun, 1 Sep 2019 23:28:17 -0700

Yes/support

Cheers,
Jeff
> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr

---

From: <[email-masked]>
Date: Mon, 2 Sep 2019 09:59:40 +0000

Support.
This is needed for using MPLS Entropy Label in SR-MPLS.

Please find below some proposed comments. Please feel free to silently discard.
§1 Introduction
OLD:

“This capability, referred to as Entropy

   Readable Label Depth (ERLD) as defined in

   [I-D.ietf-mpls-spring-entropy-label<https://tools.ietf.org/html/draft-ietf-isis-mpls-elc-07#ref-I-D.ietf-mpls-spring-entropy-label>] may be used by ingress LSRs to

   determine whether it's necessary to insert an EL for a given LSP in

   the case where there has already been at least one EL in the label

   stack [I-D.ietf-mpls-spring-entropy-label<https://tools.ietf.org/html/draft-ietf-isis-mpls-elc-07#ref-I-D.ietf-mpls-spring-entropy-label>].”

NEW:

This capability, referred to as Entropy

   Readable Label Depth (ERLD) as defined in

   [I-D.ietf-mpls-spring-entropy-label<https://tools.ietf.org/html/draft-ietf-isis-mpls-elc-07#ref-I-D.ietf-mpls-spring-entropy-label>] may be used by ingress LSRs to

   determine the position of the EL label in the stack, and whether it's necessary to insert multiple EL at different depth.

§7 Security Considerations

“This document does not introduce any new security risks.”

Incorrectly setting the E flag (ELC capable) (during origination, propagation, redistribution) may lead to black-holing the traffic on the egress node. I believe this risk should be mentioned.

Regards,
--Bruno
From: Lsr [mailto:[email-masked]] On Behalf Of Les Ginsberg (ginsberg)
Sent: Monday, September 2, 2019 6:48 AM
To: Acee Lindem (acee); [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Lsr] Working Group Last Call for "Signaling Entropy Label Capability and Entropy Readable Label-stack Depth Using ISIS" - draft-ietf-isis-mpls-elc-07

   Les

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Peter Psenak <[email-masked]>
Date: Mon, 2 Sep 2019 12:16:41 +0200

Hi Acee,

support as co-author.

thanks,
Peter

On 30/08/2019 21:44, Acee Lindem (acee) wrote:
> We’ve gone through a number of iterations with these ELC drafts and I 
> believe they are ready and meets all the use case requirements. Note 
> that “Entropy Label for Spring tunnels” – 
> draft-ietf-mpls-spring-entropy-label-12 is on the RFC editor’s queue.
> 
> This begins a two week last call for the subject draft. Please indicate 
> your support or objection on this list prior to 12:00 AM UTC on Sept 
> 14^th , 2014. Also, review comments are certainly welcome.
> 
> Thanks,
> Acee
>

---

From: Peter Psenak <[email-masked]>
Date: Mon, 2 Sep 2019 13:03:41 +0200

Hi Bruno,

On 02/09/2019 11:59, [email-masked] wrote:
> [I-D.ietf-mpls-spring-entropy-label  <https://tools.ietf.org/html/draft-ietf-isis-mpls-elc-07#ref-I-D.ietf-mpls-spring-entropy-label>] may be used by ingress LSRs to
> 
> stack [I-D.ietf-mpls-spring-entropy-label  <https://tools.ietf.org/html/draft-ietf-isis-mpls-elc-07#ref-I-D.ietf-mpls-spring-entropy-label>].”
> 
> NEW:
> 
> [I-D.ietf-mpls-spring-entropy-label  <https://tools.ietf.org/html/draft-ietf-isis-mpls-elc-07#ref-I-D.ietf-mpls-spring-entropy-label>] may be used by ingress LSRs to
> 
> determine the position of the EL label in the stack, and whether it's 
> necessary to insert multiple EL at different depth.

What about the slightly modified wording:

"This capability, referred to as Entropy Readable Label Depth (ERLD) as
defined in <xref target="I-D.ietf-mpls-spring-entropy-label"/> may be
used by ingress LSRs determine the position of the EL in the stack, and 
whether it's necessary to insert multiple ELs at different position in 
the label stack."

> 
> §7Security Considerations
> 
> Incorrectly setting the E flag (ELC capable) (during origination, 
> propagation, redistribution) may lead to black-holing the traffic on the 
> egress node. I believe this risk should be mentioned.

done.

thanks,
Peter
> 
> Regards,
> 
> --Bruno
> 
> *From**:*Lsr [mailto:[email-masked]] *On Behalf Of * Les Ginsberg 
> (ginsberg)
> *Sent:* Monday, September 2, 2019 6:48 AM
> *To:* Acee Lindem (acee); [email-masked]
> *Cc:* [email-masked]; [email-masked]; [email-masked]
> *Subject:* Re: [Lsr] Working Group Last Call for "Signaling Entropy 
> Label Capability and Entropy Readable Label-stack Depth Using ISIS" - 
> draft-ietf-isis-mpls-elc-07
> 
> There are clearly use cases for this functionality and the solution has 
> been vetted with providers who intend to deploy this.
> 
>     Les
> 
> *From:*Lsr <[email-masked]> *On Behalf Of *Acee Lindem (acee)
> *Sent:* Friday, August 30, 2019 12:44 PM
> *To:* [email-masked]
> *Cc:* [email-masked]; [email-masked]; [email-masked]
> *Subject:* [Lsr] Working Group Last Call for "Signaling Entropy Label 
> Capability and Entropy Readable Label-stack Depth Using ISIS" - 
> draft-ietf-isis-mpls-elc-07
>

---

From: <[email-masked]>
Date: Mon, 2 Sep 2019 14:33:25 +0000

Hi Peter,

Thanks, looks good.

--Bruno

-----Original Message-----
From: Peter Psenak [mailto:[email-masked]] 
Sent: Monday, September 2, 2019 1:04 PM
To: DECRAENE Bruno TGI/OLN; Acee Lindem (acee); [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: Working Group Last Call for "Signaling Entropy Label Capability and Entropy Readable Label-stack Depth Using ISIS" - draft-ietf-isis-mpls-elc-07

Hi Bruno,

done.

thanks,
Peter

---

From: "徐小虎(义先)" <[email-masked]>
Date: Thu, 12 Sep 2019 09:51:09 +0800

Hi Bruno,

It's the ELC which is used to determine the POSSIBLE position of inserting the EL in the stack, meanwhile, it's the ERLC  which is 
used to determine the necessity of inserting an EL at any possible position of the EL except the deepest position. Hence, the OLD definition of the ERLC seems more straightforward, IMHO.

Best regards,
Xiaohu

------------------------------------------------------------------
From:bruno.decraene <[email-masked]>
Send Time:2019年9月2日(星期一) 22:33
To:Peter Psenak <[email-masked]>; Acee Lindem (acee) <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Cc:[email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject:Re: [Lsr] Working Group Last Call for "Signaling Entropy Label Capability and Entropy Readable Label-stack Depth Using ISIS" - draft-ietf-isis-mpls-elc-07

Hi Peter,

Thanks, looks good.

--Bruno

-----Original Message-----
From: Peter Psenak [mailto:[email-masked]] 
Sent: Monday, September 2, 2019 1:04 PM
To: DECRAENE Bruno TGI/OLN; Acee Lindem (acee); [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: Working Group Last Call for "Signaling Entropy Label Capability and Entropy Readable Label-stack Depth Using ISIS" - draft-ietf-isis-mpls-elc-07

Hi Bruno,

done.

thanks,
Peter