Subject: [Lsr] Regarding SRv6 SID Structure Sub-Sub-TLV in draft-ietf-lsr-isis-srv6-extensions

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Mon, 22 Jun 2020 11:50:59 +0000

Hi authors,

When I read the document, I noticed that the format of the SRv6 SID Structure Sub-Sub-TLV has no reserved bits, which may bring troubles for future extensions.

What if new architecture of SID is proposed? We have to introduce a new SID structure TLV. But actually a backward-compatible format design of this TLV can solve this kind of problems.

IMHO, if we introduced 16 bits reserved bits after the Length, then the length aligns with  64 bits and the future SID structure can be supported.

Thanks,
Cheng

---

From: Peter Psenak <[email-masked]>
Date: Mon, 22 Jun 2020 14:42:47 +0200

Cheng,

On 22/06/2020 13:50, Chengli (Cheng Li) wrote:
> Hi authors,
> 
> When I read the document, I noticed that the format of the SRv6 SID 
> Structure Sub-Sub-TLV has no reserved bits, which may bring troubles for 
> future extensions.

what bits do you need?

> 
> What if new architecture of SID is proposed? We have to introduce a new 
> SID structure TLV. But actually a backward-compatible format design of 
> this TLV can solve this kind of problems.

new architecture of SID is proposed, we will add what is needed.

thanks,
Peter

> 
> IMHO, if we introduced 16 bits reserved bits after the Length, then the 
> length aligns with  64 bits and the future SID structure can be supported.
> 
> Thanks,
> 
> Cheng
>