Subject: [Lsr] draft-ietf-lsr-flex-algo

From: <[email-masked]>
Date: Tue, 30 Jun 2020 14:53:01 +0000

Hi all,

I can live with the current text, but I'm just raising the point for discussion (better safe than sorry).

"16.1.1.  IGP Algorithm Types Registry

   This document makes the following registrations in the "IGP Algorithm Types" registry:

      Type: 128-255.

      Description: Flexible Algorithms.
"
https://tools.ietf.org/html/draft-ietf-lsr-flex-algo-07#section-16.1.1

This is essentially burning half of the registry for flex-algo. Indeed, any network operator could use any value, e.g. 222, hence the IETF could never define a different usage for this value without creating interop issues for the network operator.

We could discuss whether we really need 127 values for this. (i.e. a network operator requiring 127 flex algo, typically multiplying its IGP FIB entries by 127...).
We could also discuss whether this range could be change to the IANA well-known "Private Use" [1]. This would allow for alternative private usages in the future (e.g. Flexible Alorithms v2).
[1] https://tools.ietf.org/html/rfc8126#section-4.1

It seems to me that the latter would equally work for flex algo, but would provide more flexibility :-) for the future.

Regards,
--Bruno

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Peter Psenak <[email-masked]>
Date: Tue, 30 Jun 2020 17:06:22 +0200

Hi Bruno,

please see inline:

> This is essentially burning half of the registry for flex-algo. Indeed, any network operator could use any value, e.g. 222, hence the IETF could never define a different usage for this value withou…

what is the real problem? Is the space 2-127 that is free not sufficient 
for other standardized algorithms that may come?

> We could discuss whether we really need 127 values for this. (i.e. a network operator requiring 127 flex algo, typically multiplying its IGP FIB entries by 127...).

above is not necessarily true and more importantly completely irrelevant 
to the number of algos we reserve for FA.

> It seems to me that the latter would equally work for flex algo, but would provide more flexibility :-) for the future.

I don't think so. We need an allocated range of algos for FA for 
compatibility.

thanks,
Peter
> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr
> 
>

---

From: <[email-masked]>
Date: Tue, 30 Jun 2020 16:08:39 +0000

Hi Peter,

Thanks for your reply.

> From: Peter Psenak [mailto:[email-masked]]
> 
> Hi Bruno,
> 
> please see inline:
> 
> > This is essentially burning half of the registry for flex-algo. Indeed, any
> network operator could use any value, e.g. 222, hence the IETF could never
> define a different usage for this value without creating interop issues for the
> network operator.
> 
> > We could discuss whether we really need 127 values for this. (i.e. a
> network operator requiring 127 flex algo, typically multiplying its IGP FIB
> entries by 127...).
> 
> > We could also discuss whether this range could be change to the IANA well-
> known "Private Use" [1]. This would allow for alternative private usages in
> the future (e.g. Flexible Alorithms v2).
> > It seems to me that the latter would equally work for flex algo, but would
> provide more flexibility :-) for the future.
> 

The allocated range of algos for FA would be the same. Just not dedicated to FA.

--Bruno
 
> 
> thanks,
> Peter
> >
> > Regards,
> > --Bruno
> >
> >
> __________________________________________________________
> __________________________________________________________
> _____
> >
> > Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> > a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> > This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: Peter Psenak <[email-masked]>
Date: Tue, 30 Jun 2020 18:24:39 +0200

Hi Bruno,

> The allocated range of algos for FA would be the same. Just not dedicated to FA.

this would not work. If I have a mix of routers, one set using value 222 
for flex-algo and another set for something else, how are they going to 
interoperate?

We need a standardized range, using Private Use is not an option here.

thanks,
Peter

---

From: <[email-masked]>
Date: Tue, 30 Jun 2020 16:39:44 +0000

Hi Peter,

> >>> I can live with the current text, but I'm just raising the point for
> discussion
> >> (better safe than sorry).
> >>>

My understanding is that the value of the flexalgo is chosen by the network operator and configured on the router. 

" We want the mapping between the Flex-Algorithm and it's meaning to be flexible and defined by the user."
[...]
" Flexible-Algorithm is a numeric identifier in the range 128-255 that
   is associated via provisioning with the Flexible-Algorithm
   Definition."

IOW, "private or local use only, with the type and
   purpose defined by the local site.  No attempt is made to prevent
   multiple sites from using the same value in different (and
   incompatible) ways.  IANA does not record assignments from registries
   or ranges with this policy (and therefore there is no need for IANA
   to review them) and assignments are not generally useful for broad
   interoperability.  It is the responsibility of the sites making use
   of the Private Use range to ensure that no conflicts occur (within
   the intended scope of use)."

Which is the definition of Private Use by IANA.

> We need a standardized range, using Private Use is not an option here.

Yes we need a standardized range.
I'm not sure that this range needs to be dedicated to FA. But I leave this to you/the WG.

And thanks again for your active engagement in the discussion.

-- Bruno

> >>> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu
> ce
> >> message par erreur, veuillez le signaler
> >>> Orange decline toute responsabilite si ce message a ete altere, deforme
> ou
> >> falsifie. Merci.
> >>>
> >>> If you have received this email in error, please notify the sender and
> delete
> >> this message and its attachments.
> >>> As emails may be altered, Orange is not liable for messages that have
> been
> >> modified, changed or falsified.
> >>> Thank you.
> >>>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 30 Jun 2020 16:50:23 +0000

Speaking as WG chair:
    
I'm delighted to see discussion on a draft that isn't in WG last call.

Speaking as WG member:

Maybe I'm missing something but do we really think we’re going to run out of non-flexible algorithms with 128? I just don't see it happening in my lifetime. 

Thanks,
Acee

On 6/30/20, 12:27 PM, "Lsr on behalf of Peter Psenak" <[email-masked] on behalf of ppsenak=[email-masked]> wrote:

    Hi Bruno,

    thanks,
    Peter