Subject: [Lsr] A question about draft-ietf-lsr-flex-algo

From: Huzhibo <[email-masked]>
Date: Wed, 3 Jun 2020 12:06:45 +0000

Hi Peter:

I noticed that draft-ietf-lsr-flex-algo-07 adds exclude SRLG TLV. SRLG defines a group of risk-sharing link groups. It is generally used to prevent the primary and standby paths from passing the same risk-sharing link group .I don't know why a group of SRLG links should be excluded from the FlexAlgo calculation. What is its usecase?

Thanks

Zhibo Hu

---

From: Peter Psenak <[email-masked]>
Date: Wed, 3 Jun 2020 14:09:26 +0200

Hi Zhibo,

this has been explained in the WG alias already.

Can you please go over archives.

thanks,
Peter

On 03/06/2020 14:06, Huzhibo wrote:
> Hi Peter:
> 
> I noticed that draft-ietf-lsr-flex-algo-07 adds exclude SRLG TLV. SRLG 
> defines a group of risk-sharing link groups. It is generally used to 
> prevent the primary and standby paths from passing the same risk-sharing 
> link group .I don't know why a group of SRLG links should be excluded 
> from the FlexAlgo calculation. What is its usecase?
> 
> Thanks
> 
> Zhibo Hu
>

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 3 Jun 2020 12:18:34 +0000

Hi Zhibo Hu,
Welcome to the club - I have already asked the same question and got a response from Peter.
You can find the relevant email thread here<https://mailarchive.ietf.org/arch/msg/spring/wvowYz7mOwR9f6je46qPV_pD9pU/>.

My 2c,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

From: Lsr <[email-masked]> On Behalf Of Huzhibo
Sent: Wednesday, June 3, 2020 3:07 PM
To: Peter Psenak (ppsenak) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: [Lsr] A question about draft-ietf-lsr-flex-algo

Hi Peter:

Thanks

Zhibo Hu

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: Huzhibo <[email-masked]>
Date: Wed, 3 Jun 2020 12:40:56 +0000

Hi Alexander, Peter:

     Thank you very much，After I read the WG alias, I still have a lot of doubts, can we calculate the disjoint path by exclude  SRLG in flexalgo? In fact, unless you previously defined two disjoint planes using SRLG, you cannot guarantee that different FlexAlgo can calculate disjoint paths.

Thanks

Zhibo Hu
From: Alexander Vainshtein [mailto:[email-masked]]
Sent: Wednesday, June 3, 2020 8:19 PM
To: Huzhibo <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: RE: A question about draft-ietf-lsr-flex-algo

Hi Zhibo Hu,

My 2c,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]<mailto:[email-masked]>

From: Lsr <[email-masked]<mailto:[email-masked]>> On Behalf Of Huzhibo
Sent: Wednesday, June 3, 2020 3:07 PM
To: Peter Psenak (ppsenak) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [Lsr] A question about draft-ietf-lsr-flex-algo

Hi Peter:

Thanks

Zhibo Hu

---

From: Peter Psenak <[email-masked]>
Date: Wed, 3 Jun 2020 14:53:29 +0200

Hi Zhibo,

n 03/06/2020 14:40, Huzhibo wrote:
> Hi Alexander, Peter:
> 
>       Thank you very much，After I read the WG alias, I still have a lot 
> of doubts, can we calculate the disjoint path by exclude  SRLG in 
> flexalgo? In fact, unless you previously defined two disjoint planes 
> using SRLG, you cannot guarantee that different FlexAlgo can calculate 
> disjoint paths.

the point is that if you did provide such path, flex-algo can calculate 
them. As I mentioned earlier, this use case came from the field, so 
people out there apparently have such topologies and SRLG assignments.

At the end of the day, use of any of the FAD constraints is optional. 
Look at them as lego blocks - if they fit to your network, use them, if 
they don't, leave them alone.

thanks,
Peter

> 
> Thanks
> 
> Zhibo Hu
> 
> *From:*Alexander Vainshtein [mailto:[email-masked]]
> *Sent:* Wednesday, June 3, 2020 8:19 PM
> *To:* Huzhibo <[email-masked]>; Peter Psenak (ppsenak) 
> <[email-masked]>
> *Cc:* [email-masked]; [email-masked]
> *Subject:* RE: A question about draft-ietf-lsr-flex-algo
> 
> Hi Zhibo Hu,
> 
> You can find the relevant email thread here 
> <https://mailarchive.ietf.org/arch/msg/spring/wvowYz7mOwR9f6je46qPV_pD9pU/>.
> 
> My 2c,
> 
> Sasha
> 
> Office: +972-39266302
> 
> Cell:      +972-549266302
> 
> <mailto:[email-masked]>
> 
> *From:*Lsr <[email-masked] <mailto:[email-masked]>> *On 
> Behalf Of *Huzhibo
> *Sent:* Wednesday, June 3, 2020 3:07 PM
> *To:* Peter Psenak (ppsenak) <[email-masked] <mailto:[email-masked]>>
> *Cc:* [email-masked] <mailto:[email-masked]>; 
> [email-masked] <mailto:[email-masked]>
> *Subject:* [Lsr] A question about draft-ietf-lsr-flex-algo
> 
> Hi Peter:
>