Subject: [Lsr] Query on OSPFv2 Extended Link TLV

From: JAZEEL MOHAMMED <[email-masked]>
Date: Fri, 5 Jun 2020 16:12:33 +0530

Hi LSR WG,

I am finding it hard to understand the below statement under section "3.1.
OSPFv2 Extended Link TLV" in RFC7684.

" If this TLV is advertised multiple times in the same OSPFv2 Extended Link
Opaque LSA, only the first instance of the TLV is used by receiving OSPFv2
routers. This situation SHOULD be logged as an error."

is this statement applicable only for multiple Extended Link TLV with
same Link Type and Link Id or any multiple Extended Link TLV in same OSPFv2
Extended Link Opaque LSA?

Please advise on the same.

Thank you,
Jazeel Mohammed

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 5 Jun 2020 11:53:22 +0000

Hi Jazeel,

From: Lsr <[email-masked]> on behalf of JAZEEL MOHAMMED <[email-masked]>
Date: Friday, June 5, 2020 at 7:41 AM
To: "[email-masked]" <[email-masked]>
Subject: [Lsr] Query on OSPFv2 Extended Link TLV

Hi LSR WG,

I am finding it hard to understand the below statement under section "3.1. OSPFv2 Extended Link TLV" in RFC7684..

" If this TLV is advertised multiple times in the same OSPFv2 Extended Link Opaque LSA, only the first instance of the TLV is used by receiving OSPFv2 routers. This situation SHOULD be logged as an error."

is this statement applicable only for multiple Extended Link TLV with same Link Type and Link Id or any multiple Extended Link TLV in same OSPFv2 Extended Link Opaque LSA?

An OSPFv2 Extended Link Opaque LSA will include attributes for a single link so it applies irrespective of Link Type and Link ID.

Thanks,
Acee

Thank you,
Jazeel Mohammed

---

From: JAZEEL MOHAMMED <[email-masked]>
Date: Fri, 5 Jun 2020 17:35:39 +0530

Thanks a lot Acee for quick response.

Regards,
Jazeel Mohammed

On Fri, Jun 5, 2020 at 5:23 PM Acee Lindem (acee) <[email-masked]> wrote:

> Hi Jazeel,
>
>
>
>
>
> *From: *Lsr <[email-masked]> on behalf of JAZEEL MOHAMMED <
> [email-masked]>
> *Date: *Friday, June 5, 2020 at 7:41 AM
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *[Lsr] Query on OSPFv2 Extended Link TLV
>
>
>
> Hi LSR WG,
>
>
>
> OSPFv2 Extended Link TLV" in RFC7684..
>
>
>
> " If this TLV is advertised multiple times in the same OSPFv2
> Extended Link Opaque LSA, only the first instance of the TLV is used
> by receiving OSPFv2 routers. This situation SHOULD be logged as an error."
>
>
>
> An OSPFv2 Extended Link Opaque LSA will include attributes for a single
> link so it applies irrespective of Link Type and Link ID.
>
>
>
> Thanks,
>
> Acee
>
>
>
>
>
>
>