Subject: [Lsr] I-D Action: draft-ietf-lsr-ospf-prefix-originator-06.txt

From: [email-masked]
Date: Tue, 30 Jun 2020 01:29:18 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Link State Routing WG of the IETF.

        Title           : OSPF Prefix Originator Extensions
        Authors         : Aijun Wang
                          Acee Lindem
                          Jie Dong
                          Peter Psenak
                          Ketan Talaulikar
	Filename        : draft-ietf-lsr-ospf-prefix-originator-06.txt
	Pages           : 11
	Date            : 2020-06-30

Abstract:
   This document defines OSPF extensions to include information
   associated with the node originating a prefix along with the prefix
   advertisement.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lsr-ospf-prefix-originator/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-lsr-ospf-prefix-originator-06
https://datatracker.ietf.org/doc/html/draft-ietf-lsr-ospf-prefix-originator-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lsr-ospf-prefix-originator-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Tue, 30 Jun 2020 08:42:05 +0000

Hi All,

We've recently submitted an update to this draft with the following changes:

1)  Introduced a new Prefix Originator Sub-TLV for carrying the reachable address of the node originating the prefix advertisement. This is equivalent to the similar ISIS extension - https://tools.ietf.org/html/rfc7794#section-2.2.
2) Removed the text related to use-case/justification for ELC since that no longer applies now with the updated IGP ELC drafts where this capability is now advertised as a prefix attribute. 
3) Removed references to ERLD and MSD since the originator node is the destination and not the transit or ingress for the flows towards the specific prefix.
4) Moved some remaining topology reconstruction use-case related text into the Appendix since it is non-normative.
5) Clarified and updated the procedures with normative text describing the origination of the sub-TLVs in more detail.
6) Other minor editorial changes.

Look forward to the WG review and feedback on this.

Thanks,
Ketan (on behalf of co-authors)

-----Original Message-----
From: Lsr <[email-masked]> On Behalf Of [email-masked]
Sent: 30 June 2020 13:59
To: [email-masked]
Cc: [email-masked]
Subject: [Lsr] I-D Action: draft-ietf-lsr-ospf-prefix-originator-06.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Lsr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lsr