Subject: [Lsr] FW: New Version Notification for draft-white-lsr-distoptflood-00.txt

From: Shraddha Hegde <[email-masked]>
Date: Mon, 30 Nov 2020 04:36:08 +0000

WG members,

We have posted new version of the draft-white-lsr-distoptflood.
This draft has been around for sometime by name openfabric and
draft-white-distoptflood. The current revision has the name changed
to reflect LSR WG.
This draft describes a flood reduction mechanism in ISIS which is based on
similar mechanisms implemented in OSPF for mobile-ad-hoc Networks
([RFC5449], [RFC5614], and [RFC7182]).

Request working group to review and provide inputs.

Rgds
Shraddha

Juniper Business Use Only

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Monday, November 30, 2020 9:59 AM
To: Shraddha Hegde <[email-masked]>; Russ White <[email-masked]>; Shawn Zandi <[email-masked]>
Subject: New Version Notification for draft-white-lsr-distoptflood-00.txt

[External Email. Be cautious of content]

A new version of I-D, draft-white-lsr-distoptflood-00.txt
has been successfully submitted by Shraddha Hegde and posted to the IETF repository.

Name:           draft-white-lsr-distoptflood
Revision:       00
Title:          IS-IS Optimal Distributed Flooding for Dense Topologies
Document date:  2020-11-29
Group:          Individual Submission
Pages:          12
URL:            https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-white-lsr-distoptflood-00.txt__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSEm2FfjO$
Status:         https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-white-lsr-distoptflood/__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSC0pwavY$
Htmlized:       https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-white-lsr-distoptflood__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSFYebZSl$
Htmlized:       https://urldefense.com/v3/__https://tools.ietf.org/html/draft-white-lsr-distoptflood-00__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSANTt6Q2$

Abstract:
   In dense topologies, such as data center fabrics based on the Clos
   and butterfly fabric topologies, flooding mechanisms designed for
   sparse topologies, when used in these dense topologies, can
   "overflood," or carry too many copies of topology and reachability to
   fabric devices.  This results in slower convergence times and higher
   resource utilization.  The modifications to the flooding mechanism in
   the Intermediate System to Intermediate System (IS-IS) link state
   protocol described in this document reduce resource utilization to a
   minimum, while increaseing convergence performance in dense
   topologies.

   Note that a Clos fabric is used as the primary example of a desne
   flooding topology throughout this document.  However, the flooding
   optimizations described in this document apply to any dense topology.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 30 Nov 2020 06:13:39 +0000

Draft authors -

I note that as the draft has evolved over the years a number of mechanisms have been removed (revised adjacency formation and auto tier detection) and the draft now focuses exclusively on flooding optimizations.

The draft now also references the recent work done in draft-ietf-lsr-dynamic-flooding.

A couple of things are not clear to me.

1)Is it your intent to use the mechanisms defined in draft-ietf-lsr-dynamic-flooding? I am specifically - though not exclusively - referring to how flooding adapts to topology changes.

It isn't clear from Section 3 whether you are actually intending to use the mechanisms defined in https://tools.ietf.org/html/draft-ietf-lsr-dynamic-flooding-07#section-6.8 or whether you simply want to use the Flooding sub-TLV defined in draft-ietf-lsr-dynamic-flooding to (optionally??) advertise your algorithm and all other procedures are specific to your algorithm.

2)The text at the end of https://tools.ietf.org/html/draft-white-lsr-distoptflood-00#section-2.1 states:

" LSPs transmitted to adjacent

   neighbors on the DNR list, however, MUST be transmitted using a

   circuit scope PDU as described in [RFC7356]."

Although this text is not new to this revision, it raises a number of questions/concerns - some of which relate to how this draft fits with draft-ietf-lsr-dynamic-flooding.

For "DNR neighbors", although a circuit scoped LSP was received, the actual content is a traditional area scoped LSP. This presumably needs to be used internally (e.g., when running the Decision Process) in the same way as an area scoped LSP. So there are now two internal databases (traditional area LSPs and Circuit Scoped LSPs) which have to be used as if they are a single database?

When a node sends a traditional CSNP does it include the LSPs it received as Circuit-Scoped LSPs?

If not, how is resynchronization achieved when necessary?

Given the base work defined in draft-ietf-lsr-dynamic-flooding why is the use of Circuit Scoped LSPs required/useful?

In general, it would be helpful to more completely define the relationship between this draft and draft-ietf-lsr-dynamic-flooding.

Thanx.

   Les

> From: Lsr <[email-masked]> On Behalf Of Shraddha Hegde

> Sent: Sunday, November 29, 2020 8:36 PM

> To: [email-masked]

> Subject: [Lsr] FW: New Version Notification for draft-white-lsr-distoptflood-

> 00.txt

> From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>

> To: Shraddha Hegde <[email-masked]<mailto:[email-masked]>>; Russ White <[email-masked]<mailto:[email-masked]>>;

> Shawn Zandi <[email-masked]<mailto:[email-masked]>>

> has been successfully submitted by Shraddha Hegde and posted to the IETF

> repository.

> URL:

> https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-white-<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-white-lsr-distoptflood-00.txt__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSEm2FfjO$>

> lsr-distoptflood-00.txt__;!!NEt6yMaO-<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-white-lsr-distoptflood-00.txt__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSEm2FfjO$>

> gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSEm2FfjO<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-white-lsr-distoptflood-00.txt__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSEm2FfjO$>

> $<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-white-lsr-distoptflood-00.txt__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSEm2FfjO$>

> Status:

> https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-white-<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-white-lsr-distoptflood/__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSC0pwavY$>

> lsr-distoptflood/__;!!NEt6yMaO-<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-white-lsr-distoptflood/__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSC0pwavY$>

> gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSC0pwav<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-white-lsr-distoptflood/__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSC0pwavY$>

> Y$<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-white-lsr-distoptflood/__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSC0pwavY$>

> Htmlized:

> https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-white-lsr-distoptflood__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSFYebZSl$>

> white-lsr-distoptflood__;!!NEt6yMaO-<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-white-lsr-distoptflood__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSFYebZSl$>

> gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSFYebZSl<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-white-lsr-distoptflood__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSFYebZSl$>

> $<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-white-lsr-distoptflood__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSFYebZSl$>

> Htmlized:       https://urldefense.com/v3/__https://tools.ietf.org/html/draft-<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-white-lsr-distoptflood-00__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSANTt6Q2$>

> white-lsr-distoptflood-00__;!!NEt6yMaO-<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-white-lsr-distoptflood-00__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSANTt6Q2$>

> gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSANTt6Q<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-white-lsr-distoptflood-00__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSANTt6Q2$>

> 2$<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-white-lsr-distoptflood-00__;!!NEt6yMaO-gk!T5HX4Enn7jt3zwKoZBiA85YlysK0tdcELjk7Fy829PRSockmshBtqxzkSANTt6Q2$>

> Please note that it may take a couple of minutes from the time of submission

> until the htmlized version and diff are available at tools.ietf.org.

> _______________________________________________

> Lsr mailing list

> [email-masked]<mailto:[email-masked]>

> https://www.ietf.org/mailman/listinfo/lsr