Subject: [Lsr] some doubt about RFC5329 ( Traffic Engineering Extensions to OSPF Version 3)

From: "Zengmin (A)" <[email-masked]>
Date: Tue, 20 Apr 2021 02:11:00 +0000

Hi ALL,

In RFC5329, OSPFv3 TE Link TLV have below sub-TLVs
18 - Neighbor ID (8 octets) ： Neighbor Interface ID ， Neighbor Router ID
19 - Local Interface IPv6 Address
20 - Remote Interface IPv6 Address

question1：
4.4. Remote Interface IPv6 Address Sub-TLV
if link-LSA not have a prefix length of 128 and the LA-bit
how to get remote Interface ipv6 address to fill the tlv value.

question2：
if router only advertise :
18 - Neighbor ID (8 octets) ： Neighbor Interface ID ， Neighbor Router ID
19 - Local Interface IPv6 Address
how to match router's TE Link TLV with peer router's TE Link TLV

question3：
4. Link TLV --- " The Neighbor ID sub-TLV is mandatory for OSPFv3 Traffic Engineering support. "
it means Local Interface IPv6 Address Sub-TLV is not mandatory
if only advertise : 18 - Neighbor ID (8 octets)
how to match router's TE Link TLV with peer router's TE Link TLV

Thanks,
Jenny

In section 4 Link TLV：

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Tue, 20 Apr 2021 14:11:35 +0000

Hello,

Please check inline below.

From: Lsr <[email-masked]> On Behalf Of Zengmin (A)
Sent: 20 April 2021 07:41
To: [email-masked]
Cc: Gaoqiangzhou <[email-masked]>
Subject: [Lsr] some doubt about RFC5329 ( Traffic Engineering Extensions to OSPF Version 3)

Hi ALL,

question1：
4.4. Remote Interface IPv6 Address Sub-TLV
if link-LSA not have a prefix length of 128 and the LA-bit
how to get remote Interface ipv6 address to fill the tlv value.
[KT] I believe the LA-bit is required, the prefix length of 128 is not a must-have. If the remote address cannot be determined then there is no issue - it is possible that links have only link-local addresses.

question2：
[KT] Matching is done using the interface-IDs in OSPFv3. This is something that is always there and available unlike IPv6 local/remote addresses which are optional (e.g. when links have link-local addressing only).

question3：
[KT] Please see previous comment. The local & remote interface IDs are available in the base OSPFv3 Router-LSA description of the link and are therefore fundamental for link correlation in OSPFv3.

Thanks,
Ketan

Thanks,
Jenny

In section 4 Link TLV：