Subject: Re: [Lsr] Doubt regarding A bit set/clear

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 19 Apr 2021 13:24:01 +0000

Gurusiddesh,

I’ll defer to the RFC authors on your question. However, please refrain from referring to bits as being “unset”. They are set or clear.

Thanks,
Acee

From: Lsr <[email-masked]> on behalf of Gurusiddesh Nidasesi <[email-masked]>
Date: Monday, April 19, 2021 at 6:13 AM
To: "[email-masked]" <[email-masked]>
Cc: Spencer Giacalone <[email-masked]>, Stefano Previdi <[email-masked]>, "Les Ginsberg (ginsberg)" <[email-masked]>, Dona Maria John <[email-masked]>, Vikram Agrawal <[email-masked]>, Mahalakshmi Kumar <[email-masked]>
Subject: [Lsr] Doubt regarding A bit set/unset

Hi All,

I had a query regarding setting/unsetting A bit.

https://tools.ietf.org/html/rfc8570#section-4.1 states that

A bit:  This field represents the Anomalous (A) bit.  The A bit is

      set when the measured value of this parameter exceeds its

      configured maximum threshold.  The A bit is cleared when the

      measured value falls below its configured reuse threshold.  If the

      A bit is cleared, the sub-TLV represents steady-state link

      performance.

So does it mean we have to have two configurations one for reuse and another for maximum threshold?

Will below example follow the RFC?

reuse threshold : 50 usec

maximum threshold : 100 usec

1st measured value : 110 usec

conclusion: Set A bit.

2nd measured value : 75 usec

conclusion : Do nothing (Maintain pervious state of A bit as the value is less than reuse or greater than threshold)

3rd measurement value : 30 usec

conclusion: Unset A bit.

 If we have to have two configuration for threshold to set/unset A bit, will they be different from the threshold that we use for advertisements?

Regards,
Gurusiddesh V N

.

---

From: Gurusiddesh Nidasesi <[email-masked]>
Date: Fri, 23 Apr 2021 11:02:49 +0530

Hi All.

*Gentle Reminder!*

Regards,
Gurusiddesh V N

On Mon, Apr 19, 2021 at 6:54 PM Acee Lindem (acee) <[email-masked]> wrote:

> Gurusiddesh,
>
>
>
> I’ll defer to the RFC authors on your question. However, please refrain
> from referring to bits as being “unset”. They are set or clear.
>
>
>
> Thanks,
>
> Acee
>
>
>
> *From: *Lsr <[email-masked]> on behalf of Gurusiddesh Nidasesi <
> [email-masked]>
> *Date: *Monday, April 19, 2021 at 6:13 AM
> *To: *"[email-masked]" <[email-masked]>
> *Cc: *Spencer Giacalone <[email-masked]>, Stefano Previdi <
> [email-masked]>, "Les Ginsberg (ginsberg)" <[email-masked]>,
> Dona Maria John <[email-masked]>, Vikram Agrawal <
> [email-masked]>, Mahalakshmi Kumar <
> [email-masked]>
> *Subject: *[Lsr] Doubt regarding A bit set/unset
>
>
>
> Hi All,
>
>
>

-- 
Thanks,
Gurusiddesh V N

-- 
.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 23 Apr 2021 11:21:44 +0000

Gurusiddesh –

The short answer to all your questions is “yes”.
More inline.

From: Gurusiddesh Nidasesi <[email-masked]>
Sent: Thursday, April 22, 2021 10:33 PM
To: Acee Lindem (acee) <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Les Ginsberg (ginsberg) <[email-masked]>; Dona Maria John <[email-masked]>; Vikram Agrawal <[email-masked]>; Mahalakshmi Kumar <[email-masked]>
Subject: Re: [Lsr] Doubt regarding A bit set/clear

Hi All.

Gentle Reminder!

Regards,
Gurusiddesh V N

On Mon, Apr 19, 2021 at 6:54 PM Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
Gurusiddesh,

Thanks,
Acee

From: Lsr <[email-masked]<mailto:[email-masked]>> on behalf of Gurusiddesh Nidasesi <[email-masked]<mailto:[email-masked]>>
Date: Monday, April 19, 2021 at 6:13 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Spencer Giacalone <[email-masked]<mailto:[email-masked]>>, Stefano Previdi <[email-masked]<mailto:[email-masked]>>, "Les Ginsberg (ginsberg)" <[email-masked]<mailto:[email-masked]>>, Dona Maria John <[email-masked]<mailto:[email-masked]>>, Vikram Agrawal <[email-masked]<mailto:[email-masked]>>, Mahalakshmi Kumar <[email-masked]<mailto:[email-masked]>>
Subject: [Lsr] Doubt regarding A bit set/unset

Hi All,

      performance.

[Les:] Yes. The goal is to prevent altering the advertisement due to small oscillations of the advertisement. If you had a single value then if the measured value bounced between (for example) +1/-1 of the threshold) the advertisement of the A-bit would change rapidly – this is undesirable.

So the max threshold triggers setting of the A-bit and the reuse threshold triggers clearing of the bit. The reuse threshold provides some confidence that the measurement has stabilized below the maximum anomalous threshold.

conclusion: Set A bit.

conclusion: Unset A bit.

[Les:] Yes this conforms to specified behavior.

[Les:] Yes .  This is clearly stated in Section 5:

“4.  For sub-TLVs that include an A bit, an additional threshold

       SHOULD be included corresponding to the threshold for which the

       performance is considered anomalous (and sub-TLVs with the A bit

       are sent)…”
   Les

Regards,
Gurusiddesh V N

.

--
Thanks,
Gurusiddesh V N

.

---

From: Gurusiddesh Nidasesi <[email-masked]>
Date: Fri, 23 Apr 2021 18:28:29 +0530

Hi Les,

Thank you very much for your response.
On top of your response, I have a few more queries. Please find them below.

1. For Min/Max Unidirectional Link Delay Sub-TLV, there is only one *A-bit.*

     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    |   Type        |     Length    |
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    |A| RESERVED    |                   Min Delay                   |
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    |   RESERVED    |                   Max Delay                   |
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Does this mean A-bit is applicable only for Min-delay?

IF not, then should we maintain 2 different maximum threshold and
reuse thresholds?

And if both min-delay and max-delay values fall below reuse threshold
we have clear A-bit.

Will below example follow the RFC?
min-delay reuse threshold : 50 usec
min-delay maximum threshold : 100 usec

max-delay reuse threshold : 200 usec
max-delay maximum threshold : 300 usec
*1st measured value:*

min-delay: 110 usec

max-delay: 190 usec

conclusion: Set A bit. (As min-delay value has exceeded max-threshold value?)

*2nd measured value :*

min-delay: 40 usec

max-delay: 320 usec

conclusion : Do nothing (Maintain pervious state of A bit as max-delay
value has exceeded max-threshold value?)

*3rd measured value :*

min-delay: 40 usec

max-delay: 150 usec

conclusion : Clear A bit (As both min-delay and max-delay values are
falling below resue threshold?)

Thanks & Regards,

Gurusiddesh V N

On Fri, Apr 23, 2021 at 4:51 PM Les Ginsberg (ginsberg) <[email-masked]>
wrote:

> *From:* Gurusiddesh Nidasesi <[email-masked]>
> *Sent:* Thursday, April 22, 2021 10:33 PM
> *To:* Acee Lindem (acee) <[email-masked]>
> *Cc:* [email-masked]; [email-masked]; [email-masked]; Les
> Ginsberg (ginsberg) <[email-masked]>; Dona Maria John <
> [email-masked]>; Vikram Agrawal <[email-masked]>;
> Mahalakshmi Kumar <[email-masked]>
> *Subject:* Re: [Lsr] Doubt regarding A bit set/clear
>
>
>
> Hi All.
>
>
>
> *Gentle Reminder!*
>
>
>
> Regards,
>
> Gurusiddesh V N
>
>
>
> *[Les:] Yes. The goal is to prevent altering the advertisement due to small oscillations of the advertisement. If you had a single value then if the measured value bounced between (for example) +1/-1 of the threshold) the advertisement of the A-bit would change rapidly – this is undesirable.*
>
> *So the max threshold triggers setting of the A-bit and the reuse threshold triggers clearing of the bit. The reuse threshold provides some confidence that the measurement has stabilized below the maximum anomalous threshold.*
>
>
>
>
>
> *[Les:] Yes this conforms to specified behavior.*
>
>
>
> *[Les:] **Yes . ** This is clearly stated in Section 5:*
>
>
>
> *“4.  For sub-TLVs that include an A bit, an additional threshold*
>
> *       SHOULD be included corresponding to the threshold for which the*
>
> *       performance is considered anomalous (and sub-TLVs with the A bit*
>
> *       are sent)…”*
>
> *   Les*
>
>
>
>
>
>
>
> Regards,
>
> Gurusiddesh V N
>
>
> .
>
>
>
>
> --
>
> Thanks,
>
> Gurusiddesh V N
>
>
> .
>

-- 
Thanks,
Gurusiddesh V N

-- 
.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 23 Apr 2021 13:30:07 +0000

Gurusiddesh -

From: Gurusiddesh Nidasesi <[email-masked]>
Sent: Friday, April 23, 2021 5:58 AM
To: Les Ginsberg (ginsberg) <[email-masked]>
Cc: Acee Lindem (acee) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; Dona Maria John <[email-masked]>; Vikram Agrawal <[email-masked]>; Mahalakshmi Kumar <[email-masked]>
Subject: Re: [Lsr] Doubt regarding A bit set/clear

Hi Les,

1. For Min/Max Unidirectional Link Delay Sub-TLV, there is only one A-bit.

    |   Type        |     Length    |

    |   RESERVED    |                   Max Delay                   |

[Les:] The RFC states in Section 4.2 (emphasis added):

“A bit:  This field represents the Anomalous (A) bit.  The A bit is

      set when one or more measured values exceed a configured maximum

      threshold…”

I think the rest you can figure out for yourself.

   Les

IF not, then should we maintain 2 different maximum threshold and reuse thresholds?

And if both min-delay and max-delay values fall below reuse threshold we have clear A-bit.

1st measured value:

min-delay: 110 usec

max-delay: 190 usec

2nd measured value :

min-delay: 40 usec

max-delay: 320 usec

conclusion : Do nothing (Maintain pervious state of A bit as max-delay value has exceeded max-threshold value?)

3rd measured value :

min-delay: 40 usec

max-delay: 150 usec

conclusion : Clear A bit (As both min-delay and max-delay values are falling below resue threshold?)

Thanks & Regards,

Gurusiddesh V N

On Fri, Apr 23, 2021 at 4:51 PM Les Ginsberg (ginsberg) <[email-masked]<mailto:[email-masked]>> wrote:
Gurusiddesh –

From: Gurusiddesh Nidasesi <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, April 22, 2021 10:33 PM
To: Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Les Ginsberg (ginsberg) <[email-masked]<mailto:[email-masked]>>; Dona Maria John <[email-masked]<mailto:[email-masked]>>; Vikram Agrawal <[email-masked]<mailto:[email-masked]>>; Mahalakshmi Kumar <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] Doubt regarding A bit set/clear

Hi All.

Gentle Reminder!

Regards,
Gurusiddesh V N

Thanks,
Acee

Hi All,

      performance.

conclusion: Set A bit.

conclusion: Unset A bit.

       are sent)…”
   Les

Regards,
Gurusiddesh V N

.

--
Thanks,
Gurusiddesh V N

.

--
Thanks,
Gurusiddesh V N

.

---

From: Gurusiddesh Nidasesi <[email-masked]>
Date: Fri, 23 Apr 2021 19:04:07 +0530

Hi Les,

Thanks for the quick response and confirmation.

Regards,
Gurusiddesh V N

On Fri, Apr 23, 2021 at 7:00 PM Les Ginsberg (ginsberg) <[email-masked]>
wrote:

> *Sent:* Friday, April 23, 2021 5:58 AM
> *To:* Les Ginsberg (ginsberg) <[email-masked]>
> *Cc:* Acee Lindem (acee) <[email-masked]>; [email-masked];
> [email-masked]; [email-masked]; Dona Maria John <
> 1. For *Min/Max Unidirectional Link Delay Sub-TLV, *there is only one
> *A-bit.*
>
> *[Les:] The RFC states in Section 4.2 (emphasis added):*
>
>
>
> *“A bit:  This field represents the Anomalous (A) bit.  The A bit is*
>
> *      set when one or more measured values exceed a configured maximum*
>
> *      threshold…”*
>
>
>
> *I think the rest you can figure out for yourself.*
>
>
>
> *   Les*
>
>
>
>
>
>
>
> On Fri, Apr 23, 2021 at 4:51 PM Les Ginsberg (ginsberg) <
> [email-masked]> wrote:
>
> Gurusiddesh –
>
>
>

-- 
Thanks,
Gurusiddesh V N

-- 
.