Subject: Re: [Lsr] some doubt about RFC5329 ( Traffic Engineering Extensions to OSPF Version 3)

From: "Zengmin (A)" <[email-masked]>
Date: Sun, 25 Apr 2021 06:45:04 +0000

question3：
4. Link TLV --- " The Neighbor ID sub-TLV is mandatory for OSPFv3 Traffic Engineering support. "
it means Local Interface IPv6 Address Sub-TLV is not mandatory
if only advertise : 18 - Neighbor ID (8 octets)
how to match router's TE Link TLV with peer router's TE Link TLV
[KT] Please see previous comment. The local & remote interface IDs are available in the base OSPFv3 Router-LSA description of the link and are therefore fundamental for link correlation in OSPFv3.

About get te link's local interface ID from base router lsa:

router lsa link have 3 keys：
local interface ID
neighbor interface  ID
neighbor router-id

te lsa link have 2 keys
neighbor interface  ID
neighbor router-id

It is possible router lsa have more then one link with differert local interface ID，match the same te lsa link，
(eg. when router-id conflict happen, later change the router-id to no conflict,
although the conflict senario is temporary, but it may cause the match flow very complex)

Why not consider to add an extra mandatory local interface ID sub-tlv in Intra-Area-TE LSA?

发件人: Ketan Talaulikar (ketant) [mailto:[email-masked]]
发送时间: 2021年4月20日 22:12
收件人: Zengmin (A) <[email-masked]>; [email-masked]
抄送: Gaoqiangzhou <[email-masked]>
主题: RE: [Lsr] some doubt about RFC5329 ( Traffic Engineering Extensions to OSPF Version 3)

Hello,

Please check inline below.

From: Lsr <[email-masked]<mailto:[email-masked]>> On Behalf Of Zengmin (A)
Sent: 20 April 2021 07:41
To: [email-masked]<mailto:[email-masked]>
Cc: Gaoqiangzhou <[email-masked]<mailto:[email-masked]>>
Subject: [Lsr] some doubt about RFC5329 ( Traffic Engineering Extensions to OSPF Version 3)

Hi ALL,

In RFC5329, OSPFv3 TE Link TLV have below sub-TLVs
18 - Neighbor ID (8 octets) ： Neighbor Interface ID ， Neighbor Router ID
19 - Local Interface IPv6 Address
20 - Remote Interface IPv6 Address

question1：
4.4. Remote Interface IPv6 Address Sub-TLV
if link-LSA not have a prefix length of 128 and the LA-bit
how to get remote Interface ipv6 address to fill the tlv value.
[KT] I believe the LA-bit is required, the prefix length of 128 is not a must-have. If the remote address cannot be determined then there is no issue – it is possible that links have only link-local addresses.

question2：
if router only advertise :
18 - Neighbor ID (8 octets) ： Neighbor Interface ID ， Neighbor Router ID
19 - Local Interface IPv6 Address
how to match router's TE Link TLV with peer router's TE Link TLV
[KT] Matching is done using the interface-IDs in OSPFv3. This is something that is always there and available unlike IPv6 local/remote addresses which are optional (e.g. when links have link-local addressing only).

question3：
4. Link TLV --- " The Neighbor ID sub-TLV is mandatory for OSPFv3 Traffic Engineering support. "
it means Local Interface IPv6 Address Sub-TLV is not mandatory
if only advertise : 18 - Neighbor ID (8 octets)
how to match router's TE Link TLV with peer router's TE Link TLV
[KT] Please see previous comment. The local & remote interface IDs are available in the base OSPFv3 Router-LSA description of the link and are therefore fundamental for link correlation in OSPFv3.

Thanks,
Ketan

Thanks,
Jenny

In section 4 Link TLV：

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sun, 25 Apr 2021 11:44:41 +0000

Hi Jenny,

From: Lsr <[email-masked]> on behalf of "Zengmin (A)" <[email-masked]>
Date: Sunday, April 25, 2021 at 2:45 AM
To: "[email-masked]" <[email-masked]>
Subject: Re: [Lsr] some doubt about RFC5329 ( Traffic Engineering Extensions to OSPF Version 3)

question3：

te lsa link have 2 keys
neighbor interface  ID
neighbor router-id

How is this possible? The neighbor interface ID will be unique for the <neighbor router ID, neighbor interface ID> tuple.

Thanks,
Acee

Hello,

Hi ALL,

question1：

question2：

question3：

Thanks,
Ketan

Thanks,
Jenny

In section 4 Link TLV：