Subject: [Lsr] questions about draft-ietf-lsr-flex-algo-bw-con-01

From: Linda Dunbar <[email-masked]>
Date: Thu, 16 Sep 2021 19:27:50 +0000

Shraddha, Bill, Rajesh, Bruno, Peter, and Tony,

Is it correct that the intent of the draft is to prevent some "elephant flows" from being placed over certain links?

Section 2.1 listed the TLV for the ISIS Generic Metric

Is the property of preventing some flows being placed on a link to be encoded in the Value field of the ISIS Generic Metric  in Section 2.1?

Why not directly included in the value field of Flex Algo TLV?  Section 2.3 says that using FAPM sub-TLV to indicate Flex Algo needs to use the Generic Metric. But this property of preventing some flows to be placed on certain links doesn't need to be generic, does it?

How does an IGP node know which link to advertise this property? Is it by configuration?

Linda Dunbar

From: Acee Lindem (acee) <[email-masked]>
Sent: Wednesday, September 15, 2021 4:30 PM
To: Linda Dunbar <[email-masked]>; Tony Li <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>
Cc: Acee Lindem (acee) <acee=[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Lsr] draft-ietf-lsr-flex-algo

Hi Linda, Tony,

From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, September 15, 2021 at 3:45 PM
To: Tony Li <[email-masked]<mailto:[email-masked]>>, "Peter Psenak (ppsenak)" <[email-masked]<mailto:[email-masked]>>
Cc: "Acee Lindem (acee)" <acee=[email-masked]<mailto:acee=[email-masked]>>, Acee Lindem <[email-masked]<mailto:[email-masked]>>, Bruno Decraene <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Lsr] draft-ietf-lsr-flex-algo

Tony,

Answers are inserted below:

From: Tony Li <[email-masked]<mailto:[email-masked]>> On Behalf Of Tony Li
Sent: Wednesday, September 15, 2021 1:26 PM
To: Peter Psenak <[email-masked]<mailto:[email-masked]>>
Cc: Acee Lindem (acee) <acee=[email-masked]<mailto:acee=[email-masked]>>; Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>>; Linda Dunbar <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Lsr] draft-ietf-lsr-flex-algo

On Sep 15, 2021, at 11:17 AM, Peter Psenak <[email-masked]<mailto:[email-masked]>> wrote:

So, if someone wants to define new constraints (e.g., Linda's server/application metrics), they would need to define the semantics and encodings similar to what is being done for bandwidth metrics in https://datatracker.ietf.org/doc/draft-ietf-lsr-flex-algo-bw-con/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-flex-algo-bw-con%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C5b92535cbd7e4501dadd08d978900d0d%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637673382361243040%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=%2Bvy%2FOpJOrTO3zhdZ16p3iNo2yD%2F4LkrJWShiDoU3z7o%3D&reserved=0> . Then the flex algos could be defined using these metrics. Correct?

yes, they would need to define a new FAD constraint and/or metric only.

I agree that if the goal is a new metric, then that's sufficient.  [Plug for generic metrics.]

It sounded a bit like Linda was wanting a fundamental change to the SPF algorithm.  If, so, I believe that would require a new Calc-Type. Linda, could you please clarify?
[Linda] I don't think so. We want a constrained SPF algorithm that take into additional metrics. Just like TE being added into the SPF.

I was thinking that as well. These metrics would be defined to have precedence over the path cost - sort of like OSPF Type 2 external metrics do for OSPF AS External routes.

Thanks,
Acee

Linda Dunbar

Tony

---

From: Tony Li <[email-masked]>
Date: Thu, 16 Sep 2021 12:56:50 -0700

Hi Linda,

> Is it correct that the intent of the draft is to prevent some “elephant flows” from being placed over certain links?

I would phrase it somewhat differently.

One of the goals of the draft is to allow network operators to define a minimum bandwidth threshold for a FlexAlgo topology.  If you know that you have 200Gb/s flows, then you might well want to ensure that they are placed on 400Gb/s links (or greater). You would then route your ‘elephant flows’ on your ‘elephant topology’.

Another goal is to allow operators to cause SPF to follow a metric other than the best-effort or TE metric.  One application might well be to assign metrics based on bandwidth, causing flows to travel along the highest bandwidth paths.  We are not proposing changing SPF, so it will still optimize for the cumulative metric to the destination, so the result will be the lowest cumulative metric, which is not necessarily just the absolute maximum of link bandwidths.

> Is the property of preventing some flows being placed on a link to be encoded in the Value field of the ISIS Generic Metric  in Section 2.1?

No.  Constraints on the topology are done with the “Exclude Minimum Bandwidth” and “Maximum Delay” TLVs and are orthogonal to the metric.

> Why not directly included in the value field of Flex Algo TLV?  

I’m not sure I understand the question, forgive me if this doesn’t address your question.  Metrics need to attached to links.  Thus, they need to be advertised as part of the ASLA TLV. Constraints on the topology are part of the description of the algorithm itself and belong to the FlexAlgo Definition TLV.

> Section 2.3 says that using FAPM sub-TLV to indicate Flex Algo needs to use the Generic Metric. But this property of preventing some flows to be placed on certain links doesn’t need to be generic, does it? 

Again, they are orthgonal.  The generic metric may be used with a leaked prefix by carrying it in the FAPM. This does NOT constrain the topology.

> How does an IGP node know which link to advertise this property? Is it by configuration?

The IGP would know to advertise topology constraints for an algorithm by administrative configuration.  Link attributes are also typically configured on a per-link basis and advertised by the IGP.

Tony

---

From: Shraddha Hegde <[email-masked]>
Date: Thu, 23 Sep 2021 10:39:06 +0000

Hi Linda,

I read your draft draft-dunbar-lsr-5g-edge-compute.
>From my understanding you are using various parameters such as capacity index, preference,network delay etc
To derive a metric. You want to use this derived metric for SPF computation.

My suggestion would be to define new standard metric under generic metric called
"Edge computing metric". This metric would be similar to "bandwidth metric " defined in
draft-ietf-lsr-flex-algo-bw-con. This edge computing metric will be computed based on various advertised
parameters (similar to bandwidth metric which is computed based on link-bandwidth).
A flex-algo can then be used to compute using metric-type "Edge computing metric".

Rgds
Shraddha

Juniper Business Use Only
From: Lsr <[email-masked]> On Behalf Of Linda Dunbar
Sent: Friday, September 17, 2021 12:58 AM
To: Acee Lindem (acee) <[email-masked]>; Tony Li <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>
Cc: [email-masked]; [email-masked]; Acee Lindem (acee) <acee=[email-masked]>
Subject: [Lsr] questions about draft-ietf-lsr-flex-algo-bw-con-01

[External Email. Be cautious of content]

Linda Dunbar

From: Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, September 15, 2021 4:30 PM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; Tony Li <[email-masked]<mailto:[email-masked]>>; Peter Psenak (ppsenak) <[email-masked]<mailto:[email-masked]>>
Cc: Acee Lindem (acee) <acee=[email-masked]<mailto:acee=[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Lsr] draft-ietf-lsr-flex-algo

Hi Linda, Tony,

Tony,

So, if someone wants to define new constraints (e.g., Linda's server/application metrics), they would need to define the semantics and encodings similar to what is being done for bandwidth metrics in https://datatracker.ietf.org/doc/draft-ietf-lsr-flex-algo-bw-con/<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-ietf-lsr-flex-algo-bw-con*2F&data=04*7C01*7Clinda.dunbar*40futurewei.com*7C5b92535cbd7e4501dadd08d978900d0d*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C0*7C637673382361243040*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=*2Bvy*2FOpJOrTO3zhdZ16p3iNo2yD*2F4LkrJWShiDoU3z7o*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!XpHrOqWnYWMc805FAvf4iN-4Fb7MxNhxNRTQ2p94eWcBZuoBEWo8hTKOJSY-LUDB$> . Then the flex algos could be defined using these metrics. Correct?

Thanks,
Acee

Linda Dunbar

Tony

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 23 Sep 2021 15:08:57 +0000

Shraddha,

Thank you very much for the suggestion.

Should the "Edge computing metric" be a value in Metric-Type of the FlexAlgo Sub-TLV?
Can multiple sub-sub-TLV carried by the  FlexAlgo SubTLV indicate different metric-types?  If YES, the individual metrics sub-subTLV has its own Metrics Type, which can be different from the Metric-Type of the FlexAlgo Sub-TLV.  Is it a problem?

I am still not clear the different purpose of "Flex-Algorithm" and "Calc-Type". Can someone give an example?

We will update the draft per Acee's and your suggestion to encode the 5G EC servers running environment metrics in the Flexalgo advertisement.

Thank you.

Linda

From: Shraddha Hegde <[email-masked]>
Sent: Thursday, September 23, 2021 5:39 AM
To: Linda Dunbar <[email-masked]>; Acee Lindem (acee) <[email-masked]>; Tony Li <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>
Cc: [email-masked]; [email-masked]; Acee Lindem (acee) <acee=[email-masked]>
Subject: RE: questions about draft-ietf-lsr-flex-algo-bw-con-01

Hi Linda,

Rgds
Shraddha

Juniper Business Use Only
From: Lsr <[email-masked]<mailto:[email-masked]>> On Behalf Of Linda Dunbar
Sent: Friday, September 17, 2021 12:58 AM
To: Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>>; Tony Li <[email-masked]<mailto:[email-masked]>>; Peter Psenak (ppsenak) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Acee Lindem (acee) <acee=[email-masked]<mailto:acee=[email-masked]>>
Subject: [Lsr] questions about draft-ietf-lsr-flex-algo-bw-con-01

Linda Dunbar

Hi Linda, Tony,

Tony,

So, if someone wants to define new constraints (e.g., Linda's server/application metrics), they would need to define the semantics and encodings similar to what is being done for bandwidth metrics in https://datatracker.ietf.org/doc/draft-ietf-lsr-flex-algo-bw-con/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-ietf-lsr-flex-algo-bw-con*2F%26data%3D04*7C01*7Clinda.dunbar*40futurewei.com*7C5b92535cbd7e4501dadd08d978900d0d*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C0*7C637673382361243040*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3D*2Bvy*2FOpJOrTO3zhdZ16p3iNo2yD*2F4LkrJWShiDoU3z7o*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!XpHrOqWnYWMc805FAvf4iN-4Fb7MxNhxNRTQ2p94eWcBZuoBEWo8hTKOJSY-LUDB%24&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C139456e340344c6efff508d97e7e6286%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637679903574821488%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=4TMORatu0qBbRPauLB6YY9LmKkSwW9Ar7KEWRRC33SQ%3D&reserved=0> . Then the flex algos could be defined using these metrics. Correct?

Thanks,
Acee

Linda Dunbar

Tony

---

From: Shraddha Hegde <[email-masked]>
Date: Thu, 23 Sep 2021 16:21:29 +0000

Hi Linda,

Pls see inline..

Juniper Business Use Only
From: Linda Dunbar <[email-masked]>
Sent: Thursday, September 23, 2021 8:39 PM
To: Shraddha Hegde <[email-masked]>; Acee Lindem (acee) <[email-masked]>; Tony Li <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>
Cc: [email-masked]; [email-masked]; Acee Lindem (acee) <acee=[email-masked]>
Subject: RE: questions about draft-ietf-lsr-flex-algo-bw-con-01

Shraddha,

Should the "Edge computing metric" be a value in Metric-Type of the FlexAlgo Sub-TLV?
<Shraddha> metric-type is carried in Flex-algo Definition FAD sub-TLV.

Can multiple sub-sub-TLV carried by the  FlexAlgo SubTLV indicate different metric-types?
<Shraddha> For one flex-algo there can be only  FAD sub-TLV and one metric-type.
Flex-algo SPF will be computed based on that metric-type.

If YES, the individual metrics sub-subTLV has its own Metrics Type, which can be different from the Metric-Type of the FlexAlgo Sub-TLV.  Is it a problem?
<shraddha> No. Multiple metric-types in one flex-algo is not allowed.
Why would you want to send multiple metric-types?

I am still not clear the different purpose of "Flex-Algorithm" and "Calc-Type". Can someone give an example?
<Shraddha> Flex-algo basically runs an algorithm on a given topology to find paths. The algorithm is identified by
Calc-type. Currently only SPF algorithm is supported. If you want to run any different algorithm you have to
Define new calc-type. From your draft it appeared to me that you will be running SPF algorithm on this new type of metric. Is that right?

Thank you.

Linda

From: Shraddha Hegde <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, September 23, 2021 5:39 AM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>>; Tony Li <[email-masked]<mailto:[email-masked]>>; Peter Psenak (ppsenak) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Acee Lindem (acee) <acee=[email-masked]<mailto:acee=[email-masked]>>
Subject: RE: questions about draft-ietf-lsr-flex-algo-bw-con-01

Hi Linda,

Rgds
Shraddha

Linda Dunbar

Hi Linda, Tony,

Tony,

So, if someone wants to define new constraints (e.g., Linda's server/application metrics), they would need to define the semantics and encodings similar to what is being done for bandwidth metrics in https://datatracker.ietf.org/doc/draft-ietf-lsr-flex-algo-bw-con/<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Furldefense.com*2Fv3*2F__https*3A*2Fnam11.safelinks.protection.outlook.com*2F*3Furl*3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-ietf-lsr-flex-algo-bw-con*2F*26data*3D04*7C01*7Clinda.dunbar*40futurewei.com*7C5b92535cbd7e4501dadd08d978900d0d*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C0*7C637673382361243040*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000*26sdata*3D*2Bvy*2FOpJOrTO3zhdZ16p3iNo2yD*2F4LkrJWShiDoU3z7o*3D*26reserved*3D0__*3BJSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!XpHrOqWnYWMc805FAvf4iN-4Fb7MxNhxNRTQ2p94eWcBZuoBEWo8hTKOJSY-LUDB*24&data=04*7C01*7Clinda.dunbar*40futurewei.com*7C139456e340344c6efff508d97e7e6286*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C0*7C637679903574821488*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=4TMORatu0qBbRPauLB6YY9LmKkSwW9Ar7KEWRRC33SQ*3D&reserved=0__;JSUlJSUlJSUlJSoqKioqKiUlKioqKioqKioqKioqJSUqKioqJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!XvlwMd3QCxSY5HCSQz3txvgkDlTpkdKcesAG2g7oAhwn1v5J4YRwkd-vmaMU81yb$> . Then the flex algos could be defined using these metrics. Correct?

Thanks,
Acee

Linda Dunbar

Tony