Subject: Re: [Lsr] draft-decraeneginsberg-lsr-isis-fast-flooding-00

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 22 Oct 2021 16:36:41 +0000

Thanks Bruno, Les, Tony Li, and Guillaume Solignac for your work on the merged draft. Also thanks to Tony Przygienda and Peter Psenak who participated in the merged draft discussions. 

I plan to review it this weekend and would ask other WG members to read as well. 

Thanks,
Acee 

On 10/22/21, 9:10 AM, "Lsr on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    Dear all,

    During LSR interim meeting on September 29th [0] authors of draft-decraene-lsr-isis-flooding-speed [1] and draft-ginsberg-lsr-isis-flooding-scale [2] agreed to work together and publish a common combined draft by October 25 [3].

    New draft has been published today [4]. As presented during the interim, it's scope is:
    - Define new TLV supporting:
    -- InterfaceLSPReceiveWindow (RWIN)
    -- LSP/PSNPThreshold(LPP)
    -- partialSNPInterval(milliseconds)
    -- Extensible to advertise other values
    - TLV supported in IIHs and PSNPs

    This provides tools for multiple solutions and the draft informatively describes two algorithm as examples.

    Review and comments is more than welcome.

    Thanks,
    Regards,
    Authors

    [0] https://datatracker.ietf.org/wg/lsr/meetings/
    [1] https://datatracker.ietf.org/doc/html/draft-decraene-lsr-isis-flooding-speed
    [2] https://datatracker.ietf.org/doc/html/draft-ginsberg-lsr-isis-flooding-scale
    [3] https://datatracker.ietf.org/meeting/interim-2021-lsr-01/materials/slides-interim-2021-lsr-01-sessa-1-joint-statement-00.pdf
    [4] https://datatracker.ietf.org/doc/html/draft-decraeneginsberg-lsr-isis-fast-flooding

    Orange Restricted

    -----Original Message-----
    From: [email-masked] <[email-masked]> 
    Sent: Friday, October 22, 2021 10:55 AM
    To: DECRAENE Bruno INNOV/NET <[email-masked]>; Chris Bowers <[email-masked]>; Guillaume Solignac <[email-masked]>; Gunter Van de Velde <[email-masked]>; Les Ginsberg <[email-masked]>; Marek Karasek <[email-masked]>; Peter Psenak <[email-masked]>; Tony Li <[email-masked]>; Tony Przygienda <[email-masked]>
    Subject: New Version Notification for draft-decraeneginsberg-lsr-isis-fast-flooding-00.txt

    A new version of I-D, draft-decraeneginsberg-lsr-isis-fast-flooding-00.txt
    has been successfully submitted by Bruno Decraene and posted to the
    IETF repository.

    Name:		draft-decraeneginsberg-lsr-isis-fast-flooding
    Revision:	00
    Title:		IS-IS Fast Flooding
    Document date:	2021-10-22
    Group:		Individual Submission
    Pages:		24
    URL:            https://www.ietf.org/archive/id/draft-decraeneginsberg-lsr-isis-fast-flooding-00.txt
    Status:         https://datatracker.ietf.org/doc/draft-decraeneginsberg-lsr-isis-fast-flooding/
    Htmlized:       https://datatracker.ietf.org/doc/html/draft-decraeneginsberg-lsr-isis-fast-flooding

    Abstract:
       Current Link State Protocol Data Unit (PDU) flooding rates are much
       slower than what modern networks can support.  The use of IS-IS at
       larger scale requires faster flooding rates to achieve desired
       convergence goals.  This document discusses the need for faster
       flooding, the issues around faster flooding, and some example
       approaches to achieve faster flooding.  It also defines protocol
       extensions relevant to faster flooding.

    The IETF Secretariat

    _________________________________________________________________________________________________________________________

    Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
    pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
    a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
    Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

    This message and its attachments may contain confidential or privileged information that may be protected by law;
    they should not be distributed, used or copied without authorisation.
    If you have received this email in error, please notify the sender and delete this message and its attachments.
    As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
    Thank you.

    _______________________________________________
    Lsr mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/lsr

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 28 Oct 2021 21:45:49 +0000

I reviewed the draft and believe it is ready for WG adoption. From my perspective, it is pretty clear other than that the congestion control algorithm wasn't intuitive. However, that could be due to my unfamiliarity with "TCP Congestion Control" as described in RFC 5681. We plan to start a WG adoption poll at the IETF 112 LSR meeting. 

Please read as well as the other drafts on the IETF 112 agenda - https://datatracker.ietf.org/meeting/112/session/lsr

Thanks,
Acee

On 10/22/21, 12:38 PM, "Lsr on behalf of Acee Lindem (acee)" <[email-masked] on behalf of acee=[email-masked]> wrote:

    Thanks,
    Acee 

        Dear all,

        Thanks,
        Regards,
        Authors

        Orange Restricted

        -----Original Message-----
        From: [email-masked] <[email-masked]> 
        Sent: Friday, October 22, 2021 10:55 AM
        To: DECRAENE Bruno INNOV/NET <[email-masked]>; Chris Bowers <[email-masked]>; Guillaume Solignac <[email-masked]>; Gunter Van de Velde <[email-masked]>; Les Ginsberg <[email-masked]>; Marek Karasek <[email-masked]>; Peter Psenak <[email-masked]>; Tony Li <[email-masked]>; Tony Przygienda <[email-masked]>
        Subject: New Version Notification for draft-decraeneginsberg-lsr-isis-fast-flooding-00.txt

        Abstract:

        The IETF Secretariat