Subject: [Lsr] Is it necessary for OSPF and ISIS to have different FAD Constraint Sub-TLV in draft-ietf-lsr-flex-algo-bw-con-1?

From: Linda Dunbar <[email-masked]>
Date: Tue, 5 Oct 2021 02:59:06 +0000

Shraddha, Bill, Rajesh, Bruno, Peter, and Tony:

draft-ietf-lsr-flex-algo-bw-con-1 has two different sub-TLVs for ISIS FAD Constraint and OSPF FAD constraint. But the only differences are:

  *   ISIS Exclude Minimum Bandwidth sub-TLV has one octet for Type and Length
  *   OSPF Exclude Minimum Bandwidth sub-TLV has two octets for Type and Length

Why can't just have one Exclude Minimum Bandwidth sub-TLV to be used for both ISIS and OSPF FlexAlgo?

Thank you very much,
Linda Dunbar

---

From: Shraddha Hegde <[email-masked]>
Date: Tue, 5 Oct 2021 03:50:11 +0000

Linda,

The ISIS and OSPF sub-TLVs are following the base ISIs and OSPF su-TLV structures.
In ISIS it's always 1 octet for type and length each and in OSPF it is 2 otctets each.
This will help maintain the consistency of protocol processing.

Hope that clarifies
Rgds
Shraddha

Juniper Business Use Only
From: Linda Dunbar <[email-masked]>
Sent: Tuesday, October 5, 2021 8:29 AM
To: [email-masked]
Cc: [email-masked]
Subject: Is it necessary for OSPF and ISIS to have different FAD Constraint Sub-TLV in draft-ietf-lsr-flex-algo-bw-con-1?

[External Email. Be cautious of content]

Thank you very much,
Linda Dunbar