Subject: XSD Schema considerations

From: "Jesus Maria Mendez Perez" <[email-masked]>
Date: Tue, 18 Nov 2008 09:34:19 +0100

Hello,

I have checked lastest versions of LTANS drafts, and i have some questions
about xsd´s schemas.

In xmlers.xsd, inside EvidenceRecord element we can add this new elements to
save up certificates and information of revocation.

<xsd:element name="KeyInfo" type="ds:KeyInfoType"/>  ----- defined in
xmldisg-core-schema.xsd
<xsd:element name="CompleteRevocationRefs"
type="xa:CompleteRevocationRefsType"/> ----- defined in XAdES.xsd

and change the complextype TimeStamp

<xsd:complexType name="TimeStamp">
       <xsd:sequence>
            <xsd:any namespace="##other" minOccurs="0"
maxOccurs="unbounded"/>
       </xsd:sequence>
   </xsd:complexType>

by this which is defined in oasis-dss-core-schema-v1.0-os.xsd:

<xsd:complexType name="TimeStampType">
        <xsd:choice>
            <xsd:element ref="ds:Signature"/>
            <xsd:element name="RFC3161TimeStampToken"
type="xsd:base64Binary"/>
            <xsd:element name="Other" type="tn:AnyType"/>
        </xsd:choice>
</xsd:complexType>

<xsd:complexType name="AnyType">
        <xsd:sequence>
            <xsd:any processContents="lax" minOccurs="0"
maxOccurs="unbounded"/>
        </xsd:sequence>
</xsd:complexType>

I want to know your opinion about these changes.

Thanks.

---

From: TSG <[email-masked]>
Date: Tue, 18 Nov 2008 08:00:43 -0800

Jesus Maria Mendez Perez wrote:
> Hello,
>
> I have checked lastest versions of LTANS drafts, and i have some 
> questions about xsd´s schemas.
>
> In xmlers.xsd, inside EvidenceRecord element we can add this new 
> elements to save up certificates and information of revocation.
>

What are the specific use models intended? It will make a difference. 
There is no one-size-fits-all type of evidence container yet, so the use 
models are specific to the evidence structures.

Also any use model must be brought into alignment with the US Federal 
Rules of Evidence's five-point test for determining the strength and 
admissibility of the data contained therein, otherwise this is just 
another IETF game which will not produce a legally defensible data model 
IMHO.
>
> Thanks.
>
>
>
>
>
> ------------------------------------------------------------------------
>
>
> Internal Virus Database is out of date.
> Checked by AVG - http://www.avg.com 
> Version: 8.0.175 / Virus Database: 270.9.0/1779 - Release Date: 11/10/2008 7:53 AM
>
>