Subject: [ltans] I-D Action:draft-ietf-ltans-dssc-12.txt

From: [email-masked]
Date: Wed, 30 Sep 2009 01:00:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Long-Term Archive and Notary Services Working Group of the IETF.

	Title           : Data Structure for the Security Suitability of Cryptographic Algorithms (DSSC)
	Author(s)       : T. Kunz, et al.
	Filename        : draft-ietf-ltans-dssc-12.txt
	Pages           : 48
	Date            : 2009-09-30

Since cryptographic algorithms can become weak over the years, it is
necessary to evaluate their security suitability.  When signing or
verifying data, or when encrypting or decrypting data, these
evaluations must be considered.  This document specifies a data
structure that enables an automated analysis of the security
suitability of a given cryptographic algorithm at a given point of
time which may be in the past, at the present time or in the
future.Conventions used in this document

The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
"SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in this
document are to be interpreted as described in [RFC2119].

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ltans-dssc-12.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: <[email-masked]>
Date: Wed, 30 Sep 2009 16:10:57 +0200

Hi all,
there are some clashes in the ASN.1 code of the draft that prevents to use it with e.g. RFC3280/RFC5280.

1.
The Draft defines
-- Extension ::= SEQUENCE {
--   extensionType           OBJECT IDENTIFIER,
--   extension               ANY DEFINED BY extensionType
--   }

which has a (presumably better defined) twin in RFC5280:
Extension  ::=  SEQUENCE  {
     extnID      OBJECT IDENTIFIER,
     critical    BOOLEAN DEFAULT FALSE,
     extnValue   OCTET STRING
                 -- contains the DER encoding of an ASN.1 value
                 -- corresponding to the extension type identified
                 -- by extnID
     }

I suggest to import the type Extension from PKIX1Explicit88. Please take into account that already since 1997 the ASN.1 types ANY/ANY DEFINED BY are deprecated (http://www.itu.int/ITU-T/studygroups/com07/changing-ASN.html).

2. 
The Draft defines
-- Validity ::= SEQUENCE {
--   start  [0] GeneralizedTime OPTIONAL,
--   end    [1] GeneralizedTime OPTIONAL
--   }

which clashes also with a twin in RFC3280/RFC5280:

Validity ::= SEQUENCE {
     notBefore      Time,
     notAfter       Time  }

It seems to me that this is based on a misunderstanding already in section 1.1 (Motivation)

   Cryptographic algorithms that are used in signatures shall be
   selected to resist such attacks during their period of use.  For
   signature keys included in public key certificates, it is the
   validity period of the certificate.  Cryptographic algorithms that
   are used for encryption shall resist during the time during which it
   is planned to keep the information confidential.

The validity period of a certificate is primarily *not* a period where resistance against attacks is assured but "is the time interval during which the CA warrants that it will maintain information about the status of the certificate". If the signatures are made in a authentication context, then the validity is almost the same as the usage time. But if the signatures are related to a non-repudiation context then the documented in the certificate validity time may be longer then predicted at time of certificate generation. If the algorithm becomes weaker then the certificate can be easily revoked, which reduces the "usage time" immediately, leaving the "warranty time" unchanged. If on the other side it turned out that the algorithm is harder than predicted, it is not necessary to revoke the certificate based on a still secure algorithm.

Just another thought: For a certificate the dates notBefore and notAfter make sense. But how we understand the notBefore date for algorithm resistance? A certificate may become valid later, but how a weak algorithm may become hard after a while?

I would suggest to remove the Validity type and replace it by a single notAfter date.

Regards,
Ernst.
--
	Ernst G Giessmann
	T-Systems Enterprise Services GmbH
	ICT Operations
	Security and Smart Card Solutions
	Goslarer Ufer 35, D-10589 Berlin
	tel:+49-30-3497-4342

Legal Notice
T-Systems Enterprise Services GmbH
Supervisory Board: René Obermann (Chairman)
Executive Committee: Reinhard Clemens (Chairman), 
Dr. Ferri Abolhassan, Olaf Heyden, Joachim Langmack, 
Dr. Matthias Schuster, Klaus Werner

Commercial Register: Amtsgericht Frankfurt am Main, HRB 55933
Registered Office: Frankfurt am Main
WEEE-Reg.-No. DE87523644

Importante Notice: 
If you received this transmittal in error, please notify us 
immediately, and delete this message and its attachments. 
Thank you.

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] 
> Im Auftrag von [email-masked]
> Gesendet: Mittwoch, 30. September 2009 10:00
> An: [email-masked]
> Cc: [email-masked]
> Betreff: [ltans] I-D Action:draft-ietf-ltans-dssc-12.txt
> 
> 	Title           : Data Structure for the Security 
> Suitability of Cryptographic Algorithms (DSSC)
> Since cryptographic algorithms can become weak over the 
> years, it is necessary to evaluate their security 
> suitability.  When signing or verifying data, or when 
> encrypting or decrypting data, these evaluations must be 
> considered.  This document specifies a data structure that 
> enables an automated analysis of the security suitability of 
> a given cryptographic algorithm at a given point of time 
> which may be in the past, at the present time or in the 

...
> http://www.ietf.org/internet-drafts/draft-ietf-ltans-dssc-12.txt
...

---

From: Bill Russell <[email-masked]>
Date: Wed, 30 Sep 2009 11:39:11 -0400

I propose that we just change the name in our draft but keep the new definitions. For the Validity, GeneralizedTime IMHO is better than Time, since the current year would still code as UTCTime as part of that def (making it a two digit year rather than four until something like 2050). And, if there is no use for a criticality field, there is no sense in reusing that definition for extensions.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, September 30, 2009 10:11 AM
To: [email-masked]
Subject: Re: [ltans] I-D Action:draft-ietf-ltans-dssc-12.txt

Hi all,

1.
The Draft defines

2. 
The Draft defines

Validity ::= SEQUENCE {
     notBefore      Time,
     notAfter       Time  }

Regards,
Ernst.

Legal Notice

Importante Notice: 

...
> http://www.ietf.org/internet-drafts/draft-ietf-ltans-dssc-12.txt
...
_______________________________________________
ltans mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltans

---

From: "Carl Wallace" <[email-masked]>
Date: Wed, 30 Sep 2009 16:21:35 -0400

I think the name change suggestion is fine.  This can be handled during the AUTH48 period for this draft, which cleared IESG review today as this draft addressed the last of the issues.

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Bill Russell
> Sent: Wednesday, September 30, 2009 11:39 AM
> To: [email-masked]; [email-masked]
> I propose that we just change the name in our draft but keep the new
> definitions. For the Validity, GeneralizedTime IMHO is better than
> Time, since the current year would still code as UTCTime as part of
> that def (making it a two digit year rather than four until something
> like 2050). And, if there is no use for a criticality field, there is
> no sense in reusing that definition for extensions.
> 
> I suggest to import the type Extension from PKIX1Explicit88. Please
> take into account that already since 1997 the ASN.1 types ANY/ANY
> DEFINED BY are deprecated (http://www.itu.int/ITU-
> T/studygroups/com07/changing-ASN.html).
> 
> 
> 2.
> The Draft defines
> The validity period of a certificate is primarily *not* a period where
> resistance against attacks is assured but "is the time interval during
> which the CA warrants that it will maintain information about the
> status of the certificate". If the signatures are made in a
> authentication context, then the validity is almost the same as the
> usage time. But if the signatures are related to a non-repudiation
> context then the documented in the certificate validity time may be
> longer then predicted at time of certificate generation. If the
> algorithm becomes weaker then the certificate can be easily revoked,
> which reduces the "usage time" immediately, leaving the "warranty time"
> unchanged. If on the other side it turned out that the algorithm is
> harder than predicted, it is not necessary to revoke the certificate
> based on a still secure algorithm.
> 
> Just another thought: For a certificate the dates notBefore and
> notAfter make sense. But how we understand the notBefore date for
> algorithm resistance? A certificate may become valid later, but how a
> weak algorithm may become hard after a while?
>