Subject: RE: [Ltru] Great Script Debate Part II: Formats...

From: "L.Gillam" <[email-masked]>
Date: Wed, 13 Apr 2005 16:45:27 +0100

I wonder what the most used 2nd (i.e. non-native spoken/written) 
language in the world happens to be, which helps people to discuss
where discussion may otherwise be limited?

"language is the first and basic social contract of a nation"
"printf("$stringNN") is not a programer reflex"
These two statements, and the rest of what you've written, is
impenetrable.

http://minc.org? 

Perhaps http://www.minc.org/WG/arabic/ and the key arabic language 
documents for IDN deployment may help you?

Perhaps a look at their history will help you?

"After years of working on the multilingualisation of Internet content and software with the vision of lowering linguistic barriers for non-native English speakers of the Asian region, his attention was drawn towards the naming problem. 
..
Whereas content in the Internet was rapidly proliferating in native languages, the URLs, email addresses, hostnames and domain names, still did not support multilingual scripts. "

They seem to have identified particular needs and have no trouble that I can see with existing ISO standards.

NB, though, "The Arabic working group does not have the mandate to look 
    after larger issues with regards to the Arabic language and 
    the Internet such as Arabicisation of ISO 3166, keyboard input, 
    Arabic internet glossary, and many other Arabic language IT issues."

> -----Original Message-----
> From: JFC (Jefsey) Morfin [mailto:[email-masked]]
> Sent: 13 April 2005 14:27
> To: Gillam L Dr (Computing)
> Cc: ltru Working Group
> Subject: RE: [Ltru] Great Script Debate Part II: Formats...
> 
> 
> Dear L.Guillam,
> this certainly is a right of everyone - and a possibility and 
> a certain 
> work. This is the same as for 10646: building a list of name of usage 
> correcting or adapting the 100646 names to the reality of 
> usage. And be 
> sure this is exactly what we are working on as a prototype CRC.
> 
> What I oppose in "your" position, is four things: dominance, 
> lack of QA, 
> complexity, inconsistency, decency. Since you certainly do 
> not see where 
> let me explain again.
> 
> - dominance is not good because it is not appropriate to the network 
> architecture. Since Paul Bahan in the 60s and the work 
> carried in the 80s 
> we know that networks can be centralized by a dominance, 
> decentralised by a 
> governance, distributed by an intergovernance. These are natural 
> interest/forces/solutions which are the very architecture of 
> every network. 
> They mostly result of their granularity, which means for wide 
> systems of 
> their density. Today the internet itself which started in a 
> centralised 
> development phase (mid 80s) to a decentralised deployment 
> phase (mid 90s) 
> enter its distributed scalability phase. Dominance concepts 
> (IANA, ICANN, 
> ASCII, English) were until now acceptable as only "old". They become 
> progressively totally outdated and an architectural flaw more 
> and more 
> people and concept will oppose and already suffer from. The idea of a 
> reviewer in English for the language of the world, was a 
> bizarre oddity, it 
> is becoming an unacceptable bug.
> 
> - lack of QA results from abandon of cross culture control 
> and protection. 
> Look at the ieft-languages list and at this list. How many people of 
> English/non English culture/mother tongue when we are 
> precisely discussing 
> languages and cultures. Look at the number of represented 
> nationalities 
> when you know (and this is what is precisely discussed and 
> acknowledged 
> through the ISO 3166 country codes) a language is the first and basic 
> social contract of a nation. I am not interested here in 
> politics but in 
> quality. Look at the number of wrong 10646 names in spite of all the 
> accumulated efforts. Look at the ietf-languages lists which 
> doubled the 
> considered Greek languages tags when I called upon the Greek 
> ccTLD and the 
> University of Athens. There is a need for cross cultural 
> control. This 
> control is provided by French for centuries and at ISO. Be 
> sure I will not 
> accept that all of us we lose that QA.
> 
> - complexity. The hook of a language is not an easy thing because 
> printf("$stringNN") is not a programer reflex. In permitting 
> to have a 
> single reference name, you do not oblige programers to 
> support several 
> languages (when there are two, there are hooks for all).
> 
> - inconsistency. We know that the reference names are just 
> because France 
> accepted not to delay ISO 639-3 (I concurred) in having not the 
> budget/people to carry the work. The response was "we will 
> use autonyms". 
> Autonyms would be nice. But "fra french" is not really an 
> autonym. Now, the 
> problem is may be something we could fix. We have to discuss.
> 
> - decency. A Draft has been introduced twice, and failed. We 
> ([email-masked] 
> opponents) proposed a small rewrite of two or three point or 
> a real WG. A 
> WG and a charter have resulted, which uses the same Draft. 
> And while the 
> Draft is not even submitted to the IESG the Draft is 
> enforced. This is 
> playing a lot on a very well known idea: people today cannot 
> be internet 
> builder anymore, so they are afraid of being remembered as Internet 
> wreckers, and they do not dare to oppose. It happens that I 
> do not fear 
> that: my past is behind me already. But I do not want to be 
> remembered as 
> the one "who could have" ...  As pointed out in another mail, 
> the problem 
> here is that it is a call to extremism. Everyone serious 
> outside of this 
> long working together group, and interested (but IAB, IESG 
> and IETF is not 
> really interested in multilingualism), sees that the Draft is 
> a clumsy 
> attempt at proposing an XML patch (Addison well documented 
> it) and will 
> oppose it to be made a Multilingual Internet confusion. In 
> the process 
> these "everyone" will most likely fight and forget Addison's 
> legitimate 
> need for solution to the real, urgent and important (but not 
> fundamental) 
> need of an XML patch.
> 
> all the best.
> jfc
> 
> PS. Since you are going to tell me "and why IAB, IESG and IETF is not 
> interested ???", what result from observation (for example 
> the very odd RFC 
> 3869 which is a call of IAB to Governments for Internet R&D 
> financing and 
> does not even allude to languages after 192 unanimous 
> Governments made it 
> their priority and it is the US year of multilingualism). I 
> started a draft 
> last summer on the way the Internet standard process could 
> support the 
> documentation of a Multilingual Internet. It was interrupted 
> by the RFC 
> 3066 bis saga. From this I think it is the syndrome I quoted 
> above and Vint 
> made his leit-motive "why to fix what ain't broke". The architectural 
> change is huge. The problem is that the question is not "to 
> fix what would 
> be broken", but "to replace what is outdated".
> 
> PS. In case you ask what the hell can be a "Multilingual Internet", I 
> suggest to use http://minc.org . You may not know it, but it 
> terms of users 
> it is a substantial one. Not so far from the majority if not 
> already the 
> majority. But the growth of the ASCII Internet is so slow 
> (800 millions 
> against 1.4 billion mobiles). Vernacular is not supported. 
> Architecture is 
> too rigid.
> 
> 
> 
>   13:22 13/04/2005, L.Gillam said:
> 
> >Jefsey,
> >
> >For once I find I might be able agree with you - I might
> >have misunderstood you however, so please don't comment
> >it as a certainty.
> >
> >Reference name provides the "hook", as you refer to it.
> >You (2nd person singular/plural) can provide whatever additional
> >translations you (2nd person singular/plural) desire for such
> >reference names, in whatever languages you (..) desire,
> >keep whatever local copies you (..) wish, and so on. The
> >problem you are making for people on this list is that
> >you (2nd person singular) seem to be insisting that the registry
> >MUST contain names in EVERY language for EVERY language, or should
> >produce translations where they are not available from the source
> >standards (e.g. reference names in 639-3). I see little purpose -
> >we are taking about "names" that help to identify tags, not
> >imposing restrictions on "languages", per se, which would
> >be somewhat different.
> >
> >Nobody is prevented from creating French names for these
> >7000 reference names, German names, Slovakian names, and
> >so on. Making it a necessary and essential task is
> >unrealistic - look at the army of translators needed by
> >the EU, for example.
> >
> >As I said, feel free to create your own hooks in other
> >languages of your (2nd s/p) choice for your (2nd s/p)
> >presentation - provided that in interchange the presented
> >item transforms into the correct tag there will be no
> >difficulties.
> >
> > > -----Original Message-----
> > > From: JFC (Jefsey) Morfin [mailto:[email-masked]]
> > > Sent: 12 April 2005 17:48
> > > To: Gillam L Dr (Computing); ltru
> > > Subject: RE: [Ltru] Great Script Debate Part II: Formats...
> > >
> > >
> > > I think you are globally right.
> > >
> > > At 16:50 12/04/2005, L.Gillam wrote:
> > > Where did I make something forbidden Jefsey?
> > >
> > > Ah! I thought you wanted to forbid French and hooks for other
> > > languages.
> > >
> > > On the contrary,
> > > >I think you'll find I say there are certain things we should
> > > >not impose (just above here for example).
> > >
> > > This implies that default references should be autonyms? 
> I was wrong
> > > reading you differently.
> > >
> > > >Quite the reverse. Please do not twist what I, or indeed
> > > others, write in
> > > >an attempt to validate your position.
> > >
> > > I have no position. Just observation. When I say that the
> > > lack of support
> > > of English and French is a blocking element. This is because
> > > I observe that
> > > it will be real world blocking, because applications are
> > > under current
> > > development and projects under financing which say otherwise.
> > >
> > > >There's a "forbid" if you want one.
> > >
> > > How rigth you are.
> > > jfc
> > >
> > > PS. I suppose you will want to respond I a wrong or
> > > unintelligible. No
> > > need, I have already taken your response into account.
> > >
> > >
> >
> >_______________________________________________
> >Ltru mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/ltru
> 
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 13 Apr 2005 09:20:53 -0700

For one metric, see "GDP by Language" http://www.unicode.org/notes/tn13/

‎Mark

----- Original Message ----- 
From: "L.Gillam" <[email-masked]>
To: "ltru" <[email-masked]>
Sent: Wednesday, April 13, 2005 08:45
Subject: RE: [Ltru] Great Script Debate Part II: Formats...

http://minc.org?

"After years of working on the multilingualisation of Internet content and
software with the vision of lowering linguistic barriers for non-native
English speakers of the Asian region, his attention was drawn towards the
naming problem.
..
Whereas content in the Internet was rapidly proliferating in native
languages, the URLs, email addresses, hostnames and domain names, still did
not support multilingual scripts. "

They seem to have identified particular needs and have no trouble that I can
see with existing ISO standards.

---

From: John Cowan <[email-masked]>
Date: Wed, 13 Apr 2005 12:24:55 -0400

> where discussion may otherwise be limited?

Mandarin Chinese is the most widely taught *second* language in the world.
English is the most widely taught *foreign* language in the world, however,
since most people who are taught Mandarin Chinese as a second language are
residents of China.

Note also that those who are taught and those who learn may or may not
be the same.

> "language is the first and basic social contract of a nation"

This remark isn't impenetrable; it's just true of some nations (Poland and
Bangladesh come to mind) and false of others (Nigeria comes to mind).
All nations have speakers of minority languages, but some nations make
a common language central to their national identity.

-- 
John Cowan  [email-masked]  www.ccil.org/~cowan  www.reutershealth.com
Any sufficiently-complicated C or Fortran program contains an ad-hoc,
informally-specified bug-ridden slow implementation of half of Common Lisp.
        --Greenspun's Tenth Rule of Programming (rules 1-9 are unknown)