Subject: RE: [Ltru] Re: [psg.com #900] remove region subtag 200

From: "Addison Phillips" <[email-masked]>
Date: Fri, 8 Apr 2005 09:05:11 -0700

Not any more it doesn't. I commented it out in the most recent update of the -01 draft precisely because of this discussion. (Note that I didn't actually delete the paragraph!)

Either the rules work or they don't. Let's not make a single exception unless we have really good reason.

NB> I didn't remove one or two examples of -200 from the draft yet, pending final consensus.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of John Cowan
> Sent: vendredi 8 avril 2005 05:22
> To: Doug Ewell
> Cc: [email-masked]
> Subject: Re: [Ltru] Re: [psg.com #900] remove region subtag 200
> 
> Doug Ewell scripsit:
> 
> > Frank Ellermann originally opposed this subtag, then appeared to soften
> > his objection.  Conversely, I originally supported the subtag, then grew
> > less supportive of it.  I don't recall any other dialogue concerning
> > this subtag.  It was retained in the April 6 registry.  Currently I am
> > *very weakly* in favor of removing it.
> 
> The -01 draft has a paragraph talking about it, and I have proposed an
> editorial change to strengthen its exceptionality.  So I do support it,
> specially called out in the RFC as an exception for a particular purpose
> to the general rules about M.49 codes.
> 
> --
> Principles.  You can't say A is         John Cowan
> <[email-masked]>
> made of B or vice versa.  All mass      http://www.reutershealth.com
> is interaction.  --Richard Feynman      http://www.ccil.org/~cowan
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Fri, 8 Apr 2005 12:11:07 -0400

> unless we have really good reason.

I believe we do have a really good reason.  So far, the ISO authorities have
stuck to the _de facto_ rule "Don't reuse codes", with exactly one exception:
ISO 3166/MA reused the code for Czechoslovakia.  We can and should introduce an
exactly compensating exception that makes it possible to map any existing codes
referring to that former country into something permanent.

-- 
Mos Eisley spaceport.  You will never           John Cowan
see a more wretched hive of scum and            [email-masked]
villainy -- unless you watch the                http://www.ccil.org/~cowan
Jerry Springer Show.   --georgettesworld.com    http://www.reutershealth.com

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 09 Apr 2005 01:18:46 +0200

John Cowan wrote:

> So far, the ISO authorities have stuck to the _de facto_ rule
> "Don't reuse codes", with exactly one exception

There's no such rule, it wouldn't work, and CS is not the only
case where they reused codes:

SK Sikkim vs. Slovakia, GE Gilber and Ellice Is. vs. Georgia
come to mind.

> We can and should introduce an exactly compensating exception

First of all we MUST acknowledge that our concept of alpha-2
country codes was completely wrong.

Until we haven't done this we end up with the bogus "forever
canonical" rules, and the abomination to hide the canonical
value in a "comment", where implementations won't find it.

If these details are unnderstood we can check the fixed rules
against the problems of splits and unions.  At the moment the
rules just break down and lose some former regions.

Only if all this is fixed we can consider to add an exception
for 200, because this split between date A and B is a special
case.  But as long as the general rules are broken don't even
think about exceptions from broken rules.

                            Bye, Frank
-- 
Subject tags considerd inefficient at best

---

From: John Cowan <[email-masked]>
Date: Sat, 9 Apr 2005 01:44:19 -0400

> SK Sikkim vs. Slovakia, GE Gilber and Ellice Is. vs. Georgia

I believe that all of these precede Date A, and so are out of scope
for us.

-- 
Schlingt dreifach einen Kreis vom dies!    John Cowan <[email-masked]>
Schliesst euer Aug vor heiliger Schau,     http://www.reutershealth.com      
Denn er genoss vom Honig-Tau,              http://www.ccil.org/~cowan  
Und trank die Milch vom Paradies.            -- Coleridge (tr. Politzer)