Subject: RE: [Ltru] Re: new version posted online

From: "Addison Phillips" <[email-masked]>
Date: Mon, 18 Apr 2005 13:29:02 -0700

Interlinear below.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: lundi 18 avril 2005 12:44
> To: [email-masked]
> Subject: [Ltru] Re: new version posted online
> 
> Addison Phillips wrote:
> 
> > http://www.inter-locale.com/ID/draft-ietf-ltru-registry-01.txt
> 
> Very quick scan:
> 
> | lang            = 2*3ALPHA           ; shortest ISO 639 code
> 
> We discussed 2*4ALPHA and a change of registered-lang, and/or
> to replace registered-lang by "individual" (i-* split off from
> grandfathered)
[Addison Phillips] 

I strongly dislike the i-* being put back. Why separate registered values of any type? We have a registry: that makes things clean.

I support reserving the alpha4 for the possibility of ISO 639-6 (we know it exists, why pretend otherwise?) But I'd prefer we do it by rule rather than in the ABNF. See previous email.

> 
> | subtlety in the ABNF for 'variant'
> 
> Yes, let's eliminate it, how about this:
> 
>   variant   = (5*8alphanum) ; registered variants
>             / (DIGIT 3alphanum)
[Addison Phillips] 

Because that's fairly subtle too? And incorrect as written. Should be:

   Variant = 5*8alphanum 
             / DIGIT 3*7alphanum

That is, we don't have the Y10K problem :-)

> 
> Why do you get [RFC2234] in your xref, if the reference is the
> 2234bis I-D, is that an xml2rfc oddity ?
[Addison Phillips] 

Fixed the text. It is obliquely an xml2rfc oddity.

> 
> | However, in the tags defined by this document, the uppercase
> | US-ASCII letters in the range 'A' (ABNF: %x41) through 'Z'
> | (ABNF: %x5A) are considered equivalent and mapped directly
> | to their US-ASCII lowercase equivalents in the range 'a'
> | (ABNF: %x61) through 'z' (ABNF: %x7A). Thus the tag
> | "mn-Cyrl-MN
> [...]
> 
> The mysteries of case insensitive ASCII, please replace it by:
> 
>   The tags defined by this document are case insensitive.
>   Thus the tag "mn-Cyrl-MN
> [...]
[Addison Phillips] 

Argh. Somebody make up their mind. We put them in, we take them out.

I put them in globally during recent rounds for consistency. They are ugly and I'd prefer them to go away. So they're gone now.

> 
> For the "missing" empty line before "However" you could use...
>    </t></list><vspace blankLines="1" />
> ...near the end of the bullet-list.
[Addison Phillips] 

Yes, but created a separate <t> element instead. Thanks.
> 
> | Any such a limitation MUST be clearly documented
> 
> MUST instead of "pray" is ugly.  The text after the RfC 2231
> example is obscure, do you need it ?  Why not simply say that
> the only way to truncate tags is to remove subtags RTL ?
[Addison Phillips] 

This text was agreed to in a long thread previously (I believe during the old last call). I am loathe to change normative language without consensus. But I agree that this text is hideous.
> 
> | Single letter and digit subtags are reserved for
> 
> There are no single digits in the ABNF.
[Addison Phillips] 

No, there aren't. Be we reserve them here so that people don't think we overlooked them. Question: should we reserve them for extensions now? Or preserve them for unforeseen circumstances?
> 
> | The primary subtag is the first subtag in a language tag
> | and cannot be empty
> 
> No subtag can be empty, how about s/empty/omitted/ ?
[Addison Phillips] 

Okay. Changed to omitted. 
> 
> | All language subtags of 4 to 8 characters in length
> 
> 5 to 8, ecause 4 was set aside for Debbie.  Don't forget to get
> rid of "STRONGLY" in this chapter.
[Addison Phillips] 

Waiting on consensus.
> 
> | Other values MUST NOT be assigned to the primary subtag
> 
> I don't see any i-whatever before this item, is this a trick,
> the i-whatever case is no primary subtag ?  OTOH there must be
> a primary subtag.
[Addison Phillips] 

i-* are all grandfathered by rule.
> 
> | There MAY be any additional number of extended language
> | subtags
> 
> Oops, indeed, the ABNF says  *("-" extlang).  What's the idea ?
[Addison Phillips] 

The idea is that there may be any number of them. Such as "zh-min-nan". This doesn't break the ABNF or subtag-length-based matching by 3066bis processors and the like. 
> 
> | Users who wished to utilize SIL Ethnologue
> 
> IMHO that needs an informative reference URL.
[Addison Phillips] 

Agreed. I'll dig one up.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 18 Apr 2005 13:59:32 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "Frank Ellermann" <[email-masked]>; <[email-masked]>
> Sent: Monday, April 18, 2005 1:29 PM
> Subject: RE: [Ltru] Re: new version posted online
...
> This text was agreed to in a long thread previously
> (I believe during the old last call). I am loathe to change
> normative language without consensus. But I agree that
> this text is hideous.
...

This is a new working group, and we shouldn't get hung up
on what happened during the old last call on ietf-languages.
If there are purely editorial repairs you'd like to propose to
the text in question, I think it suffices to float them on this
list, and, if no one objects, go ahead and make them.

Randy

---

From: John Cowan <[email-masked]>
Date: Mon, 18 Apr 2005 17:10:41 -0400

Addison Phillips scripsit:

> The idea is that there may be any number of them. Such as
> "zh-min-nan". This doesn't break the ABNF or subtag-length-based
> matching by 3066bis processors and the like.

zh-min-nan is an evolutionary dead end; we aren't going to represent languages
with this sort of (truncated) genealogical tree.  When 639-3 comes on line,
Min Nan will be zh-nan, and the other Min languages will be zh-mnp (Min Bei),
zh-cdo (Min Dong), and zh-czo (Min Zhong).

Consequently, I'd be in favor of allowing just a single extlang subtag.

> > IMHO that needs an informative reference URL.

I think it's a poor example, given that the current (15th) edition of
the Ethnologue uses DIS 639-3 codes, which we expect to incorporate
in a different way.

-- 
John Cowan  www.ccil.org/~cowan  www.reutershealth.com  [email-masked]
There are books that are at once excellent and boring.  Those that at
once leap to the mind are Thoreau's Walden, Emerson's Essays, George
Eliot's Adam Bede, and Landor's Dialogues.  --Somerset Maugham

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 18 Apr 2005 23:22:33 +0200

Addison Phillips wrote:
 
> I strongly dislike the i-* being put back.

Okay, let's solve the alpha-4 issue in -01 and discuss the
need of any other registered-lang after -01, it's unrelated.

> Because that's fairly subtle too? And incorrect as written.

No, it's okay, anything with 5 up to 8 let-dig uses the first
alternative, the second alternative handles the special case
"length 4" (starting with a digit).  

>              / DIGIT 3*7alphanum

Also correct, but then both alternatives match for length > 4
starting with a digit.  I'd prefer an unambiguous ABNF where
possible.  Your subtle ABNF (reflected in the text later) is
"alpha or digit", my less subtle variant is "length 5..8 or 4".

 [case insensitive US ASCII]
> Argh. Somebody make up their mind. We put them in, we take

It's not that important.  Arguing formally you could say that
it's explained in 2234bis.  Or reference RfC 20 just for fun.

> No, there aren't. Be we reserve them here so that people
> don't think we overlooked them.

Okay, you could add DIGIT to singleton in the ABNF.  Otherwise
it makes me nervous if the text talks about something that's
not in the ABNF or vice versa.

>> I don't see any i-whatever before this item, is this a
>> trick, the i-whatever case is no primary subtag ?  OTOH
>> there must be a primary subtag.
 
> i-* are all grandfathered by rule.

Sure, but your text says:

Then you enumerate all cases incl. x-, but not i-.  Somewhere
I miss i-.  Maybe you need something like this:
 
 The primary subtag is the first subtag in a language tag,
 if the language tag is no grandfathered tag (see 2.2.8).

                        Bye, Frank