Subject: RE: [Ltru] [psg.com #882] registry should copy non-English fieldsfrom ISO documents

From: "Peter Constable" <[email-masked]>
Date: Mon, 11 Apr 2005 15:23:22 -0700

> From: [email-masked] [mailto:[email-masked]]
On Behalf Of
> Randy Presuhn

>     1) there is a reference name from the ISO documents.  In some
cases
>         this is the English name of the language, in others it's a
transcription...

>     2) in some cases the ISO documents also include a French name for
>         a language.

This also may, in some cases, be a transcription -- just one done for
French speakers rather than English speakers.

>  This tracker item is on the question of whether this information,
>         when available, should also be included in the registry.  It
looks like there
>         is a slight preference among active participants in the WG to
include this
>         information.

I think it is unnecessary. On the other hand, I'm not absolutely opposed
to it. Bruce Lilly had first suggested it (before the LTRU list was
started), insisting that it was required for localization purposes and
because excluding the French names was not accurately reflecting the ISO
standard. I think the first reason is bogus, myself, and the second one
not terribly important.

If it's included, though, we just need to be aware that not all of the
source ISO standards will necessarily have distinct English and French
names; in particular, ISO 639-3 will have (initially) only "reference"
names, which may or may not correspond to English names.

Peter Constable

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "L.Gillam" <[email-masked]>
Date: Tue, 12 Apr 2005 09:26:24 +0100

Who's going to pay for all these items to be translated into
the variety of languages? 

Who is going to maintain all the servers, code lists and so 
forth, and deal with all those hits? 

Your opposition simply is not scalable - you're insisting on
developing nations with small finances making budgetary decisions
that may not be in their best interests.

I think you have to "eat your own dog food" here - you can't 
hunt with the hounds and run with the foxes (especially not 
in the UK any more). 

> I am sorry, I can only repeat this a definitive blocking 
> opposition for me. 
> For the reasons I gave several times. However once the 
> principle of dual 
> language (at least) naming necessity is established, 
> practical arrangements 
> can be quite flexible.
> 
> 1. if an Englist or French (or other languages to be added) 
> name for a 
> language is missing, it will be accepted as non fully 
> documented until a 
> name is provided (a IANA procedure and Reviewer will have to 
> be designated).
> 2. the same IANA registration could only be entered in 
> English or French. 
> It will be up to the French/English Reviewer to make sure the 
> name in the 
> missing language(s) is provided.
> 
> jfc
> 
>

---

From: "Addison Phillips" <[email-masked]>
Date: Wed, 13 Apr 2005 07:53:20 -0700

We don't. The character set is Unicode. We only restrict the description field to the Latin script by rule.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Tex Texin
> Sent: mercredi 13 avril 2005 04:14
> To: Doug Ewell
> Cc: LTRU Working Group
> Subject: Re: [Ltru] Re: [psg.com #882] registry should copy non-English
> fieldsfrom ISO documents
> 
> fwiw, I wouldn't favor adding the French at this time.
> 
> As for Latin-1, if we move out of the ASCII realm, I would prefer
> Unicode. We might not use chars out of the latin-1 set, but we shouldn't
> hem ourselves into a limited architecture.
> 
> My 2 cents.
> tex
> 
> Doug Ewell wrote:
> >
> > Randy Presuhn <randy underscore presuhn at mindspring dot com> wrote:
> >
> > > Currently, here's where I think we are:
> > >
> > > Those in opposition are Randy, Addison, Mark, Peter, and Robin.
> > > Those in support are Jefsey, John, Ned, and Doug.
> >
> > I prefer to be counted as "neutral" rather than "in support."  I meant
> > it when I said 51-49: definitely not a decisive margin.  I see both
> > sides of this one.
> >
> > > Both John and Doug, as well as several of those who are neutral,
> > > are opposed to Jefsey's provisos.
> >
> > Correct there.
> >
> > I note that if the inclusion of French continues to be portrayed as a
> > first step toward adding more translations, I will change my vote on the
> > French question to a clear "no."
> >
> > -Doug Ewell
> >  Fullerton, California
> >  http://users.adelphia.net/~dewell/
> >
> --
> -------------------------------------------------------------
> Tex Texin   cell: +1 781 789 1898   mailto:[email-masked]
> Xen Master                          http://www.i18nGuy.com
> 
> XenCraft		            http://www.XenCraft.com
> Making e-Business Work Around the World
> -------------------------------------------------------------
>

---

From: "Peter Constable" <[email-masked]>
Date: Thu, 14 Apr 2005 07:23:01 -0700

> From: [email-masked] [mailto:[email-masked]]
On
> Behalf Of Doug Ewell

> Would you prefer...

> If you had other provisos besides these two, please send them to the
> list...

Randy has already indicated that issue 882 has been closed as rejected.
Please don't invite further discussion of this issue.

Peter Constable