Subject: RE: [Ltru] Re: new version posted online

From: "Addison Phillips" <[email-masked]>
Date: Mon, 18 Apr 2005 14:15:24 -0700

> 
> > > Oops, indeed, the ABNF says  *("-" extlang).  What's the idea ?
> >
> > The idea is that there may be any number of them. Such as
> > "zh-min-nan". This doesn't break the ABNF or subtag-length-based
> > matching by 3066bis processors and the like.
> 
> zh-min-nan is an evolutionary dead end; we aren't going to represent
> languages
> with this sort of (truncated) genealogical tree.  When 639-3 comes on line,
> Min Nan will be zh-nan, and the other Min languages will be zh-mnp (Min
> Bei),
> zh-cdo (Min Dong), and zh-czo (Min Zhong).
[Addison Phillips] 

Yes, I know, but I needed an example. And it wasn't clear if when we last examined the issue whether one-layer would be enough or not. Multiple extlangs don't necessarily hurt anything, although they are a royal pain to process.

Is there consensus to limit to one?
> 
> Consequently, I'd be in favor of allowing just a single extlang subtag.
> 
> > > | Users who wished to utilize SIL Ethnologue
> > >
> > > IMHO that needs an informative reference URL.
> >
> > Agreed. I'll dig one up.
> 
> I think it's a poor example, given that the current (15th) edition of
> the Ethnologue uses DIS 639-3 codes, which we expect to incorporate
> in a different way.
> 
It is now. It wasn't historically so. Any suggestions? How about a transliteration example?

Addison

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Mon, 18 Apr 2005 17:36:33 -0400

Addison Phillips scripsit:

> Yes, I know, but I needed an example. And it wasn't clear if when
> we last examined the issue whether one-layer would be enough or
> not.

The only way that multiple extlang subtags would be needed in the 639-3
context is if one of the 365 individual languages that are components
of a macrolanguage (about 0.5% of the total) was itself determined to
be a macrolanguage; that is, if ISO 639-3/RA decided that some of its
dialects were really distinct languages.  Since Ethnologue is already
quite far toward the splitter end of the lumper/splitter continuum,
I'd be comfortable with betting against that.  In any case, if we'd
already registered the dialects as variants, stability would require
that we keep them that way.

> Multiple extlangs don't necessarily hurt anything, although they
> are a royal pain to process.

Being a pain to process does indeed "hurt something", namely implementation cost.

> It is now. It wasn't historically so. Any suggestions? How about a

Frankly, I have a lot of trouble thinking of anything that would be closely
coupled to languages but isn't already covered by our quadripartite scheme.

-- 
Do I contradict myself?                         John Cowan
Very well then, I contradict myself.            [email-masked]
I am large, I contain multitudes.               http://www.ccil.org/~cowan
        --Walt Whitman, Leaves of Grass         http://www.reutershealth.com