Subject: RE: [Ltru] Compatibility with existing use (LDAP)

From: Misha Wolf <[email-masked]>
Date: Thu, 07 Apr 2005 20:26:20 +0100

Frank Ellermann wrote: 

> > Putting the script subtag after the region subtag exchanges
> > one incompatibility for another, as Doug points out.
> 
> If it makes no big difference for 3066bis implementations and
> helps 3066 implementations I'd like it.

It would break access to resources using new tags (eg zh-Han?) when 
faced with applications which use remove-from-right matching.

Many (most?) applications use and will continue to use such matching.

Misha

-----------------------------------------------------------------
        Visit our Internet site at http://www.reuters.com

To find out more about Reuters Products and Services visit http://www.reuters.com/productinfo 

Any views expressed in this message are those of  the  individual
sender,  except  where  the sender specifically states them to be
the views of Reuters Ltd.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 07 Apr 2005 22:49:43 +0200

Misha Wolf wrote:
 
> It would break access to resources using new tags (eg 
> zh-Han?) when faced with applications which use
> remove-from-right matching.

> Many (most?) applications use and will continue to 

Let's say that all "old" implementations try RTL expecting
lang-region-more-stuff.  So that's by definition hopeless,
we can only pray that they understand at least lang-region.

But "new" implementations are "new" and not forced to use
RTL if we say that it's a bad idea for lang-region-script.

Or in John's terms we could say 8-2-4-1 instead of 8-4-2-1
for new implementations and a lang-region-script-variant(s)
scheme. 
                        Bye, Frank