Subject: [Ltru] Format for extension registry

From: "Addison Phillips" <[email-masked]>
Date: Fri, 8 Apr 2005 13:36:18 -0700

It was pointed out that there is no definition of the extensions registry. Currently the draft says:

<t>IANA will maintain a registry of allocated single-letter subtags. 
    This registry contains the following information:
    letter identifier; name; purpose; RFC defining the subtag namespace and 
    its use;
    and the name, URL, and email address of the maintaining authority.</t>

I would like to modify this to say:

<t>IANA will maintain a registry of allocated single-letter (singleton) subtags. This registry will use the record-jar format described in Section 3.1, using the ABNF  (RFC2234bis) in that section. Upon publication of an extension as an RFC, the maintaining authority defined in the RFC must forward to [email-masked] the registration form defined in this section and required in the extension's RFC for inclusion into the registry. </t>

We would then define the records as follows:

%%
Identifier: (letter identifying the extension)
Description: (name and purpose of the extension)
Comments: (comments)
Added: (date in ISO 8601 full-date format when this record added)
RFC: (RFC defining the extension)
Authority: (name of the maintaining authority)
Email: (email of the maintaining authority)
URL: (URL of the extension)
%%

Comments/suggestions?

Addison

Addison P. Phillips
Globalization Architect, Quest Software
http://www.quest.com

Chair, W3C Internationalization Core Working Group
http://www.w3.org/International

Internationalization is not a feature.
It is an architecture. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Fri, 08 Apr 2005 23:32:45 +0200

Addison,
everything you propose in term of your format is fine. You know what you want.

Just stop claiming your solution is universal in wanting your document to 
become the BCP 047. Explain how your format will be used by applications, 
to understand the load on the IANA.

We will stop being harassed by your proposition and develop our own system 
quietly for what your proposition does not address and we work on... There 
is room for everyone and for innovation.

jfc

On 22:36 08/04/2005, Addison Phillips said:
>content-class: urn:content-classes:message
>Content-Type: text/plain;
>         charset="utf-8"
>
><t>IANA will maintain a registry of allocated single-letter (singleton) 
>subtags. This registry will use the record-jar format described in Section 
>3.1, using the ABNF  (RFC2234bis) in that section. Upon publication of an 
>extension as an RFC, the maintaining authority defined in the RFC must 
>forward to [email-masked] the registration form defined in this section and 
>required in the extension's RFC for inclusion into the registry. </t>
>

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 09 Apr 2005 02:32:16 +0200

> Comments/suggestions?

Fine.  Could you use it get rid of the "x" ABNF ?  Initialize
the singleton registry section with "x" (private use, defined
in 3066is).  And a production singleton = ALPHA would be nice.

OTOH that could conflict with John's singleton sorting ideas.

                         Bye, Frank