Subject: RE: [Ltru] considerations for ISO 639-6 at consensus? (was:newversionposted online)

From: "Addison Phillips" <[email-masked]>
Date: Mon, 18 Apr 2005 15:31:16 -0700

I put something even vaguer in 2.2.1:

"All 4-character language subtags are reserved for possible future standardization."

I used Peter's formulation in Section 3.5

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Mark Davis
> Sent: lundi 18 avril 2005 15:27
> To: Peter Constable; [email-masked]
> Subject: Re: [Ltru] considerations for ISO 639-6 at consensus?
> (was:newversionposted online)
> 
> That wording sounds reasonable.
> 
> ‎Mark
> 
> ----- Original Message -----
> From: "Peter Constable" <[email-masked]>
> To: <[email-masked]>
> Sent: Monday, April 18, 2005 14:26
> Subject: RE: [Ltru] considerations for ISO 639-6 at consensus?
> (was:newversion posted online)
> 
> 
> > From: [email-masked] [mailto:[email-masked]]
> On Behalf Of
> > Addison Phillips
> 
> 
> > Personally, I'd favor changing the rules in Section 3.5 (possibilities
> for registration) to
> > say that alpha4 subtags will not be considered for registration of
> primary languages
> > "anticipating work that is currently under way on ISO 639".
> 
> I have a bit of reservation about this wording. In contrast to the
> situation with ISO 639-3, which had passed a CD ballot prior to any
> suggestion that anything anticipatory be done in the RFC, the ISO 639-6
> project is just beginning; I believe a working draft hasn't yet been
> registered. It's entirely possible that the ISO 639-6 project may not
> result in an alpha-4 code.
> 
> I've no problem with reserving alpha4 subtags; it's just the wording
> "anticipating work that is currently under way on ISO 639" on which I
> have some reservations: it causes this document to create a level of
> expectation regarding ISO deliverables that are not appropriate for IETF
> to be setting. I'd rather see a vaguer wording, something like,
> "allowing for the possibility of an alpha4 code in some future addition
> to the ISO 639 family of standards."
> 
> 
> 
> Peter Constable
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Mon, 18 Apr 2005 15:55:11 -0700

I have posted Yet Another Editor's Copy. In section 3.5 you'll find:

Note: 4-character primary language subtags are currently reserved to allow for the possibility of alpha4 codes in some future addition to the ISO 639 family of standards.

I'm dropping the word 'currently', btw.

Addison

Addison P. Phillips

> Behalf Of Debbie Garside
> Sent: lundi 18 avril 2005 15:50
> To: 'Peter Constable'; [email-masked]
> Peter Constable wrote:
> I think this is entirely appropriate.
> 
> Debbie Garside
> 
> On
> > Behalf Of Peter Constable
> > Sent: 18 April 2005 22:27
> > To: [email-masked]