Subject: RE: [Ltru] Re: [psg.com #875] should initial registry contents be madeinto an internet-draft?

From: "Addison Phillips" <[email-masked]>
Date: Fri, 8 Apr 2005 09:34:57 -0700

I still fail to see how an I-D does anything useful. Putting the draft registry under some form of version control and making it available on the IETF website under "internet-drafts" strikes me as sufficient. The I-D can be (copyrights and other legal matters excluded) one line long, containing the URI of the registry itself in a non-rubbished format suitable for actual publication.

Here's what it could say:

"The initial contents of the Language Subtag Registry defined by RFC 3066bis SHALL be the file at this location, subject to the provisions in Section 3.6 of RFC 3066bis:  <http://www.ietf.org/internet-drafts/where-the-registrations-are>"

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: jeudi 7 avril 2005 23:22
> To: LTRU Working Group
> Subject: [Ltru] Re: [psg.com #875] should initial registry contents be
> madeinto an internet-draft?
> 
> Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:
> 
> > Pro, something like RfC 4021 is nice.  If Doug somehow forces
> > page footers below %% lines, and page headers above the next
> > registry entry.  Please no big gap like 4021-3864.
> 
> It's a data file.  Record breaks are going to fall wherever they fall.
> "48 lines per page" is completely orthogonal to this.
> 
> -Doug Ewell
>  Fullerton, California
>  http://users.adelphia.net/~dewell/
> 
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 8 Apr 2005 12:19:28 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "Doug Ewell" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Friday, April 08, 2005 9:34 AM
> Subject: RE: [Ltru] Re: [psg.com #875] should initial registry contents bemadeinto an internet-draft?

(re-formatted so I can read it)

> I still fail to see how an I-D does anything useful.
> Putting the draft registry under some form of version control
> and making it available on the IETF website under "internet-drafts"
> strikes me as sufficient.
> The I-D can be (copyrights and other legal matters excluded) one line long,
> containing the URI of the registry itself in a non-rubbished format suitable for actual publication.
>
> "The initial contents of the Language Subtag Registry defined by RFC 3066bis
> SHALL be the file at this location, subject to the provisions in Section 3.6 of RFC
> 3066bis:  <http://www.ietf.org/internet-drafts/where-the-registrations-are>"
...

As a contributor...
This approach misses the whole point of bothering to put the initial
content into an i-d, and is equivalent to the registry-00 proposal.  The
concern is about ensuring the integrity of whatever IANA is given a
pointer to, and that that initial content that is there when IANA retrieves
it is what was approved by the WG.

Randy