Subject: RE: [Ltru] Re: draft review

From: "Addison Phillips" <[email-masked]>
Date: Fri, 8 Apr 2005 09:29:51 -0700

> Please point out a passage in RFC 1958 that says that if one protocol
> uses a character sequence such as "--", that no other protocol may use
> that same two-character sequence, no matter how unrelated the uses are.

Furthermore, as pointed out previously, language tags do not use the sequence "--" anyway. Draft-00 uses it in the canonical field to indicate a deprecated code (not an actual value to assign).

In the current draft of Draft-01, this sequence is entirely removed, replaced by the Deprecated field (which contains a date). So this whole thread may be moot.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: jeudi 7 avril 2005 23:51
> To: LTRU Working Group
> Subject: [Ltru] Re: draft review
> 
> JFC (Jefsey) Morfin <jefsey at jefsey dot com> wrote:
> 
> >>> The concern on this point is high enough to see the Draft blocked.
> >>
> >> Whose concern?  Blocked by whom?  Vague and unfounded.
> >
> > Unless IESG drops the rule of consensus, there is no possible
> > consensus on the present Draft. I am a documentation of it. At the
> > present stage I can only oppose. This is why I try to see my
> > opposition reduced. But this is a consensus process, not a compromise
> > and obviously not an enforcement process. This means that at the end
> > of the day APMD and I must be equally satisfied with the result.
> 
> "Consensus" in an IETF Working Group means "rough consensus."  It does
> not require absolute unanimity.  If you doubt this, ask the chairs, or
> go over their heads to the ADs.
> 
> >>> Concerns are also the double "-" which is specifically used by the
> >>> IANA code "xn".
> >>
> >> The IDN code space is unrelated in any way to the language tag code
> >> space.
> >
> > Private assumption.
> > BTW I say otherwise. It is at least through RFC 1958 basic principle
> > and consistency rule.
> 
> Please point out a passage in RFC 1958 that says that if one protocol
> uses a character sequence such as "--", that no other protocol may use
> that same two-character sequence, no matter how unrelated the uses are.
> 
> Language tags are not encoded in Punycode.  Domain names,
> internationalized or otherwise, do not contain language tags.  There is
> no conflict.
> 
> -Doug Ewell
>  Fullerton, California
>  http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Fri, 08 Apr 2005 23:10:50 +0200

At 18:29 08/04/2005, Addison Phillips wrote:
>Content-class: urn:content-classes:message
>Content-Type: text/plain;
>         charset="utf-8"
>
>Furthermore, as pointed out previously, language tags do not use the 
>sequence "--" anyway. Draft-00 uses it in the canonical field to indicate 
>a deprecated code (not an actual value to assign).
>
>In the current draft of Draft-01, this sequence is entirely removed, 
>replaced by the Deprecated field (which contains a date). So this whole 
>thread may be moot.

Perfect. Thank you.