Subject: [Ltru] Re: Date of deprecation

From: "Doug Ewell" <[email-masked]>
Date: Tue, 5 Apr 2005 19:56:04 -0700

Addison Phillips <addison dot phillips at quest dot com> wrote:

>>> One of our chairs proposed to prepare the LTRU registry as far
>>> as possible for this case.  IMHO a good idea, of course not for
>>> what you plan to publish tomorrow.
>>
>> I missed something there.  Did Randy or Martin say something about
>> working on the registry itself?
>
> To prepare the 3066bis regime to handle ISO 639-3 as much as possible
> is what I believe Frank means.

and Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

> What I meant was Randy's (hat off) question...
>
> | If we already have a good idea how the ISO specifications
> | will look, wouldn't it make sense to ensure that 3066bis
> | works correctly for those cases, so we don't have to bother
> | doing a 3066ter?
>
> | I think it would be really nice if we could put in text now
> | that would not need revision later.  It sounds like all that
> | is needed is text that spells out precisely when using the
> | macro-language code is required.

Ah, you are right.  Technically that's preparing the draft, not the
registry per se, which is why I missed something.

But I completely agree, and think we should include as much information
as we can -- depending on how much confidence we have in the stability
of the 639-3 draft between now and the time it's published -- about how
extlangs will work, and which types of 639-3 codes will be primary
language subtags and which will be extlangs.

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Tue, 5 Apr 2005 21:11:00 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

> I've added 0 for '*' = '*' and no match.  Otherwise 8/4/2/1,
> is this what you wanted ?

No, that's not right.  '*' = '*' is a match, just the same as 'de' =
'de', and should be assigned the full complement of points, depending on
which subtag it is.  'de' = 'en', by contrast, would be a zero.

Suppose I request "sr-CS".  The script is not specified, so in our
matching syntax, this is equivalent to "sr-*-CS".  Accordingly, this
request should retrieve content labeled "sr-CS", "sr-Latn-CS",
"sr-Cyrl-CS", or "sr-Yiii-CS" with equal success.

'*' matches everything, and earns full points.  Try your metrics again.

-Doug Ewell
 Fullerton, California

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 06 Apr 2005 23:35:52 +0200

Doug Ewell wrote:

> that's not right.  '*' = '*' is a match
[...]
> Try your metrics again.

column 1 is en-scouse
column 2 is en-GB-scouse
column 3 is en-Latn-GB-scouse
column 4 is en-Latn-scouse

Test 8-4-2-1 weights

en-scouse         15 13  9 11
en-GB-scouse      13 15 11  9
en-Latn-GB-scouse  9 11 15 13
en-Latn-scouse    11  9 13 15

xx-Latn-GB-scouse  1  3  7  5
en-Latn-GB         8 10 14 12
en-Latn-US         8  8 12 12
en-Latn-US-scouse  9  9 13 13
en-Brai-GB-scouse  9 11 11  9

In column 2 (en-GB-scouse) en-Brai-GB-scouse beats en-GB-Latn
and en-Latn-US-scouse.

In column 3 (en-Latn-GB-scouse) en-GB-Latn beats
en-Latn-US-scouse.  Of course still a draw in column 1.

Test 4-3-1-2 weights

en-scouse         10  9  6  7
en-GB-scouse       9 10  7  6
en-Latn-GB-scouse  6  7 10  9
en-Latn-scouse     7  6  9 10

xx-Latn-GB-scouse  2  3  6  5
en-Latn-GB         4  5  8  7
en-Latn-US         4  4  7  7
en-Latn-US-scouse  6  6  9  9
en-Brai-GB-scouse  6  7  7  6

Here colums 3 and 4 are "sane", column 1 is of course a draw,
and column 2 is minimally "better" than John's metrics, but it
still prefers en-Brai-GB-scouse before en-Latn-US-scouse.

Maybe 4-2-1-3 would do the trick for these examples, but then
we need a new set of test cases, w(variant) > w(script) can't
be a generally good idea.
                          Bye, Frank