Subject: RE: [Ltru] Re: Proposed Text for Moving Forward

From: "Addison Phillips" <[email-masked]>
Date: Sun, 17 Apr 2005 16:33:19 -0700

Okay, so we put suppress back for the reasons I put it in there in the first place. Never mind my contributions to this weekend's thread. :-)

> The "because" doesn't work with undocumented "suppress_script"
> concepts.  I didn't know that Goth is _not_ the default for
> got, I also didn't know that Latn is _not_ the default for yi.

Yes, I see that. You are trying to achieve clarity in tag choice (trying to limit the cases in which content authors must "guess" whether to use the script or not). What you aim to do can *only* be done if you document both sides of the equation (require and suppress).

If we try to short one side or the other, we will end up with a larger set of nebulous cases, which is apparently the sticking point.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: dimanche 17 avril 2005 13:46
> To: [email-masked]
> Subject: [Ltru] Re: Proposed Text for Moving Forward
> 
> Addison Phillips wrote:
> 
> > 1. Script subtags SHOULD NOT be used to form a language tag
> > unless they add some distinguishing information. For example,
> > the 'Latn' subtag is generally unnecessary with the primary
> > language 'en' because nearly all English documents are
> > written in Latin script.
> 
> The "because" doesn't work with undocumented "suppress_script"
> concepts.  I didn't know that Goth is _not_ the default for
> got, I also didn't know that Latn is _not_ the default for yi.
> 
> Now after John mentioned it the latter is convincing, I don't
> even bother to check it.  OTOH it's clear that all yi content
> I've seen so far was yi-Latn, my knowledge of Hebrew is limited
> to what I needed to read mathematical texts (= mainly "aleph").
> 
> > 2. The script subtag SHOULD always be used to form a language
> > tag when the script of the tagged content matches a
> > 'Required_Script' field for the associated primary language.
> 
> Less convincing, in a hrefang= to a WAV or MP3 I don't need any
> Hans or Hant.  As far as I'm concerned the only function of the
> "required_script" field is to block erroneous registrations of
> a "suppress_script" for the same language (if you say so in the
> rules for these fields).
>                         Bye, Frank
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 18 Apr 2005 02:46:04 +0200

Addison Phillips wrote:

> What you aim to do can *only* be done if you document both
> sides of the equation (require and suppress).

I've no serious problems with required_script, but from my POV
it's not strictly necessary, unlike suppress_script.  If the
only idea of required_script is to block erroneous attempts to
get a suppress_script, you could also define a "Multiscript: 1".

Of course that's too ugly to consider it, but it illustrates my
POV on required_script.

> If we try to short one side or the other, we will end up
> with a larger set of nebulous cases, which is apparently the
> sticking point.

We only want to get rid of an explicit Latn for languages like
en, got, fy, or an explicit Cyrl for ru, etc.  That's why I
don't understand the idea of more than one suppress_script for
the same language, IMO that should not be allowed.  Bye, Frank