Subject: [Ltru] Re: Registry in record-jar format - smart matching?

From: "L.Gillam" <[email-masked]>
Date: Wed, 6 Apr 2005 13:21:16 +0100

Defaults + fallback = ?

If "en" defaults to en-Latn, does en-Cyrl falls back to en and default to en-Latn. Is it better to receive en-Latn rather than "nothing" in response to en-Cyrl? What if more than one script is implicated by the 2 letter language code, there is a default, but the fallback should produce all available? 

What do people think is the best result from this combination?

> -----Original Message----- 
> From: [email-masked] 
> [mailto:[email-masked]]On 
> Behalf Of Frank Ellermann 
> Sent: 04 April 2005 22:07 
> To: [email-masked] 
> Subject: [Ltru] Re: Registry in record-jar format 
> 
> 
> Debbie Garside wrote: 
> 
> > What do you -think- you would apply to the proposed 639-3 tags like 
> > "ess" Central Siberian Yupik which is written in Cyrillic script in 
> > Siberia and Latin script in Alaska? 
> 
> No default when it's unclear.  This case sounds like the now 
> deprecated sh (sr + hr).  Bye, Frank 
> 
> 
> 
> _______________________________________________ 
> Ltru mailing list 
> [email-masked] 
> https://www1.ietf.org/mailman/listinfo/ltru 
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Wed, 06 Apr 2005 15:27:29 +0200

At 14:21 06/04/2005, L.Gillam wrote:
>Content-class: urn:content-classes:message
>Content-Type: multipart/alternative;
>         boundary="----_=_NextPart_001_01C53AA3.212C7525"
>
>Defaults + fallback = ?
>
>If "en" defaults to en-Latn, does en-Cyrl falls back to en and default to 
>en-Latn. Is it better to receive en-Latn rather than "nothing" in response 
>to en-Cyrl? What if more than one script is implicated by the 2 letter 
>language code, there is a default, but the fallback should produce all 
>available?
>

The question seems precisely that: what "people think". Because there can 
be different types of defaults depending of the types of people (educated 
or not, bi-scriptural,.. this is in part alluded to in the  APMD Draft) or 
inter-application or man/machine. For example if the concerned page has a 
lot of visuals and language is only a help or  is full text, this makes a 
real difference.

This means that the same page may be better read by two different people 
with two different defaults. This kind of issue is precisely the purpose of 
the "context" we work on - which may include languages, locales, scripts, 
terminology etc. at low load (preloaded at boot in using the CRCD I 
documented). An XML page should be able to document its context tag and its 
elements to overide its langtag default. This corresponds to the mention of 
"preferences" in the Charter.

jfc

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 6 Apr 2005 14:40:27 -0700

Hi -

> From: "L.Gillam" <[email-masked]>
> To: "ltru" <[email-masked]>
> Sent: Wednesday, April 06, 2005 5:21 AM
> Subject: [Ltru] Re: Registry in record-jar format - smart matching?
>

> Defaults + fallback = ?
>
> If "en" defaults to en-Latn, does en-Cyrl falls back to en and default to en-Latn.
> Is it better to receive en-Latn rather than "nothing" in response to en-Cyrl?
> What if more than one script is implicated by the 2 letter language code,
> there is a default, but the fallback should produce all available?
>
...

(as contributor)

I think questions like these demonstrate the need for multiple matching
algorithms (or a very general, parameterised matching algorithm), which
is what we are chartered to produce.  The "best" result would depend
on the application.  For some applications, "fallback" is desirable. For
others, it is not.

I think they also show why the concept of "default script" (distinct from
"script not specified") has received little support.

Randy