Subject: RE: [Ltru] Re: hyphen-minus (was: new version posted online)

From: "McDonald, Ira" <[email-masked]>
Date: Sat, 23 Apr 2005 15:25:41 -0700

Hi Doug,

I'm confused here.  Are you really mixing Latin-1 in plaintext 
with Unicode via NCRs in the Registry?

Latin-1 is only mentioned once in the current LTRU draft,
in the change log comment:

"o  Remove the Latin-1 restriction on the 'Description' field."

Latin-1 (ISO 8859 Part 1) is NOT the same thing as "the 
Latin script" as used in a number of places in the latest 
LTRU draft (the Latin script includes a larger character
repertoire).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Doug Ewell
> Sent: Saturday, April 23, 2005 5:11 PM
> To: LTRU Working Group
> Subject: [Ltru] Re: hyphen-minus (was: new version posted online)
> 
> 
> Addison Phillips <addison dot phillips at quest dot com> wrote:
> 
> > If no one objects, I'll remove the restriction to Latin-1 from
> > description. Variant registrations will be asked to provide a
> > Description using or transcribed into the Latin script.
> 
> I don't object.  As a reminder, I've restricted the existing 
> entries in
> the draft registry to Latin-1 characters, and so far nobody 
> has objected
> to this.
> 
> The descriptions that appear in ISO standards, together with the
> corresponding description in the registry, are as follows (warning:
> UTF-8 ahead):
> 
> Hangul (Hangŭl, Hangeul) --> Hangul (Hangeul)
> Ge‘ez --> Ge'ez
> N’ko --> N'ko
> Gwich´in --> Gwich'in
> 
> (The character replaced in the last example is actually in 
> Latin-1, but
> seems not to be the correct character for the purpose.)
> 
> --
> Doug Ewell
> Fullerton, California
> http://users.adelphia.net/~dewell/
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Sat, 23 Apr 2005 21:45:42 -0400

> with Unicode via NCRs in the Registry?

The entity encoding (charset) is ASCII; the document encoding (on which
the NCRs are based) is Unicode; the repertoire is restricted to Latin-1.
Those are three different things.

-- 
XQuery Blueberry DOM                            John Cowan
Entity parser dot-com                           [email-masked]
    Abstract schemata                           http://www.reutershealth.com
    XPointer errata                             http://www.ccil.org/~cowan
Infoset Unicode BOM                                 --Richard Tobin

---

From: "Doug Ewell" <[email-masked]>
Date: Sun, 24 Apr 2005 00:47:58 -0700

> with Unicode via NCRs in the Registry?

John answered this pretty well, but no, I haven't mixed anything up.
The registry is made up of Unicode characters; all except the Basic
Latin (ASCII) characters are represented as NCRs; the current version is
limited in repertoire to Latin-1 (U+0000 through U+00FF).

> "o  Remove the Latin-1 restriction on the 'Description' field."

Limiting the repertoire to Latin-1 is something I've done in the current
draft registry, not necessarily a requirement of the draft.  Frank has
since asked for the ISO-based descriptions NOT to be arbitrarily
restricted to Latin-1; anyone else?

> LTRU draft (the Latin script includes a larger character

I do understand this distinction.

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/
Individual member, Unicode Consortium