Subject: RE: [Ltru] Re: Proposed changes to region subtags

From: "McDonald, Ira" <[email-masked]>
Date: Fri, 1 Apr 2005 15:05:41 -0800

Addison Phillips wrote:

>(editor hat on)
>
>It doesn't because that debate seems to have fallen off without a genuine
>consensus being reached. I *think* the consensus is record-jar. And maybe 
>also XML. 

>At present I intend that when I next sit down to update the editor's copy 
>(that usually being my job in our editing duopoly) I'll incorporate the 
>changes necessary to make record-jar the format with no mention of XML. 
>Any objections?
>
>(removing editor hat)

I agree that the working group concensus now is record-jar.  I also
agree that it's fine (better) not to mention any XML format in the
next draft.  When the metadata elements in this LT registry have
crystallized further is soon enough to require or recommend any
additional XML format.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Misha Wolf <[email-masked]>
Date: Wed, 06 Apr 2005 07:11:09 +0100

Doug Ewell wrote:

> Description: Occitan (post 1500)&#x003B Proven&#x00E7;al

Don't you mean:

  Description: Occitan (post 1500)&#x003B; Proven&#x00E7;al

or:

  Description: Occitan (post 1500)&#x3B; Proven&#xE7;al

?

Misha

-----------------------------------------------------------------
        Visit our Internet site at http://www.reuters.com

To find out more about Reuters Products and Services visit http://www.reuters.com/productinfo 

Any views expressed in this message are those of  the  individual
sender,  except  where  the sender specifically states them to be
the views of Reuters Ltd.

---

From: "Addison Phillips" <[email-masked]>
Date: Wed, 6 Apr 2005 09:18:55 -0700

I put text to allow it into the editor's copy already.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: mardi 5 avril 2005 20:01
> To: [email-masked]
> Subject: Re: [Ltru] Re: Proposed changes to region subtags
> 
> Hi -
> 
> > From: "Frank Ellermann" <[email-masked]>
> > To: <[email-masked]>
> > Sent: Saturday, April 02, 2005 1:43 PM
> > Subject: [Ltru] Re: Proposed changes to region subtags
> ...
> > And one reason pro XML (clear support for Unicode character
> > references in an otherwise US-ASCII text).  JFTR, I prefer
> > record-jar in the body of the I-D registry.
> ...
> 
> Pardon the naive question:
> Couldn't we simply use Unicode character references (as needed)
> in a record-jar format?
> 
> Randy
> 
> 
>

---

From: "Addison Phillips" <[email-masked]>
Date: Thu, 7 Apr 2005 09:06:24 -0700

It isn't the draft registry, but the rules in the registry draft that we care about. They need to be comprehensive.

It is easier to spec the escape format widely and then limit the range permitted than to be narrow in our definitions.

Finally, there may be good reason to put in comments (i.e. non-normative material) that contain non-ASCII and non-Latin code points (pointing out differences in usage or names in some specific language---Chinese comes immediately to mind).

Addison

Addison P. Phillips

> Behalf Of Frank Ellermann
> Sent: mercredi 6 avril 2005 15:19
> To: [email-masked]
> Randy Presuhn wrote:
> > Couldn't we simply use Unicode character references (as
> > needed) in a record-jar format?
> 
> That would be an ad-hoc format, an ABNF for the complete
> record-jar format with this idea is of course possible.
> 
> Essentially we'd need &#xabcd; or &#xabcde; - let's ignore
> &#x10bcdef;  Anything else not starting with &#x is ASCII.
> 
> But there are no Unicode points above 126 in the draft
> registry at the moment, so why do we discuss this now ?
> 
>                         Bye, Frank
> 
> 
>