Subject: [Ltru] RE: [psg.com #882] registry should copy non-English fields from ISO documents

From: "Addison Phillips" <[email-masked]>
Date: Thu, 7 Apr 2005 14:33:31 -0700

I concur.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: World Wide Web Owner [mailto:[email-masked]] On Behalf Of rt+ltru-
> [email-masked]
> Sent: jeudi 7 avril 2005 14:32
> To: Addison Phillips
> Cc: [email-masked]
> Subject: Re: [psg.com #882] registry should copy non-English fields from
> ISO documents
> 
> Hi -
> 
> (co-chair hat ON)
> 
> In  http://www1.ietf.org/mail-archive/web/ltru/current/msg00083.html
> the request was made to copy non-English fields from ISO documents.
> 
> (Not to be confused with the "native name of language" question!!!)
> 
> At this point, I believe the rough consensus is to reject this request,
> but I'd like confirmation from the WG that my understanding of the
> rough consensus is correct.
> 
> Randy
> 
> 
> 
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "L.Gillam" <[email-masked]>
Date: Mon, 11 Apr 2005 09:28:43 +0100

John,

> > 1. A "reference name" is for interoperability. The 
> reference name for
> > a language can be taken from that language, and need not be 
> in either
> > English or French, as I believe Peter was alluding to. I 
> believe this to
> > be the case with -3 and it's certainly intended for -6. 
> 
> ISO 639-3 reference names are English names (which may in 
> many cases be
> identical to native names, but only when there is no 
> traditional English
> name).  "French", "German", "Chinese" are so named.  This 
> reflects 639-3's
> inheritance from the Ethnologue.  Note also that many 639-3 languages
> have no written form, and would have to have the names transcribed in
> some system rather than simply written.

"need not be in either English or French". See below.

> > 3. A code (e.g. alpha3 in 639-3) stands as synonymous with 
> the reference
> > name and as entry point into the "conceptual" entry - the mantra is
> > "I don't care what you call it as long as we are referring to the
> > same thing"
> 
> The code points to the name, but the name does not always 
> unambiguously
> point to the language.  In ISO 639-1/2 (which are unambiguously
> mapped, so I treat them as one), there is the language coded "zh" or
> "chi" or "zho" and named "Chinese" and "chinois".  But there is no
> way of knowing whether that means:
> 
> 1) Mandarin Chinese, a specific Sinitic language
> 2) The Sinitic languages as a collection
> 3) The languages called "Chinese" as a collection
> 4) A macrolanguage incorporating the Sinitic languages as components
> 5) A macrolanguage incorporating the languages called 
> "Chinese" as components
> 
> ISO 639-3 takes position 5.

This is why I referred to a "conceptual" entry. One "term" for one "concept"
is a terminological ideal. Multiple codes leading into an ambiguous entry
requires one of 1-5 possible interpretations as above. 

> > ensuring -4 has necessary and sufficient coverage.
> 
> >From what I understand (I have not seen a draft), -4 will be 
> conceptual
> and introductory (-0, in other words, if ISO rules permitted 
> a -0 part)
> and will not provide coverage of anything.  Has this changed?

That it will not provide coverage of anything? Certainly! 

Presentations have been made of a "Language Description Framework" 
in ISO TC37 SC2 (by Laurent Romary). I may be able to dig out a 
copy if you are interested. 

It has to identify what it is principles/concepts/introduction OF, 
and how it applies. For example, a general principle of a "reference 
name" could be that it can be used as a unique and unambiguous 
"language-independent" identifier for a language that. 
"language-independent": not necessarily bound to English or French.

> > The question, as I see it, becomes:
> > ISO code lists already contain French and English names. If 
> the registry
> > identifies the code list and the code, does it really need 
> to duplicate
> > all the fields from this list? 
> 
> There is no evidence which name is the reference name, however.

The item you identified above ("Chinese") has 3 codes, multiple
names and various criteria. One "view" into the code scheme is via 
the "alpha-2 if available, (one of) alpha-3 otherwise" rule. It is
not necessarily the only view.

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 11 Apr 2005 22:29:14 -0700

Randy Presuhn <randy underscore presuhn at mindspring dot com> wrote:

> Of those who support copying available French names (and
transcriptions)
> for the names of languages, would you be willing to support Jefsey's
> provisos?  My "pro" tally is Jefsey Morfin, "contra": John Cowan.

I am almost totally neutral on the basic question of adding French
names.  Maybe 51-49 in favor.

I am *completely* opposed to making this a precedent for adding names in
any other language.  The registry is not a general localization
resource.

Note that this question should not apply only to language subtags, but
to scripts, regions, variants, and (when they become available)
extended-language subtags and extensions.

> Of those who have been neutral on the question, would Jefsey's
provisos
> make it unpalatable to you?

Yes, mostly.  I can see some value in being consistent with the
bilingual nature of the names, as opposed to having some in two
languages and others in only one.  But they are already inconsistent in
that regard; there is no currently documented French translation of
"Boontling" or "Scouse."  It was just stated on the list that many of
the ISO 639-3 languages have a "reference name" that is not inherently
English or French.

I don't like the idea of appointing a French/English Policeman to
enforce bilingualism.  It should be the responsibility of the proposer
of a new entity to supply suitable descriptions, as it already is.

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/

---

From: "L.Gillam" <[email-masked]>
Date: Tue, 12 Apr 2005 09:28:12 +0100

+1

> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of John Cowan
> Sent: 12 April 2005 03:21
> To: Randy Presuhn
> Cc: [email-masked]
> Subject: Re: [Ltru] [psg.com #882] registry should copy non-English
> fields from ISO documents
> 
> 
> Randy Presuhn scripsit:
> 
> > provisos?
> No, indeed.  Most 639-3 names don't have French versions, and because
> standard written French is a vocabulary-controlled language (unlike
> standard written English) there is no reasonable prospect of getting
> such standard names.
> 
> -- 
> Unless it was by accident that I had            John Cowan
> offended someone, I never apologized.           
> [email-masked]
>         --Quentin Crisp                         
> http://www.ccil.org/~cowan
>

---

From: "Doug Ewell" <[email-masked]>
Date: Wed, 13 Apr 2005 22:59:23 -0700

JFC (Jefsey) Morfin <jefsey at jefsey dot com> wrote:

>> Speaking only for myself, I wasn't confused at all.  Randy's blanket
>> term, "Jefsey's provisos," was sufficiently vague that I had to
>> actually go back and read the post(s) in question, which I had
>> skimmed over before.  After reading them, I clearly understood
>> Jefsey's various suggestions, and was confident of my opposition to
>> them.
>
> you increase the problem rather than clarifiy it. What you oppose is
> my bundled personal positions (plural). Not different questions (each
> singular). But may be this is a normal way of thinking in this group,
> since the main problem it faces is of same nature: the bundling of XML
> parameters.

Would you prefer if I express my opposition to the points individually,
rather than bundling them together?  Very well:

> 1. if an Englist or French (or other languages to be added) name for a
> language is missing, it will be accepted as non fully documented until
> a name is provided (a IANA procedure and Reviewer will have to be
> designated).

I oppose this because of the needless overhead involved in blacklisting
a registry entry as "non fully documented" because it has not been
retrofitted with both an English and a French name.  As others have
indicated, many of the ISO 639-3 names are neither demonstrably English
nor demonstrably French.  This is not an issue for ISO 639-1 and -2, ISO
15924, ISO 3166, and UN M.49 because those standards already have French
names; however, the existing variant subtags and grandfathered and
redundant tags would all have to be retrofitted.

> 2. the same IANA registration could only be entered in English or
> French. It will be up to the French/English Reviewer to make sure the
> name in the missing language(s) is provided.

I oppose the concept of appointing a separate French/English Reviewer to
enforce the registration (and presumably the linguistic suitability) of
dual names.  The descriptions of items proposed for registration have
always been the responsibility of the person submitting the proposal,
and should continue to be so.

If you had other provisos besides these two, please send them to the
list so I can consider them as well.  I hate asking people to re-send
things they have already sent, but there has been a huge amount of
traffic on this list lately and I may have missed something.

-Doug Ewell
 Fullerton, California

---

From: "L.Gillam" <[email-masked]>
Date: Thu, 14 Apr 2005 08:35:06 +0100

Jefsey,
 
It may surprise you to learn that 639-3 will emerge from ISO, not this list. More specifically, it will emerge from ISO TC 37, whose title is currently "Terminology and other language resources". Currently there is a proposal to extend this title further to something like "Terminology and other language and content resources". TC 37 is made up of nominated representatives from national member bodies from a variety of countries. Originally it just dealt with "Terminology". The various representatives have in-depth understanding of, amongst other things, issues of translation in relation to languages in specialisations - ISO/IEC background, the work of Wuster (sans umlaut) and so forth. Such a committee understands, very well,  the principles of conceptually-oriented systems. Based on this extensive expertise, the current DIS document was created. Do you suggest that you have more expertise in these matters than the entirety of TC 37 and the members of this list on such matters? 
 
The purpose of reference names is to EXPLICITLY not be associated to a single language. They are used to act as "conceptual" identifiers as I have said previously on this very list. They are intended to be used to avoid accusations of language preference. They might be in English, they might be in French, they might be an autonym. The names are meant to "exist" outside the context of a language, and the intention is that they SHOULD NOT be analysed. A reference name COULD be /x1k4as5d6s7kb/ - why not? The reference name stands in place of the documentary evidence and so forth for that item. I don't see why this causes you a problem. 
 
For further reading, please, please, see:
http://www.iso.org/iso/en/stdsdevelopment/tc/tclist/TechnicalCommitteeDetailPage.TechnicalCommitteeDetail?COMMID=1459
 
I would also recommend reading, and fully digesting, documents including ISO 10241, ISO 16642, ISO 12620, ISO 704 and ISO 1087 parts 1 and 2 and other drafts as are emerging from TC 37. John Sowa's book on "Knowledge Representation", 
http://www.benjamins.com/jbp/series/TERM/9-2/art/0006a.pdf, and a library-load of other such documents will help you understand better what is being discussed.

________________________________

From: [email-masked] on behalf of JFC (Jefsey) Morfin
Sent: Thu 14/04/2005 00:46

(it makes the registry empty since ISO 639-3
uses reference names which by essence are not of a language, therefore not
English. And even if you twisted the text of the  "consensus" in accepting
ISO 639-3 reference names of English origin, the autonyms should stay
blocked .... these people refusing "1000" languages, forgetting that ISO
639-3 uses probably more than 1000 languages ...

---

From: "Doug Ewell" <[email-masked]>
Date: Sat, 16 Apr 2005 23:14:22 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

> If you want a dictionary of language / script / region names
> just create it.  IMHO it's unnecessary, dictionaries already
> exist.  Here are two utter dubious Google translations:
>
> http://purl.net/net/en2fr/users.adelphia.net/~dewell/lstreg.html
> http://purl.net/net/en2de/users.adelphia.net/~dewell/lstreg.html

Dubious is the word, all right.  I especially like the way the subtags
themselves were translated, so that 'av' for Avaric became "poids du
commerce" in French, and 'bm' for Bambara became "Schwerpunktshandbuch"
in German.

Thankfully, the Google translator limited its own damage by giving up
after the first ~400 translations.

-Doug Ewell
 Fullerton, California