Subject: RE: [Ltru] Re: Supress & Require Script

From: "Addison Phillips" <[email-masked]>
Date: Mon, 18 Apr 2005 09:13:53 -0700

Here is the proposed text for the draft. I have includes all of the rules together. Comments?

Addison

--
<t>The choice of subtags used to form a language tag should be guided by the following rules:

<list style="numbers">
   <t>Use as precise a tag as possible, but no more specific than is   
   justified. Avoid using subtags that are not important for 
   distinguishing content in an application. 

   <list>
      <t>For example, 'de' might suffice for tagging an email written 
         in German, while "de-CH-1996" is probably unnecessarily precise 
         for such a task.</t>
   </list></t>

   <t>The script subtag SHOULD NOT be used to form language 
   tags unless the script adds some distinguishing information to 
   the tag. The field 'Suppress_Script' in the primary language 
   record in the registry indicates which script subtags do not 
   add distinguishing information for most applications.

   <list>
      <t>For example, the subtag 'Latn' should not be used with the 
      primary language 'en' because most English documents are written 
      in the Latin script and it adds no distinguishing information. 
      However, if a document were written in English mixing Latin 
      script with another script such as Braille ('Brai'), then it 
      may be appropriate to choose to indicate both scripts to aid 
      in content selection, such as the application of a 
      stylesheet.</t>
   </list></t>

   <t>If a subtag has a 'Canonical' field in its registry entry, you 
   SHOULD use the canonical subtag in preference to any
   of its aliases. 

   <list>
      <t>For example, you should use 'he' for Hebrew in 
      Preference to 'iw'.</t>
   </list></t>

   <t>You SHOULD NOT use the 'UND' (Undetermined) language subtag to 
   label content, even if the language is unknown. Omitting the tag 
   is preferred. Some protocols may force you to give a value for the
   language tag and the 'UND' subtag may be useful when matching 
   language tags in certain situations.</t>

   <t>You SHOULD NOT use the 'MUL' (Multiple) subtag if the protocol 
   allows you to use multiple languages, as is the case for the 
   Content-Language header in HTTP.</t>

   <t>You SHOULD NOT use the same variant subtag more than once within 
   a language tag.

   <list>
      <t>For example, you should not use "en-GB-scouse-scouse".</t>
   </list> </t>
</list></t>
--

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Mark Davis
> Sent: dimanche 17 avril 2005 20:44
> To: [email-masked]; Frank Ellermann
> Subject: Re: [Ltru] Re: Supress & Require Script
> 
> It sounds to me like we have rough consensus for
> 
> suppress_script
> SHOULD NOT (but maybe a follow-on sentence or so)
> no real need for required_script
> 
> ‎Mark
> 
> ----- Original Message -----
> From: "Frank Ellermann" <[email-masked]>
> To: <[email-masked]>
> Sent: Sunday, April 17, 2005 18:25
> Subject: [Ltru] Re: Supress & Require Script
> 
> 
> > Randy Presuhn wrote:
> >
> > > 2) there seems to be general support for wording the
> > >    guidelines on the use of script subtags fairly strongly,
> > >    using "MUST ... except" rather than "SHOULD"
> >
> > Only "rough consensus" for the proposed "MUST NOT ... unless",
> > see <http://article.gmane.org/gmane.ietf.ltru:1240> - I'd like
> > a "SHOULD NOT ..." without "unless" clause better.  Bye, Frank
> >
> >
> >
> > _______________________________________________
> > Ltru mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ltru
> >
> >
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Mon, 18 Apr 2005 09:48:08 -0700

Looks good. Some wording:

> For example, the subtag 'Latn' should not be used with the
> most English documents are written
...
=>
For example, the subtag 'Latn' should not normally be used with the primary
language 'en' because the overwhelming majority of English documents are
written in the Latin script, thus 'Latn' does not normally add useful
distinguishing information.
However, if a document were written in English mixing Latin
...

[If it were only 'most' (eg > 50%) we would still need it, plus some other
wording to bridge to the next sentence.]

> We do the ones we know (probably most of the ISO 639-1 codes) and leave
the rest to the registration process?

agreed

‎Mark

----- Original Message ----- 
From: "Addison Phillips" <[email-masked]>
To: <[email-masked]>
Sent: Monday, April 18, 2005 09:13
Subject: RE: [Ltru] Re: Supress & Require Script

> Here is the proposed text for the draft. I have includes all of the rules
together. Comments?

----------------------------------------------------------------------------
----

---

From: Marion Gunn <[email-masked]>
Date: Mon, 18 Apr 2005 17:46:57 +0100

Is there any particular need to use 'YOU' forms, Addison? 

For example: 
(a) 'You should not use X';
rather than 
(b) 'X should not be used'.

I ask this, because your document contains an admixture of the two.

This creates problems of translation if taken literally, because the YOU
forms come across as rude in many languages (in the context of instructions/commands).

Indeed, I should prefer form (b) to be used throughout, even in English.

Hope this helps,
mg

Addison Phillips wrote:
> > â€*Mark
>   ------------------------------------------------------------------------

-- 

Marion Gunn * EGTeo (Estab.1991)
27 Páirc an Fhéithlinn, Baile an 
Bhóthair, Co. Átha Cliath, Éire.
* [email-masked] * [email-masked] *

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 18 Apr 2005 20:06:52 +0200

Addison Phillips wrote:

>| The script subtag SHOULD NOT be used to form language tags
>| unless the script adds some distinguishing information to
>| the tag. The field 'Suppress_Script' in the primary language
>| record in the registry indicates which script subtags do not
>| add distinguishing information for most applications.

Minor modification:

 | The script subtag should not be used to form language tags
 | unless the script adds some distinguishing information to
 | the tag. The field 'Suppress_Script' in the primary language
 | record in the registry indicates which script subtag SHOULD
 | NOT be used in tags with the given language.

>| You SHOULD NOT use the same variant subtag more than once
>| within a language tag.

 | Don't use the same variant subtag more than once within a
 | language tag.

Any SHOULD or MUST less makes the remaining SHOULD and MUST
stronger.  Probably that's only a matter of taste.  Bye, Frank

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 18 Apr 2005 11:59:19 -0700

Hi -

> From: "Marion Gunn" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Monday, April 18, 2005 9:46 AM
...
...
> forms come across as rude in many languages (in the context of instructions/commands).

Any translator worth his/her salt would use the correct form for the target
language.  Likewise, if one were translating German "man" or French "on"
into colloquial American English, I'd hope that the result would be an
appropriate "you" or "they", rather than the stuffy, though literal, "one".
I do, however, agree that the use of "you" in this way seems odd in
a specification, which by nature is relatively formal.

...

I really dislike passive voice, even though there are times when it is
useful.  I suspect it may cause more problems for non-native speakers
than the colloquial "you".  To your list of alternatives I'd add a third option:

(c) Implementations SHOULD NOT use X

However, I'm personally content to leave these matters to the editors'
discretion.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 18 Apr 2005 12:08:52 -0700

Hi -

> Sent: Monday, April 18, 2005 11:06 AM
> Subject: [Ltru] Re: Suppress & Require Script
...
...

It's more than a matter of taste, and I'd be willing to bet that if we
handed something like that to the IESG it'd come back with questions
about why we mixed "should" and "SHOULD" in the same paragraph,
and I, as a co-chair, would want to be able to give a coherent reply.

RFC 2119 tells us to use these sparingly, but whenever they are
truly necessary.  If we need to constrain the use of certain subatags
in certain contexts in order to preserve interoperability, that's
precisely the kind of situation where SHOULD/MUST language is
appropriate.

Randy

---

From: Marion Gunn <[email-masked]>
Date: Mon, 18 Apr 2005 21:33:47 +0100

> a specification, which by nature is relatively formal.

GRMA (Irish acronym for 'Thanks').

> ... 
> To your list of alternatives I'd add a third option:
> 

As am I.
mg

--

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 18 Apr 2005 22:34:52 +0200

Randy Presuhn wrote:

> I'd be willing to bet that if we handed something like that
> to the IESG it'd come back with questions about why we mixed
> "should" and "SHOULD" in the same paragraph,

I accept this bet, send them to me... ;-)  The problem here is
that we want to attach the SHOULD NOT to the "Suppress_script".

That's the critical point in this paragraph, "Supprees_script"
SHOULD NOT be used.

Addison's text doesn't say so, it attaches the SHOULD NOT to a
completely different and obvious issue:

>| the tag.

In other words, don't use script for e.g. audio data.  That's
interesting and correct, but not the really critical case of a
"Suppress_script" in the next sentence.

The rationale is also incomplete, it doesn't say why we had
the "Great Script Debate", and that "Suppress_script" is for
compatibility with existing content and 3066 implementations.

> If we need to constrain the use of certain subatags in
> certain contexts in order to preserve interoperability

Is that the case ?  An en-scouse-scouse-scouse is obviously
nonsense, there's no interoperability issue, the user will
get what he wants, some random garbage.

But en-Latn-US is critical, and Addison's text doesn't say so.
The "Latn" _is_ a "distinguishing information", and the point
is that it nevertheless SHOULD NOT be used.

                        Bye, Frank

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 18 Apr 2005 22:13:51 +0200

Randy Presuhn wrote:

> I really dislike passive voice

Me too.  It's an ugly 20th century pseudo-scientific style.
It tries to eliminate the subjects and the responsibility.

                          Bye, Frank

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 18 Apr 2005 13:51:08 -0700

Hi -

> Sent: Monday, April 18, 2005 1:34 PM
...
...

The fact that several (including you) see "en-Latn-us" as "critical"
is precisely what leads me, as a technical contributor, to believe
that "MUST NOT" is closer to what we intend.

Regarding the need for claritiy that the value of including rationale,
I think you and I are in violent agreement.

Randy