Subject: RE: [Ltru] Re: [psg.com #874] propagation of parent organizationdeprecations

From: "Addison Phillips" <[email-masked]>
Date: Thu, 7 Apr 2005 13:44:10 -0700

One small clarification and a difference:

Clarification: The draft already deals with collisions of new assignments with existing entries (deprecated or not). A withdrawal coupled with an assignment is TWO actions by the standards body, separately considered. Rules govern both actions independently (i.e. if Code A is withdrawn in favor of Code B and Code B already exists as Subtag B, Code A remains and is canonical, Subtag B remains and is canonical/deprecated as it sits with no changes and Code B is not inserted).

Difference: At present the editor's copy is different from #4 below, in that it allows a code to be deprecated when it is withdrawn. This would have an effect on stability of validation (in that a currently non-deprecated tag can become deprecated) but not on stability of validity (the tag is still valid and is in canonical form).

Another way to look at this is:

Previously we had only one field, "Canonical", and it served both for mapping and indicating deprecation. 

Now we have TWO fields, "Canonical" and "Deprecated" and these can be assigned independently and have separate stability guarantees.

Thus a subtag can be deprecated (because it was withdrawn) without mapping it to a new tag.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of John Cowan
> Sent: jeudi 7 avril 2005 13:20
> To: Randy Presuhn
> Cc: [email-masked]
> Subject: Re: [Ltru] Re: [psg.com #874] propagation of parent
> organizationdeprecations
> 
> Randy Presuhn scripsit:
> 
> > It seems that the discussion of this point evolved into discussions of
> > dealing with legacy data, tracking the dates of deprecations, and
> several
> > other questions.  Would someone like to take a stab at making a
> > concise statement of consensus on the basic question of how to deal
> > with deprecations, both past and future?
> 
> Here's my attempt:
> 
> 1) When a code is deprecated before Date A, it never gets into the
> registry at all.
> 
> 2) When a code is deprecated between Dates A and B, and a replacement code
> is provided, the new code goes into the registry as canonical, and the old
> code goes into the registry as deprecated with the canonical form given.
> 
> 
> 3) When a code is deprecated between Dates A and B, and a replacement
> code is not provided, the old code goes into the registry as deprecated
> with no canonical form.
> 
> 4) When a code is deprecated after Date B, and a replacement code is
> provided, the old code remains unchanged in the registry, and the new
> code goes into the registry as deprecated with the canonical form given.
> 
> 5) When a code is deprecated after Date B, and a replacement code is
> not provided, the old code remains unchanged in the registry.
> 
> This does not address the question of what happens when the new code is a
> recycled old code.
> 
> --
> Mos Eisley spaceport.  You will never           John Cowan
> see a more wretched hive of scum and            [email-masked]
> villainy -- unless you watch the                http://www.ccil.org/~cowan
> Jerry Springer Show.   --georgettesworld.com
> http://www.reutershealth.com
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Thu, 7 Apr 2005 23:16:17 -0700

Addison Phillips <addison dot phillips at quest dot com> wrote:

> Now we have TWO fields, "Canonical" and "Deprecated" and these can be
> assigned independently and have separate stability guarantees.
>

Is this a suggestion to get rid of all Canonical fields with value "--"
(dash-dash)?

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/