Subject: RE: [Ltru] Re: Proposed Text for Moving Forward

From: "Addison Phillips" <[email-masked]>
Date: Thu, 14 Apr 2005 16:48:36 -0700

Hmm...

So I didn't write prototype text for that yet. Mentally I had thought (and the text proposed implies rather strongly) that Expected_Script is a 2*[subtag] field. And that it is mutually exclusive with default.

The alternative I had thought of was letting Expected Script do both jobs, as in:

0*1[script] == SHOULD NOT use
2*[script] == SHOULD use

Let's consider for a moment a hypothetical case. Let's say language 'xyz' is listed initially with no script information. A user asks to register 'Cyrl' as the default script, produces information in language "xyz-Cyrl" to prove the point, and the result is registered.

Later another user complains that the language is also written in 'Latn'. 

1. Does the default script get removed and two expected scripts created?
2. Does the default script remain and a new expected script get created?
3. Does the default script remain and two expected scripts get created?

Clearly the case for registering a default script should be pretty darned convincing given the mess removing one makes. Perhaps we should allow zero or more expected scripts and write the rules based on that.

Perhaps the rules should be:

1. If the primary language has no associated script, you SHOULD NOT use a script subtag unless it adds distinguishing information for that context.

2. If the primary language has a single associated script and the content uses that script, you SHOULD NOT use the script subtag (unless etc.).

3. If the primary language has two or more associated scripts and the content uses one of them, you SHOULD use the script subtag (unless it is harmful to do so).

4. If the primary language has any number of associated scripts, but the content uses a different script, you SHOULD use the script subtag (unless it is harmful to do so).

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: jeudi 14 avril 2005 16:15
> To: [email-masked]
> Subject: [Ltru] Re: Proposed Text for Moving Forward
> 
> Misha Wolf wrote:
> 
> > 1. Is an Expected_Script_Subtag field and a Default_Script
> > field mutually exclusive?
> 
> No, the latter can be identified as "only one expected script"
> The rules are of course very different, SHOULD vs, SHOULD NOT.
> 
> > 3. Does an Expected_Script[_Subtag] field always contain at
> > least two Scripts?
> 
> Not if you combine them as in (1),  Probably that was your
> real question, can they be used together for the same language.
> 
> That's also possible, but then the "default" script cannot be
> "expected", otherwise you'd get a NOT RECOMMENDED SHOULD for
> this script.
> 
> In this version the number of expected sripts can be also one,
> e.g. language got, default Latn, expected Goth.   Bye, Frank
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 15 Apr 2005 03:51:03 +0200

> 0*1[script] == SHOULD NOT use

That's the KISS variant, therefore I like it.  Misha apparently
wanted a more complex solution allowing to mix a default script
with _additional_ expected scripts.  I don't see where Misha's
feature is necessary for 3066 compatibility, but it's possible.

> a hypothetical case. Let's say language 'xyz' is listed
> initially with no script information.

That could be a spoken language without script, a case of two
or more undetermined expected scripts, or a very dubious entry.
 
> A user asks to register 'Cyrl' as the default script,
> produces information in language "xyz-Cyrl" to prove the
> point, and the result is registered.

Better, now it has a script, xyz is processed as xyz-Cyrl. 

> Later another user complains that the language is also

Bad, the first user and the tag review got it wrong.  In the
KISS-variant Latn would be simply added => no more default, all
content tagged as "xyz implicitly xyz-Cyrl" should be updated.

As soon as there's no more default script 3066-compatibility
is impossible.  It's one of the two points of RfC 3066bis that
in this case the script should be used / added, a.s.a.p.  Here
a bit later than a.s.a.p. because the first user got it wrong,
but the final effect for 3066-compatibility is the same, it's
not possible for this language.

 [Misha's variant] 
> 1. Does the default script get removed and two expected
     scripts created?

One solution, same effect as in the KISS-scenario.

> 2. Does the default script remain and a new expected script
     get created?

Possible, Misha's variant allows this.  The hard question is
which of the two scripts should be the default.  And what's
the purpose of the other script, for info, a hint for taggers,
plausibility tests ?

> 3. Does the default script remain and two expected scripts
    get created?

That's not okay, it results in a NOT RECOMMENDED SHOULD.  You
could assign the same meaning for this case, but if it's the
same as in (2) you better forbid (3).

> 1. If the primary language has no associated script, you
>    SHOULD NOT use a script subtag unless it adds
>    distinguishing information for that context.

What's that, a spoken language, pictures of hieroglyphs or
knots, a WAV with Canarian whistles, Zxxx, Zyyy, or Zzzz ?

Your points 2..4 are what I called the KISS-variant.
 
> 3. If the primary language has two or more associated
>    scripts and the content uses one of them, you SHOULD use
>    the script subtag (unless it is harmful to do so).

When would it be harmful ?  It just doesn't work with RfC 3066
implementations or content.  It's more like "unless it's useful
to get any content, especially pre-3066bis content".
 
> 4. If the primary language has any number of associated
>    scripts, but the content uses a different script, you
>    SHOULD use the script subtag (unless it is harmful to do
>    so).

Same as 3, here it's only something like Brai, not Latn/Cyrl
or Hans/Hant.  RfC 3066bis is simply not fully compatible with
RfC 3066, the awful "default script" kludge can only fix this
for your case 2, but not for your cases 3 and 4.  Bye, Frank

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 14 Apr 2005 19:32:18 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "Frank Ellermann" <[email-masked]>; <[email-masked]>
> Sent: Thursday, April 14, 2005 4:48 PM
> Subject: RE: [Ltru] Re: Proposed Text for Moving Forward
...
> 1. If the primary language has no associated script,
> you SHOULD NOT use a script subtag
> unless it adds distinguishing information for that context.
>
> 2. If the primary language has a single associated script
>  and the content uses that script,
> you SHOULD NOT use the script subtag (unless etc.).
>
> 3. If the primary language has two or more associated scripts
> and the content uses one of them,
> you SHOULD use the script subtag (unless it is harmful to do so).
>
> 4. If the primary language has any number of associated scripts,
> but the content uses a different script,
> you SHOULD use the script subtag (unless it is harmful to do so).

To get the desired results for Gothic, (no subtag for Gothic transcribed
into latin alphabet, subtag required if using the historical Gothic alphabet)
I think this would mean that the entry for Gothic could not identify Gothic
as an associated script, and that the associated script (if any) would be
latin.  I guess this works, but I'd classify it as "obvious only if previously
understood."

Randy