Subject: RE: [Ltru] Re: Compatibility with existing use (LDAP)

From: "McDonald, Ira" <[email-masked]>
Date: Thu, 7 Apr 2005 08:43:56 -0700

Hi,

Inline below.

Cheers,
- Ira

Doug Ewell wrote:
> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Doug Ewell
> Sent: Thursday, April 07, 2005 3:09 AM
> To: LTRU Working Group
> Subject: [Ltru] Re: Compatibility with existing use (LDAP)
> 
> 
> Kurt D. Zeilenga <Kurt at OpenLDAP dot org> wrote:
> 
> > If you change the syntax and semantics of RFC 3066 tags,
> > you will break everything that relies on them.
> 
> Fortunately, we're not doing that.
> 

I don't believe that this quiet insertion of script between
language and region is harmless to RFC 3066 implementations.

It's true that such tags were allowed to be registered by
RFC 3066.  But there are literally millions of documents 
currently language tagged on the Internet in the style of 
'language-REGION-whatever' and lots of naive software thinks
that's the only valid form of a language tag.

The linguistic purity of infixing 'script' (between language
and region) is unwise.  The recent (all unsuccessful) numeric 
weighting algorithms for 'smart matching' make this point 
eloquently.

> Ira McDonald had written:
> 
> > Also, LTRU is developing an IANA registry of EVERY
> > possible valid language tag.
> 
> We're not doing that either.  Important distinction: we are 
> developing a
> registry of every possible valid *subtag*, not tag.  The 
> former adds up
> to just under a thousand items; the latter (including all the 
> ridiculous
> ones) would be about 15 million.
> 

Oops!  My silly mistake.  Tired fingers.

> -Doug Ewell
>  Fullerton, California
>  http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Thu, 7 Apr 2005 12:31:33 -0400

> that's the only valid form of a language tag.

Buggy and nonconformant software, I think you mean.  In any case, the
expectation is that such tags will be relatively rare, and only used
where needed.

> weighting algorithms for 'smart matching' make this point 

It's not linguistic purity, it's practicality.  A language in a script you
can't read, like en-Brai, is much worse than one from a different region.

-- 
Híggledy-pìggledy / XML programmers            John Cowan
Try to escape those / I-eighteen-N woes;        http://www.ccil.org/~cowan
Incontrovertibly / What we need more of is      http://www.reutershealth.com
Unicode weenies and / François Yergeaus.        [email-masked]