Subject: [Ltru] Registry in RDF/XML format.

From: "Jon Hanna" <[email-masked]>
Date: Sun, 3 Apr 2005 18:01:45 +0100

Hi, I've only barely been able to keep up with this list of late due to other obligations, but is an RDF/XML format completely out of the question?

Regards,
Jon Hanna
Work: <http://www.selkieweb.com/>
Play: <http://www.hackcraft.net/>
Chat: <irc://irc.freenode.net/selkie>

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Sun, 3 Apr 2005 14:43:01 -0700

Jon Hanna <jon at hackcraft dot net> wrote:

> is an RDF/XML format completely out of the question?

Nothing is completely out of the question yet.  The current thought
seems to be that record-jar would be easy for everyone to parse, while
XML requires a lot more overhead unless you already have an XML parser,
which is far from universally true.

There may be an XML version available for informative purposes, but the
record-jar version would be the one and only normative resource.  (For
that matter, I suppose anyone could host an XML version privately, as
long as it was clear that it was not official.)

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/

---

From: "Addison Phillips" <[email-masked]>
Date: Mon, 4 Apr 2005 09:21:05 -0700

No, but you and I are currently the only supporters of it, so it is unlikely to make the next draft. At this point I suspect that it could be defined in a future draft as an ancillary format (to the official registry in record-jar format).

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Jon Hanna
> Sent: dimanche 3 avril 2005 10:02
> To: 'LTRU Working Group'
> Subject: [Ltru] Registry in RDF/XML format.
> 
> Hi, I've only barely been able to keep up with this list of late due to
> other obligations, but is an RDF/XML format completely out of the question?
> 
> Regards,
> Jon Hanna

---

From: "Addison Phillips" <[email-masked]>
Date: Mon, 4 Apr 2005 13:53:36 -0700

> There are clearly numerous benefits to the XML registry.
> One of them (the ability to use the full range of Unicode
> characters) is one of the strongest arguments _against_
> the XML format registry as the Normative one (because
> it cannot be published in an initial registry RFC, which
> has been customary with most other new IANA registries).

That infelicity is clearly an argument against past IETF practice, not XML :-). Also, an XML file could be published in an RFC using NCRs. For that matter, I don't see that record-jar is defined formally anywhere: it is well-defined, but not in a capital-S Standard that I know of. 

We could thus define that the record-jar registry uses a \uxxxx (or similar) syntax to get the same effect in the registry as using a Unicode encoding. In fact, we should probably define the that values outside the range U+0000..U+007E use \u escaped hex syntax. 

The argument here is whether the utility of having an XML format is worth the cost, or whether the nature of the registry is such that a structured format such as XML is a better way in which to represent the data. And I believe the consensus is "no, it isn't necessary, use record-jar as the normative format".

Addison

Addison P. Phillips

> From: McDonald, Ira [mailto:[email-masked]]
> Sent: lundi 4 avril 2005 13:14
> To: Addison Phillips; Jon Hanna; LTRU Working Group
> Subject: RE: [Ltru] Registry in RDF/XML format.
> 
> Hi,
> 
> As long as the XML format registry is clearly labelled
> 'Informative' and only the one Record-Jar format registry
> is labelled 'Normative' (and maintained by IANA), I'd be
> happy to see an auxiliary XML format registry.
> 
> There are clearly numerous benefits to the XML registry.
> One of them (the ability to use the full range of Unicode
> characters) is one of the strongest arguments _against_
> the XML format registry as the Normative one (because
> it cannot be published in an initial registry RFC, which
> has been customary with most other new IANA registries).
> 
> Cheers,
> - Ira
> 
> Ira McDonald (Musician / Software Architect)
> Blue Roof Music / High North Inc
> PO Box 221  Grand Marais, MI  49839
> phone: +1-906-494-2434
> email: [email-masked]
> 
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Addison Phillips
> Sent: Monday, April 04, 2005 12:21 PM
> To: Jon Hanna; LTRU Working Group
> Subject: RE: [Ltru] Registry in RDF/XML format.
> 
> 
> No, but you and I are currently the only supporters of it, so it is
> unlikely
> to make the next draft. At this point I suspect that it could be defined
> in
> a future draft as an ancillary format (to the official registry in
> record-jar format).
> 
> Addison
> 
> Addison P. Phillips