Subject: RE: [Ltru] Re: ISO 639-6

From: "Addison Phillips" <[email-masked]>
Date: Tue, 12 Apr 2005 09:37:42 -0700

STRONGLY RECOMMENDED is an RFC 2119-ism. We're not screaming. Since it doesn't make a lot of difference in practice, though, I can change the case on STRONGLY.

The old i-* format is ghastly and greatly complicates processing (since it is a singleton). Let's avoid it and use just subtags.

As for removing the ability to register a primary language subtag, we have a conceit that variant can be used to register anything not indicated by one of the ISO/UN based standards. But this cannot work for one case, which is primary language. The fact that all of the registered primary languages turned out to be junk doesn't necessarily mean that the same will hold true in the future. So we leave a very small loophole to allow it.

The existence of a registry makes some of this moot, however. What's valid in a language tag is whatever the registry says. Some of the ABNF handwaving is no longer strictly necessary by that measure. We could use the ABNF I proposed and merely forbid or greatly restrict the use of registered primary languages.

What's important to a well-formed processor is that a primary language is a 2*8ALPHA. What's important to a validating processor is that the subtag is in the registry. How it got into the registry is another matter. I can easily agree to restrict independent registrations to 5*8ALPHA (especially since I think we'll get zero of them).

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: mardi 12 avril 2005 09:06
> To: [email-masked]
> Subject: [Ltru] Re: ISO 639-6
> 
> Addison Phillips wrote:
> 
> > lang = 2*8ALPHA  ; primary language subtags
> 
> At the moment it's:
> 
> lang            = 2*3ALPHA         ; shortest ISO 639 code
>                   / registered-lang
> registered-lang = 4*8ALPHA         ; registered language subtag
> 
> If the idea is to reserve alpha-4 for ISO 639-6, how about:
> 
> lang            = 2*4ALPHA         ; shortest ISO 639 code
>                   / registered-lang
> registered-lang = 5*8ALPHA         ; registered language subtag
> 
> Your text says about registered-lang tags (none at the moment):
> 
> | MAY be used to form the primary language subtag
> [...]
> | future registrations of this type will be discouraged:
> | primary languages are STRONGLY RECOMMENDED for registration
> | with ISO 639 and subtags rejected by ISO 639 will be closely
> | scrutinized before they are registered with IANA.
> 
> In other words NOT RECOMMENDED, please use lower case instead
> of STRONGLY, screaming doesn't help with RfC 2119.  Why do we
> need registered-lang at all ?  The old i-whatever was good
> enough for this purpose.  You would get a much simpler ABNF,
> and the old i-whatever system is automagically discouraging.
> 
> Just say (modulo "shortest" if necessary for ISO 639-6):
> lang            = 2*4ALPHA         ; shortest ISO 639 code
> 
> Remove registered-lang everywhere.  Then fix the registration
> procedures to allow new IANA i-whatever tags.  For the ABNF
> that means:
> 
> 1 - insert "individual" between "private-use / gradfathered"
> 2 - lang = 2*4ALPHA, remove "registered-lang" in "lang"
> 3 - remove registered-lang
> 4 - replace 1*3ALPHA in "grandfathered" by 2*3ALPHA, strip the
>     singleton i- comment from "grandfathered"
> 5 - add a new "individual" before "grandfathered":
>     individual = "i" 1*2("-" (2*8alphanum))
> 
> In the procedures replace "registered-lang" by "individual",
> mention that an "individual" tag is deprecated when a proper
> ISO 639 tag is introduced.
> 
> The tag reviewer has accepted several obscure tags for fantasy
> Macao-languages, it's time to stop this nonsense in 3066bis.
> 
> The old i-whatever was better for dubious tags.  Bye, Frank
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Scott Hollenbeck" <[email-masked]>
Date: Tue, 12 Apr 2005 13:12:22 -0400

> STRONGLY RECOMMENDED is an RFC 2119-ism. We're not screaming. 
> Since it doesn't make a lot of difference in practice, 
> though, I can change the case on STRONGLY.

"STRONGLY" is not described in 2119, "RECOMMENDED" is.  The case should
definitely be changed to "strongly".

-Scott-