Subject: RE: [Ltru] hyphen-minus (was: new version posted online)

From: "Addison Phillips" <[email-masked]>
Date: Tue, 19 Apr 2005 09:02:31 -0700

If no one objects, I'll remove the restriction to Latin-1 from description. Variant registrations will be asked to provide a Description using or transcribed into the Latin script. Perhaps:

---
The 'Description' field must contain a description of the tag being registered written or transcribed into the Latin script; it may also include a description in a non-Latin script. Non-ASCII characters must be escaped using the syntax described in Section 3.1. The 'Description' field is used for identification purposes and should not be taken to represent the actual native name of the language or variation or to be in any particular language. Most descriptions are taken directly from source standards such as ISO 639 or ISO 3166. 

While the 'Description' field is not guaranteed to be stable and errata corrections may be undertaken from time to time, attempts to provide translations or transcriptions of entries in the registry itself will probably be frowned upon by the community or rejected outright.
---

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: mardi 19 avril 2005 08:08
> To: [email-masked]
> Subject: [Ltru] hyphen-minus (was: new version posted online)
> 
> Addison Phillips wrote:
> 
> >> Do we have any convincing reasons to use "_" instead of "-"
> >> in field names ?  Mail and news header field names use "-"
> >> (no rule, an observation).
> 
> > No reason. Actually, hyphen-minus would be more in keeping
> > with the spirit of 3066 I suppose.
> 
> With Doug 3:0 for HYPHEN-MINUS (a.k.a. 'dash' in 2234bis)
> 
> > The names are all Unicode character names.
> 
> The x-refs in U40M030411.lst use lower case:
> 
> | 2010    HYPHEN
> |         x (hyphen-minus - 002D)
> |         x (soft hyphen - 00AD)
> 
> > Thankfully we don't have any examples that use Indic zero
> > digits :-).
> 
> Checking, yes, thanks.  One of the many advantages of Unicode,
> it's impossible to have a worse idea that still makes sense.
> 
>  [yuml but no Yuml]
> > Various folks wanted that limitation to reference ISO 8859-1,
> > but as a Unicadet I fudged and used Unicode blocks.
> 
> The but-part is clear, I don't get the premise:  If now Doug or
> later IANA are forced to filter "official" descriptions found
> in the source standards against Latin-1 it could be a problem.
> 
> What if the only official description uses Latin-0 characters
> not covered by Latin-1 ?  Yuml is on the letterbase list with
> characters required for French, Jefsey wil kill us if that's
> true and we exclude it without good reasons:
> 
> http://www.eki.ee/letter/chardata.cgi?lang=fr+French&imgonly=on&script=lat
> in
> 
> > Limiting to "script = Latn" is messy
> 
> True, why not simply copy whatever the official source says ?
> Let them do their own limiting.
> 
> > Personally, I don't agree with having to have a limitation.
> > Why restrict ourselves unnecessarily?
> 
> Add me.  Bye, Frank
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Wed, 20 Apr 2005 02:23:25 +0200

On 18:02 19/04/2005, Addison Phillips said:
>attempts to provide translations or transcriptions of entries in the 
>registry itself will probably be frowned upon by the community or rejected 
>outright.

I do not see the need for this. It would certainly kill the remaining 
chance of possible consensus if some of my still undiscussed points were 
positively addressed. If maintained and accepted by the IESG it could only 
lead to an appeal, most probably supported by many authorities.

In my opinion the purpose of BCP 047 is to give a common framework to the 
various language identification classes, schemes, formats and filters and 
to permit the provision of coherent translations and transcriptions of each 
registry entries to each lingual community.

jfc