Subject: RE: [Ltru] Re: Proposed changes to region subtags

From: "McDonald, Ira" <[email-masked]>
Date: Sat, 2 Apr 2005 05:30:34 -0800

John Cowan replied to Doug Ewell:

>> - max line length (80, 72, etc.)
>
>No opinion on this one.
>
>> - character(s) used for comments ("%%" versus "#")
>
>In record-jar the %% is a separator, and anything following that on the
>same line is not part of the data structure.  So IMHO comments should
>be handled as a separate "comment:" field.
>
>> - line breaking convention (backslash-newline, newline-space, etc.)
>
>Record-jar is based on RFC (2)822, so newline-space(s) is the convention.

I agree with John's comments above on comments and line breaking.

Please make max line length 72 - otherwise it can't be published
in an RFC with margins (which the RFC editor now requires).  Also,
the record-jar can then be reviewed in plaintext with prefix or
suffix line numbers and still be within 80 characters.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Sat, 2 Apr 2005 12:49:37 -0800

> I agree with John's comments above on comments and line breaking.

I have to admit, I'm surprised that newline-space (with no backslash) is
preferred.  I would think that would make parsing more difficult, since
you have to look one line ahead to see if you have line continuation.

> suffix line numbers and still be within 80 characters.

Will do.

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/