Subject: RE: [Ltru] Re: Compatibility with existing use (LDAP)

From: "Addison Phillips" <[email-masked]>
Date: Fri, 8 Apr 2005 10:31:07 -0700

To back up for a second: does my proposal about recommended prefix (I think you indicated initial enthusiasm, Ned) solve this problem sufficiently to move forward with this design?

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of John Cowan
> Sent: vendredi 8 avril 2005 10:18
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Ltru] Re: Compatibility with existing use (LDAP)
> 
> [email-masked] scripsit:
> 
> > A compliant RFC 3066 implementation can (and I know for a fact has) been
> > written that handles these exceptions through an exception table, but
> still
> > operates under the assumption that a two letter code in the second
> position is
> > a country code but a two letter code elsewhere is not.
> 
> An assumption quite without warrant in the text of RFC 3066.
> 
> > Like it or not, there are lots of application domains where script
> information
> > is much less readily available than country information.
> 
> The intention (as Addison has developed in his messages on the subject) is
> to use script information only for those languages where it is commonly
> required.
> 
> > Not true. The question is what was or was not standardized in the past.
> The
> > rules for country code positioning were clearly written and clearly
> normative.
> 
> RFC 3066 states that a 2-letter subtag in the second position is
> normatively
> a country code.  It nowhere states the converse, and goes out of its way
> to say that there are no rules for positions past the second.
> 
> --
> De plichten van een docent zijn divers,         John Cowan
> die van het gehoor ook.                         [email-masked]
>       --Edsger Dijkstra                         http://www.ccil.org/~cowan
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: [email-masked]
Date: Fri, 08 Apr 2005 16:03:00 -0700 (PDT)

> To back up for a second: does my proposal about recommended prefix (I think
> you indicated initial enthusiasm, Ned) solve this problem sufficiently to move
> forward with this design?

I think it does. There's still a backwards compatibility problem, but this
mechanism is the best way I've seen to try and minimize it.

Part of the issue here lies in the nature of script codes themselves. There are
lots of cases where the script something is written in can easily be determined
from the content iself with a high degree of reliability. This means its
possible that script subtags will start showing up in all sort of places where
they aren't really needed.

Providing guidance as to where they are needed (and by inference where they are
probably superfluous) will help limit this behavior.

				Ned