Subject: RE: [Ltru] Re: Registry in record-jar format

From: "Addison Phillips" <[email-masked]>
Date: Mon, 4 Apr 2005 09:26:52 -0700

REGISTERED tags from the RFC 3066 registry that are deprecated will be maintained as grandfathered entries.

The current text was added in the current draft to prevent the variant subtag 'lojban'. Adding the word in caps above would fix that, I believe.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: dimanche 3 avril 2005 12:59
> To: LTRU Working Group
> Subject: [Ltru] Re: Registry in record-jar format
> 
> Mark Davis <mark dot davis at jtcsv dot com> wrote:
> 
> >>> Do we need the "redundant" entries ?  As the name says they are
> >>> really redundant.
> >
> > I don't care much either way. What I was saying in my note that the
> > redundant *comments* on the redundant records were, well, redundant.
> 
> I don't like them either.  I thought there was a statement in the draft
> that "redundant" entries had to have such a comment.  Maybe it has to do
> with the passage in Appendix C that grandfathered entries have to have a
> comment "indicating... [the] reason for the deprecation."  Maybe it was
> part of a discussion months ago.  Maybe I just dreamed it.
> 
> In any case, I'm happy to remove the redundant comments (ambiguity
> intended) if it's OK with everyone else.
> 
> BTW, that whole paragraph in Appendix C is confusing to me:
> 
> "Tags that are currently deprecated will be maintained as grandfathered
> entries. The record for the grandfathered entry will contain a note
> indicating that the entry is 'deprecated' and reason for the
> deprecation. For example, the tag "art-lojban" is deprecated and will be
> placed in the grandfathered section."
> 
> There is no intrinsic relationship between grandfathered and deprecated.
> The tag "i-ami" is grandfathered but not deprecated, while the tag "in"
> is deprecated but not grandfathered.  Only 28% of the grandfathered tags
> are deprecated, and in fact none were until we added the long-missing
> provision to give them a whole-tag canonical value.
> 
> -Doug Ewell
>  Fullerton, California
>  http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 4 Apr 2005 22:04:42 -0700

Addison Phillips <addison dot phillips at quest dot com> wrote:

> The current text was added in the current draft to prevent the variant
> subtag 'lojban'. Adding the word in caps above would fix that, I
> believe.

Thanks; that makes a lot more sense.

-Doug Ewell
 Fullerton, California