Subject: RE: [Ltru] New version posted: ready for publication??

From: "Addison Phillips" <[email-masked]>
Date: Thu, 21 Apr 2005 10:59:55 -0700

See below. Excised excess text.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> 
> > >
> > > 2.1.1
> > > [add] All subtags are from 1 to 8 characters in length.
> > [Addison Phillips]
> >
> > Not sure where you want me to put this. 2.1.1 is the length
> considerations
> section and I don't see a particular spot to stick this text.
> 
> We can put this below the ABNF itself in a note. In the Length
> considerations, perhaps the following
> " This limits most tags to a sequence of four subtags (excluding any
> extensions or private use sequences). "
> =>
>  In practice, this limits most tags to a sequence of four subtags -- and
> thus a length of 35, because subtags are limited to a length of 8 each
> (excluding any extensions or private use sequences).
[Addison Phillips] 

There were a couple of problems with that text (it seemed to suggest that extensions and private use were not limited to 8 character subtags), so I put:

<t>In particular,  variant subtags SHOULD be used only with their recommended prefix.  In practice, this limits most tags to a sequence of four subtags, and
thus a length of 35 (excluding any extensions or private use sequences), because subtags are limited to a length of eight characters. See <xref target="choice"></xref> for more information on selecting the most appropriate Language Tag.</t>
> 
> >
> > > 4.1 [some extra you's]
> > >  Some protocols may force you to give a value for the language tag and
> the
> > > 'UND' subtag may be useful when matching language tags in certain
> > > situations.
> > > =>
> > >  The 'UND' subtag may be necessary when a protocol requires a value
> for
> > > the
> > > language tag, or when matching language tags in certain situations.
> > [Addison Phillips]
> >
> > I did a slightly different rewrite:
> >
> > Some protocols may require a value for the language tag and the 'UND'
> subtag may be useful when matching language tags in certain situations.
> 
> I did a bit more shuffling around, because the sentences was very clumsy.
> The two clauses are really disconnected, separate reasons for why someone
> might want to use UND, but the "and" makes them sound like they are
> supposed
> to be connected. So I prefer my rewrite.
[Addison Phillips] 

I hear you. I changed it to:

<t>The 'UND' (Undetermined) primary language subtag SHOULD NOT be used to label content, even if the language is unknown. Omitting the tag is preferred. Some protocols may require a value for the language tag. The 'UND' subtag may also be useful when matching language tags in certain situations.</t>
> 
> > >
> 
> >
> > --
> > The 'MUL' subtag conveys little useful information: content in multiple
> languages should individually tag the languages where they appear or
> otherwise indicate the actual language in preference to the 'MUL' subtag.
> SURE
> 
> > --
[Addison Phillips] 

Inserted.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 21 Apr 2005 21:35:04 +0200

Addison Phillips wrote:

> In practice, this limits most tags to a sequence of four
> subtags, and thus a length of 35 (excluding any extensions
> or private use sequences), because subtags are limited to a
> length of eight characters.

35 = 4*8 + 3 dashes is clear, but not "in practice".  This is
something Bruce and the RfC 2231 cohorts will find.  BTW, you
still have 2*3ALPHA / registered-lang and *("-" extlang)

Assuming that you fix it to 2*4ALPHA / registered-lang and at
most one extlang you get 22 = 8 + 4 + 3 + 8 + 3 dashes for a
registered-lang without extlang or 25 = 3 + 3 + 4 + 3 + 8 + 4
dashes for an alpha-3 language with extlang.

A worst case 25 is much more friendly than 35 for the encoded
words in mail headers.

=?pc-multilingual-850+euro*xxx-yyy-Latn-999-limerick?Q?yes?=
....5...10....5...20....5...30....5...40....5...50....5...60

Excellent, the RfC 2047 limit is 75 => 13 characters left for
the content, that's nine characters for base64, and certainly
more than one B64 encoded UTF-8.

Something I've tested for USEFOR:

 =?UTF-8*de-DE-1996?B?RG9uYXVkYW1wZnNjaGlmZmZhaHJ0c2thcGl0w6Ruc23DvHR6ZQ==?=
....5...10....5...20....5...30....5...40....5...50....5...60....5...70....5.

Yes, it's ridiculous.  But Ned didn't like my idea to obsolete
RfC 2231 for "various reasons".
                               Bye, Frank

---

From: "Mark Davis" <[email-masked]>
Date: Thu, 21 Apr 2005 11:10:46 -0700

‎Mark

----- Original Message ----- 
From: "Addison Phillips" <[email-masked]>
To: "ltru Working Group" <[email-masked]>
Sent: Thursday, April 21, 2005 10:59
Subject: RE: [Ltru] New version posted: ready for publication??

> There were a couple of problems with that text (it seemed to suggest that
extensions and private use were not limited to 8 character subtags), so I
put:
>
> <t>In particular,  variant subtags SHOULD be used only with their
recommended prefix.  In practice, this limits most tags to a sequence of
four subtags, and
> thus a length of 35 (excluding any extensions or private use sequences),
because subtags are limited to a length of eight characters. See <xref
target="choice"></xref> for more information on selecting the most
appropriate Language Tag.</t>

Good

> <t>The 'UND' (Undetermined) primary language subtag SHOULD NOT be used to
label content, even if the language is unknown. Omitting the tag is
preferred. Some protocols may require a value for the language tag. The
'UND' subtag may also be useful when matching language tags in certain
situations.</t>

Good

> > otherwise indicate the actual language in preference to the 'MUL'
subtag.

Good.

> Inserted.

----------------------------------------------------------------------------
----