Subject: RE: [Ltru] updated editor's copies...

From: "Addison Phillips" <[email-masked]>
Date: Wed, 6 Apr 2005 12:23:49 -0700

Randy informed me. I'm waiting for the updated xml2rfc to be final before making that change.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: Scott Hollenbeck [mailto:[email-masked]]
> Sent: mercredi 6 avril 2005 12:11
> To: Addison Phillips; [email-masked]
> Subject: RE: [Ltru] updated editor's copies...
> 
> One quick comment: RFC 2234 (the ABNF spec) is being obsoleted.  Please
> reference draft-crocker-abnf-rfc2234bis-00.txt instead of RFC 2234 and
> confirm that everything that was valid before is still valid.  The IESG
> approved this document as a Draft Standard last week.
> 
> -Scott-
> 
> > -----Original Message-----
> > From: Addison Phillips [mailto:[email-masked]]
> > Sent: Wednesday, April 06, 2005 3:00 PM
> > To: [email-masked]
> > Subject: [Ltru] updated editor's copies...
> >
> >
> > Are now available on:
> >
> > http://www.inter-locale.com/ID/draft-ietf-ltru-registry-01.html
> > http://www.inter-locale.com/ID/draft-ietf-ltru-registry-01.txt
> > http://www.inter-locale.com/ID/draft-ietf-ltru-registry-01.xml
> >
> > More textual work is necessary before these are submitted,
> > but comments are especially welcome at this point. Sections
> > that have been heavily modified include 3.1 (registry
> > format), 3.3 (registration process), and Appendix C (registry
> > conversion). Other changes are noted in the changes section.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 07 Apr 2005 00:55:44 +0200

Addison Phillips wrote:
 
> waiting for the updated xml2rfc to be final

It works, ipr="full3978".  There's also a new nice validator:
<http://rtg.ietf.org/~fenner/ietf/xml2rfc-valid/>

No idea why Scott is so adamant about 2234bis, the bibxml is:
<http://xml.resource.org/public/rfc/bibxml3/reference.I-D.crocker-abnf-rfc2234bis.xml>

                        Bye, Frank

---

From: "Scott Hollenbeck" <[email-masked]>
Date: Thu, 7 Apr 2005 07:32:18 -0400

> <http://xml.resource.org/public/rfc/bibxml3/reference.I-D.croc

Scott is adamant about it because 2234 is being obsoleted, and you can't use
obsolete specs as normative references.  Pay me now or pay me later, new
docs will not get approved by the IESG if you cite obsolete specs.

-Scott-

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 07 Apr 2005 18:43:33 +0200

Scott Hollenbeck wrote:

> Pay me now or pay me later

Later could be less expensive, changing the reference in the
XML source once when 2234bis got a number.  And the xml2rfc
output for I-Ds in an <xref> is rather ugly.

I'm "almost sure "that the minor differences between 2234bis
and 2234 are irrelevant for the LTRU ABNF.  But "almost sure"
is not necessarily good enough if it contains vague factors
like "Bruce checked it".

> new docs will not get approved by the IESG if you cite
> obsolete specs.

There's no serious problem with 2234, otherwise you'd be very
busy to update numerous RfCs using the "old" ABNF.  And it's
not always illegal to cite old specs as normative reference:  I
could use 822 instead of 2822 (relevant here for the folding
of registry lines - I've checked LWSP in 2234 and 2234bis, it's
not what we need).

Ok., 2243bis vs. 2234 is not exatly the same as 2822 vs. 822,
because their status is different.  For me that's all still
"esoteric", like the fine points of "experimental RfCs" created
by a WG vs. "experimental RfCs" as individual submission.

Normally I'd prefer to say "RfC 2234" if that's what I checked,
and not to pretend that I checked "2234bis" when that's simply
not true.  "Almost sure" can be very dangerous.  In that case I
risk it because I trust that Dave, you, and Bruce got it right.

                             Bye, Frank