Subject: RE: [Ltru] ISO 3166-1 DIS ballot

From: "L.Gillam" <[email-masked]>
Date: Tue, 26 Apr 2005 15:53:00 +0100

Something like that........

7.5.2 Reallocation period 
Code elements that the ISO 3166/MA has altered or
deleted should not be reallocated during a period of
at least fifty years after the change. The exact
period is determined in each case on the basis of
the importance of the extent to which the former
code element was used.

7.5.2 Codets réservés pour une durée
déterminée
Les codets qui ont été modifiés ou supprimés par
l'ISO 3166/MA ne doivent pas être réattribués
pendant cinquante ans au moins à partir du
changement. La période exacte est déterminée,
dans chaque cas, selon l'importance de l'usage de
l'ancien codet.

7.5.3 Period of non-use 
Certain code elements existing at the time of the
first publication of the ISO 3166 country codes and
differing from those in this part of ISO 3166 should
not be used for an indeterminate period to
represent other country names. This provision
applies to certain vehicle designations notified
under the 1949 and 1968 Conventions on Road
Traffic (see Bibliography).

Code elements to which this provision applies
should be included in the list of reserved code
elements (see 7.5.6) and should not be reallocated
during a period of at least fifty years after the date
when the countries or organizations concerned
have discontinued their use.

7.5.3 Période de non-usage
Certains codets utilisés au moment de la première
publication de l'ISO 3166, mais qui diffèrent de ceux
figurant dans la présente partie de l'ISO 3166, ne
doivent pas être utilisés pour représenter d'autres
pays, et ce, pour une durée indéterminée. Ceci
s'applique à certaines désignations de véhicules
notifiés dans les Conventions sur la Circulation
Routière (1949 et 1968; voir la Bibliographie).

Les codets auxquels s'applique cette réserve
doivent être introduits dans la liste des codets
réservés (voir 7.5.6) et ne pas être réallouées
pendant une période d'au moibs cinquante ans
après la date à laquelle les pays ou organisations
ont cessé de les utiliser

> -----Original Message-----
> From: John Cowan [mailto:[email-masked]]
> Sent: 26 April 2005 15:31
> To: Gillam L Dr (Computing)
> Cc: [email-masked]
> Subject: Re: [Ltru] ISO 3166-1 DIS ballot
> 
> 
> L.Gillam scripsit:
> > 
> > With discussion of country codes, I can't remember if anybody had
> > brought the DIS ballot on 3166 that began 2005-02-24 and 
> will terminate
> > 2005-07-24 to the attention of the WG. 
> 
> I don't think so, no.  This is the version that sets the 50-year lower
> limit for code reuse?
> 
> -- 
> John Cowan  www.reutershealth.com  www.ccil.org/~cowan  
> [email-masked]
> The Penguin shall hunt and devour all that is crufty, gnarly and
> bogacious; all code which wriggles like spaghetti, or is infested with
> blighting creatures, or is bound by grave and perilous 
> Licences shall it
> capture.  And in capturing shall it replicate, and in 
> replicating shall
> it document, and in documentation shall it bring freedom, serenity and
> most cool froodiness to the earth and all who code therein.  
> --Gospel of Tux
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 27 Apr 2005 03:28:57 +0200

L.Gillam wrote:

> Code elements that the ISO 3166/MA has altered or deleted
> should not be reallocated during a period of at least fifty
> years after the change.  The exact period is determined in
> each case on the basis of the importance of the extent to
> which the former code element was used.

In other words 3066bis draft -01 should work without problems
at least until date A plus 50 years (2038).  And maybe we can
improve this situation in draft -02 with a new "canonical" rule
following 3166-1 as long as possible - until the registry is
finally forced to take the emergency exit "UN number".  

Not bad.  If the future Internet users really hate it they are
free to invent a new 3066ter where all old 3166-1 codes are
frozen and deprecated and replaced by UN numbers.  And in that
case I'd want an "I told you so" on my grave. ;-)  Bye, Frank

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Wed, 27 Apr 2005 11:48:34 +0200

On 03:28 27/04/2005, Frank Ellermann said:
>case I'd want an "I told you so" on my grave.   Bye, Frank

I do not think this is an acceptable statement both in regard to the 
non-yet debatted charter and of industry needs and market criteria.

It is not either an acceptabe proposition. A position statement should be 
included in the IANA part, since IANA - through ICANN - is a member of the 
ISO 3166 committee, how dormant it is.

The use of 3166-1 alpha2 codes is a choice of this Draft to match some 
existing Internet standard formats. It is up to BCP 047 to document the 
possible use of other formats. No need to wait your decease (unless you 
want the Draft to be your grave).

jfc

---

From: "Randy Presuhn" <[email-masked]>
Date: Sat, 30 Apr 2005 11:52:37 -0700

Hi -

> From: "Frank Ellermann" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, April 26, 2005 6:28 PM
> Subject: [Ltru] Re: ISO 3166-1 DIS ballot
>

> finally forced to take the emergency exit "UN number".
...

Do you have specific text you'd like to propose?
Keep in mind that we don't want to make a normative reference
to work-in-progress.

Randy