Subject: RE: [Ltru] Re: registry should copy non-English fields from ISOdocuments

From: "Peter Constable" <[email-masked]>
Date: Mon, 11 Apr 2005 10:32:46 -0700

From: [email-masked] [mailto:[email-masked]]
On Behalf Of L.Gillam

> The second question becomes:
> If 639-3 is using the name of the language in the language itself...

The initial table of 639-3 will be using a name by which the given
entity has been documented, but the origins of which are not specified.
It would have been an impossible task to validate that all of 7000+
names have this or that kind of origin.

Peter Constable

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "L.Gillam" <[email-masked]>
Date: Tue, 12 Apr 2005 08:59:26 +0100

> > > 3. A code (e.g. alpha3 in 639-3) stands as synonymous with the
> reference
> > > name and as entry point into the "conceptual" entry - the 
> mantra is
> > > "I don't care what you call it as long as we are referring to the
> > > same thing"
> > 
> > The code points to the name, but the name does not always
> unambiguously
> > point to the language...
> 
> I think Lee's point is that the name used is intended to document the
> conceptual entity in a way that ideally is unambiguous. I don't think
> you two are actually disagreeing about anything; you're just 
> struggling
> over common words to describe a common understanding.

Indeed, and clearly the use of good descriptions for such items in the 
relevant documents is going to be paramount to try and develop common
understanding for unknown readers. The "how many language names" discussion
shows differences in practice in the -1/-2/-3 documents - I will address
this in a later mail.

> > > ensuring -4 has necessary and sufficient coverage.
> > 
> > >From what I understand (I have not seen a draft), -4 will be
> conceptual
> > and introductory (-0, in other words, if ISO rules permitted a -0
> part)
> > and will not provide coverage of anything.  Has this changed?
> 
> If by "coverage" you mean "specify identifiers for some 
> languages", your
> assumption is correct: part 4 will not do this (and has not changed in
> that regard).

Ah, got the contextualisation now. Necessary and sufficient coverage of
the principles. No new tags! ;-)