Subject: Re: [Ltru] Registry in record-jar format

From: "Mark Davis" <[email-masked]>
Date: Sat, 2 Apr 2005 13:02:08 -0800

The deprecated info might as well be a real field instead of just a comment:

Type: language
Subtag: in
Description: Indonesian
Date: 2004-07-06
Canonical_Value: id
# deprecated 1989

=> Type: language
Subtag: in
Description: Indonesian
Date: 2004-07-06
Canonical_Value: id
Deprecated: 1989
Same for the name change: Type: region
Subtag: NH
Description: Vanuatu
Date: 2004-07-06
Canonical_Value: VU
# changed 1980, formerly New Hebrides=> Type: region
Subtag: NH
Description: Vanuatu
Date: 2004-07-06
Canonical_Value: VU
Name_Changed: 1980Former_Value: New HebridesThe comments for redundant can
be dropped, they don't add information:

Type: redundant
Subtag: az-Cyrl
Description: Azerbaijani in Cyrillic script
Date: 2003-05-30
# use language az + script Cyrl

‎Mark

----- Original Message ----- 
From: "Doug Ewell" <[email-masked]>
To: "LTRU Working Group" <[email-masked]>
Sent: Tuesday, March 22, 2005 22:44
Subject: [Ltru] Registry in record-jar format

> At least one person expressed some interest in seeing the draft /
> proposed / sample registry in record-jar format, so here it is:
>
> http://users.adelphia.net/~dewell/lstreg-rj.txt
>
> This has no official sanction or consensus; it's just there so people
> can visualize it (which I guess is true for the other one as well).
>
> -Doug Ewell
>  Fullerton, California
>  http://users.adelphia.net/~dewell/
>
>
>
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
>

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Sat, 2 Apr 2005 17:30:53 -0800

Mark Davis <mark dot davis at jtcsv dot com> wrote:

> ...
> Same for the name change:
> ...
> Name_Changed: 1980
> Former_Value: New Hebrides

That adds new fields "Deprecated," "Name_Changed," and "Former_Value,"
which aren't mentioned anywhere in the draft, and which constitute more
of a change than converting from vertical-bar-delimited to record-jar in
the first place.

I don't feel comfortable with this unless there's some consensus.  In
the latest version, due to be posted around Wednesday if there is
consensus, I've changed "Canonical_Value" to "Canonical" and
"Recommended_Prefix" to "Prefix," and I wondered if even that was too
much to do unilaterally.

-Doug Ewell
 Fullerton, California

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 03 Apr 2005 05:20:00 +0200

Doug Ewell wrote:
 
> That adds new fields "Deprecated," "Name_Changed," and
> "Former_Value," which aren't mentioned anywhere in the draft,

Maybe one new field "Comment" is better than separate fields
"Depecated" + "Name_Changed" + "Former_Value".

Please don't mention any former value like NH, if it's not more
in the registry.  Don't mention CS as former value for CZ or as
former value for SK.  Any "Former_Value" is like a pointer to a
deprecated tag, the inverse of "Canonical".  This won't work in
a case like the old CS.  

> I've changed "Canonical_Value" to "Canonical" and
> "Recommended_Prefix" to "Prefix,"

I like it.  I'd like "Related" instead of "Prefix" even better,
if that's the way to get a "default script" for some languages.
Otherwise "Prefix" is fine.

Do we need the "redundant" entries ?  As the name says they are
really redundant. 
                           Bye, Frank

---

From: "Debbie Garside" <[email-masked]>
Date: Sun, 3 Apr 2005 09:55:37 +0100

Doug Ewell wrote:

>which aren't mentioned anywhere in the draft, and which constitute more of 
>a change than converting from vertical-bar-delimited to record-jar in the 
>first place.

IMHO, these fields should be included... I am including something similar in
-6.  I am also including a date field for "last updated"

Debbie Garside

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Doug Ewell
Sent: 03 April 2005 02:31
To: LTRU Working Group
Subject: Re: [Ltru] Registry in record-jar format

-Doug Ewell
 Fullerton, California

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Sun, 03 Apr 2005 11:15:45 +0200

>-6.  I am also including a date field for "last updated"

Great. Will it be by the date of by the year?

I would suggest that updates are carried by January 1st as for UDC (with 
the hope of a generalization) when to the day. The reason why is that it 
permits to cover the entire History (-32.000/+32.000) with two bytes. 
Otherwise Unix like dates will be used, what will cause much more troubles. 
I feel from experience that one full year incertitude is - one way or 
another - the degree of error we can expect in real life (and it is widely 
covered by the current practices of 5, 10 or 50 years delays).

jfc

---

From: "Debbie Garside" <[email-masked]>
Date: Sun, 3 Apr 2005 11:35:36 +0100

At 10:55 03/04/2005, Debbie Garside wrote:
> >which aren't mentioned anywhere in the draft, and which constitute 
> >more of a change than converting from vertical-bar-delimited to 
> >record-jar in the first place.
>
>IMHO, these fields should be included... I am including something 
>similar in -6.  I am also including a date field for "last updated"

>Great. Will it be by the date of by the year?

I had thought by the date as I want to be as concise as possible but
everything (in my draft) is up for discussion. 

Debbie Garside

-----Original Message-----
From: JFC (Jefsey) Morfin [mailto:[email-masked]] 
Sent: 03 April 2005 10:16
To: Debbie Garside; 'Doug Ewell'; 'LTRU Working Group'
Subject: RE: [Ltru] Registry in record-jar format

> >which aren't mentioned anywhere in the draft, and which constitute more
of

jfc

---

From: "Debbie Garside" <[email-masked]>
Date: Sun, 3 Apr 2005 12:50:33 +0100

For my own purposes (and these are purely database maintenance at the
moment) I would want to see a full date... However, there is no reason why
the proposed registry itself could not just be year (as taken from full
date).

Debbie

-----Original Message-----
From: JFC (Jefsey) Morfin [mailto:[email-masked]] 
Sent: 03 April 2005 10:16
To: Debbie Garside; 'Doug Ewell'; 'LTRU Working Group'
Subject: RE: [Ltru] Registry in record-jar format

of

jfc

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Sun, 03 Apr 2005 16:03:31 +0200

>Do we need the "redundant" entries ?  As the name says they are

Dear Frank,
The first thing you are to publish in a compilation - as in every open 
source code - is the list of your sources and of their intellectual 
property rights or acknowledgements. So everyone can make its own 
compilation.  So there is no real problem if deontology is respected. What 
may help is a note on the filtering process of each document, to avoid the 
mistakes others have already experimented.
jfc

---

From: "Mark Davis" <[email-masked]>
Date: Sun, 3 Apr 2005 09:19:35 -0700

> I don't feel comfortable with this unless there's some consensus.

Of course.

‎Mark

---

From: "Doug Ewell" <[email-masked]>
Date: Sun, 3 Apr 2005 09:47:46 -0700

> similar in -6.  I am also including a date field for "last updated"

That is what our existing "Date" field is for.

-Doug Ewell
 Fullerton, California

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 04 Apr 2005 15:43:22 +0200

Doug Ewell wrote:

>> I am also including a date field for "last updated"

> That is what our existing "Date" field is for.

Having both could make sense, date of introduction and date of
last update.  Some "whois" databases do it this way.  For a
case like i-klingon the LTRU registry could give the date of
the registration, and later the date of the deprecation.  At
the moment i-klingon is still an officially registered tag.

Probably it's different from tlh, with Klingons you never know,
maybe they have more than one language. ;-)  No, I've not yet
asked IANA why they stopped to maintain the old 3066-registry.

                            Bye, Frank