Subject: RE: [Ltru] Re: Supress & Require Script

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 18 Apr 2005 13:31:10 -0700

> -----Original Message-----
> From: Addison Phillips [mailto:[email-masked]]
> Sent: Monday, April 18, 2005 1:05 PM
> To: McDonald, Ira; Marion Gunn
> Cc: [email-masked]
> Subject: RE: [Ltru] Re: Supress & Require Script 
> 
> No, each requires a rewrite to make it grammatically correct 
> and to have a proper subject.
> 
>    1. Use as precise a tag as possible, but no more specific 
> than is justified.

Addison, did you perhaps learn grammar from an unusual source? 

The _first_ sentence in your "grammatically correct" rewrite
is at least no longer in passive voice, but it now lacks a 
_subject_ who will take the "Use...a tag" action.

Every conformance statement in any standard that contains an 
uppercase imperative (MUST, SHOULD, etc.) should be written 
with a very explicit subject.  In your fragment of a sentence 
above, was your intended subject:

(a) a human or software content searcher;
(b) a human or software content creator;
(c) a content distribution application; or
(d) whatever?

Cheers,
- Ira

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 18 Apr 2005 23:48:46 +0200

> _subject_ who will take the "Use...a tag" action.

What's wrong with an imperative ?
  
| Note that the force of these words is modified by the
| requirement level of the document in which they are used.

The subject of Addison's "Use" or this "Note" is the reader.

That covers your cases (a)..(d).  Is there a reason why you
think that not all readers are directly affected ?

As far as I'm concered the complete "Use..." imperative is
hot air, I read "be precise but OTOH don't exaggerate it".  It
would be much more interesting with reasons WHY very precise
tags are not always useful, or even counterproductive.

                    Bye, Frank