Subject: RE: [Ltru] New version posted: ready for publication??

From: Misha Wolf <[email-masked]>
Date: Thu, 21 Apr 2005 19:10:18 +0100

Addison Phillips wrote:

> The 'UND' (Undetermined) primary language subtag SHOULD NOT be used to

> label content, even if the language is unknown. Omitting the tag is 
> preferred. Some protocols may require a value for the language tag. 
> The 'UND' subtag may also be useful when matching language tags in 
> certain situations.

This makes me feel as if a bunch of sentences ended up accidentally 
in the same para.  How about:

  Omitting the tag is preferred.  Some protocols, however, may 
  require a value for the language tag. 

I also don't like "require a value for the language tag".  How about 
"require a language tag"?  Or "require a non-empty language tag"?

Misha

-----------------------------------------------------------------
        Visit our Internet site at http://www.reuters.com

To find out more about Reuters Products and Services visit http://www.reuters.com/productinfo 

Any views expressed in this message are those of  the  individual
sender,  except  where  the sender specifically states them to be
the views of Reuters Ltd.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Thu, 21 Apr 2005 11:46:47 -0700

Yes, I agree. How about:

--

<t>The 'UND' (Undetermined) primary language subtag SHOULD NOT be used to label content, even if the language is unknown. Omitting the tag is preferred. The 'UND' tag may be useful for protocols that require a language tag to be provided. The 'UND' subtag may also be useful when matching language tags in certain situations.</t>

--

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Misha Wolf
> Sent: Thursday, April 21, 2005 11:10 AM
> To: ltru Working Group
> Subject: RE: [Ltru] New version posted: ready for publication??
> 
> Addison Phillips wrote:
>

---

From: "Addison Phillips" <[email-masked]>
Date: Thu, 21 Apr 2005 11:48:39 -0700

Done.

Addison P. Phillips

> From: Mark Davis [mailto:[email-masked]]
> Sent: Thursday, April 21, 2005 10:42 AM
> To: Addison Phillips; Mark Davis; Addison Phillips; ltru Working Group
> Subject: Re: [Ltru] New version posted: ready for publication??
> 
> Oh, almost forgot.
> 
> UND, MUL and FR should use recommended [ISO 639] casing (lowercase) in the
> following:
> 
> preferred. Some protocols may force you to give a value for the language
> tag
> and the 'UND' subtag may be useful when matching language tags in certain
> situations.
> 
> >The 'MUL' (Multiple) primary language subtag SHOULD NOT be used if the
> protocol allows you to use multiple languages, as is the case for the
> Content-Language header in HTTP.
> 
> >  <span lang="FR">C'est la vie.</span> in
>

---

From: Misha Wolf <[email-masked]>
Date: Thu, 21 Apr 2005 20:03:48 +0100

If you reconcile that and Mark's text, it'll be fine.

Thanks,
Misha

-----Original Message-----
From: Addison Phillips [mailto:[email-masked]] 
Sent: 21 April 2005 19:59
To: Misha Wolf; ltru Working Group
Subject: RE: [Ltru] New version posted: ready for publication??

No, probably not. More holdover text, I'm afraid.

How about:

> <t>The 'UND' (Undetermined) primary language subtag SHOULD NOT be used
> to label content, even if the language is unknown. Omitting the
language tag altogether is preferred to using a tag with a primary
language subtag of 'und'. The 'UND' subtag may be useful for protocols
that require a
> language tag to be provided. The 'UND' subtag may also be useful when
> matching language tags in certain situations.</t>

---

From: "Addison Phillips" <[email-masked]>
Date: Thu, 21 Apr 2005 12:09:28 -0700

That's the reconciled version (except that I didn't fix the case on UND in my message). I'll make the change.

Addison

Addison P. Phillips

> Sent: Thursday, April 21, 2005 12:04 PM
> To: ltru Working Group