Subject: RE: [Ltru] Re: Proposed Text for Moving Forward

From: "McDonald, Ira" <[email-masked]>
Date: Sat, 16 Apr 2005 14:08:28 -0700

Hi,

"Implicit" is not very clear - it's capable of being misread as
"Default" (meaningless) and is not a verb like "Suppress" - it sure 
doesn't indicate Suppress in plain English.

By the way, IETF standards do often use the construction MUST NOT 
followed by one or more exceptions.  So a stronger rewrite of the 
Mark's two rule set would be:

1. Script subtags listed in the 'Suppress_Script' field MUST NOT be used
to form language tags unless they add specific information to the language
tag required by an application, to improve language tag matching for legacy
content.
 
2. Script subtags not listed in the 'Suppress_Script' field SHOULD always
be used to form language tags when the script used by the content being
identified matches the script unless there is a specific reason to omit
the script subtag in the application.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Addison Phillips
> Sent: Saturday, April 16, 2005 3:19 PM
> To: Peter Constable; [email-masked]
> Subject: RE: [Ltru] Re: Proposed Text for Moving Forward
> 
> 
> I dislike "default" because it implies way too many things 
> that aren't really true about the field. "Implicit" isn't bad, though.
> 
> Addison
> 
> Addison P. Phillips
> Globalization Architect, Quest Software
> Chair, W3C Internationalization Core Working Group
> 
> Internationalization is not a feature.
> It is an architecture. 
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]] On
> > Behalf Of Peter Constable
> > Sent: samedi 16 avril 2005 05:34
> > To: [email-masked]
> > Subject: RE: [Ltru] Re: Proposed Text for Moving Forward
> > 
> > > From: JFC (Jefsey) Morfin [mailto:[email-masked]]
> > 
> > > As a non English speaker I more or less understand the English of
> > > "Suppress_Script" because I know its history. I am not sure an
> > occasional
> > > developper will understand/remember the meaning of it. Unneeded,
> > needless,
> > > redundant_script would be clearer to me.
> > 
> > Keep in mind, we do expect someone to have at least glanced 
> at the RFC.
> > But if "Suppress_Script" really doesn't communicate well 
> enough, then
> > what about "Implied_Script" or "Implicit_Script"?
> > 
> > 
> > A side note: In a paper I wrote three years ago, I had a section
> > entitled "Default values and implicit tagging", discussing 
> specifically
> > the issue of script subtags. I find it interesting that we 
> started with
> > a suggestion of a field called "Default_Script" and have 
> now come around
> > to a suggestion that it be called "Implicit_Script". FYI, here's an
> > excerpt from the end of that section of that paper:
> > 
> > <quote>
> > The choice of whether or not to adopt the use of implicit default
> > semantics amounts to a trade-off between simpler tags and 
> compatibility
> > with existing implementations on the one hand, and 
> identifiers with more
> > predictable forms, more predictable semantics, and 
> therefore no need to
> > maintain a database of implicit relationships on the other hand.
> > </quote>
> > 
> > 
> > 
> > Peter Constable
> > 
> > _______________________________________________
> > Ltru mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ltru
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Sat, 16 Apr 2005 14:48:15 -0700

I'm ok with MUST NOT, if the exception is clearly stated (and it is not just
legacy that is at issue). For parallelism with #2, they could be:

1. Script subtags listed in the 'Suppress_Script' field MUST NOT be used
to form language tags unless there is a specific reason to include
the script subtag in the application.

2. Script subtags not listed in the 'Suppress_Script' field SHOULD always
be used to form language tags when they match the script used by the content
unless there is a specific reason to omit the script subtag in the
application.

‎Mark

----- Original Message ----- 
From: "McDonald, Ira" <[email-masked]>
To: "'Addison Phillips'" <[email-masked]>; "Peter Constable"
<[email-masked]>; <[email-masked]>
Sent: Saturday, April 16, 2005 14:08
Subject: RE: [Ltru] Re: Proposed Text for Moving Forward

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 17 Apr 2005 22:23:14 +0200

Mark Davis wrote:

> 1. Script subtags listed in the 'Suppress_Script' field
> MUST NOT be used to form language tags unless there is a
> specific reason to include the script subtag in the
> application.

That's almost exactly the same as this shorter rule:

| 1. Script subtags listed in the 'Suppress_Script' field
| SHOULD NOT be used to form language tags.

The difference between MUST NOT and SHOULD NOT is what you
say in your "unless..." clause, you need specific and good
reasons to violate a SHOULD NOT.

Or at least that's my interpretation of RfC 2119, sometimes
Bruce apparently didn't agree (only my personal impression).

                        Bye, Frank