Subject: [Ltru] Re: Date of deprecation (was: Re: Registry in record-jar format)

From: "Doug Ewell" <[email-masked]>
Date: Mon, 4 Apr 2005 08:47:20 -0700

Mark Davis <mark dot davis at jtcsv dot com> wrote:

> If it is worth putting in a comment for every instance, it is worth
> making it a field, because then it can be parsed.

Similarly, Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

> Having both could make sense, date of introduction and date of
> last update.  Some "whois" databases do it this way.

I know it would be physically possible to add these additional date
fields.  My question was, what is the benefit for language tagging?  How
are these fields to be used in practice?

There have already been complaints about the size of the registry (maybe
not now, but once the ISO 639-3 codes are added).  We should have a
demonstrably good reason for adding more stuff to it.

> For a case like i-klingon the LTRU registry could give the date of
> the registration, and later the date of the deprecation.  At
> the moment i-klingon is still an officially registered tag.

Tags that are deprecated don't become un-registered, as this seems to
imply.  They just have a note attached to them that says, "You shouldn't
use this."

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Mon, 04 Apr 2005 17:54:05 +0200

>demonstrably good reason for adding more stuff to it.

The good reason is simple. You just prove that it is easier to remove than 
to add. For the rest I documented it already.
jfc

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 04 Apr 2005 19:11:57 +0200

Doug Ewell wrote:

> My question was, what is the benefit for language tagging?

It could help to figure out what happened when and why.  I've
no idea how important this is for language tags, but I'm sure
that I like it in "whois" entries.

> There have already been complaints about the size of the
> registry (maybe not now, but once the ISO 639-3 codes are 
> added).

And some possible solutions, like an A..Z organization.  Scott
said that IANA won't try to be smart unless we tell them what
to do (or that's how I interpreted his remark).

If the size is a problem, then the number of 7000+ entries is
the key, the size of individual entries is secondary.

[ Is this use of "secondary" en-DE or still en ? ;-) ]

>> i-klingon is still an officially registered tag.

> Tags that are deprecated don't become un-registered

Yes, sorry, I meant "officially undeprecated tag".  Bye, Frank

---

From: "Mark Davis" <[email-masked]>
Date: Tue, 5 Apr 2005 00:25:05 -0700

> demonstrably good reason for adding more stuff to it.

Let me be a bit clearer. Right a whole class of characters have a comment,
with a common structure. Making the items in that comment into fields
doesn't essentially change the size of the registry; it just regularizes
that part of the format to make it machine-readable.

If we are so concerned with the size of the registry that we don't want the
information in that comment, we would delete it. But we're not.

‎Mark

----- Original Message ----- 
From: "Doug Ewell" <[email-masked]>
To: "LTRU Working Group" <[email-masked]>
Sent: Monday, April 04, 2005 08:47
Subject: [Ltru] Re: Date of deprecation (was: Re: Registry in
record-jarformat)