Subject: RE: [Ltru] new version posted online

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 18 Apr 2005 13:41:41 -0700

Hi,

Please reserve the alpha4, rather than just changing the
single line of ABNF to "lang = 2*8ALPHA".  Keeping the
distinction between ISO-based tags and registered tags
is important and has rough concensus on this list, IMHO.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Debbie Garside
> Sent: Monday, April 18, 2005 3:47 PM
> To: 'Addison Phillips'; [email-masked]
> Subject: RE: [Ltru] new version posted online
> 
> 
> Hi Addison (on list this time :-))
> 
> Will you be incorporating a reserved alpha4 for ISO 639-6 in 
> the next draft?
> I believe consensus was reached on this issue... as raised by Doug.
> 
> Kind regards
> 
> Debbie
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]] On
> > Behalf Of Addison Phillips
> > Sent: 18 April 2005 18:32
> > To: [email-masked]
> > Subject: [Ltru] new version posted online
> > 
> > The draft-01 prototype has been updated and posted at:
> > 
> > http://www.inter-locale.com/ID/draft-ietf-ltru-registry-01.txt
> > http://www.inter-locale.com/ID/draft-ietf-ltur-registry-01.html
> > 
> > I have incorporated 'Suppress_Script' into the various 
> places required to
> > define it (many parts of section 3). Of course we can decide on a
> > different name if so desired. Right now the text is the 
> key. Note that I
> > used a different example from en/en-Latn in section 3.1. I 
> also put a
> > script of 'Arab' on the language 'ar' in the example registry.
> > 
> > Other minor changes/corrections are listed in the changes section.
> > 
> > Are we close to done with this issue, enough for me to start work on
> > preparing the next officially submitted draft?
> > 
> > Best Regards,
> > 
> > Addison
> > 
> > Addison P. Phillips
> > Globalization Architect, Quest Software
> > http://www.quest.com
> > 
> > Chair, W3C Internationalization Core Working Group
> > http://www.w3.org/International
> > 
> > Internationalization is not a feature.
> > It is an architecture.
> > 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Mon, 18 Apr 2005 15:31:31 -0700

Okay, I did some work on primary language subtag. See if this works better:

---
2.2.1  Primary Language Subtag

   The primary language subtag is the first subtag in a language tag
   (with the exception of private-use and certain grandfathered tags)
   and cannot be omitted.  The following rules apply to the primary
   language subtag:

   o  All 2-character language subtags were defined in the IANA registry
      according to the assignments found in the standard ISO 639 Part 1,
      "ISO 639-1:2002, Codes for the representation of names of
      languages -- Part 1: Alpha-2 code" [ISO 639-1] [1], or using
      assignments subsequently made by the ISO 639 Part 1 maintenance
      agency or governing standardization bodies.
   o  All 3-character language subtags were defined in the IANA registry
      according to the assignments found in ISO 639 Part 2, "ISO
      639-2:1998 - Codes for the representation of names of languages --
      Part 2: Alpha-3 code - edition 1" [ISO 639-2] [2], or assignments
      subsequently made by the ISO 639 Part 2 maintenance agency or
      governing standardization bodies.
   o  The subtags in the range 'qaa' through 'qtz' are reserved for
      private use in language tags.  These subtags correspond to codes
      reserved by ISO 639-2 for private use.  These codes MAY be used
      for non-registered primary-language subtags (instead of using
      private-use subtags following 'x-').  Please refer to Section 4.4
      for more information on private use subtags.
   o  All language subtags of 5 to 8 characters in length in the IANA
      registry were defined via the registration process in Section 3.4
      and MAY be used to form the primary language subtag.  At the time
      this document was created, there were no examples of this kind of
      subtag and future registrations of this type will be discouraged:
      primary languages are STRONGLY RECOMMENDED for registration with
      ISO 639 and subtags rejected by ISO 639 will be closely
      scrutinized before they are registered with IANA.
   o  The single character subtag 'x' as the primary subtag indicates
      that the language tag consists solely of subtags whose meaning is
      defined by private agreement.  For example, in the tag "x-fr-CH",
      the subtags 'fr' and 'CH' should not be taken to represent the
      French language or the country of Switzerland (or any other value
      in the IANA registry) unless there is a private agreement in place
      to do so.  See Section 4.4.

   o  The single character subtag 'i' is used by some grandfathered tags
      (see Section 2.2.8) such as "i-klingon" and "i-bnn". (Other grandfathered tags have a primary language subtag in their first position)
   o  All 4-character language subtags are reserved for possible future standardization.

   o  Other values MUST NOT be assigned to the primary subtag except by
      revision or update of this document.
---

Addison P. Phillips

> From: [email-masked] [mailto:[email-masked]] On
> Sent: lundi 18 avril 2005 15:05
> To: Frank Ellermann; [email-masked]
> Subject: RE: [Ltru] Re: new version posted online
> 
> Some more interlinear, elision as necessary.
> 
> Addison P. Phillips
> > From: [email-masked] [mailto:[email-masked]]
> On
> > Behalf Of Frank Ellermann
> 
> >
> > >>   variant   = (5*8alphanum) ; registered variants
> > >>             / (DIGIT 3alphanum)
> >
> > > Because that's fairly subtle too? And incorrect as written.
> >
> > No, it's okay, anything with 5 up to 8 let-dig uses the first
> > alternative, the second alternative handles the special case
> > "length 4" (starting with a digit).
> [Addison Phillips]
> 
> Yes, I caught that.
> 
> >
> > >    Variant = 5*8alphanum
> > >              / DIGIT 3*7alphanum
> >
> > Also correct, but then both alternatives match for length > 4
> > starting with a digit.  I'd prefer an unambiguous ABNF where
> > possible.  Your subtle ABNF (reflected in the text later) is
> > "alpha or digit", my less subtle variant is "length 5..8 or 4".
> [Addison Phillips]
> 
> Yes, I saw that. You appear to be the only other person who liked my
> original date subtag from draft-phillips-langtags-less-than-zero :-). I
> think there is a diminishing return to ruling out various subtag forms.
> Why allow '1dr5' and not '1234567'?
> 
> >
> >  [case insensitive US ASCII]
> > > Argh. Somebody make up their mind. We put them in, we take
> > > them out.
> >
> > It's not that important.  Arguing formally you could say that
> > it's explained in 2234bis.  Or reference RfC 20 just for fun.
> [Addison Phillips]
> 
> (laughing) I took them out.
> >
> > >>| Single letter and digit subtags are reserved for
> > >> There are no single digits in the ABNF.
> >
> > > No, there aren't. Be we reserve them here so that people
> > > don't think we overlooked them.
> >
> > Okay, you could add DIGIT to singleton in the ABNF.  Otherwise
> > it makes me nervous if the text talks about something that's
> > not in the ABNF or vice versa.
> [Addison Phillips]
> 
> Okay.
> >
> > >> I don't see any i-whatever before this item, is this a
> > >> trick, the i-whatever case is no primary subtag ?  OTOH
> > >> there must be a primary subtag.
> >
> > > i-* are all grandfathered by rule.
> >
> > Sure, but your text says:
> >
> > | The primary subtag is the first subtag in a language tag
> >
> > Then you enumerate all cases incl. x-, but not i-.  Somewhere
> > I miss i-.  Maybe you need something like this:
> >
> >  The primary subtag is the first subtag in a language tag,
> >  if the language tag is no grandfathered tag (see 2.2.8).
> >
> That's an excellent idea.
> 
>

---

From: "Doug Ewell" <[email-masked]>
Date: Tue, 19 Apr 2005 00:09:36 -0700

Addison Phillips <addison dot phillips at quest dot com> wrote:

>> IMHO it's better to enumerate them.  Do we have any convincing
>> reasons to use "_" instead of "-" in field names ?  Mail and
>> news header field names use "-" (no rule, an observation).
> [Addison Phillips]
>
> No reason. Actually, hyphen-minus would be more in keeping with the
> spirit of 3066 I suppose.

I would greatly prefer hyphen over underscore.

> The names are all Unicode character names. Thankfully we don't have
> any examples that use Indic zero digits :-).

Or worse yet, Tamil Aytham.  We could be held criminally liable for that
one.

>> | Latin-1 blocks as defined by Unicode [7] (that is, ISO/IEC
>> | 10646 character numbers less than U+0100).
>>
>> Why this restriction ?  What's wrong with say Zcaron, Yuml, or
>> OElig ?  You even have the Euro as example elsewhere.
> [Addison Phillips]
>
> Description is separate from Comment. Comment allows anything.
> Description is fixed to Latin-1. Various folks wanted that limitation
> to reference ISO 8859-1, but as a Unicadet I fudged and used Unicode
> blocks. And saved a reference.

This doesn't have to be carved in stone.  I thought it would make things
easier for existing non-Unicode display mechanisms.  The only effect
this restriction has on the items in the draft registry is to remove the
u-with-breve spelling of Hangul (Hangŭl) and a couple of directional
single-quotes, also in script names.  I've also replaced the acute
accent U+00B4 (´) with an ordinary apostrophe in the name Gwich'in,
since I could find no evidence that the acute accent was used there as
anything other than a fancy apostrophe, and plenty of examples that an
ordinary apostrophe was just fine.

I think the Euro example is a bit goofy since that particular character
would never appear in the description of a language, script, region,
etc., but it's harmless.

>> | Comments
>>
>> The examples use "Comment" (singular).  Later there's another
>> "Comments".  Quite a lot of examples, maybe you can delete some
>> less interesting examples, e.g. either Africa or North America.

I prefer "Comment" myself, but it doesn't make much difference.

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/