Subject: RE: [Ltru] Re: Proposed Text for Moving Forward

From: "Addison Phillips" <[email-masked]>
Date: Fri, 15 Apr 2005 14:07:17 -0700

Hence the comment...

> > Comment: only an example

So the mechanism works for you?

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: vendredi 15 avril 2005 13:19
> To: [email-masked]
> Subject: Re: [Ltru] Re: Proposed Text for Moving Forward
> 
> Hi -
> 
> > From: "Addison Phillips" <[email-masked]>
> > To: "Addison Phillips" <[email-masked]>; "Randy Presuhn"
> <[email-masked]>; <[email-masked]>
> > Sent: Friday, April 15, 2005 12:26 PM
> > Subject: RE: [Ltru] Re: Proposed Text for Moving Forward
> ...
> > Instead, we should create fields that exactly match what you do with
> them.
> 
> Sounds like a good principle.
> 
> ...
> > Subtag: got
> > Suppress_Script: Latn, Goth
> > Comment: only an example
> 
> If the desired behaviour is for transcribed Gothic to be "got" and
> for Gothic in its historic alphabet to be "got-Goth", then I
> think this should have been:
> 
> + Subtag: got
> + Supress_Script: Latn
> + Require_Script: Goth
> 
> (It's been nearly a quarter century since I worked with Gothic, so
> I'm *not* making any claims that this would indeed be the desired
> behaviour now, though it would have been correct then.)
> 
> Randy
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 15 Apr 2005 14:50:46 -0700

Hi -

> To: "Randy Presuhn" <[email-masked]>; <[email-masked]>
> Sent: Friday, April 15, 2005 2:07 PM
...
...

It seems to be able to produce the desired results for the cases
where I have first-hand knowledge of the language, and is easier
to understand than the approaches that required counting.

If the WG converges on this approach, what will be critical is the
clarity of the SHOULDs and SHOULD NOTs.  It might be helpful
to include an example explaining why tagging data with en-Latn
would normally be a bad idea, in order to give implementers a
serious clue about just how strong the SHOULD NOTs are
meant to be.

Now, probing a bit deeper, (and these may be purely theoretical
problems, and could be dismissed as such) do we have any
cases like this:
    language L in general is written in script S1 overwhelmingly,
    and there is a substantial corpus of data tagged simply "L".
    language L has several important variants, V1..Vn
    V2, a rather rare variant, uses script S2 overwhelmingly

If there are cases like this (for example, a hypothetical community
of German speakers using the Hebrew alphabet in a manner similar to
Yiddish, or a community of Yiddish speakers using the latin alphabet)
would there be any need to represent this in the registry?
The tag L-S2-V2 would be preferred to the tag L-V2, right?  How would
a developer looking at the registry determine this?

Randy

---

From: John Cowan <[email-masked]>
Date: Sat, 16 Apr 2005 13:37:21 -0400

> Yiddish, or a community of Yiddish speakers using the latin alphabet)

Yiddish is in fact often written in the Latin alphabet nowadays,
though the orthography (more than a transcription now, I think)
is not associated with any one variety and is in fact deliberately
cross-dialectal.  The tag yi-Latn was accordingly approved by the Language
Tag Reviewer on 2003-01-07, according to Michael's unofficial list at
http://www.evertype.com/standards/iso639/iana-lang-assignments.html .
Beser a tsebrokhene Yidish vi nisht kayn Yidish.

As for Judaeo-German, it was indeed written in the Hebrew alphabet and
was much closer to German than today's Yiddish is: it's normally called
"Western Yiddish" and is nearly extinct due to the combined efforts of
assimilation and extermination.

> a developer looking at the registry determine this?

By determining that S2 is not a suppressed script for L.  Cases are hard
to find, however, because the Ethnologue jesuitically defines away the
problem by viewing the minority variant as a separate language, which
sociolinguistically it generally is.  One of the main things preventing
Maltese being treated as an Arabic colloquial, or Dzungan as a Mandarin
diale, or Italkian (Judaeo-Italian) as just part of the Italo-Romance
dialect/language continuum, is precisely the writing system, which has
profound effects in separating the minority from the other speakers of
the language or language group.

(If this posting seems to be about Jewish languages, it's because they
constitute a large number of the historical examples of languages written
in a script not widely adopted by non-Jewish speakers of what were originally
the same languages.)

-- 
John Cowan  www.reutershealth.com  www.ccil.org/~cowan  [email-masked]
Shayt oyf ir ale ver nor shklafen / Vas hunger leiden mus in noyt!
Der gayst er kokht unruft teu wafen / In shlakht uns firen is er grayt
Di velt fun gvaldtaten un laydn / Tzrushteren velen mir, undan
Fun freiheit gleikhheit a ganeiden / Bashayen vet der arbetsman!
	(This may not be quite YIVO-standard; sorry about that.)

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 17 Apr 2005 21:56:38 +0200

> Beser a tsebrokhene Yidish vi nisht kayn Yidish.

Okay, I understand it... meschugge ;-)  For Randy's problem
L-S2-V2 we could (ab)use L-S2 as a prefix of V2, and S1 as
an "suppress_script" for L.  I don't see a solution allowing
to suppress S2 for L only in conjunction with V2.

Unless we'd allow a "suppress_script" in the variant entry to
overrule the normal "suppress_script".  But is this needed
anywhere ?  The "suppress" kludge is for compatibility with
existing 3066 content and implementations, not for hypothetical
L-V2 cases.

> the Ethnologue jesuitically defines away the problem by
> viewing the minority variant as a separate language, which
> sociolinguistically it generally is.

Apparently a good idea.  Bye, Frank