Subject: RE: [Ltru] Fw: I-D ACTION:draft-lilly-content-script-01.txt

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 12 Apr 2005 14:15:05 -0700

Hi,

In light of recent threads here on script, a question.

Are the RFC3066bis editors confident that 'Content-Script'
will not be approved/adopted into HTTP/1.x and MIME headers?

Because _two_ methods in wide use for tagging script in the
same content is a good deal worse than none, IMHO.

Frankly, Bruce Lilly's rationale for the separation looks sound
to me.  Script is intimately related to charset and merely usefully
related to language.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Randy Presuhn
> Sent: Friday, April 08, 2005 7:07 PM
> To: LTRU Working Group
> Subject: [Ltru] Fw: I-D ACTION:draft-lilly-content-script-01.txt
> 
> 
> Hi -
> 
> I believe this may be of interest to many members of the ltru WG.
> 
> Randy
> 
> > From: <[email-masked]>
> > To: <[email-masked]>
> > Sent: Friday, April 08, 2005 7:25 AM
> > Subject: I-D ACTION:draft-lilly-content-script-01.txt
> >
> > A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> >
> >
> > Title : Indicating and Negotiating Text Script
> > Author(s) : B. Lilly
> > Filename : draft-lilly-content-script-01.txt
> > Pages : 14
> > Date : 2005-4-7
> >
> > Some written text in some languages can be represented in multiple
> >    scripts, or writing forms.  This memo proposes mechanisms for
> >    identification and negotiation of script for written text.
> >
> > A URL for this Internet-Draft is:
> > 
> http://www.ietf.org/internet-drafts/draft-lilly-content-script-01.txt
> >
> > To remove yourself from the I-D Announcement list, send a message to
> > [email-masked] with the word unsubscribe in 
> the body of the message.
> > You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce
> > to change your subscription settings.
> >
> >
> > Internet-Drafts are also available by anonymous FTP. Login 
> with the username
> > "anonymous" and a password of your e-mail address. After logging in,
> > type "cd internet-drafts" and then
> > "get draft-lilly-content-script-01.txt".
> >
> > A list of Internet-Drafts directories can be found in
> > http://www.ietf.org/shadow.html
> > or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> >
> >
> > Internet-Drafts can also be obtained by e-mail.
> >
> > Send a message to:
> > [email-masked].
> > In the body type:
> > "FILE /internet-drafts/draft-lilly-content-script-01.txt".
> >
> > NOTE: The mail server at ietf.org can return the document in
> > MIME-encoded form by using the "mpack" utility.  To use this
> > feature, insert the command "ENCODING mime" before the "FILE"
> > command.  To decode the response(s), you will need "munpack" or
> > a MIME-compliant mail reader.  Different MIME-compliant mail readers
> > exhibit different behavior, especially when dealing with
> > "multipart" MIME messages (i.e. documents which have been split
> > up into multiple messages), so check your local documentation on
> > how to manipulate these messages.
> >
> >
> > Below is the data which will enable a MIME compliant mail reader
> > implementation to automatically retrieve the ASCII version of the
> > Internet-Draft.
> >
> 
> 
> --------------------------------------------------------------
> ------------------
> 
> 
> > _______________________________________________
> > I-D-Announce mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/i-d-announce
> >
> 
> 
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Tue, 12 Apr 2005 14:44:18 -0700

Well, script is necessary in language tags to distinguish the written forms
of languages; and language tags are much broader in scope.

Script is intimately related to the written form of language, and script is
only very remotely related to legacy charsets:
a) Legacy charsets in very few cases contain all the characters in a script
b) Legacy charsets often contain characters from multiple scripts (look at
JIS, GBK, etc).
c) And legacy charsets are in the process of being superceded by Unicode /
10646 in any event.

Having scripts cited in parallel, in some circumstances, to language tags is
a bad idea.

‎Mark

----- Original Message ----- 
From: "McDonald, Ira" <[email-masked]>
To: "'Randy Presuhn'" <[email-masked]>; "LTRU Working Group"
<[email-masked]>
Sent: Tuesday, April 12, 2005 14:15
Subject: RE: [Ltru] Fw: I-D ACTION:draft-lilly-content-script-01.txt

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Tue, 12 Apr 2005 23:58:22 +0200

On 23:15 12/04/2005, McDonald, Ira said:
>Frankly, Bruce Lilly's rationale for the separation looks sound to 
>me.  Script is intimately related to charset and merely usefully related 
>to language.

de facto script extend to much more. For example the need to support Greek 
characters is a must for math and scientific communities. There are the 
need to specify adapted scripts independently from the language. I know 
IDNs are banned, but we nevertheless need their Tables.

A stupid question I have however is why (except for aged applications and 
for information) do we need scripts for applications? They are made of 
Unicode codes. Either the character is available or it is not?

When is not a language side information or an independent information, used 
for different decisions (for choice and not for presentation). It seems 
reasonable to manage it separately, so we can use at a different times.

Now, Addison may say this is a big problem for his XML. So what prevents to 
include it also in his XML lang3tag? As long as it can also be supported 
independently. I am always puzzled when one wants to hidde parameters and 
madatorily bundle them.

jfc