Subject: RE: [Ltru] Re: Moving Forward

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 13 Apr 2005 10:38:32 -0700

Hi,

A good deal of digital ink is being expended on a problem
(Default/Associated/Expected Script) that _only_ occurs
because RFC3066bis is infixing script between language
and region.

And there remains every possibility that a software vendor
who sells a widely used application for mounting content
on Web servers will ignore that SHOULD NOT about using tags
like 'en-Latn-GB' and wreak a fair amount of havoc.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Peter Constable
> Sent: Wednesday, April 13, 2005 11:23 AM
> To: [email-masked]
> Subject: RE: [Ltru] Re: Moving Forward
> 
> 
> > From: [email-masked] 
> [mailto:[email-masked]]
> On
> > Behalf Of John Cowan
> 
> 
> > Note that the purpose of Associated_Script is
> > not to tell an implementer the usual script used with a 
> language, but
> > simply to serve notice which script *subtags*, if any, 
> should normally
> > be used with this language subtag.  This difference is fundamental.
> 
> We could make it more obvious, though. What about changing 
> the label for
> the field to Expected_Script_Subtags? (I.e. 'it is expected 
> that one of
> the following script subtags will also be used'.)
> 
> 
> > The specific answer is that for centuries Gothic has been written
> solely
> > in the Latin script.  (This may start to change with the presence of
> > Gothic in Unicode and the ready availability of Gothic fonts, or it
> > may not.)  Therefore, no Associated_Script header should be present,
> > and the tag got-Latn should be avoided (though got-Goth would be in
> > order as an unusual script).
> 
> The one concern for our plan would be what to do if some apparently
> stable mono-script situation suddenly changes. If we tag "got" today,
> with Latin script assumed, and "got-Goth" for the unusual 
> scenario, and
> then next year a reform gets underway with the result that in 
> five years
> the situation has reversed, then what do we do? 
> 
> Of course, I'm describing another scenario like Turkish, and those
> aren't all that likely. But a scenario such as going from 
> only Cyrillic
> today to Cyrillic and Latin next year might not be so far fetched.
> 
> 
> 
> Peter Constable
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Wed, 13 Apr 2005 13:55:42 -0400

> because RFC3066bis is infixing script between language

Not so.  If you can only read Azerbaijani in the Cyrillic script, and
you ask for az-Cyrl, you will get RFC 2616 failures if the content is
tagged az-XX or az-XX-Cyrl for any of the various national varieties
of Azerbaijani.  Yet the differences between national varieties are
much smaller to the reader than the difference between Arabic, Cyrillic,
or Latin script.

> like 'en-Latn-GB' and wreak a fair amount of havoc.

It is a proven fact that software vendors who sell widely used
applications ignore MUST NOTs in RFCs.  These things happen.   We can
warn, we can complain, and finally we can boycott.

-- 
Newbies always ask:                             John Cowan
  "Elements or attributes?                      http://www.ccil.org/~cowan
Which will serve me best?"                      http://www.reutershealth.com
  Those who know roar like lions;               [email-masked]
  Wise hackers smile like tigers.                   --a tanka, or extended haiku

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 13 Apr 2005 11:02:09 -0700

There are very good reasons for having script second; I won't repeat them.

The chances that a vendor would gratuitously use "'en-Latn-GB" in that case,
is vanishingly small, since it would cause clients grief for no purpose.

‎Mark

---

From: Markus Scherer <[email-masked]>
Date: Wed, 13 Apr 2005 16:39:05 -0700

I completely agree with Mark Davis here: For the identification of
written language it is important to specify the script when languages
are written in multiple scripts; for technical reasons of
identification and matching that have been discussed on this list, the
script needs to go in second position, after the language code and
certainly before the country code.

Best regards,
markus
(also at [email-masked])

-- 
Opinions expressed here may not reflect my company's positions unless
otherwise noted.

---

From: [email-masked]
Date: Wed, 13 Apr 2005 16:43:25 -0700 (PDT)

> is vanishingly small, since it would cause clients grief for no purpose.

I have to say I find your faith in implementors doing the right thing in the
absence of guidance to be rather sweet. It is also at odds with my own past
experience with many implementations. Cases abound where implementors have done
things for no purpose that caused huge amounts of grief.

As I have commented previously, given how easy it is to extract script
information from many sorts of data objects it is entirely possible that
implementors will do it in a misguided attempt to make things work "better".

Ira concern is that implementors will do this no matter what we say. This is
possible as well, but it is much easier (and more legitimate) to criticize an
implementation ignoring a SHOULD NOT for no good reason than it is to criticize 
an implementation done in a guidance vacuum.

				Ned