Subject: RE: [Ltru] considerations for ISO 639-6 at consensus? (was: new version posted online)

From: "Addison Phillips" <[email-masked]>
Date: Mon, 18 Apr 2005 12:54:59 -0700

Hi Debbie,

I agree that we probably did reach consensus and support the changes you'd like to make but am waiting for Randy to bless same.

I only made changes to section 8 [Changes] (you'll find your name there next to the entry describing what I did). 

Personally, I'd favor changing the rules in Section 3.5 (possibilities for registration) to say that alpha4 subtags will not be considered for registration of primary languages "anticipating work that is currently under way on ISO 639". 

We should also change this item in section 2.2.1:

<t>Other values MUST NOT be assigned to the primary subtag except by revision or update of this document.</t> 

To say:

<t>Other values MUST NOT be assigned to the primary subtag except by revision or update of this document. Work on additional parts of ISO 639 is the most likely source for future assignments.</t>

If we change the ABNF I think it should be to:

  lang = 2*8ALPHA ; ISO 639 code or other registered value

But I don't think the ABNF really needs to be changed.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: Debbie Garside [mailto:[email-masked]]
> Sent: lundi 18 avril 2005 12:47
> To: Addison Phillips; [email-masked]
> Subject: RE: [Ltru] new version posted online
> 
> Hi Addison (on list this time :-))
> 
> Will you be incorporating a reserved alpha4 for ISO 639-6 in the next
> draft?
> I believe consensus was reached on this issue... as raised by Doug.
> 
> Kind regards
> 
> Debbie
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> On
> > Behalf Of Addison Phillips
> > Sent: 18 April 2005 18:32
> > To: [email-masked]
> > Subject: [Ltru] new version posted online
> >
> > The draft-01 prototype has been updated and posted at:
> >
> > http://www.inter-locale.com/ID/draft-ietf-ltru-registry-01.txt
> > http://www.inter-locale.com/ID/draft-ietf-ltur-registry-01.html
> >
> > I have incorporated 'Suppress_Script' into the various places required
> to
> > define it (many parts of section 3). Of course we can decide on a
> > different name if so desired. Right now the text is the key. Note that I
> > used a different example from en/en-Latn in section 3.1. I also put a
> > script of 'Arab' on the language 'ar' in the example registry.
> >
> > Other minor changes/corrections are listed in the changes section.
> >
> > Are we close to done with this issue, enough for me to start work on
> > preparing the next officially submitted draft?
> >
> > Best Regards,
> >
> > Addison
> >
> > Addison P. Phillips
> > Globalization Architect, Quest Software
> > http://www.quest.com
> >
> > Chair, W3C Internationalization Core Working Group
> > http://www.w3.org/International
> >
> > Internationalization is not a feature.
> > It is an architecture.
> >
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 18 Apr 2005 13:37:20 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "Debbie Garside" <[email-masked]>; <[email-masked]>
> Sent: Monday, April 18, 2005 12:54 PM
> Subject: RE: [Ltru] considerations for ISO 639-6 at consensus? (was: newversion posted online)
>

> Hi Debbie,
>
> I agree that we probably did reach consensus and support
> the changes you'd like to make but am waiting for Randy to
> bless same.

As co-chair:
There certainly seems to be enough agreement (I don't recall any dissent)
to warrant incorporating them at this time.  I'd like to see an updated i-d
posted sooner rather than later.  If there are problems in the updated i-d,
I'm sure they will be pointed out on this list.  This WG's members are not
shy.

> I only made changes to section 8 [Changes] (you'll find your name there
> next to the entry describing what I did).
>
> Personally, I'd favor changing the rules in Section 3.5 (possibilities for
> registration) to say that alpha4 subtags will not be considered for registration
> of primary languages "anticipating work that is currently under way on ISO 639".
...

As a contributor: this seems reasonable, along with the related mods so that
it does the right thing once the ISO 639 alpha4s become available.

Randy