Subject: RE: [Ltru] Re: Compatibility with existing use (LDAP)

From: "Peter Constable" <[email-masked]>
Date: Mon, 11 Apr 2005 11:56:50 -0700

> From: [email-masked] [mailto:[email-masked]]
On Behalf Of
> Frank Ellermann

> > Of course, we cannot guarantee that no one will ever use
> > something like "en-Latn-GB", but we should not get overly
> > concerned about bad-practice usage.
> 
> At the moment the complete formal definition of "bad practice"
> is an appeal to "use tags wisely", that's not enough.  We need
> either language => script or script => language(s) pointers to
> define bad practice or good practice.

Agreed.

BTW, notice that now we're discussing how to ensure good practice to
avoid specific problems in functionality. This is quite different from
the unqualified statement "backwards compatibility is broken".

Peter Constable

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 11 Apr 2005 21:15:11 +0200

Peter Constable wrote:
 
> quite different from the unqualified statement "backwards
> compatibility is broken".

It's related, we're trying to avoid problems with existing
software for language-script-region...  One way is to shift
the script to the right behind language-region, another way
is to get rid of the script where it's unnecesary.  Without
the compatibility problem "use tags wisely" would be enough.

                           Bye, Frank

---

From: [email-masked]
Date: Mon, 11 Apr 2005 14:00:40 -0700 (PDT)

> the unqualified statement "backwards compatibility is broken".

Actually, the two are intimately related and almost impossible to
separate.

				Ned