Subject: RE: [Ltru] Re: Supress & Require Script

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 18 Apr 2005 10:02:07 -0700

Hi,

Please don't change them by just removing "YOU".

"X SHOULD NOT be used..." is not a valid conformance
requirement.  There's no actor (the missing "YOU").

However, "YOU" should _never_ be used.  A verifiable
conformance requirement should be written as a simple
subject/verb/object sentence like "Client applications 
(such as Web browsers) SHOULD NOT use X", with any needed
exception clause(s) trailing at the end.

Software entities (not human beings) are subjects for
protocol requirements.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Addison Phillips
> Sent: Monday, April 18, 2005 12:54 PM
> To: Marion Gunn
> Cc: [email-masked]
> Subject: RE: [Ltru] Re: Supress & Require Script
> 
> 
> Sadly, most of the 'you' forms are holdovers from RFC 3066. 
> I'll happily change them.
> 
> Addison
> 
> Addison P. Phillips
> Globalization Architect, Quest Software
> Chair, W3C Internationalization Core Working Group
> 
> Internationalization is not a feature.
> It is an architecture. 
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]] On
> > Behalf Of Marion Gunn
> > Sent: lundi 18 avril 2005 09:47
> > Cc: [email-masked]
> > Subject: Re: [Ltru] Re: Supress & Require Script
> > 
> > Is there any particular need to use 'YOU' forms, Addison?
> > 
> > For example:
> > (a) 'You should not use X';
> > rather than
> > (b) 'X should not be used'.
> > 
> > I ask this, because your document contains an admixture of the two.
> > 
> > This creates problems of translation if taken literally, 
> because the YOU
> > forms come across as rude in many languages (in the context of
> > instructions/commands).
> > 
> > Indeed, I should prefer form (b) to be used throughout, 
> even in English.
> > 
> > Hope this helps,
> > mg
> > 
> > Addison Phillips wrote:
> > >
> > > Here is the proposed text for the draft. I have includes 
> all of the
> > rules together. Comments?
> > >
> > > Addison
> > >
> > > --
> > > <t>The choice of subtags used to form a language tag 
> should be guided by
> > the following rules:
> > >
> > > <list style="numbers">
> > >    <t>Use as precise a tag as possible, but no more 
> specific than is
> > >    justified. Avoid using subtags that are not important for
> > >    distinguishing content in an application.
> > >
> > >    <list>
> > >       <t>For example, 'de' might suffice for tagging an 
> email written
> > >          in German, while "de-CH-1996" is probably 
> unnecessarily precise
> > >          for such a task.</t>
> > >    </list></t>
> > >
> > >    <t>The script subtag SHOULD NOT be used to form language
> > >    tags unless the script adds some distinguishing information to
> > >    the tag. The field 'Suppress_Script' in the primary language
> > >    record in the registry indicates which script subtags do not
> > >    add distinguishing information for most applications.
> > >
> > >    <list>
> > >       <t>For example, the subtag 'Latn' should not be 
> used with the
> > >       primary language 'en' because most English 
> documents are written
> > >       in the Latin script and it adds no distinguishing 
> information.
> > >       However, if a document were written in English mixing Latin
> > >       script with another script such as Braille ('Brai'), then it
> > >       may be appropriate to choose to indicate both scripts to aid
> > >       in content selection, such as the application of a
> > >       stylesheet.</t>
> > >    </list></t>
> > >
> > >    <t>If a subtag has a 'Canonical' field in its registry 
> entry, you
> > >    SHOULD use the canonical subtag in preference to any
> > >    of its aliases.
> > >
> > >    <list>
> > >       <t>For example, you should use 'he' for Hebrew in
> > >       Preference to 'iw'.</t>
> > >    </list></t>
> > >
> > >    <t>You SHOULD NOT use the 'UND' (Undetermined) 
> language subtag to
> > >    label content, even if the language is unknown. 
> Omitting the tag
> > >    is preferred. Some protocols may force you to give a 
> value for the
> > >    language tag and the 'UND' subtag may be useful when matching
> > >    language tags in certain situations.</t>
> > >
> > >    <t>You SHOULD NOT use the 'MUL' (Multiple) subtag if 
> the protocol
> > >    allows you to use multiple languages, as is the case for the
> > >    Content-Language header in HTTP.</t>
> > >
> > >    <t>You SHOULD NOT use the same variant subtag more 
> than once within
> > >    a language tag.
> > >
> > >    <list>
> > >       <t>For example, you should not use 
> "en-GB-scouse-scouse".</t>
> > >    </list> </t>
> > > </list></t>
> > > --
> > >
> > > Addison P. Phillips
> > > Globalization Architect, Quest Software
> > > Chair, W3C Internationalization Core Working Group
> > >
> > > Internationalization is not a feature.
> > > It is an architecture.
> > >
> > > > -----Original Message-----
> > > > From: [email-masked] 
> [mailto:[email-masked]]
> > On
> > > > Behalf Of Mark Davis
> > > > Sent: dimanche 17 avril 2005 20:44
> > > > To: [email-masked]; Frank Ellermann
> > > > Subject: Re: [Ltru] Re: Supress & Require Script
> > > >
> > > > It sounds to me like we have rough consensus for
> > > >
> > > > suppress_script
> > > > SHOULD NOT (but maybe a follow-on sentence or so)
> > > > no real need for required_script
> > > >
> > > > âEUR*Mark
> > > >
> > > > ----- Original Message -----
> > > > From: "Frank Ellermann" <[email-masked]>
> > > > To: <[email-masked]>
> > > > Sent: Sunday, April 17, 2005 18:25
> > > > Subject: [Ltru] Re: Supress & Require Script
> > > >
> > > >
> > > > > Randy Presuhn wrote:
> > > > >
> > > > > > 2) there seems to be general support for wording the
> > > > > >    guidelines on the use of script subtags fairly strongly,
> > > > > >    using "MUST ... except" rather than "SHOULD"
> > > > >
> > > > > Only "rough consensus" for the proposed "MUST NOT ... unless",
> > > > > see <http://article.gmane.org/gmane.ietf.ltru:1240> - I'd like
> > > > > a "SHOULD NOT ..." without "unless" clause better.  Bye, Frank
> > > > >
> > > > >
> > > > >
> > > > > _______________________________________________
> > > > > Ltru mailing list
> > > > > [email-masked]
> > > > > https://www1.ietf.org/mailman/listinfo/ltru
> > > > >
> > > > >
> > > >
> > > >
> > > >
> > > > _______________________________________________
> > > > Ltru mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/ltru
> > >
> > >   
> ----------------------------------------------------------------------
> > --
> > > _______________________________________________
> > > Ltru mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/ltru
> > 
> > --
> > 
> > Marion Gunn * EGTeo (Estab.1991)
> > 27 Páirc an Fhéithlinn, Baile an
> > Bhóthair, Co. Átha Cliath, Éire.
> > * [email-masked] * [email-masked] *
> > 
> > _______________________________________________
> > Ltru mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ltru
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Marion Gunn <[email-masked]>
Date: Mon, 18 Apr 2005 18:47:11 +0100

Ira's suggestion would certainly make it easier to read/translate/quote.

Best,
mg

--

---

From: Marion Gunn <[email-masked]>
Date: Mon, 18 Apr 2005 18:52:03 +0100

Best,
mg

--