Subject: RE: [Ltru] Re: Proposed Text for Moving Forward

From: "McDonald, Ira" <[email-masked]>
Date: Sat, 16 Apr 2005 16:12:32 -0700

Hi Mark,

I know that legacy's not the only problem, but it happens
to be _the_ issue on which Kurt, Ned, and I have expressed
concerns and deserves to be included in the rule set, e.g.,

1. Script subtags listed in the 'Suppress_Script' field MUST NOT be used
to form language tags unless there is a specific reason to include
the script subtag in the application.  

...

Rationale:  Rule 1 is designed to improve language tag matching by
applications using the RFR (remove from right) algorithm that is 
common among legacy applications.

I dislike the standards style that says "don't state the rationale 
- just be terse".  Nothing is gained.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: Mark Davis [mailto:[email-masked]]
> Sent: Saturday, April 16, 2005 5:48 PM
> To: McDonald, Ira; 'Addison Phillips'; Peter Constable; [email-masked]
> Subject: Re: [Ltru] Re: Proposed Text for Moving Forward
> 
> 
> I'm ok with MUST NOT, if the exception is clearly stated (and 
> it is not just
> legacy that is at issue). For parallelism with #2, they could be:
> 
> 1. Script subtags listed in the 'Suppress_Script' field MUST 
> NOT be used
> to form language tags unless there is a specific reason to include
> the script subtag in the application.
> 
> 2. Script subtags not listed in the 'Suppress_Script' field 
> SHOULD always
> be used to form language tags when they match the script used 
> by the content
> unless there is a specific reason to omit the script subtag in the
> application.
> 
> ‎Mark
> 
> ----- Original Message ----- 
> From: "McDonald, Ira" <[email-masked]>
> To: "'Addison Phillips'" <[email-masked]>; "Peter 
> Constable"
> <[email-masked]>; <[email-masked]>
> Sent: Saturday, April 16, 2005 14:08
> Subject: RE: [Ltru] Re: Proposed Text for Moving Forward
> 
> 
> > Hi,
> >
> > "Implicit" is not very clear - it's capable of being misread as
> > "Default" (meaningless) and is not a verb like "Suppress" - it sure
> > doesn't indicate Suppress in plain English.
> >
> > By the way, IETF standards do often use the construction MUST NOT
> > followed by one or more exceptions.  So a stronger rewrite of the
> > Mark's two rule set would be:
> >
> > 1. Script subtags listed in the 'Suppress_Script' field 
> MUST NOT be used
> > to form language tags unless they add specific information 
> to the language
> > tag required by an application, to improve language tag matching for
> legacy
> > content.
> >
> > 2. Script subtags not listed in the 'Suppress_Script' field 
> SHOULD always
> > be used to form language tags when the script used by the 
> content being
> > identified matches the script unless there is a specific 
> reason to omit
> > the script subtag in the application.
> >
> > Cheers,
> > - Ira
> >
> > Ira McDonald (Musician / Software Architect)
> > Blue Roof Music / High North Inc
> > PO Box 221  Grand Marais, MI  49839
> > phone: +1-906-494-2434
> > email: [email-masked]
> >
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]]On
> > > Behalf Of Addison Phillips
> > > Sent: Saturday, April 16, 2005 3:19 PM
> > > To: Peter Constable; [email-masked]
> > > Subject: RE: [Ltru] Re: Proposed Text for Moving Forward
> > >
> > >
> > > I dislike "default" because it implies way too many things
> > > that aren't really true about the field. "Implicit" isn't 
> bad, though.
> > >
> > > Addison
> > >
> > > Addison P. Phillips
> > > Globalization Architect, Quest Software
> > > Chair, W3C Internationalization Core Working Group
> > >
> > > Internationalization is not a feature.
> > > It is an architecture.
> > >
> > > > -----Original Message-----
> > > > From: [email-masked]
> > > [mailto:[email-masked]] On
> > > > Behalf Of Peter Constable
> > > > Sent: samedi 16 avril 2005 05:34
> > > > To: [email-masked]
> > > > Subject: RE: [Ltru] Re: Proposed Text for Moving Forward
> > > >
> > > > > From: JFC (Jefsey) Morfin [mailto:[email-masked]]
> > > >
> > > > > As a non English speaker I more or less understand 
> the English of
> > > > > "Suppress_Script" because I know its history. I am not sure an
> > > > occasional
> > > > > developper will understand/remember the meaning of 
> it. Unneeded,
> > > > needless,
> > > > > redundant_script would be clearer to me.
> > > >
> > > > Keep in mind, we do expect someone to have at least glanced
> > > at the RFC.
> > > > But if "Suppress_Script" really doesn't communicate well
> > > enough, then
> > > > what about "Implied_Script" or "Implicit_Script"?
> > > >
> > > >
> > > > A side note: In a paper I wrote three years ago, I had a section
> > > > entitled "Default values and implicit tagging", discussing
> > > specifically
> > > > the issue of script subtags. I find it interesting that we
> > > started with
> > > > a suggestion of a field called "Default_Script" and have
> > > now come around
> > > > to a suggestion that it be called "Implicit_Script". 
> FYI, here's an
> > > > excerpt from the end of that section of that paper:
> > > >
> > > > <quote>
> > > > The choice of whether or not to adopt the use of 
> implicit default
> > > > semantics amounts to a trade-off between simpler tags and
> > > compatibility
> > > > with existing implementations on the one hand, and
> > > identifiers with more
> > > > predictable forms, more predictable semantics, and
> > > therefore no need to
> > > > maintain a database of implicit relationships on the other hand.
> > > > </quote>
> > > >
> > > >
> > > >
> > > > Peter Constable
> > > >
> > > > _______________________________________________
> > > > Ltru mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/ltru
> > >
> > >
> > > _______________________________________________
> > > Ltru mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/ltru
> > >
> >
> > _______________________________________________
> > Ltru mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ltru
> >
> >
> 
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Sat, 16 Apr 2005 16:31:39 -0700

Hi -

> To: "'Mark Davis'" <[email-masked]>; "McDonald, Ira" <[email-masked]>; "'Addison Phillips'"
<[email-masked]>; "Peter Constable" <[email-masked]>; <[email-masked]>
> Sent: Saturday, April 16, 2005 4:12 PM
...
...

As co-chair, I'm all for including rationale in the specification when it helps
us gain consensus or results in a clearer specification.  As a technical contributor,
I think that in this particular case the potential for harm makes it essential
to explain why violating rule 1 is generally a bad idea, even though we haven't
been able to make the prohibition absolute.

Randy

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Sun, 17 Apr 2005 04:07:24 +0200

+1

On 01:31 17/04/2005, Randy Presuhn said:
> > To: <[email-masked]>