Subject: RE: [Ltru] [psg.com #882] registry should copy non-English fields from ISO documents

From: "L.Gillam" <[email-masked]>
Date: Tue, 12 Apr 2005 09:16:22 +0100

Does the summary below entail something along the lines of:

/reference_name/
/names lang="en"/
/names lang="fr"/

/reference_name/ filled if 639-3
/reference_name/ = pointer to first name in /names lang="en"/ if 639-1/2
/names lang="en"/ filled if 639-1/2
/names lang="fr"/ filled if 639-1/2

Peter, I'm assuming a 639-3 reference name to be unique (one name only).

The above is also a reason I'm in favour of an XML registry also - the proof
of the registry becomes its application to itself!

On the consensus side, I'm not bothered either way, as long as it's clear -
but I'd draw the line at filling fields that were not available in the source
documents.

The devil, however, will be in the detail.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Randy Presuhn
> Sent: 11 April 2005 23:03
> To: ltru
> Subject: Re: [Ltru] [psg.com #882] registry should copy non-English
> fields from ISO documents
> 
> 
> Hi -
> 
> > From: "Peter Constable" <[email-masked]>
> > To: <[email-masked]>
> > Sent: Monday, April 11, 2005 10:43 AM
> > Subject: RE: [Ltru] Re: registry should copy non-English 
> fields fromISOdocuments
> ...
> > I think Lee's point is that the name used is intended to 
> document the
> > conceptual entity in a way that ideally is unambiguous. I 
> don't think
> > you two are actually disagreeing about anything; you're 
> just struggling
> > over common words to describe a common understanding.
> ...
> 
> Trying to sum up this thread:
> 
>     1) there is a reference name from the ISO documents.  In 
> some cases
>         this is the English name of the language, in others 
> it's a transcription.
>         This is currently part of an entry in the registry, 
> and no one is suggesting
>         that it be removed.
> 
>     2) in some cases the ISO documents also include a French name for
>         a language.  This tracker item is on the question of 
> whether this information,
>         when available, should also be included in the 
> registry.  It looks like there
>         is a slight preference among active participants in 
> the WG to include this
>         information.  (Those who want it appear to want it 
> more than those who
>         oppose it don't want it.)
> 
>     3) In those cases where a French name for a language is 
> available from the
>         ISO documents, the remaining question is whether it 
> should be included
>         in the same field as the reference name, using some 
> kind of delimiter, or
>         given a field of its own.  Based on the technical 
> arguments so far, I believe
>         the preference would be to use a separate field to 
> hold the French name,
>         when available, for a language.
> 
> Note that this resolution would NOT entail translating 
> entries for which French
> translations are not already present in the ISO documents, 
> nor would it require
> a registrant to obtain a French name for a language, nor 
> should it be in any way
> understood as constraining the names displayed by 
> implementations or used by
> users.
> 
> Would this be an acceptable statement of rough consensus?
> 
> Randy, ltru co-chair
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 12 Apr 2005 19:02:03 +0200

L.Gillam wrote:

> The above is also a reason I'm in favour of an XML registry
> also - the proof of the registry becomes its application to
> itself!

That's a beautiful idea, but you could also do it with an XML
version derived from whatever IANA puts on its Web pages or
ftp server.

> I'd draw the line at filling fields that were not available
> in the source documents.

Of course, and IMHO better than Doug's line "Latn", bye, Frank
-- 
<URL:http://www.rfc-editor.org/queue.html#malamud-subject-line>