Subject: RE: [Ltru] Re: registry should copy non-English fields from ISOdocuments

From: "Addison Phillips" <[email-masked]>
Date: Fri, 8 Apr 2005 17:38:15 -0700

I mean: how does one distinguish the French from the English the Language Subtag Directory after we've imported the values?

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: vendredi 8 avril 2005 17:11
> To: Addison Phillips
> Cc: [email-masked]; John Cowan; Doug Ewell; [email-masked]
> Subject: RE: [Ltru] Re: registry should copy non-English fields from
> ISOdocuments
> 
> > Two potential issues.
> 
> > 1. How do we distinguish the French names from the English ones? (Other
> than
> > by inspection)
> 
> I guess I don't understand. Aren't there two names for each? Or are there
> some
> blanks in the ISO data?
> 
> > 2. Do we include (require?)(allow?) French, English, or both for future
> registrations that are not sourced from one of the ISO standards (i.e.
> variants)
> 
> My preference would be to allow but not require.
> 
> 				Ned

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 09 Apr 2005 02:46:18 +0200

Addison Phillips wrote:
 
> how does one distinguish the French from the English the
> Language Subtag Directory after we've imported the values?

How about:  English name semicolon French name ?  Bye, Frank

---

From: [email-masked]
Date: Fri, 08 Apr 2005 18:03:56 -0700 (PDT)

> How about:  English name semicolon French name ?  Bye, Frank

Yah, that was pretty much what I had in mind.

				Ned

---

From: John Cowan <[email-masked]>
Date: Fri, 8 Apr 2005 21:25:44 -0400

> How about:  English name semicolon French name ?  Bye, Frank

XML and its xml:lang attribute are looking better all the kind.
Recursive, of course.  :-)

-- 
I don't know half of you half as well           John Cowan
as I should like, and I like less than half     [email-masked]
of you half as well as you deserve.             http://www.ccil.org/~cowan
        --Bilbo                                 http://www.reutershealth.com

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 8 Apr 2005 18:31:35 -0700

Hi -

> From: <[email-masked]>
> To: "Frank Ellermann" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Friday, April 08, 2005 6:03 PM
> Subject: Re: [Ltru] Re: registry should copy non-English fields fromISOdocuments
>

> Yah, that was pretty much what I had in mind.
...

How about making them separate fields?

<soap>
I don't like adding redundant data,
but I'm thinking ahead to when folks decide
that just having French and English is too blatantly euro-centric,
and that it's time to add Chinese (tagged appropriately, of course)
to better support that developer community.
</soap>

Randy