Subject: RE: [Ltru] Re: Registry in record-jar format

From: "Addison Phillips" <[email-masked]>
Date: Mon, 4 Apr 2005 12:03:41 -0700

I've thought about it. First a comment, then some observations.

Extlang and variant can both be repeated and order is significant. Does one variant matching from a list of variants count as "1 point" or as a fraction?

Extensions are always ignored (good). What about private use subtags?

Unless you receive a "perfect" score of 15, is it a match? What do I do with tags with a score of 14, 13, 11, 2?

Finally, how is this different in practice from the "extended language range" matching currently proposed?

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of John Cowan
> Sent: lundi 4 avril 2005 11:49
> To: Frank Ellermann
> Cc: [email-masked]
> Subject: Re: [Ltru] Re: Registry in record-jar format
> 
> Frank Ellermann scripsit:
> 
> > At the moment I only _think_ that default scripts are a MUST
> > HAVE, because otherwise en-Latn-GB-scouse, en-GB-scouse,
> > en-Latn-scouse, and en-scouse could run into trouble if they
> > don't match each other.
> >
> > Maybe I'm wrong and this only breaks RTL matching.  Maybe it
> > causes major havoc for all Web servers and browsers.  I don't
> > know before I see the matching draft.
> 
> I have yet to receive any comments on my proposed alternative
> (not replacement) matching algorithm.  People seemed to get lost in
> the details of Date A and Date B.  To recap in a way that doesn't
> reawaken that:
> 
> 1) Normalize the tag.
> 
> 2) Create a quadruple (lang, script, region, variant), filling in missing
>    components with *s.
> 
> 3) Subtags match if they are the same or if either is "*".
> 
> 4) Add {8, 4, 2, 1} to the figure of merit if the {lang, script, region,
>    variant} matches.
> 
> --
> Using RELAX NG compact syntax to        John Cowan
> develop schemas is one of the simple    http://www.reutershealth.com
> pleasures in life....                   http://www.ccil.org/~cowan
>         --Jeni Tennison                 <[email-masked]>
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Mon, 4 Apr 2005 18:55:12 -0400

Addison Phillips scripsit:

> Extlang and variant can both be repeated and order is significant. Does
> one variant matching from a list of variants count as "1 point" or as
> a fraction?

I'm not taking extlangs into account yet.

I hadn't noted that variants can be repeated; I agree that that requires more
thought.

> Extensions are always ignored (good). What about private use subtags?

Also ignored.  You can supplement this algorithm with an "exact match gets
16" if you want.

> Unless you receive a "perfect" score of 15, is it a match? What do I
> do with tags with a score of 14, 13, 11, 2?

The idea is to sort candidates in order of usefulness.  What to do then
is up to the matcher (return an ordered list of candidates, pick the top
candidate, whatever).

> range" matching currently proposed?

Precisely because of this question of ordering.

-- 
Values of beeta will give rise to dom!          John Cowan
(5th/6th edition 'mv' said this if you tried    http://www.ccil.org/~cowan
to rename '.' or '..' entries; see              [email-masked]
http://cm.bell-labs.com/cm/cs/who/dmr/odd.html)