Subject: [Ltru] Re: Supress & Require Script

From: "Doug Ewell" <[email-masked]>
Date: Sun, 17 Apr 2005 22:02:27 -0700

Randy Presuhn <randy underscore presuhn at mindspring dot com> wrote:

> Have I missed something major?

Where do we get the initial data from?  We know all about English and
Chinese and Serbian -- they've been beaten to death in this thread -- 
but what about the other 470+ languages in the registry?  Does the
initial data come from anything resembling an authoritative source, or
do we start out with nothing and wait for registrations to come in?

We've been able to defend the initial registry data as having come from
ISO and UN standards and (in the case of variants) from previously
registered tags.  I don't believe we can say the same for
language-script associations.

Anyway, I did my best with regard to "required script," and I still
think it's going to be a real can of worms, but apparently a lot of
people really like it.  So just let me know what needs to be added to
the registry, both syntax and initial data, and I'll do it.

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Mon, 18 Apr 2005 15:37:22 +0200

+1

---

From: "Addison Phillips" <[email-masked]>
Date: Mon, 18 Apr 2005 09:16:12 -0700

We do the ones we know (probably most of the ISO 639-1 codes) and leave the rest to the registration process?

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: dimanche 17 avril 2005 22:02
> To: LTRU Working Group
> Subject: [Ltru] Re: Supress & Require Script
>

---

From: "Addison Phillips" <[email-masked]>
Date: Mon, 18 Apr 2005 09:53:46 -0700

Sadly, most of the 'you' forms are holdovers from RFC 3066. I'll happily change them.

Addison

Addison P. Phillips

> Behalf Of Marion Gunn
> Sent: lundi 18 avril 2005 09:47
> Cc: [email-masked]
> Subject: Re: [Ltru] Re: Supress & Require Script
> 
> Is there any particular need to use 'YOU' forms, Addison?
> 
> For example:
> (a) 'You should not use X';
> rather than
> (b) 'X should not be used'.
> 
> I ask this, because your document contains an admixture of the two.
> 
> This creates problems of translation if taken literally, because the YOU
> forms come across as rude in many languages (in the context of
> instructions/commands).
> 
> Indeed, I should prefer form (b) to be used throughout, even in English.
> 
> Hope this helps,
> mg
> 
> Addison Phillips wrote:
> >
> > Here is the proposed text for the draft. I have includes all of the
> rules together. Comments?
> >
> > Addison
> >
> > --
> > <t>The choice of subtags used to form a language tag should be guided by
> the following rules:
> >
> > <list style="numbers">
> >    <t>Use as precise a tag as possible, but no more specific than is
> >    justified. Avoid using subtags that are not important for
> >    distinguishing content in an application.
> >
> >    <list>
> >       <t>For example, 'de' might suffice for tagging an email written
> >          in German, while "de-CH-1996" is probably unnecessarily precise
> >          for such a task.</t>
> >    </list></t>
> >
> >    <t>The script subtag SHOULD NOT be used to form language
> >    tags unless the script adds some distinguishing information to
> >    the tag. The field 'Suppress_Script' in the primary language
> >    record in the registry indicates which script subtags do not
> >    add distinguishing information for most applications.
> >
> >    <list>
> >       <t>For example, the subtag 'Latn' should not be used with the
> >       primary language 'en' because most English documents are written
> >       in the Latin script and it adds no distinguishing information.
> >       However, if a document were written in English mixing Latin
> >       script with another script such as Braille ('Brai'), then it
> >       may be appropriate to choose to indicate both scripts to aid
> >       in content selection, such as the application of a
> >       stylesheet.</t>
> >    </list></t>
> >
> >    <t>If a subtag has a 'Canonical' field in its registry entry, you
> >    SHOULD use the canonical subtag in preference to any
> >    of its aliases.
> >
> >    <list>
> >       <t>For example, you should use 'he' for Hebrew in
> >       Preference to 'iw'.</t>
> >    </list></t>
> >
> >    <t>You SHOULD NOT use the 'UND' (Undetermined) language subtag to
> >    label content, even if the language is unknown. Omitting the tag
> >    is preferred. Some protocols may force you to give a value for the
> >    language tag and the 'UND' subtag may be useful when matching
> >    language tags in certain situations.</t>
> >
> >    <t>You SHOULD NOT use the 'MUL' (Multiple) subtag if the protocol
> >    allows you to use multiple languages, as is the case for the
> >    Content-Language header in HTTP.</t>
> >
> >    <t>You SHOULD NOT use the same variant subtag more than once within
> >    a language tag.
> >
> >    <list>
> >       <t>For example, you should not use "en-GB-scouse-scouse".</t>
> >    </list> </t>
> > </list></t>
> > --
> >
> > Addison P. Phillips
> > > Behalf Of Mark Davis
> > > Sent: dimanche 17 avril 2005 20:44
> > > To: [email-masked]; Frank Ellermann
> > > Subject: Re: [Ltru] Re: Supress & Require Script
> > >
> > > It sounds to me like we have rough consensus for
> > >
> > > suppress_script
> > > SHOULD NOT (but maybe a follow-on sentence or so)
> > > no real need for required_script
> > >
> > > âEUR*Mark
> > >
> > > ----- Original Message -----
> > > From: "Frank Ellermann" <[email-masked]>
> > > To: <[email-masked]>
> > > Sent: Sunday, April 17, 2005 18:25
> > > > Randy Presuhn wrote:
> > > > > 2) there seems to be general support for wording the
> > > > >    guidelines on the use of script subtags fairly strongly,
> > > > >    using "MUST ... except" rather than "SHOULD"
> > > >
> > > > Only "rough consensus" for the proposed "MUST NOT ... unless",
> > > > see <http://article.gmane.org/gmane.ietf.ltru:1240> - I'd like
> > > > a "SHOULD NOT ..." without "unless" clause better.  Bye, Frank
> > > >
> > > >
> > > >
> >   ----------------------------------------------------------------------
> --
> --
> Marion Gunn * EGTeo (Estab.1991)
> 27 Páirc an Fhéithlinn, Baile an
> Bhóthair, Co. Átha Cliath, Éire.
> * [email-masked] * [email-masked] *
>

---

From: "Addison Phillips" <[email-masked]>
Date: Mon, 18 Apr 2005 10:04:36 -0700

No, each requires a rewrite to make it grammatically correct and to have a proper subject.

   1. Use as precise a tag as possible, but no more specific than is justified. Avoid using subtags that are not important for distinguishing content in an application.
          * For example, 'de' might suffice for tagging an email written in German, while "de-CH-1996" is probably unnecessarily precise for such a task.
   2. The script subtag SHOULD NOT be used to form language tags unless the script adds some distinguishing information to the tag. The field 'Suppress_Script' in the primary language record in the registry indicates which script subtags do not add distinguishing information for most applications.
          * For example, the subtag 'Latn' should not be used with the primary language 'en' because nearly all English documents are written in the Latin script and it adds no distinguishing information. However, if a document were written in English mixing Latin script with another script such as Braille ('Brai'), then it may be appropriate to choose to indicate both scripts to aid in content selection, such as the application of a stylesheet.
   3. If a subtag has a 'Canonical' field in its registry entry, the canonical subtag SHOULD be used to form the language tag in preference to any of its aliases.
          * For example, use 'he' for Hebrew in preference to 'iw'.
   4. The 'UND' (Undetermined) primary language subtag SHOULD NOT be used to label content, even if the language is unknown. Omitting the tag is preferred. Some protocols may force you to give a value for the language tag and the 'UND' subtag may be useful when matching language tags in certain situations.
   5. The 'MUL' (Multiple) primary language subtag SHOULD NOT be used if the protocol allows you to use multiple languages, as is the case for the Content-Language header in HTTP.
   6. The same variant subtag SHOULD NOT be used more than once within a language tag.
          * For example, do not use "en-GB-scouse-scouse".

Addison P. Phillips

> From: McDonald, Ira [mailto:[email-masked]]
> Sent: lundi 18 avril 2005 10:02
> To: Addison Phillips; Marion Gunn
> Cc: [email-masked]
> Subject: RE: [Ltru] Re: Supress & Require Script
> 
> Hi,
> 
> Please don't change them by just removing "YOU".
> 
> "X SHOULD NOT be used..." is not a valid conformance
> requirement.  There's no actor (the missing "YOU").
> 
> However, "YOU" should _never_ be used.  A verifiable
> conformance requirement should be written as a simple
> subject/verb/object sentence like "Client applications
> (such as Web browsers) SHOULD NOT use X", with any needed
> exception clause(s) trailing at the end.
> 
> Software entities (not human beings) are subjects for
> protocol requirements.
> 
> Cheers,
> - Ira
> 
> Ira McDonald (Musician / Software Architect)
> Blue Roof Music / High North Inc
> PO Box 221  Grand Marais, MI  49839
> phone: +1-906-494-2434
> email: [email-masked]
> 
> > From: [email-masked]
> > [mailto:[email-masked]]On
> > Behalf Of Addison Phillips
> > Sent: Monday, April 18, 2005 12:54 PM
> > To: Marion Gunn
> > Cc: [email-masked]
> > Subject: RE: [Ltru] Re: Supress & Require Script
> >
> >
> > > > > From: [email-masked]
> > [mailto:[email-masked]]
> > > On
> > > > > Behalf Of Mark Davis

---

From: "Addison Phillips" <[email-masked]>
Date: Mon, 18 Apr 2005 13:57:01 -0700

> Addison, did you perhaps learn grammar from an unusual source?

Don't insult my English teachers. They did a fine job, thank you.

For starters, I didn't modify either of those sentences in the rewrite. Here they are from draft-00:

# Use as precise a tag as possible, but no more specific than is justified. 
# Avoid using subtags that are not important for distinguishing content in an application. 

They've been that way for a long time. They were that way in draft-phillips-langtags-01, for example. And they inherit from RFC 3066's rather chewy:

   1. Use the most precise tagging known to the sender that can be
      ascertained and is useful within the application context.

These can't really be considered "conformance statements". They embody the famous (but unstated) Rule Zero: tag content wisely and are directed to the person selecting the tag. In this they differ from the other items in the list and I left them in a different form to set them out from the others.

In all of these cases, the text is not missing a subject. The subject is implied, as these sentences are written in the imperative. Go look it up. (Dang, he did it again)

I don't see how we can rewrite them as conformance statements, as those two sentences represent individual judgment rather than ironclad requirements. We could move them outside the list, I suppose.

Addison

Addison P. Phillips

> Sent: lundi 18 avril 2005 13:31
> > From: Addison Phillips [mailto:[email-masked]]
> > Sent: Monday, April 18, 2005 1:05 PM
> > To: McDonald, Ira; Marion Gunn
> > Cc: [email-masked]
> >    1. Use as precise a tag as possible, but no more specific
> > than is justified.
> 
> Addison, did you perhaps learn grammar from an unusual source?
> 
> The _first_ sentence in your "grammatically correct" rewrite
> is at least no longer in passive voice, but it now lacks a
> _subject_ who will take the "Use...a tag" action.
> 
> Every conformance statement in any standard that contains an
> uppercase imperative (MUST, SHOULD, etc.) should be written
> with a very explicit subject.  In your fragment of a sentence
> above, was your intended subject:
> 
> (a) a human or software content searcher;
> (b) a human or software content creator;
> (c) a content distribution application; or
> (d) whatever?
> 
> Cheers,
> - Ira
>

---

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 18 Apr 2005 14:10:05 -0700

> Sent: Monday, April 18, 2005 4:57 PM
> <...snip...>
> In all of these cases, the text is not missing a subject. The 
> subject is implied, as these sentences are written in the 
> imperative. Go look it up. (Dang, he did it again)
> 
> I don't see how we can rewrite them as conformance 
> statements, as those two sentences represent individual 
> judgment rather than ironclad requirements. We could move 
> them outside the list, I suppose.

Your grammar's still shaky.  An imperative sentence can only
be grammatically correct if, in the _preceding_ context, there
is exactly one possible implied subject.  As my list of possible
subjects demonstrated, that's not the case here.

And yes, certainly those sentences can be rewritten to be
conformance statements.  If they can't, then delete them.
The IESG may well do so anyway.  

RFC3066bis will become a BCP which is binding on many other 
future RFCs.  It should be unambiguous enough to yield a 
largely useable translation by direct machine translation.  
Otherwise, it's a loose cannon.

Cheers,
- Ira

---

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 18 Apr 2005 14:15:32 -0700

Hi,

Agreed - the job of editor in this WG is both mostly thankless
and very underpaid (smile).

Cheers,
- Ira

> Behalf Of Randy Presuhn
> Sent: Monday, April 18, 2005 5:15 PM
> To: [email-masked]
> Hi -
> > From: "McDonald, Ira" <[email-masked]>
> > To: "'Frank Ellermann'" <[email-masked]>; <[email-masked]>
> > Sent: Monday, April 18, 2005 1:56 PM
> ...
> > If there are any passive voice sentences anywhere in RFC3066bis
> > they should be rewritten to active voice with precise subjects
> > or deleted.  Every single one of them.
> ...
> 
> Let's not micro-manage our editors.  The job is tough enough as
> it is.  Having made our preferences known, let's trust them to make
> sensible editorial choices.  When the updated i-d appears, if there
> are specific problematic passages that are worth spending WG
> time on, we can discuss them then.
> 
> Randy
> 
> 
> 
>