Subject: RE: [Ltru] Re: registry should copy non-English fields from ISO documents

From: "L.Gillam" <[email-masked]>
Date: Sun, 10 Apr 2005 19:42:07 +0100

Aside from wondering whether an ontlogy is a spelling error or a new invention, I consider the following:
 
1. A "reference name" is for interoperability. The reference name for a language can be taken from that language, and need not be in either English or French, as I believe Peter was alluding to. I believe this to be the case with -3 and it's certainly intended for -6. Difficulty only arises if the name of the language itself causes a code (i.e. Unicode) problem, as discussed previously. 
2. A reference name acts as a "conceptual" identifier - a code is an abbreviated form of such a "concept" (c/w terminological model). Nobody is prevented from making and maintaining as many sets of names of languages in other languages as they require (Jefsey's "multilingual internet" perhaps?). For "network" interoperability, however, you need to refer somehow to the chosen item in the "conceptual" entry. 
3. A code (e.g. alpha3 in 639-3) stands as synonymous with the reference name and as entry point into the "conceptual" entry - the mantra is "I don't care what you call it as long as we are referring to the same thing"
4. Applicability, or otherwise, of ISO 639-6 will be discussed when the appropriate draft versions are available. A number of people are involved in producing the draft of 639-6, learning from the various experiences and discussions in a variety of locations, and some of those are also involved with ensuring -4 has necessary and sufficient coverage. Whatever consensus is achieved for -3 and/or -6, and indeed -4 and -5 (has unanimous consensus ever been required on forums such as this?) is for this forum to discuss. Doug is right to be cautious.
 
The reference name, therefore, seems to be an adequate and highly extensible approach. I don't understand how it can be otherwise.
 
The question, as I see it, becomes:
ISO code lists already contain French and English names. If the registry identifies the code list and the code, does it really need to duplicate all the fields from this list? If 639-1 and 639-2 were XML namespaces, such replication could be made avoidable.
 
The second question becomes:
If 639-3 is using the name of the language in the language itself, does the code system have to be applied to itself? (This, to me, suggests using XML - which I am currently in favour of longer-term, not least because it allows the type of namespacing as above. I suggested same in, at least, June 2004 in case anybody thinks I'm agreeing with their recent suggestions).

________________________________

From: [email-masked] on behalf of Doug Ewell
Sent: Sun 10/04/2005 18:35
To: LTRU Working Group
Subject: [Ltru] Re: registry should copy non-English fields from ISO documents

JFC (Jefsey) Morfin <jefsey at jefsey dot com> wrote:

> This reference name is obviously not a medium term user acceptable
> solution. This is why the ISO 639-3 cannot be a final solution. And
why we
> need a multi-language ontlogy.

And yet you support the inclusion not only of ISO 639-3, but also ISO
639-6, which is not nearly as far along in the draft process, and whose
contents most of us have never seen.

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Sun, 10 Apr 2005 15:52:40 -0400

L.Gillam scripsit:

> 1. A "reference name" is for interoperability. The reference name for
> a language can be taken from that language, and need not be in either
> English or French, as I believe Peter was alluding to. I believe this to
> be the case with -3 and it's certainly intended for -6. 

ISO 639-3 reference names are English names (which may in many cases be
identical to native names, but only when there is no traditional English
name).  "French", "German", "Chinese" are so named.  This reflects 639-3's
inheritance from the Ethnologue.  Note also that many 639-3 languages
have no written form, and would have to have the names transcribed in
some system rather than simply written.

> 3. A code (e.g. alpha3 in 639-3) stands as synonymous with the reference
> name and as entry point into the "conceptual" entry - the mantra is
> "I don't care what you call it as long as we are referring to the
> same thing"

The code points to the name, but the name does not always unambiguously
point to the language.  In ISO 639-1/2 (which are unambiguously
mapped, so I treat them as one), there is the language coded "zh" or
"chi" or "zho" and named "Chinese" and "chinois".  But there is no
way of knowing whether that means:

1) Mandarin Chinese, a specific Sinitic language
2) The Sinitic languages as a collection
3) The languages called "Chinese" as a collection
4) A macrolanguage incorporating the Sinitic languages as components
5) A macrolanguage incorporating the languages called "Chinese" as components

ISO 639-3 takes position 5.

> ensuring -4 has necessary and sufficient coverage.

>From what I understand (I have not seen a draft), -4 will be conceptual
and introductory (-0, in other words, if ISO rules permitted a -0 part)
and will not provide coverage of anything.  Has this changed?

> ISO code lists already contain French and English names. If the registry
> identifies the code list and the code, does it really need to duplicate
> all the fields from this list? 

There is no evidence which name is the reference name, however.

-- 
John Cowan  [email-masked]  www.reutershealth.com  www.ccil.org/~cowan
This great college [Trinity], of this ancient university [Cambridge],
has seen some strange sights. It has seen Wordsworth drunk and Porson
sober. And here am I, a better poet than Porson, and a better scholar
than Wordsworth, somewhere betwixt and between.  --A.E. Housman