Subject: [Ltru] Re: [psg.com #875] should initial registry contents be made into an internet-draft?

From: "Doug Ewell" <[email-masked]>
Date: Thu, 7 Apr 2005 23:21:59 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

> Pro, something like RfC 4021 is nice.  If Doug somehow forces
> page footers below %% lines, and page headers above the next
> registry entry.  Please no big gap like 4021-3864.

It's a data file.  Record breaks are going to fall wherever they fall.
"48 lines per page" is completely orthogonal to this.

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "McDonald, Ira" <[email-masked]>
Date: Fri, 8 Apr 2005 14:58:21 -0700

Hi,

The point of the I-D (but not necessarily an RFC) for the
registry content is to get wider review of the registry
content by the IETF and computing community.

The ONLY time that the registry needs to / should be published
as an I-D is simultaneous with the Last Call of RFC3066bis.

But Doug could perfectly well publish a dated (in the filename) 
copy of the registry content that was identical to the reviewed 
I-D (and so claimed in the I-D).  That's essentially what IANA 
did with IANA Charset MIB (RFC 3808, one SNMP textual convention) 
when the RFC came out - took the clean registry (and the tool 
that machine-generates it from an updated plaintext IANA Charset 
registry) from the named archive.

Because of I-D format rules, publishing the registry in an I-D
also makes certain that there are no:
(a) overlength lines;
(b) non-ASCII characters (except as XML character references);
(c) tabs, or other extraneous layout characters.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Addison Phillips
> Sent: Friday, April 08, 2005 3:25 PM
> To: Randy Presuhn; LTRU Working Group
> Subject: RE: [Ltru] Re: [psg.com #875] should initial 
> registry contents
> bemade into an internet-draft?
> 
> 
> > As a contributor...
> > This approach misses the whole point of bothering to put the initial
> > content into an i-d, and is equivalent to the registry-00 
> proposal.  The
> > concern is about ensuring the integrity of whatever IANA is given a
> > pointer to, and that that initial content that is there when IANA
> > retrieves
> > it is what was approved by the WG.
> 
> Well, yes, that's what I'm saying. Putting page breaks into 
> the document to make it an I-D just to have IANA pluck them 
> out again seems like a waste of time.
> 
> I'm just bemused by the notion that somehow a document hosted 
> at a particular address (especially if it is handled like an 
> I-D) is somehow inferior to a document that *is* an I-D but 
> which IANA must muck around with to make a "clean" registry.
> 
> But since I don't make the registry, you can count me as "not 
> caring". Close the issue under whatever the consensus is. I 
> *only* care about text in the -01 draft. The content of the 
> registry is entirely driven by that anyway.
> 
> Addison
> 
> Addison P. Phillips
> Globalization Architect, Quest Software
> Chair, W3C Internationalization Core Working Group
> 
> Internationalization is not a feature.
> It is an architecture. 
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]] On
> > Behalf Of Randy Presuhn
> > Sent: vendredi 8 avril 2005 12:19
> > To: LTRU Working Group
> > Subject: Re: [Ltru] Re: [psg.com #875] should initial 
> registry contents
> > bemade into an internet-draft?
> > 
> > Hi -
> > 
> > > From: "Addison Phillips" <[email-masked]>
> > > To: "Doug Ewell" <[email-masked]>; "LTRU Working Group"
> > <[email-masked]>
> > > Sent: Friday, April 08, 2005 9:34 AM
> > > Subject: RE: [Ltru] Re: [psg.com #875] should initial 
> registry contents
> > bemadeinto an internet-draft?
> > 
> > (re-formatted so I can read it)
> > 
> > > I still fail to see how an I-D does anything useful.
> > > Putting the draft registry under some form of version control
> > > and making it available on the IETF website under 
> "internet-drafts"
> > > strikes me as sufficient.
> > > The I-D can be (copyrights and other legal matters 
> excluded) one line
> > long,
> > > containing the URI of the registry itself in a 
> non-rubbished format
> > suitable for actual publication.
> > >
> > > Here's what it could say:
> > >
> > > "The initial contents of the Language Subtag Registry 
> defined by RFC
> > 3066bis
> > > SHALL be the file at this location, subject to the 
> provisions in Section
> > 3.6 of RFC
> > > 3066bis:  
> <http://www.ietf.org/internet-drafts/where-the-registrations-
> > are>"
> > ...
> > 
> > As a contributor...
> > This approach misses the whole point of bothering to put the initial
> > content into an i-d, and is equivalent to the registry-00 
> proposal.  The
> > concern is about ensuring the integrity of whatever IANA is given a
> > pointer to, and that that initial content that is there when IANA
> > retrieves
> > it is what was approved by the WG.
> > 
> > Randy
> > 
> > 
> > 
> >