Subject: RE: [Ltru] Registry in RDF/XML format.

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 4 Apr 2005 13:13:34 -0700

Hi,

As long as the XML format registry is clearly labelled
'Informative' and only the one Record-Jar format registry
is labelled 'Normative' (and maintained by IANA), I'd be
happy to see an auxiliary XML format registry.

There are clearly numerous benefits to the XML registry.
One of them (the ability to use the full range of Unicode
characters) is one of the strongest arguments _against_
the XML format registry as the Normative one (because
it cannot be published in an initial registry RFC, which
has been customary with most other new IANA registries).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Addison Phillips
Sent: Monday, April 04, 2005 12:21 PM
To: Jon Hanna; LTRU Working Group
Subject: RE: [Ltru] Registry in RDF/XML format.

No, but you and I are currently the only supporters of it, so it is unlikely
to make the next draft. At this point I suspect that it could be defined in
a future draft as an ancillary format (to the official registry in
record-jar format).

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Jon Hanna
> Sent: dimanche 3 avril 2005 10:02
> To: 'LTRU Working Group'
> Subject: [Ltru] Registry in RDF/XML format.
> 
> Hi, I've only barely been able to keep up with this list of late due to
> other obligations, but is an RDF/XML format completely out of the
question?
> 
> Regards,
> Jon Hanna
> Work: <http://www.selkieweb.com/>
> Play: <http://www.hackcraft.net/>
> Chat: <irc://irc.freenode.net/selkie>
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 04 Apr 2005 23:22:59 +0200

McDonald, Ira wrote:

> the ability to use the full range of Unicode characters
[...]
> is one of the strongest arguments _against_ the XML format
> registry as the Normative one (because it cannot be published
> in an initial registry RFC

Appendix A - registry entries in XML format

<?xml version="1.1" encoding="US-ASCII" ?>
<!DOCTYPE ltru SYSTEM "http://www.iana.org/place/ltru.dtd">
<ltru date="2005-06-01">
   <language date="2005-06-01">
      <name xml:lang="ess-Cyrl">
        &#257;&#257;&#257;
      </name>
      <name xml:lang="ess-Latn">
        no idea what "ess" is ;-)
      </name>
      ...
   </language>
<!-- ignore RfC page header

LTRU                                                  page 104
                The language tag soup (STD 123)
-->
   <language date="2005-06-01">
   ...
   </language>
   <script date="2005-06-01">
   ...
   </script>
   ...
</ltru>

Sorry, I really don't see why XML is impossible in an RfC. :-(

                          Bye, Frank