Subject: RE: [Ltru] Re: John Cowan's substantive commentsondraft-ietf-ltru-registry-01

From: "Addison Phillips" <[email-masked]>
Date: Thu, 7 Apr 2005 11:24:40 -0700

See inline.

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: jeudi 7 avril 2005 10:58
> To: [email-masked]
> Subject: [Ltru] Re: John Cowan's substantive commentsondraft-ietf-ltru-
> registry-01
> 
> Addison Phillips wrote:
> 
>  [character references]
> > I don't care, but I strongly prefer entities that are regular
> > in form. The entity &#xc0; is less obviously a Unicode value
> > than the entity &#x00C0;
> 
> Let's use <http://www.w3.org/TR/charmod/#C042> up to C048.  It
> says "use hex." (C045, C048) and "one form" (C043). 
[Addison Phillips] 

Yes, of course. But that doesn't make any different here.

> We can use
> John's "no leading zeros" or your "4 or 6 digits", but we better
> don't allow both.
[Addison Phillips] 

Per general consensus so far, I changed the text to follow XML explicitly.
> 
> Your format is not very nice for cases like Réunion and Côte,
> and John's format is odd for an odd number of hex. digits.
> The syntax for your format would be somewhat simpler:
> 
>            hrc = "&#x" ( h4 / h5 / h6 ) ";"
>            h4  = hex hex hex hex
>            h5  = "0" hex h4
>            h6  = "10" h4
>            hex = DIGIT / "A" / "B" / "C" / "D" / "E" / "F"
> 
> Whatever we do, let's not encode ";" or other printable ASCII
> characters, unless it's "&" (&#x26; or &#x0026; resp.)
[Addison Phillips] 

The text now says:

<t>
Characters from outside the US-ASCII repertoire, as well as the following characters when they occur inside a value: ":" (%x3A), "&amp;" (%x26), "\" (%x5C), and "%" (%x25) are represented by a "Numeric Character Reference" using hexadecimal notation in the style used by <xref target="XML10.3e">XML 1.0</xref> (see <eref target="http://www.w3.org/TR/2004/REC-xml-20040204/#dt-charref"></eref>). This consists of the sequence "&amp;#x" (%x26%x23%x78) followed by a hexadecimal representation of the character's code point in <xref target="ISO10646">ISO/IEC 10646</xref> followed by a closing semicolon (%x3B). For example, the EURO SIGN, U+20AC, would be represented by the sequence "&amp;#x20AC;". Note that the hexadecimal notation may have between two and six digits.
</t>

I require these escapes:

  COLON (the name/value separator, can remove this, just being overly cautious)
  AMPERSAND (the escape character)
  REVERSE SOLIDUS (the continuation character; can remove if we go with the other continuation syntax)
  PERCENT SIGN (half of an end-of-record character as a courtesy to badly written parsers everywhere: this one can be junked)

> 
>  [Registration details]
> > 1. Should the email be obfuscated? (addison dot phillips at
> > quest dot com??)
> 
> Yes.
> 
> > 2. Should it be an (ASCII) URI? In other words, how should
> > IDN's be handled?
> 
> As specified in RfC 3987, or are you talking about Martin's
> mailto I-D ?  I vaguely recall some unanswered questions about
> the latter on the URI list.
[Addison Phillips] 

Yep.
> 
> > 3. Reference is a text field naming documents. Should there
> > be rules for naming URIs? What other restrictions apply?
> 
> Are angle brackets not good enough, or what is the problem ?
[Addison Phillips] 

RFC 3987 or RFC 3986? Angle brackets are good enough to indicate an IRI.
> 
> Just in case.  Actually I don't like the proposal to add all
> registration details to the registry.
> 

[Addison Phillips] 

Which would you put in and which leave out?

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Thu, 7 Apr 2005 15:01:50 -0400

>   PERCENT SIGN (half of an end-of-record character as a courtesy to badly written parsers everywhere: this one can be junked)

Junk all but the ampersand, I say.

-- 
John Cowan  [email-masked]  http://www.ccil.org/~cowan
O beautiful for patriot's dream that sees beyond the years
Thine alabaster cities gleam undimmed by human tears!
America! America!  God mend thine every flaw,
Confirm thy soul in self-control, thy liberty in law!
        -- one of the verses not usually taught in U.S. schools

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 07 Apr 2005 21:55:13 +0200

Addison Phillips wrote:

> I changed the text to follow XML explicitly.

Why do you use XML 1.0 3rd ed. instead of XML 1.1 ?  I'm only
curious, <http://www.w3.org/TR/xml11/#dt-charref> is apparently
the same as <http://www.w3.org/TR/REC-xml/#dt-charref> or your
<http://www.w3.org/TR/2004/REC-xml-20040204/#dt-charref>
                             
>   COLON (the name/value separator, can remove this

Get rid of it, header names and header bodies are separated by
the first colon in a (2)822 header field.

>   REVERSE SOLIDUS (the continuation character

Unnecessary for normal RfC 2822 folding (= FWS minus obs-FWS).

>   PERCENT SIGN (half of an end-of-record character as a
> courtesy to badly written parsers everywhere: this one can
> be junked)

Then junk it, &#x26; is enough.

>> mailto I-D ?  I vaguely recall some unanswered questions
>> about the latter on the URI list.
 
> Yep.

First part or second part ?  For the second part Martin is the
expert, I only asked him about some details in his mailto I-D.
And his Archived-At I-D, some problems to grok 3986 on my side.

> RFC 3987 or RFC 3986? Angle brackets are good enough to

If you'd want to enforce an URL you could say <URL:about:blank>
- but AFAiK that's never necessary for today's URLs, if you're
not trying to use some very obscure legacy ftp-URLs.  For 3987
it's simply IDNA + %-encoded UTF-8,  Sorry, I probably miss
your point. 

 [registration details] 
> Which would you put in and which leave out?

What Doug has plus an URL to the IANA registration file, e.g.
URI: <http://www.iana.org/assignments/lang-tags/i-klingon>

John said that this is only relevant for variants, therfore we
probably don't need relative URLs to compresss the registry.

                             Bye, Frank