Subject: RE: [Ltru] Great Script Debate Part II: Formats...

From: "Addison Phillips" <[email-masked]>
Date: Mon, 11 Apr 2005 15:58:45 -0700

Please note that the ABNF for lang is actually:

lang            = 2*3ALPHA           ; shortest ISO 639 code
                / registered-lang
registered-lang = 4*8ALPHA          ; registered language subtag

Which means that language subtags in the registry can be 2 to 8 characters long. Full stop. So the answer to your question, Debbie, is "yes, I can foresee possibly including alpha4 subtags from whatever source in the future." If ISO 639-6 were to be considered by some future iteration of this WG to be useful in language tags, then its codes can be placed in the registry making them valid for use. The rules in 3066bis make it exceedingly unlikely that very many, if any, alpha4 registered values will be there to get in the way.

(Personally, I'm with John's comments below, and would want to see it before deciding for myself if there is additional utility in these codes.)

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of John Cowan
> Sent: lundi 11 avril 2005 15:45
> To: Debbie Garside
> Cc: [email-masked]
> Subject: Re: [Ltru] Great Script Debate Part II: Formats...
> 
> Debbie Garside scripsit:
> 
> > Are you saying that, some time in the future, you could possibly foresee
> the
> > proposed 639-6 Alpha4 as the primary language tag?
> 
> Until we know more about 639-6, nobody can say.  From what I understand,
> 639-6 4-alpha tags encode language varieties, and one must make use of
> tables to learn how the language varieties are interrelated.  I don't
> know whether these external tables are a hierarchy or what.
> 
> Any information you can reveal would be extremely useful.
> 
> --
>                 Si hoc legere scis, nimium eruditionis habes.
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Debbie Garside" <[email-masked]>
Date: Tue, 12 Apr 2005 00:30:27 +0100

Thanks for clarifying :-)

I will keep you informed of any/new developments within the proposed ISO
639-6.

Kind regards

Debbie

> Addison wrote:
> Which means that language subtags in the registry can be 2 to 8 characters
> long. Full stop. So the answer to your question, Debbie, is "yes, I can
> foresee possibly including alpha4 subtags from whatever source in the
> future." If ISO 639-6 were to be considered by some future iteration of
> this WG to be useful in language tags, then its codes can be placed in the
> registry making them valid for use. The rules in 3066bis make it
> exceedingly unlikely that very many, if any, alpha4 registered values will
> be there to get in the way.
> 
> (Personally, I'm with John's comments below, and would want to see it
> before deciding for myself if there is additional utility in these codes.)
> 
> Addison
> 
> Addison P. Phillips