Subject: [Ltru] Re: hyphen-minus (was: new version posted online)

From: "Doug Ewell" <[email-masked]>
Date: Sat, 23 Apr 2005 14:10:48 -0700

Addison Phillips <addison dot phillips at quest dot com> wrote:

> If no one objects, I'll remove the restriction to Latin-1 from
> description. Variant registrations will be asked to provide a
> Description using or transcribed into the Latin script.

I don't object.  As a reminder, I've restricted the existing entries in
the draft registry to Latin-1 characters, and so far nobody has objected
to this.

The descriptions that appear in ISO standards, together with the
corresponding description in the registry, are as follows (warning:
UTF-8 ahead):

Hangul (Hangŭl, Hangeul) --> Hangul (Hangeul)
Ge‘ez --> Ge'ez
N’ko --> N'ko
Gwich´in --> Gwich'in

(The character replaced in the last example is actually in Latin-1, but
seems not to be the correct character for the purpose.)

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Sat, 23 Apr 2005 14:29:33 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

> | Example: one two  three
>
> Some obvious ways to fold this example are:
>
> | Example: one
> |  two  three
>
> | Example: one
> |  two
> |   three
>
> Now I use _ for SP in the same examples:
>
> | Example:_one
> | _two__three
>
> | Example:_one
> | _two
> | __three

These examples seem to imply that multiple spaces *are* preserved by
line folding, and thus the examples in Appendix C of the draft:

Comment: Use private use codes in preference
  to the x- singleton for primary language

are not correct since they use two spaces instead of one.  The draft
registry follows the examples in the draft, and also uses two spaces.
Does this need to be changed to a single space?  (I hope not, since I
find two spaces much more readable.)

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 24 Apr 2005 03:14:18 +0200

Doug Ewell wrote:
 
> As a reminder, I've restricted the existing entries in the
> draft registry to Latin-1 characters, and so far nobody has
> objected to this.

Not sure about Addison, but I certainly did, IMHO you or IANA
or the future tag reviewer shouldn't be forced to second guess
the "official" ISO sources.

 [pseudo-QP by me]
> Hangul (Hang=C5=ADl, Hangeul) --> Hangul (Hangeul)

please use &#x016D; LATIN SMALL LETTER U WITH BREVE

> Ge=E2=80=98ez --> Ge'ez

better use &#x2018; LEFT SINGLE QUOTATION MARK

> N=E2=80=99ko --> N'ko

better use &#x2019; RIGHT SINGLE QUOTATION MARK

> Gwich=C2=B4in --> Gwich'in

better use &#xB4; ACUTE ACCENT

> The character replaced in the last example is actually
> in Latin-1, but seems not to be the correct character
> for the purpose.

Excluding the "small u breve" all these examples appear
to be errors, let them fix it.
                              Bye, Frank

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 24 Apr 2005 03:36:38 +0200

Doug Ewell wrote:

> These examples seem to imply that multiple spaces *are*
> preserved by line folding

Not, that was only a simplification by me, because it didn't
matter.  In reality you'd match as much as possible against
FWS (or LWSP), and then you're free to replace _one_ maximal
FWS (or LWSP) by _one_ other FWS (or LWSP).

In the case with two adjacent spaces it was one FWS (or LWSP).

You could replace it by one other FWS, e.g. SP CRLF SP or
CRLF SP SP SP or CRLF SP, the important point is that it has
at most one CRLF, and at least one WSP, and if it has CRLF,
then it has at least one WSP after the CRLF.

For the LWSP case it's very similar, but you can have more
than one CRLF, each CRLF followed by at least one WSP.  And
that's the way how you could get "empty" lines with LWSP, a
line with one or more trailing spaces and nothing else.

> Does this need to be changed to a single space?

No.  You can use as much WSP as you like, but at least one.
In theory you could also use HT or SP SP SP SP SP SP SP SP -
but better stay away from horizontal TABs ;-)

> I find two spaces much more readable.

Yes, they are nice,  Sh*t, the new 2234bis doesn't follow its
own recommendation, it says LWSP = *(WSP / CRLF WSP) instead
of LWSP = *(WSP / (CRLF WSP))
                               Bye, Frank

---

From: "Doug Ewell" <[email-masked]>
Date: Sat, 23 Apr 2005 22:54:05 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

> Thanks.  How do you want to handle missing Suppress-Script
> entries ?  I risk to propose Latn for fy, li, and oc, but
> discussing this here could be messy.  A temporary list of
> languages known to have no or more than one script could
> help to fill the gaps.

Well, sure, and I could add other Latin-only languages like Corsican and
Hawaiian and Walloon.  I could also point out that yi (Yiddish) has a
Suppress-Script of Hebr, but its alias ji does not, even though other
canonical/alias pairs like id/in and he/iw (Hebrew) do have the
Suppress-Script for both subtags.

But that's one of the major problems with Suppress-Script.  The sets are
open-ended and subject to controversy, and there is no widely accepted
authority for this information.  Erkki Kolehmainen has also pointed out
that Moldavian (listed with a Suppress-Script of Latn) formerly used a
Cyrillic orthography.  Who is to say whether this usage is recent enough
to change the "default"?  What if the changeover had happened two years
ago?

To answer Frank's question, Suppress-Script entries are intended to be
added and removed via the registration process (see Section 3.3 of
draft-01).  During this initial development stage, we need to have some
type of reference work to point to, and a Real Process for additions and
deletions.  We can't just raise our hands and yell out "Add this!
Remove that!" as though we were at some sort of rural auction.  Notice I
didn't "silently" add the entries I mentioned in the first paragraph
above, even though I doubt anyone would argue with them.

---

From: James Cloos <[email-masked]>
Date: Mon, 25 Apr 2005 01:30:59 -0400

[SIGH, sent from wrong address; resending.... -JimC]

>>>>> "Frank" == Frank Ellermann <[email-masked]> writes:

Commenting just on the 10646 choices here, not on the use of 8859-1
in lieu of 10646....

>> Ge‘ez --> Ge'ez

Frank> better use &#x2018; LEFT SINGLE QUOTATION MARK

If that is a glottal stop, àla Hawaiʻian’s ʻokina, it should really
be U+02BB MODIFIER LETTER TURNED COMMA rather than U+2018.  Even if
not, is it still the case that U+02BB is a letter whereas U+2018 is
punctuation....

>> N’ko --> N'ko

Frank> better use &#x2019; RIGHT SINGLE QUOTATION MARK

Same argument as above, but using U+02BC MODIFIER LETTER APOSTROPHE
for Nʼko.

>> Gwich´in --> Gwich'in

Frank> better use &#xB4; ACUTE ACCENT

That one is confusing.  If you are going to use 10646 there must be
a better choice than a spacing acute accent....

8859-1 is probably better right now for interoperability.  If 10646
is used then every effort should be made to use the best characters
even if homographs may be easier to enter on many (most?) keyboards.

-JimC
-- 
James H. Cloos, Jr. <[email-masked]>

---

From: James Cloos <[email-masked]>
Date: Mon, 25 Apr 2005 01:27:11 -0400

-JimC

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 26 Apr 2005 05:35:32 +0200

James Cloos wrote:

> If 10646 is used then every effort should be made to use
> the best characters

The ISO sources use Unicode, they should fix what you noted.

If Doug or the tag reviewer try to patch descriptions found
in the official sources they'd be in a bad position.

Okay, they wouldn't try decode invalid UTF-8 encodings, so
there is some leeway, but IMHO replacing u+2018 / u+2019 by
your proposals u+2BB / u+2BC is the job of ISO.  Bye, Frank