Subject: [Ltru] Re: Proposed changes to region subtags

From: "Doug Ewell" <[email-masked]>
Date: Wed, 6 Apr 2005 07:11:58 -0700

I wrote:

> John Cowan +ADw-jcowan at reutershealth dot com+AD4- wrote:
>
> +AD4APg- We could reverse the slash to a backslash, Java-style...

I apologize profoundly for the UTF-7 garbage.

Misha Wolf <Misha dot Wolf at reuters dot com> wrote:

> Don't you mean:
>
>   Description: Occitan (post 1500)&#x003B; Proven&#x00E7;al
>
> or:
>
>   Description: Occitan (post 1500)&#x3B; Proven&#xE7;al
>
> ?

Yes, something like that.

Both of these errors were brought to you by the Need for Sleep.

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Wed, 6 Apr 2005 07:46:36 -0700

L.Gillam <L dot Gillam at surrey dot ac dot uk> wrote:

> Defaults + fallback = ?
>
> If "en" defaults to en-Latn, does en-Cyrl falls back to en and default
> to en-Latn. Is it better to receive en-Latn rather than "nothing" in
> response to en-Cyrl? What if more than one script is implicated by the
> 2 letter language code, there is a default, but the fallback should
> produce all available?
>
> What do people think is the best result from this combination?

If you request "en", that means you are willing to accept any English
(i.e. anything tagged "en" or derivatives).

If you request "en-Cyrl", you are specifically asking for
Cyrillic-script English.  I do not believe you should receive content
tagged "en-Latn" in response to such a request.

Adding the "default script" mechanism erases the distinction that was
deliberately made by the user who requested "en-Cyrl."

-Doug Ewell
 Fullerton, California