Subject: RE: [Ltru] Re: Moving Forward

From: "Peter Constable" <[email-masked]>
Date: Wed, 13 Apr 2005 16:00:36 -0700

> From: [email-masked] [mailto:[email-masked]]
On Behalf Of
> Addison Phillips

> How about:
> 
> Subtags which are not important for distinguishing content in an
application SHOULD
> NOT be used to form language tags. In particular, you MUST NOT use the
script
> subtag unless (a) the language subtag has an Expected_Script field  or
(b) the specific
> script distinction is important to the application. For example, the
tag "en-Latn-US"
> should be used exceedingly rarely since nearly all English texts are
written in the Latin
> script and it is generally not important to filter out those few that
are not, while
> documents that use the primary language subtag 'sr' (Serbian) must be
distinguished
> by the choice of Latin or Cyrillic script.

I'd change the last clause slightly: from

"... while documents that use the primary language subtag 'sr' (Serbian)
must be distinguished by the choice of Latin or Cyrillic script."

to

"... while documents that use the primary language subtag 'sr' (Serbian)
generally need to be distinguished by the choice of Latin or Cyrillic
script."

I wouldn't want to suggest that someone can't use something like 'sr' or
'sr-CS' if that suits their needs in a given application.

Peter Constable

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 13 Apr 2005 16:12:59 -0700

Agreed.

‎Mark

----- Original Message ----- 
From: "Peter Constable" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, April 13, 2005 16:00
Subject: RE: [Ltru] Re: Moving Forward

On Behalf Of

application SHOULD
script
(b) the specific
tag "en-Latn-US"
written in the Latin
are not, while
distinguished

to

Peter Constable