Subject: [Ltru] Re: Date of deprecation

From: "Doug Ewell" <[email-masked]>
Date: Tue, 5 Apr 2005 07:47:03 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

>> The registry *is* in alphabetic order, of course -- but by
>> subtag, not description.
>
> Sure, but at the moment it's in one file.  For 7000+ languages
> it might be better to have one file per tag, and an additional
> directory view sorted by date, not only by "filename" (= tag).
>
> Or maybe 26 A..Z files for the languages, plus another file for
> the rest (scripts, regions, variants, grandfathered entries).

OK, you switched directions on me.  I didn't read "an A..Z organization"
as a call to split the registry into multiple files.

>> we don't have this 7000+ problem until (a) ISO 639-3 comes
>> along and (b) we go through this process all over again to
>> incorporate support for it.
>
> One of our chairs proposed to prepare the LTRU registry as far
> as possible for this case.  IMHO a good idea, of course not for
> what you plan to publish tomorrow.

I missed something there.  Did Randy or Martin say something about
working on the registry itself?

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 05 Apr 2005 19:47:24 +0200

Doug Ewell wrote:

> Did Randy or Martin say something about working on the
> registry itself?

What I meant was Randy's (hat off) question in:

<news://news.gmane.org/000601c52dca$e1e126c0$7f1afea9@oemcomputer>
<http://article.gmane.org/gmane.ietf.ltru:140>

| If we already have a good idea how the ISO specifications
| will look, wouldn't it make sense to ensure that 3066bis
| works correctly for those cases, so we don't have to bother
| doing a 3066ter?

<news://news.gmane.org/000601c52dd8$94334120$7f1afea9@oemcomputer>
<http://article.gmane.org/gmane.ietf.ltru:146>

| I think it would be really nice if we could put in text now
| that would not need revision later.  It sounds like all that
| is needed is text that spells out precisely when using the
| macro-language code is required.

                         Bye, Frank