Subject: RE: [Ltru] Re: [psg.com #1034] Add region subtags 034 and 143, delete 062

From: "Addison Phillips" <[email-masked]>
Date: Tue, 21 Jun 2005 20:23:09 -0700

Date A/Date B rules apply, no? Thus, I'm with Doug here.　But only for that reason and not for any particular logical reason.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: 2005年6月21日 19:59
> To: LTRU Working Group
> Subject: Re: [Ltru] Re: [psg.com #1034] Add region subtags 034 and
> 143,delete 062
> 
> Martin Duerst <duerst at it dot aoyama dot ac dot jp> wrote:
> 
> > I agree with Doug (and Randy). Let's keep them all.
> 
> I wasn't actually arguing to keep them all.  My point was supposed to be
> that *any* two regions in the world, say Micronesia and Middle Africa,
> could potentially have what Randy posited -- a language that shows no
> variation between the two regions, such that a distinction in tagging
> would be pointless.  There's nothing special about 034 and 143 in this
> regard, except that they were formerly subsumed under the same UN region
> code (062).
> 
> But unlike alpha-2 codes, the numeric codes have never been valid in
> language tags, so there is no backward-compatibility reason to keep 062
> valid, as there is for, say, SU.
> 
> I'm opposed to keeping 062, but I won't put up a serious fight about it.
> There are better fights to be picked.
> 
> --
> Doug Ewell
> Fullerton, California
> http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 21 Jun 2005 21:15:20 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "Doug Ewell" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Tuesday, June 21, 2005 8:23 PM
> Subject: RE: [Ltru] Re: [psg.com #1034] Add region subtags 034 and 143,delete 062
>
> Date A/Date B rules apply, no? Thus, I'm with Doug here.
> But only for that reason and not for any particular logical reason.
...

I understand the need for Date A/Date B rules where there has been or might be
re-use of codes.  Are we assuming that UN M.49 will have the same problems?

Randy

---

From: "Mark Davis" <[email-masked]>
Date: Tue, 21 Jun 2005 22:33:41 -0700

The advantage of the way the UN works (as opposed to the iso codes) is that
that they introduce new codes instead of giving old codes new meaning. So we
don't have the same compatibility issues.

The only issue that we had is what to have in the first release; it's not
really a problem.

‎Mark

----- Original Message ----- 
From: "Randy Presuhn" <[email-masked]>
To: "LTRU Working Group" <[email-masked]>
Sent: Tuesday, June 21, 2005 21:15
Subject: Re: [Ltru] [psg.com #1034] Add region subtags 034 and 143, delete
062

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 22 Jun 2005 17:03:56 +0200

Randy Presuhn wrote:
 
> Are we assuming that UN M.49 will have the same problems?

It's no big LTRU-problem if it's limited to macro-regions.
OTOH it's not related to tectonics (003, 062, 830).  

CY and GE as Western Asia are somewhat dubious.  The most
useful macro-code is es-419, otherwise I'd propose to delete
the macro-region codes, who on earth needs 001 ?  Bye, Frank

P.S., okay, tlh-001, because most of tlh would be elsewhere.

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 22 Jun 2005 10:45:16 -0700

Hi -

> From: "Frank Ellermann" <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, June 22, 2005 8:03 AM
> Subject: [Ltru] Re: [psg.com #1034] Add region subtags 034 and 143,delete 062
>
> Randy Presuhn wrote:
>

I guess what I'm having trouble understanding is this:
(1) What is the value of deleting UN M.49 codes?
(2) If there is no particular benefit dervied from deletions, why bother?
(3) If we delete one, and, in the future, someone discovers they need it,
how will it be restored?
(4) If a mechanism to handle (3) is in place, then why don't we simply start
with an empty list, rather than fretting over these cases one-by-one?

Randy

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 22 Jun 2005 22:44:30 +0200

> (1) What is the value of deleting UN M.49 codes?

They're not deleted in the tag registry, once in (reflecting
the "valid at date-B" state), forever in.  If they'd delete
e.g. 419 after date-B it won't affect valid es-419 tags.

Many possible reasons why they might want to reorganize their
macro-regions, as we have seen for the old 003, 062, and 830.

> (2) If there is no particular benefit dervied from deletions,

Because the draft says so.  Nobody is interested in obsolete
UN macro-region numbers for say the former SU excl. EE/LT/LV,
we even have a (deprecated) SU for those who think to need it.

> (3) If we delete one, and, in the future, someone discovers
>     they need it, how will it be restored?

Only valid codes are added, as specified.  There's no "but I
need the obsolete 003, 200, 830, whatever" rule in the draft.

All is well, only the date-B state changes, and that's how we
wanted it instead of an old 2005-01-01 UN M.49 snapshot.  Bye