Subject: RE: [Ltru] Confusing conformance language

From: "McDonald, Ira" <[email-masked]>
Date: Thu, 9 Jun 2005 08:00:42 -0700

Hi Addison,

Then I guess you have your AD's clear direction to content with.
I see nothing wrong with word substitution to avoid lowercase
must (almost never needed) or should (a mere convention to use
this verb).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Addison Phillips
> Sent: Thursday, June 09, 2005 9:42 AM
> To: Randy Presuhn; [email-masked]
> Subject: RE: [Ltru] Confusing conformance language
> 
> 
> Some of the changes to normative language turn out to be 
> natural (we really meant to be normative). Other changes (to 
> avoid using the lowercase) required either an extensive 
> rewrite or the need for word substitution (silly).
> 
> Should and must were relatively easy. "May" is downright 
> impossible, since that word can be used in more than one way...
> 
> Addison
> 
> Addison P. Phillips
> Globalization Architect, Quest Software
> Chair, W3C Internationalization Core Working Group
> 
> Internationalization is not a feature.
> It is an architecture. 
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]] On
> > Behalf Of Randy Presuhn
> > Sent: 2005?6?8? 21:16
> > To: [email-masked]
> > Subject: Re: [Ltru] Confusing conformance language
> > 
> > Hi -
> > 
> > > From: "McDonald, Ira" <[email-masked]>
> > > To: <[email-masked]>
> > > Sent: Wednesday, June 08, 2005 8:41 AM
> > > Subject: [Ltru] Confusing conformance language
> > ...
> > > Randy - do you have an opinion here?
> > ...
> > 
> > In the spirit of "be liberal in what you accept", I don't mind a
> > lowercase "should" or "must" when they would the most natural
> > way of saying something.  After all, the whole point of writing
> > the words as "SHOULD" and "MUST" is to distinguish them as
> > having their special standards-speak meanings.
> > 
> > Having said that, I think that in keeping with the 
> principle of being
> > "conservative in what you send", it is good to avoid the lower-case
> > ones as much as is practical.
> > 
> > Since our AD has a preference, and the editors are willing, the
> > choice is simple.  :-)
> > 
> > Randy
> > 
> > 
> > 
> > 
> > _______________________________________________
> > Ltru mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ltru
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Scott Hollenbeck" <[email-masked]>
Date: Thu, 9 Jun 2005 11:15:48 -0400

One of the reasons this gets confusing is because RFC 2119 is somewhat
unspecific on the topic.  It says this in the abstract:

"These words are often capitalized."

but it doesn't say anything about distinguishing the lower case forms from
the upper case forms.  In my mind, this leads to confusion when a document
mixes the two forms.  Is a "should" the same as a 2119 "SHOULD"?  *I* think
the intent is that they are to be interpreted in the same way, but I know
that others believe that protocol directives need to be capitalized.
They're certainly more obvious if capitalized.

I believe it best to use one form consistently, even if that means using
synonyms in places.

-Scott-

> From: McDonald, Ira [mailto:[email-masked]] 
> Sent: Thursday, June 09, 2005 11:01 AM
> To: 'Addison Phillips'; Randy Presuhn; [email-masked]

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 09 Jun 2005 19:01:01 +0200

Scott Hollenbeck wrote:

> RFC 2119 is somewhat unspecific on the topic.  It says this
> in the abstract:

> but it doesn't say anything about distinguishing the lower
> case forms from the upper case forms.  In my mind, this leads
> to confusion when a document mixes the two forms.

I'm not confused, lower case isn't a 2119 keyword.  Or rather I
_wasn't_ confused until Ira and you started.  There are quite a
lot of lower case "must", "required", and "should" in RFC 2119.

You're not trying to overrule Bruce Lilly, or are you ?  The
last time it took you, Bill, Dave, Ned, and Brian.  And then
you still approved his informational RfC clearly saying "2234"
instead of "2234bis".  Gotcha... ;-)
                                     Bye, Frank