Subject: RE: [Ltru] [psg.com #1018] Add Macro-Language field

From: "Addison Phillips" <[email-masked]>
Date: Wed, 1 Jun 2005 15:44:24 -0700

'Required-Prefix', as a name, is more extensible than 'Macrolanguage' is. It has a clear semantic relationship to 'Recommended-Prefix' (playing MUST to recommended's SHOULD).

NB> Here is the description of Recommended-Prefix in draft-02:

--
Recommended-Prefix

    * Recommended-Prefix's field-value contains a language tag with which this subtag may be used to form a new language tag, perhaps with other subtags as well. This field MUST only appear in records whose 'Type' field-value is 'variant' or 'extlang'. For example, the 'Recommended-Prefix' for the variant 'scouse' is 'en', meaning that the tags "en-scouse" and "en-GB-scouse" might be appropriate while the tag "is-scouse" is not.
--

There is the question of whether this kind of semantic wordplay makes sense at all. The reasoning behind having the weaker Recommended-Prefix to begin with was that any subtag could be used to form a tag generatively, but only some possible generative tags have a sensible meaning.

There is a certain parsimony is having just one type of prefix field and making it both general and normative. Validating processors are required to pay attention to it. Well-formed processors are not required to pay attention to it. Users certainly should pay attention to it when selecting language tags.

Or, to say it simply, can't we solve this by replacing the field name Recommended-Prefix with Required-Prefix? 3066ter can document that extlangs use this to indicate their enclosing macrolanguage (3066bis can document this as an intention).

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of McDonald, Ira
> Sent: mercredi 1 juin 2005 14:59
> To: [email-masked]
> Subject: RE: [Ltru] [psg.com #1018] Add Macro-Language field
> 
> Hi,
> 
> 'Required-Prefix' is better future-proofing.  But if we're
> _sure_ that it only affects the macrolanguage issue, then
> we could use 'Macrolanguage' (except it's confusing if there
> do turn out to be more levels of nesting - yuck!).
> 
> Cheers,
> - Ira
> 
> Ira McDonald (Musician / Software Architect)
> Blue Roof Music / High North Inc
> PO Box 221  Grand Marais, MI  49839
> phone: +1-906-494-2434
> email: [email-masked]
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On
> > Behalf Of Randy Presuhn
> > Sent: Wednesday, June 01, 2005 5:29 PM
> > To: [email-masked]
> > Subject: Re: [Ltru] [psg.com #1018] Add Macro-Language field
> >
> >
> > Hi -
> >
> > > From: "John Cowan" <[email-masked]>
> > > To: "Randy Presuhn" <[email-masked]>
> > > Cc: <[email-masked]>
> > > Sent: Wednesday, June 01, 2005 2:14 PM
> > > Subject: Re: [Ltru] [psg.com #1018] Add Macro-Language field
> > ...
> > > I understood that they were exactly the same except for the
> > actual fieldname.
> > > I am quite happy to switch from Required-Prefix to Macrolanguage.
> > ...
> >
> > I understood "Required-Prefix" as being more general than
> > "Macro-Language", but I could have completely missed the point.
> >
> > Randy
> >
> >
> >
> >
> > _______________________________________________
> > Ltru mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ltru
> >
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Wed, 1 Jun 2005 22:14:54 -0400

Addison Phillips scripsit:

> Or, to say it simply, can't we solve this by replacing the field name
> Recommended-Prefix with Required-Prefix? 3066ter can document that
> extlangs use this to indicate their enclosing macrolanguage (3066bis
> can document this as an intention).

I'm afraid not.  A variant subtag may be sensible with different prefixes.
An extlang subtag isn't: it goes with exactly one language subtag, period.

-- 
Where the wombat has walked,            John Cowan <[email-masked]>
it will inevitably walk again.          http://www.ccil.org/~cowan