Subject: RE: [Ltru] Re: draft-ietf-ltru-matching-02

From: "Addison Phillips" <[email-masked]>
Date: Mon, 13 Jun 2005 19:49:22 -0700

I think this fails to capture it. What you want is for sequential subtags (extlang and variant) to end in either a concrete tag or a "*". That is, you cannot say "es-Latn-US-*-scouse", but you can say "en-Latn-US-scouse-*". Otherwise certain matching schemes don't work right.

Same for extlangs. In fact, extlangs don't make any sense if you give xx-*-yyy (yyy has to have a very specific prefix, so you have to specify it).

Thus:

Lang = 2*8(ALPHA) / extlang / "*"
Extlang = 0*2("-" 3ALPHA) ["-" 3ALPHA / "*"]

Slightly icky, but essentially correct. I include the "0" here for illustration (it won't appear in the actual ABNF).

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: 2005?6?13? 19:34
> To: [email-masked]
> Subject: [Ltru] Re: draft-ietf-ltru-matching-02
> 
> John.Cowan wrote:
> 
> >> lng-exa-*-exc-Latn can't be what you really want
> [...]
> > No, it isn't:
> > we want * or lng-* or lng-exa-* or lng-exa-exb-*.
> 
> Okay, then let's try to fix it:
> 
>    lang    = ( 2*8ALPHA *3( "-" extlang ) ) / "*" /
>              ( 2*8ALPHA *2( "-" extlang ) "-*" )
>    extlang = 3ALPHA
> 
> => "Bill's ABNF Parser  No errors during parsing."
> 
> ------------------------------------------------------------
> Mark, I've no fresh ideas for the registry draft, my issues
> with 831...833 are already posted here, please read and / or
> answer these posts.  I don't find issues in the proper order
> of priority, and of course I know that the registry draft is
> more important.  So far only Peter and Randy commented, they
> apparently agree that "something" is still odd in draft -04.
> 
> Doug apparently agreed that "frozen" Preferred-Values aren't
> optimal, and he found various minor nits around this issue.
> 
>                       Bye, Frank
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 14 Jun 2005 05:35:07 +0200

> Slightly icky, but essentially correct

Okay, that will be clearer and better than my idea, but it's
apparently not yet correct, how about this:

extlang = *2("-" 3ALPHA) ["-" ( 3ALPHA / "*" )]

You want "-*" at the end, not only "*" as in lng-exa-exb*

                          Bye, Frank