Subject: [Ltru] Re: no linguistic content tag

From: [email-masked]
Date: Wed, 15 Jun 2005 13:25:43 -0700

Why on earth would you want to categorize instrumental music against a 
list of languages?  I must be missing something.

Karen Broome
Metadata Systems Designer
Sony Pictures Entertainment
310.244.4384

"John.Cowan" <[email-masked]>
Sent by: [email-masked]
06/15/2005 01:08 PM

        To:     Addison Phillips <[email-masked]>
        cc:     [email-masked]
        Subject:        Re: no linguistic content tag (was RE: Mandarin Chinese,        Simplified 
Script)

Addison Phillips scripsit:

> I'm not sure I like the idea. The empty tag, while not quite the
> same level of declaration, implies this well-enough. We already have
> troublesome codes like MUL and UND. A "NOT" code would represent Yet
> Another Special Code. I like the empty tag much more for a situation
> like this.

The empty string is not actually a valid tag in RFC 3066.  It is a legal
value for xml:lang, but with different semantics: it means that no 
declaration
is being made about the language of an element.  So we have three related
things here:

xml:lang="": may or may not be linguistic content
xml:lang="und": definitely linguistic content, language unknown
xml:lang="xnl" (proposed): non-linguistic content

> "Information items" that contain natural language generally
> should be separate from non-language bearing items.

See my previous posting.  I think the case of instrumental-music 
recordings
is particularly compelling.

-- 
Overhead, without any fuss, the stars were going out.
        --Arthur C. Clarke, "The Nine Billion Names of God"
                John Cowan <[email-masked]>
_______________________________________________
Ietf-languages mailing list
[email-masked]
http://www.alvestrand.no/mailman/listinfo/ietf-languages

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "John.Cowan" <[email-masked]>
Date: Wed, 15 Jun 2005 16:48:39 -0400

> list of languages?  I must be missing something.

IThe idea is that I (notionally) want to use RFC 3066 tags to categorize
my record albums, sung and spoken, according to what language they are in.
Most of my albums are in en, but I do have a few in de and one in he,
as well as a few more in mul.  But if xnl meant "no language", I could
take all the instrumental-only albums and tag them xnl.

If you want to continue, we should take this to ietf-languages.

-- 
Newbies always ask:                             John Cowan
  "Elements or attributes?                      http://www.ccil.org/~cowan
Which will serve me best?"                      http://www.reutershealth.com
  Those who know roar like lions;               [email-masked]
  Wise hackers smile like tigers.                   --a tanka, or extended haiku