Subject: [Ltru] FW: tags for written or spoken content, was Swiss german, spoken

From: "McDonald, Ira" <[email-masked]>
Date: Sun, 12 Jun 2005 10:14:11 -0700

Hi,

Many people may have seen this note from Tex Texin to the
IETF Languages list, but I cross-post it here, because it
points out a fundamental IETF last call vulnerability for
the Language Subtag Registry, to whit, that the _entire_
justification for shoehorning 'script' between 'language'
and 'region' is the overwhelming focus on traditional
uses of language tags for _written_ content.

The entire (unloved) "Suppress-Script" stuff attempts to
minimize the damage in the real world (now and in the 
indefinite future) of the 'script' interloper.

A much cleaner solution remains to push 'script' back where
it belongs in medium-neutral language tags --> after the
'region' code.

And I think that bending 'script' to include spoken (as
Randy speculated somewhere recently?) is just awful.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Tex Texin
Sent: Saturday, June 11, 2005 8:44 PM
To: Michael Everson
Cc: [email-masked]
Subject: tags for written or spoken content, was Swiss german, spoken

Michael Everson wrote:

> The tags with we are concerned assume some sort of orthography.

Well, the tendency has been to associate tags with writing since so much
of computer content is written, and so it is mostly written material
that software developers tag.

However, rfc 3066 says: 

"The language tag always defines a language as spoken (or written,
signed or otherwise signaled) by human beings for communication of
information to other human beings."

so orthography is not a requirement and in fact, this tendency to
(incorrectly I believe) presume writing, is one of the reasons I
objected to "script" being placed between language and region in
3066bis. As we tag more multimedia, the emphasis on writing is falsely
placed. Unless we want to have a separate tagging system for audio...

tex
_______________________________________________
Ietf-languages mailing list
[email-masked]
http://www.alvestrand.no/mailman/listinfo/ietf-languages

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 12 Jun 2005 23:00:03 +0200

McDonald, Ira wrote:

> IETF Languages list

Yes.

> the _entire_ justification for shoehorning 'script' between
> 'language' and 'region' is the overwhelming focus on
> traditional uses of language tags for _written_ content.

No, I don't think that that's a correct description of the
"entire justification", it meshes two independet aspects.

For written content we need the script, only the language is
not good enough.  So we either need something like Bruce's
Content-Script, or where that's no option we try to add it to
the existing language tag.

If we do the latter we could add it in theory everywhere, in
position 1, 2, 3, or at the end of a language tag.

Each way has its advantages and disadvantages wrt matching
and backwards compatibility.  E.g. if we'd add the script in
the first position it's guaranteed to be incompatible with
all 3066-applications, that might actually be a good thing.

If we decide to add it elsewhere I fail to see any advantage
of the 3rd position (between region and variant).  So we take
either the last or the 2nd position.

If we assume that LTR matching and RTL truncation is the most
natural way to process tags, the 2nd position is probably the
best choice (in relation to 3rd / last position).

 From my POV it's not necessarily better than the other ideas,
1st position or no script at all in language tags.

> it belongs in medium-neutral language tags --> after the

That's the 3rd or last position,  I don't see any advantage
of the 3rd position, en-Latn-US-boont or en-US-Latn-boont are
both ugly.  Maybe en-US-boont-Latn would be a good idea.

But actually the region codes were already a dubious idea.
If I could just start from scratch I'd kill them - if the
region is important register it as variant.

A less radical idea would be "either region or variant, but
never both at the same time".  Then we'd probably discuss a
language-( region / variant )-script scheme.

My point is, the new "unloved script" isn't the real problem.
The real problem is the legacy region.  And we're damned to
keep it - without looking into the LTRU charter I fear that's
what it says.
                          Bye, Frank

---

From: "Mark Davis" <[email-masked]>
Date: Sun, 12 Jun 2005 15:02:35 -0700

1. I'll forward a message I sent to the languages group. As far as I am
concerned, we already have a tag for unwritten language contents, using Zxxx
as the script.

2. This is no reason whatsoever to rehash the long-settled issue of where to
have the script code.

‎Mark

----- Original Message ----- 
From: "McDonald, Ira" <[email-masked]>
To: <[email-masked]>
Sent: Sunday, June 12, 2005 10:14
Subject: [Ltru] FW: tags for written or spoken content, was Swiss
german,spoken

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 13 Jun 2005 14:32:52 -0700

Hi -

As co-chair:

For now, rather than treating this as a re-opening of issue #999,
let's handle this in the context of #1033.  If we find that whatever
our resolution for #1033 requires us to revisit issue #999, we can
do so then.  Given the amount of discussion that this question
engendered on the ietf-languages list, I want to make sure that as
a WG we are comfortable with our resolution of #1033.  Furthermore,
given the pain and anguish needed to get to a rough consensus on
#999, I do not want to re-open it unless it turns out our underlying
assumptions were seriously flawed.  So let's hash out #1033, and
then see whether we really need to re-open #999.

Randy, ltru co-chair

> Sent: Sunday, June 12, 2005 10:14 AM
> Subject: [Ltru] FW: tags for written or spoken content, was Swiss german,spoken
>
> Hi,
>