Subject: RE: [Ltru] matching submitted again...

From: "Addison Phillips" <[email-masked]>
Date: Tue, 28 Jun 2005 16:07:09 -0700

::sigh::

Those tags are registered in the RFC 3066 registry explicitly. What the RFC 3066 registry actually says is:

   zh-Hans-CN   PRC Mainland Chinese in simplified script  [Davis]

The description of zh-Hans-CN in the matching and registry documents NOWHERE say Mandarin or Cantonese or anything of the sort nor imply anything about spoken language dialects and the like.

There is quite an involved thread showing the distinctions of the regional variations from the script variations and NOT involving dialects of Chinese in the ietf-languages thread related to the registration of these values. Great care was exercised in writing the drafts so as not to incorrectly imply anything about the value of one or another combination of subtags. Please read the drafts carefully on this point.

Spoken variation and written variation in Chinese are known problem cases. The introduction of script subtags rescued applications from having to use a particular region subtag (like 'TW') to imply the script (a bad policy that: implying one attribute from an unrelated attribute). I don't think I need to spell out the political problems here. Suffice it to say that there are at least four interesting ISO 3166 region codes that can be combined with 'zh', some of which are part of the PRC (like HK) and some of which are not (like SG). The differences among these do not stop with script and thus some people felt the need to register the various tags combining both.

Furthermore, RFC 3066bis, like RFC 3066 before it, features a *generative* syntax which allows subtags to be combined in a variety of ways, not all of which make sense. Thus the tags presented in the matching draft will be valid tags even if they are not best practice and rarely used. However, I suspect that for written content tags of this nature will not be uncommon. Additional work to indicate spoken dialects--which also affect word choice in written texts and would use tags such as zh-cmn-* --will also be useful.

Regards,

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Dienstag, 28. Juni 2005 15:26
> To: Addison Phillips
> Cc: LTRU Working Group
> Subject: Re: [Ltru] matching submitted again...
> 
> Did I miss last call? Forgive me if this is a rushed e-mail.
> 
> There are references to zh-Hant-TW, etc., throughout the document. I think
> it directly references zh-Hans-CN as well.  I don't think the zh-Hans-CN
> tag should be considered a best practice because the region type is in
> many ways making the same distinction as the orthography type.
> 
> I think the best practice for Simplified Chinese in China should be to
> specify Mandarin or Cantonese explicitly along with Hant or Hans if
> written. The description of the zh-Hans-CN tag indicates Mandarin, though
> none of its building blocks make this specification. This is why I
> registered zh-cmn-Hant and zh-cmn-Hans.
> 
> Karen Broome
> Metadata Systems Designer
> Sony Pictures Entertainment
> 310.244.4384
> 
> 
> 
> 
> "Addison Phillips" <[email-masked]>
> Sent by: [email-masked]
> 06/28/2005 03:16 PM
> 
> 
>         To:     "LTRU Working Group" <[email-masked]>
>         cc:
>         Subject:        [Ltru] matching submitted again...
> 
> 
> I have just submitted an updated copy of the matching draft in which I
> removed the references from the abstract, switched to symrefs, and did one
> or two other housekeeping chores to stay in sync with developments in the
> other drafts.
> 
> Addison
> 
> Addison P. Phillips
> Globalization Architect, Quest Software
> http://www.quest.com
> 
> Chair, W3C Internationalization Core Working Group
> http://www.w3.org/International
> 
> Internationalization is not a feature.
> It is an architecture.
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 
> 
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 29 Jun 2005 01:53:53 +0200

Addison Phillips wrote:

> Suffice it to say that there are at least four interesting
> ISO 3166 region codes that can be combined with 'zh',

at least four
four, some say five,
about four
four or even more
various
several

Yes, "at least four" is the most accurate version... ;-)  Bye