Subject: [Ltru] changes to deal with UN M.49 (#1026?)

From: "Addison Phillips" <[email-masked]>
Date: Wed, 15 Jun 2005 15:42:22 -0700

All,

Based on my suggestion that we forbid UN M.49 codes except for the by-rule registrations, I made the following changes in the draft:

(in 2.2.4 "Region")

<t>All other UN numeric codes for countries or areas which do not have an associated ISO 3166 MUST NOT be entered into the registry and MUST NOT be used to form language tags. For more information about these codes, see <xref target="ianastability"></xref>.</t>

(in 3.3 "Stability")

<t>For ISO 3166 codes, if the newly assigned code's meaning is associated with a UN M.49 code that is not represented by an existing region subtag, then the Language Subtag Reviewer, as described in <xref target="registrationProc"/>, SHALL prepare a proposal for entering the appropriate UN M.49 country code as an entry in the IANA registry. </t>

<t>Codes assigned by UN M.49 to countries or areas (as opposed to geographical regions and sub-regions) for which there is no corresponding ISO 3166 code MUST NOT be registered, except under the previous provision. If it is necessary to identify a region for which only a UN M.49 code exists in language tags, then the registration authority for ISO 3166 SHOULD be petitioned to assign a code, which can then be registered for use in language tags. At the time this document was written, there were only four such codes: 830 (Channel Islands), 831 (Guernsey), 832 (Jersey), and 833 (Isle of Man). This rule exists so that UN M.49 codes remain available as the value of last resort in cases where ISO 3166 reassigns a deprecated value in the registry.</t>

---

See the newly posted editor's copy.

Randy: what's left? I show #944 and #1026 addressed by the editor's copy. This leaves #1033 (Written Spoken Signed)?

If we can close that we could (with the co-chair's approval) prepare an LC version. In any event, I will be submitting draft-05 tonight.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
http://www.quest.com

Chair, W3C Internationalization Core Working Group
http://www.w3.org/International

Internationalization is not a feature.
It is an architecture. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Peter Constable" <[email-masked]>
Date: Wed, 15 Jun 2005 15:49:32 -0700

Typo: change

‎"...which do not have an associated ISO 3166 MUST NOT..."‎

to

"...which do not have an associated ISO 3166 two-letter code MUST NOT..."  (or "numeric code"? "code"?)

Peter

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Addison Phillips
> Sent: Wednesday, June 15, 2005 3:42 PM
> To: [email-masked]
> Subject: [Ltru] changes to deal with UN M.49 (#1026?)
> 
> All,
> 
> Based on my suggestion that we forbid UN M.49 codes except for the by-rule
> registrations, I made the following changes in the draft:
> 
> (in 2.2.4 "Region")
> 
> <t>All other UN numeric codes for countries or areas which do not have an associated
> ISO 3166 MUST NOT be entered into the registry and MUST NOT be used to form
> language tags. For more information about these codes, see <xref
> target="ianastability"></xref>.</t>
> 
> (in 3.3 "Stability")
> 
> <t>For ISO 3166 codes, if the newly assigned code's meaning is associated with a UN
> M.49 code that is not represented by an existing region subtag, then the Language
> Subtag Reviewer, as described in <xref target="registrationProc"/>, SHALL prepare a
> proposal for entering the appropriate UN M.49 country code as an entry in the IANA
> registry. </t>
> 
> <t>Codes assigned by UN M.49 to countries or areas (as opposed to geographical
> regions and sub-regions) for which there is no corresponding ISO 3166 code MUST
> NOT be registered, except under the previous provision. If it is necessary to identify a
> region for which only a UN M.49 code exists in language tags, then the registration
> authority for ISO 3166 SHOULD be petitioned to assign a code, which can then be
> registered for use in language tags. At the time this document was written, there were
> only four such codes: 830 (Channel Islands), 831 (Guernsey), 832 (Jersey), and 833
> (Isle of Man). This rule exists so that UN M.49 codes remain available as the value of
> last resort in cases where ISO 3166 reassigns a deprecated value in the registry.</t>
> 
> ---
> 
> If we can close that we could (with the co-chair's approval) prepare an LC version. In
> any event, I will be submitting draft-05 tonight.
> 
> Addison
> 
> Addison P. Phillips