Subject: RE: [Ltru] [psg.com #968] load on IANA server by applications

From: "Addison Phillips" <[email-masked]>
Date: Tue, 7 Jun 2005 08:03:30 -0700

Let me add: the first SHALL looks somewhat too MUSTardized. Perhaps:

> > <t>
> > Although the registry defined here is available over the
> > Internet, implementations MUST NOT depend upon it always being
> > accessible.  It is intended to be used as a resource for application
> > developers, rather than for the applications themselves.  Due
> > to obvious scalability concerns, automated access to the registry
> > by applications is NOT RECOMMENDED.
> > </t>

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Mark Davis
> Sent: 2005年6月7日 7:39
> To: Randy Presuhn; LTRU Working Group
> Subject: Re: [Ltru] [psg.com #968] load on IANA server by applications
> 
> I don't really see the need for the stronger statement, but I have no
> objection to it either.
> 
> ‎Mark
> 
> ----- Original Message -----
> From: "Randy Presuhn" <[email-masked]>
> To: "LTRU Working Group" <[email-masked]>
> Sent: Monday, June 06, 2005 23:22
> Subject: Re: [Ltru] [psg.com #968] load on IANA server by applications
> 
> 
> > Hi -
> >
> > The -03 draft says in its security considerations section:
> >
> >    Although the specification of valid subtags for an extension (see:
> >    Section 3.6) MUST be available over the Internet, implementations
> >    SHOULD NOT mechanically depend on it being always accessible, to
> >    prevent denial-of-service attacks.
> >
> > Although registry specifications don't typically talk about this
> > kind of thing, since we've already stepped into this tarpit we
> > should make our intent clear.  As a technical contributor, I propose
> > replacing this paragraph with:
> >
> > <t>
> > Although the registry defined here SHALL be available over the
> > Internet, implementations MUST NOT depend upon it always being
> > accessible.  It is intended to be used as a resource for application
> > developers, rather than for the applications themselves.  Due
> > to obvious scalability concerns, automated access to the registry
> > by applications is NOT RECOMMENDED.
> > </t>
> >
> > One could write this same thing about almost all of the other registries
> > maintained by IANA, but, since the issue was raised in the WG,
> > I'd like to ensure that we address it.
> >
> > Randy
> >
> >
> >
> >
> > _______________________________________________
> > Ltru mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ltru
> >
> >
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 7 Jun 2005 11:33:43 -0700

Hi -

Since we seem to have agreement on the thrust of the text,
I'll mark this item "resolved".

(I slightly prefer the SHALL form, but the difference doesn't
seem consequential in this case, so I'd be happy leaving it
to the editors' good judegement.)

Randy, ltru co-chair