Subject: RE: [Ltru] Re: [psg.com #944] MAY a conformant implementation imposelength constraints?

From: "Addison Phillips" <[email-masked]>
Date: Wed, 1 Jun 2005 13:04:32 -0700

Agreed, but for RFC 3066bis, in which no extlangs are defined, the idea of finding two is most perverse :-).

I tend to think that two extlangs is going to be an edge case and three borders on outright pedantry (a language enclosed by a language enclosed by a language enclosed by a language, but it isn't a variant; for example a dialect of a dialect of, say, Mandarin Chinese). Once one is talking about that language, the idea that script, region, and *two* variants are also required is, shall we say, extreme.

The recommended buffer limit of 64 is long enough to take three extlangs (62 characters up from my example of 58). 

Yes, a longer tag is possible per the ABNF, but practically speaking no such tags will exist (and users who choose them probably OUGHT to have them truncated).

If we're going to write in a limit (as it looks like we will), perhaps one that fits the length considerations section makes more sense. I don't like the idea of making the limit 65 characters (four extlangs). Question is: can we live with "just" three? I think we can.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: mercredi 1 juin 2005 12:32
> To: [email-masked]
> Subject: [Ltru] Re: [psg.com #944] MAY a conformant implementation
> imposelength constraints?
> 
> Addison Phillips wrote:
> 
> > Okay, here's what I'm doing:
> 
> I like the general direction, but "most perverse tag" is a bit
> strange for a technical document.  Especially if that's not
> true, with *("-" extlang) the "most perverse tag" defined by
> the length has an arbitrary number of extlang-s before it even
> starts with script, region, variant(s), etc.
> 
> Peter proposed lng-exa-exb-exc-exd-exe as the "most perverse
> extlang".  John proposed Required-Prefix (= my Macro-Language)
> to register lng-exa-exb-exc-exd for exe.
> 
> I still think that one level should be good enough in practice,
> but five is certainly better than no limit at all.  Bye, Frank
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 02 Jun 2005 04:20:37 +0200

Addison Phillips wrote:

> The recommended buffer limit of 64 is long enough to take
> three extlangs (62 characters up from my example of 58).

If Peter can live with that it's certainly better than five.

                       Bye, Frank