Subject: [Ltru] Re: Preferred-Value added to registry

From: "Doug Ewell" <[email-masked]>
Date: Mon, 13 Jun 2005 19:49:12 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

> Okay, I found a stupid bug in my quick and dirty script, now
> it outputs the comments shown below, no problems, bye, Frank
>
> IN (2004-07-06) => ID (1989-01-01)
> IW (2004-07-06) => HE (1989-01-01)
> JI (2004-07-06) => YI (1989-01-01)
> JW (2005-01-17) => JV (2001-08-13)
> SH (2004-07-06) => ?? (2000-02-18)
> -BU (2004-07-06) => -MM (1989-12-05)
> -DD (2004-07-06) => -DE (1990-10-30)
> -FX (2004-07-06) => -FR (1997-07-14)
> -NT (2004-07-06) => ??? (1993-07-12)
> -SU (2004-07-06) => ??? (1992-08-30)
> -TP (2004-07-06) => -TL (2002-11-15)
> -YD (2004-07-06) => -YE (1990-08-14)
> -YU (2005-01-01) => -CS (2003-07-23)
> -ZR (2004-07-06) => -CD (1997-07-14)
> [9]57 (sub)tags in 4954 lines, 249 xrefs okay

Is this a complaint that the "Added" date of the deprecated subtags
comes after their "Deprecated" date?

"Added" dates are the date the subtag was added to the LTRU registry
(except for grandfathered and redundant whole-tags, which bear the date
the tag was added to the RFC 1766/3066 tag registry).  These dates will
probably all be moved forward to Date B.

"Deprecated" dates, for those subtags that have them in the initial
registry, are the date the subtag was deprecated in the core ISO
standard.  Subtags deprecated after Date B will bear that date.

Mismatches between these two concepts are not considered errors.

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 13 Jun 2005 19:49:37 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

>> Don't forget the matching draft, and the initial registry.
>
> If you want the latter to be "last called" and approved before
> Paris, with all missing Suppress-Scripts discussed and fixed,
> then you have a serious problem.  All I can do is to post the
> current Suppress-Scripts based on Doug's lstreg.txt 2005-06-05

It is a known fact that the set of language subtags without a
Suppress-Script is not complete, and probably never will be.  (Not to
mention the languages like Chinese for which Suppress-Script is
explicitly not desired.)  The supporters of Suppress-Script, who carried
the day, did not regard this as a problem.  This is done and over with.

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 14 Jun 2005 05:05:31 +0200

Doug Ewell wrote:

>> it outputs the comments shown below, no problems
[...]

> Is this a complaint that the "Added" date of the deprecated
> subtags comes after their "Deprecated" date?

 From my POV "no problems".  My script just lists these cases
as "manual checking might be necessary, a _deprecated_ subtag
was apparently _added_ after the preferred subtag".

Mark and Addison discussed dates in an old "canonical forever"
thread.  I just wanted to be sure that it's really no problem,
and not only my POV.
                          Bye, Frank