Subject: RE: [Ltru] Re: [psg.com #1026] what to do about Guernsey and Jersey

From: "Addison Phillips" <[email-masked]>
Date: Tue, 14 Jun 2005 10:41:42 -0700

Notwithstanding my last response to Frank, I embodied the time limit differently in the draft at present. That is, I read the time limit as pertaining only to the registration of UN M.49 codes, not to ISO 3166 codes. If ISO 3166 acts, then the UN M.49 code cannot be registered (but you don't need it anyway). If they fail to act for six months, then the UN M.49 code can be registered (on the two week waiting period for registrations, not on an additional six month delay).

But forbidding all such registrations might be a better move (see response to Frank for why). UN M.49 codes are the escape hatch for ISO 3166 reassignments, not an alternate scheme.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Peter Constable
> Sent: 2005?6?14? 8:27
> To: LTRU Working Group
> Subject: RE: [Ltru] Re: [psg.com #1026] what to do about Guernsey and
> Jersey
> 
> > From: [email-masked] [mailto:[email-masked]]
> On
> > Behalf Of Doug Ewell
> 
> 
> > > Okay, ready to go for date-B.  And afterwards, if somebody
> > > wants them ?  The tag reviewer needs a way to delay UN M.49
> > > registration requests for some time (mabye ISO 3166-1 just
> > > needs some time to find a new alpha-2 code), but not until
> > > doomesday.
> >
> > That's what I was saying; there needs to be a rule, or at least a
> really
> > strong guideline, as to how long the Subtag Reviewer (more properly,
> the
> > process) waits after the UN code is assigned.  Otherwise, one person
> > will end up thinking they have to wait a year, while another will
> think
> > a week is good enough.  That will attract too much controversy.
> 
> Is this something that can be worked out by consensus on the
> IETF-languages list? I'm disinclined to specify a timeline in *this*
> document for something that's dependent on processes not under our
> control and that may change. We may specify three months, but then the
> 3166MA may establish a process that takes only two weeks, in which case
> people will be forced to wait unnecessarily; or we may specify four
> weeks and then the 3166MA may later establish a process that takes six
> weeks, in which case we'd be forced to do what we regret. (Just as right
> now we can't register "gsw" just due to technicalities even though it's
> what we'd want.)
> 
> What we *can* do without concern is specify the kind of result we
> consider best. Saying that we do not automatically register M.49
> non-region codes is one example of this, and saying that people are
> expected to submit a request for inclusion in ISO 639 before we register
> a lang subtag is another. We can say that, for M.49 non-region codes, it
> is expected that a reasonable effort must be made to determine whether a
> corresponding 2alpha ID will be assigned by the 3166MA before an M.49
> non-region code can be registered.
> 
> 
> 
> Peter Constable
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 15 Jun 2005 16:55:35 +0200

Addison Phillips wrote:

> But forbidding all such registrations might be a better move
> (see response to Frank for why). UN M.49 codes are the escape
> hatch for ISO 3166 reassignments, not an alternate scheme.

Based on KISS and from an editorial POV it's a good plan, so I
could live with it.  And if they want 831..833 despite of this
obscure "proces failure" between ISO 3166 and their Duke, are
they free to register variants for some affected languages ?

                      Bye, Frank