Subject: RE: [Ltru] Re: [psg.com #1026] what to do about Guernsey and Jersey

From: "Addison Phillips" <[email-masked]>
Date: Tue, 14 Jun 2005 08:22:47 -0700

I was thinking in terms of a rule:

1. Register any new macro-geographic regions codes (should be quite rare: plate tectonics moves slowly).

2. Do NOT register new region codes for countries, etc. Allow individuals to register them using the process, provided there is ISO 3166 code assigned.

This essentially means we mirror ISO 3166 except for (a) miscellaneous regions individually registered for which no ISO 3166 code is assigned and (b) reassignments on the part of ISO 3166 (covered by the rules on that).

Simple, I think.

Addison 

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: 2005年6月14日 7:42
> To: LTRU Working Group
> Subject: [Ltru] Re: [psg.com #1026] what to do about Guernsey and Jersey
> 
> Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:
> 
> >> that means we don't register 200 (which we already agreed
> >> on), and we also don't register 830 or 833 (which are
> >> currently there) or 831 or 832 (which aren't).
> >
> > Okay, ready to go for date-B.  And afterwards, if somebody
> > wants them ?  The tag reviewer needs a way to delay UN M.49
> > registration requests for some time (mabye ISO 3166-1 just
> > needs some time to find a new alpha-2 code), but not until
> > doomesday.
> 
> That's what I was saying; there needs to be a rule, or at least a really
> strong guideline, as to how long the Subtag Reviewer (more properly, the
> process) waits after the UN code is assigned.  Otherwise, one person
> will end up thinking they have to wait a year, while another will think
> a week is good enough.  That will attract too much controversy.
> 
> --
> Doug Ewell
> Fullerton, California
> http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 14 Jun 2005 18:11:18 +0200

Addison Phillips wrote:
 
> we mirror ISO 3166 except for 

> (a) miscellaneous regions individually registered for which
> no ISO 3166 code is assigned

Okay, cases like 831..833 or the hypothetical "888 Somaliland".

> (b) reassignments on the part of ISO 3166 (covered by the
> rules on that).

The hypothetical TE" replacing TL ?  No, that would be simply
mirrored (I hope).   A hypothetical "BU" conflicting with our
old BU, yes, that's covered by the rules.

> Simple, I think.

Probably, but I'm more dense than usual today.  We still need
a rule delaying your case (a) for the hypothetical "888" if it
gets SX later.

Peter said a fixed delay is bad, e.g. 3 months makes no sense
if SX is available after 2 weeks.  I don't see the problem with
ISO 3166-1 being faster than we fear.  

We only need a delay for the registration of UN numbers without
alpha-2 code.  Otherwise - conflict or not - the case is clear,
either add alpha-2 (no conflict) or number (conflict, e.g. BU).

Peter's idea "consensus by the language tag list" might work.

And what do we expect if somebody wants 831..833 one day after
date-B, while others prefer to wait for a "nicer" GG, IM, JE ? 

Are they allowed to fix it if they get it "wrong" ?  In other
words if they first give up waiting and register 831..833, but
later GG, IM, JE are available.  Can they then register these
alpha-2 codes in addition to 831..833 ?  I certainly hope so.

                          Bye, Frank