Subject: RE: [Ltru] [psg.com #1018] Add Macro-Language field

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 1 Jun 2005 14:59:17 -0700

Hi,

'Required-Prefix' is better future-proofing.  But if we're
_sure_ that it only affects the macrolanguage issue, then
we could use 'Macrolanguage' (except it's confusing if there
do turn out to be more levels of nesting - yuck!).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Randy Presuhn
> Sent: Wednesday, June 01, 2005 5:29 PM
> To: [email-masked]
> Subject: Re: [Ltru] [psg.com #1018] Add Macro-Language field
> 
> 
> Hi -
> 
> > From: "John Cowan" <[email-masked]>
> > To: "Randy Presuhn" <[email-masked]>
> > Cc: <[email-masked]>
> > Sent: Wednesday, June 01, 2005 2:14 PM
> > Subject: Re: [Ltru] [psg.com #1018] Add Macro-Language field
> ...
> > I understood that they were exactly the same except for the 
> actual fieldname.
> > I am quite happy to switch from Required-Prefix to Macrolanguage.
> ...
> 
> I understood "Required-Prefix" as being more general than
> "Macro-Language", but I could have completely missed the point.
> 
> Randy
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Wed, 1 Jun 2005 23:52:37 -0700

Addison Phillips <addison dot phillips at quest dot com> wrote:

> There is a certain parsimony is having just one type of prefix field
> and making it both general and normative. Validating processors are
> required to pay attention to it. Well-formed processors are not
> required to pay attention to it. Users certainly should pay attention
> to it when selecting language tags.
>
> Or, to say it simply, can't we solve this by replacing the field name
> Recommended-Prefix with Required-Prefix? 3066ter can document that
> extlangs use this to indicate their enclosing macrolanguage (3066bis
> can document this as an intention).

I would simply love it if we could declare that "is-scouse" is not only
inappropriate, but invalid.  I've never been delighted with the idea
that such a tag can be called "probably a poor choice" and yet still be
considered no less valid than "in-TP".

Section 3.4 says that allowing non-recommended prefixes "makes
validation simpler," but IMHO this is overstated.  Validators already
have to look in the registry just to see if each subtag is defined
there.

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/

---

From: "Doug Ewell" <[email-masked]>
Date: Thu, 2 Jun 2005 00:06:56 -0700

Addison Phillips <addison dot phillips at quest dot com> wrote:

> For me the substantive issue that must be dealt with is whether a
> limit of three, as opposed to five, extlangs can be sufficient (and
> avoid having a weird "minimum" required buffer size) [yes, Randy,
> issue #965]. Is there any reasonable likelihood that a five-fold
> macrolanguage "enclosing" would ever exist (requiring four extlangs
> and a primary language)?

I would be fine with reducing 5 to 3.  Frank seems to want to reduce it
to 1, and I am not fine with that; the scenario for 2 has been
demonstrated adequately, and allowing 3 as a safety net is just a simple
as 2.

> The other point is: if we agree to change the term 'recommended-
> prefix' to 'required-prefix', this adds a small new requirement to
> validating processors (i.e. those that have a copy of the registry),
> while giving us a general purpose mechanism for handling prefixes?that
> will be understood "out of the box" when extlangs are assigned. I
> would submit that the effect of this is small now, since there are
> exactly two validating processors today that I'm aware of: Doug's and
> mine. And the benefit of it later is potentially large (since by then
> we hope there are many such processors).

I would have no problem whatsoever with changing my validating processor
to (1) turn Recommended-Prefix into Required-Prefix, with the semantic
changes implied thereby, and (2) allow a maximum of 3 (or 5 or whatever)
extended-language subtags.

---

From: "Addison Phillips" <[email-masked]>
Date: Thu, 2 Jun 2005 08:19:12 -0700

The name of the field is not important, ultimately. What the field means to a processor is what is important.

A variant that has multiple prefixes should be rare, but we didn't prohibit it. I don't see how it is "semantically bizarre" to require the user to pick a valid prefix from a list.

>From a user interface perspective, when presenting the list box containing variants, you match each "Prefix" (as a range) using Basic Range Matching against the subtags already selected. If it is a match, then you display (or enable) the variant.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: jeudi 2 juin 2005 05:16
> To: [email-masked]
> Subject: [Ltru] Re: [psg.com #1018] Add Macro-Language field
> 
> John Cowan wrote:
> 
> > Addison Phillips scripsit:
> >> Which is why Required/Recommended-Prefix may be repeated for
> >> variants.
> 
> > If there are alternatives, it's semantically bizarre to label
> > each of them as "required".
> 
> Just saying "Prefix" could do the trick.  10 characters saved
> per prefix in the registry.
>                            Bye, Frank
> 
> 
>

---

From: "Addison Phillips" <[email-masked]>
Date: Thu, 2 Jun 2005 11:53:12 -0700

Elsewhere the text does say that. I'll correct this one, which was unintentional.

Addison

Addison P. Phillips

> From: John Cowan [mailto:[email-masked]]
> Sent: jeudi 2 juin 2005 11:43
> To: Addison Phillips
> Cc: LTRU Working Group
> Subject: Re: [Ltru] Re: [psg.com #1018] Add Macro-Language field
> 
> > I followed John Cowan's suggestion that extlang should have exactly
> > one Prefix field. I allow variant to have more than one (and the reason
> > is in the text!!)
> 
> 2.2.2 says:
> 
> # Extended language subtag records, once they appear in the registry,
> # must include one or more 'Prefix' fields indicating an appropriate
> # language tag or tags that should always appear as a prefix to the
> # extended language subtag.
> 
> But what I intended was:
> 
> # Extended language subtag records, once they appear in the registry,
> # MUST include exactly one 'Prefix' field indicating an appropriate
> # language subtag (or sequence of subtags) that MUST always appear as a
> prefix to the
> # extended language subtag.
> 
> --
> LEAR: Dost thou call me fool, boy?      John Cowan
> FOOL: All thy other titles              http://www.ccil.org/~cowan
>              thou hast given away:      [email-masked]
>       That thou wast born with.         http://www.reutershealth.com