Subject: RE: [Ltru] Re: Draft-01 of initial registry now up

From: "Addison Phillips" <[email-masked]>
Date: Sun, 26 Jun 2005 19:27:44 -0700

I like the structure of this document more than I did previously. Having the initialization text present is really an improvement.

How about "the initial registry uses" (since this is the document referring to itself)?

And then do a thorough edit, probably using Frank's suggestions to get started, but doing whatever editorial work makes sense from there.

There also needs to be a section containing the various UN M.49 codes that are valid for registration but which are not registered. E.g. the ones referred to by:

--
Any codes that remain MUST be listed in a separate section of the initial registry draft, indicating that these codes are valid for registration using the process in [I-D.ietf-ltru-registry] (Phillips, A., Ed. and M. Davis, Ed., "Tags for Identifying Languages," June 2005.) but were not included initially. Listing of these codes in this section is no guarantee of future registration.
--

(and with an actual link to the section)

Then, if you would, please just submit the document and I'll submit draft-07 of registry with the text included here expunged in an appropriate manner.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: dimanche 26 juin 2005 17:04
> To: [email-masked]
> Subject: [Ltru] Re: Draft-01 of initial registry now up
> 
> Doug Ewell wrote:
> 
> > nor does it add region subtags 034 and 143 nor delete region
> > subtag 062, since that issue is still unresolved.
> 
> Hi Randy, could you please state that we want 034 and 143 IN
> and 062 OUT.
> 
> > I'd especially like to know how WG members feel about Section
> > 2: whether the wording makes sense in this context
> 
> You can't say "the editor MUST" while talking with yourself.
> How about:  "The editor of the initial registry used" etc.
> 
> You could also replace s/is/was/, s/are/were/ etc. describing
> what you've done.
> 
> In the UN M.49 section get rid of all MAY, MUST, and MUST NOT,
> these keywords are unnecessary and undefined in your memo.
> 
> Proposed text:
> 
>   Actual UN numeric codes assigned to "macro-geographical
>   (continental)" regions were added to the IANA registry and
>   thereby made valid for use in language tags.
> 
> Note added "Actual", the added "regions", and s/MAY be/were/
> 
>   The UN numeric codes for "economic groupings" or "other
>   groupings," and the alphanumeric codes in Appendix X of the
>   UN document, were not added to the registry.
> 
> Here it's s/MUST NOT be/were not/
> 
>   The UN numeric codes for countries or areas not associated with
>   an assigned ISO 3166 alpha-2 code were not added to the initial
>   version of the registry.
> 
> Dito.  Then delete the following statement, there should be no
> registration rules in the initial registry:
> 
> - These values MAY be requested for registration by individuals
> - using the process defined in [I-D.ietf-ltru-registry] and
> - according to the rules described therein.
> 
>   Items withdrawn, vacated, deprecated, modified, or otherwise
>   judged by the LTRU working group to be questionable were omitted
>   from the initial registry.
> 
> Again s/MAY be/were/, then delete the next statement:
> 
> - Those selected for inclusion MUST be added to the initial
> - registry.
> 
> Yes, you added the selected codes, ready,  The next statements
> are apparently wrong, please delete them if that's the case:
> 
> - Any codes that remain were listed in a separate section of the initial
> - registry draft, indicating that these codes are valid for registration
> - using the process in [I-D.ietf-ltru-registry] but were not included
> - initially.  Listing of these codes in this section is no guarantee
> - of future registration.
> 
> I don't find any "separate" or "this section" in draft -07, let
> alone in your initial registry.
> 
> [...]
>   Such tags were placed in records of type "redundant" in the registry.
> 
> Again s/MUST be/were/ - relevant rules belong to the registry
> draft and not to the draft registry, you only state the facts,
> no rules,
> 
>   defined by [I-D.ietf-ltru-registry] have corresponding records
>   of type "grandfathered"
> 
> s/MUST//
> 
>   but may have a "Deprecated" and "Preferred-Value" field added
>   to them if a subtag assignment or combination of assignments
>   renders the tag obsolete.
> 
> s/MAY/may/  If you're (almost) sure better say s/MAY// because
> the result wasn't determined by a random generator.
> 
>   deprecated were maintained as grandfathered entries.
> 
> s/MUST be/were/
> 
>   entry contains a "Deprecated"
> 
> s/MUST contain/contains/
> 
> Etc., please get rid of each and every 2119 keyword, just the
> facts, no rules.
>                  Bye, Frank
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Mon, 27 Jun 2005 09:18:02 -0700

??

Doug asked for the specific text from the 3066bis draft and I did *no* editing of it before sending it along.

When that text was in that "other" document, it was correct to use normative language (as a set of instructions). Embedded in the document created using said instructions, it makes no sense to use normative language. There it is a record of how the document was created.

Addison

Addison P. Phillips

> Behalf Of McDonald, Ira
> Sent: lundi 27 juin 2005 09:12
> To: 'Doug Ewell'; LTRU Working Group
> Subject: RE: [Ltru] Re: Draft-01 of initial registry now up
> 
> Hi,
> 
> Note that Addison replied with some text that uses MUST.
> 
> But I'm inclined to think that Frank's got it right - this is the
> rather rare standards-related I-D (and later RFC) that should not use
> any conformance imperatives from RFC 2119.
> 
> Cheers,
> - Ira
> 
> Ira McDonald (Musician / Software Architect)
> Blue Roof Music / High North Inc
> PO Box 221  Grand Marais, MI  49839
> phone: +1-906-494-2434
> email: [email-masked]
> 
> > From: [email-masked]
> > [mailto:[email-masked]]On
> > Behalf Of Doug Ewell
> > Sent: Monday, June 27, 2005 1:02 AM
> > To: LTRU Working Group
> > Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:
> >
> > There is no consensus on this yet.  So far Frank, Mark and I agree on
> > this, and Randy has a different view.
> >
> > Frank is right.  There is much work yet to be done in this section.
> > I'll go through Frank's and Addison's corrections, and let
> > everyone know
> > when a better -01 is ready.
> >
> > In particular, I realize I was supposed to add a section of UN codes
> > that were omitted from the initial registry, and forgot to do so.
> >
> > And yes, it is true, I did edit some of the text slightly from
> > draft-registry-07, mostly for grammar and punctuation.
> >
> > --
> > Doug Ewell
> > Fullerton, California
> > http://users.adelphia.net/~dewell/
> >
> >
> >

---

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 27 Jun 2005 09:11:45 -0700

Hi,

Cheers,
- Ira

---

From: "Doug Ewell" <[email-masked]>
Date: Tue, 28 Jun 2005 19:51:23 -0700

Randy Presuhn <randy underscore presuhn at mindspring dot com> wrote:

> ...
> I guess you missed message
> http://www1.ietf.org/mail-archive/web/ltru/current/msg02405.html
> There is no disagreement, but you've kept on arguing.  :-)

I did read it, but missed the significance of "This would address my
concerns."  Sorry about that.