Subject: RE: [Ltru] Re: Confusing conformance language

From: "Addison Phillips" <[email-masked]>
Date: Thu, 9 Jun 2005 10:36:54 -0700

Nibbled to death by ducks.

The word "may" has multiple uses in the English language and some of them are clearly non-normative. These aren't capitalized in the draft. Neither are uses of MUST and SHOULD in the introduction and in the changes section (where there is a substantial informative block of text).

All of the normative language is now normalized in the editor's copy.

I invite comments about errors and omissions.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: 2005?6?9? 10:01
> To: [email-masked]
> Subject: [Ltru] Re: Confusing conformance language
> 
> Scott Hollenbeck wrote:
> 
> > RFC 2119 is somewhat unspecific on the topic.  It says this
> > in the abstract:
> 
> > "These words are often capitalized."
> 
> > but it doesn't say anything about distinguishing the lower
> > case forms from the upper case forms.  In my mind, this leads
> > to confusion when a document mixes the two forms.
> 
> I'm not confused, lower case isn't a 2119 keyword.  Or rather I
> _wasn't_ confused until Ira and you started.  There are quite a
> lot of lower case "must", "required", and "should" in RFC 2119.
> 
> You're not trying to overrule Bruce Lilly, or are you ?  The
> last time it took you, Bill, Dave, Ned, and Brian.  And then
> you still approved his informational RfC clearly saying "2234"
> instead of "2234bis".  Gotcha... ;-)
>                                      Bye, Frank
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 9 Jun 2005 11:42:51 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "Frank Ellermann" <[email-masked]>; <[email-masked]>
> Sent: Thursday, June 09, 2005 10:36 AM
> Subject: RE: [Ltru] Re: Confusing conformance language
...
> All of the normative language is now normalized in the editor's copy.
...

Since we're oh-so-close to being ready for working group last call,
please submit it as an i-d.  The secretariat has been quick to get
things through, and we have lots of integers left.  :-)

Randy, ltru co-chair

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 09 Jun 2005 21:16:00 +0200

> All of the normative language is now normalized in the

The -04 with date June 03 ?  I'm not sure what Scott checks,
but Bruce could note that "SHALL NOT" is defined but not used.

I hope you're not trying to capitalize all "should", some are
in examples, or all "must" (e.g. "special thanks MUST go to"
etc. would be nonsense... ;-)

And if they'd insist on it roll your own terminologoy, start
with STRONGLY (for SHOULD), VERY REALLY (for MUST), FOO (for
SHOULD NOT), and FOOBAR (for MUST NOT).  

"Informative" reference:  RfC 3092, the etymology of "foo".
Unfortunately it doesn't explain XYZZY (for MAY-be not).  Bye.