Subject: [Ltru] Re: [psg.com #1034] Add region subtags 034 and 143, delete 062

From: "Doug Ewell" <[email-masked]>
Date: Mon, 20 Jun 2005 21:37:31 -0700

Randy Presuhn <randy underscore presuhn at mindspring dot com> wrote:

>>> Shall the initial LTRU registry be modified to (a) add region
>>> subtags 034 and 143 and (b) delete region subtag 062?
>
> While the additions makes sense, the deletion worries me.
> If there is a language uniform across the entire 062 area,
> splitting it into 034 and 143 variants would require asserting
> that there is variation where there is none of interest.
> Of course, if we knew that 062 is not useful for any language,
> then the deletion would be harmless.  Does someone on this list
> know enough about the languages of those regions to be able to
> support such a claim?

For reference, 034 ("Southern Asia") contains:

 Afghanistan
 Bangladesh
 Bhutan
 India
 Iran (Islamic Republic of)
 Maldives
 Nepal
 Pakistan
 Sri Lanka

while 143 ("Central Asia") contains:

 Kazakhstan
 Kyrgyzstan
 Tajikistan
 Turkmenistan
 Uzbekistan

and the now-withdrawn 062 ("South-central Asia"), as mentioned before,
is the union of these two.

I would be surprised if there were not at least one language spoken in
both of these regions that exhibits significant variation, and at least
one that does not.  For that matter, I would imagine the same could be
said about any two macro regions in the list.

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 20 Jun 2005 21:40:55 -0700

Randy Presuhn <randy underscore presuhn at mindspring dot com> wrote:

> The discussion of issue #1026 (started with Jersey and Geurnsey, ended
> up principles for handling UN M.49 numeric codes) has quieted down, so
> I'd like to get a hum from the group:
>
> Can you live with how http://www.ietf.org/internet-drafts/draft-ietf-
> ltru-registry-05.txt addresses this issue?
>
> (see http://www1.ietf.org/mail-archive/web/ltru/current/msg02287.html
> for the proposed change)

I wholeheartedly agree with this approach.

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 21 Jun 2005 07:53:01 +0200

Doug Ewell wrote:
 
> I would be surprised if there were not at least one language
> spoken in both of these regions that exhibits significant
> variation, and at least one that does not.

I don't see any special problem for say uz.  Bye, Frank

---

From: Martin Duerst <[email-masked]>
Date: Wed, 22 Jun 2005 09:38:44 +0900

I agree with Doug (and Randy). Let's keep them all.    Martin.

---

From: "Doug Ewell" <[email-masked]>
Date: Tue, 21 Jun 2005 19:58:50 -0700

Martin Duerst <duerst at it dot aoyama dot ac dot jp> wrote:

> I agree with Doug (and Randy). Let's keep them all.

I wasn't actually arguing to keep them all.  My point was supposed to be
that *any* two regions in the world, say Micronesia and Middle Africa,
could potentially have what Randy posited -- a language that shows no
variation between the two regions, such that a distinction in tagging
would be pointless.  There's nothing special about 034 and 143 in this
regard, except that they were formerly subsumed under the same UN region
code (062).

But unlike alpha-2 codes, the numeric codes have never been valid in
language tags, so there is no backward-compatibility reason to keep 062
valid, as there is for, say, SU.

I'm opposed to keeping 062, but I won't put up a serious fight about it.
There are better fights to be picked.