Subject: RE: [Ltru] [psg.com #1018] Add Macro-Language field

From: "Addison Phillips" <[email-masked]>
Date: Wed, 1 Jun 2005 13:08:57 -0700

How is this different from #1017? Shouldn't this be the same discussion?

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: mercredi 1 juin 2005 12:49
> To: LTRU Working Group
> Subject: [Ltru] [psg.com #1018] Add Macro-Language field
> 
> Hi -
> 
> > ------------------------------------------------------------------------
> -
> > In message
> > http://www1.ietf.org/mail-archive/web/ltru/current/msg01919.html
> > the addition of a MAcro-Language field was suggested.
> 
> Randy, ltru co-chair
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 1 Jun 2005 13:17:28 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Wednesday, June 01, 2005 1:08 PM
> Subject: RE: [Ltru] [psg.com #1018] Add Macro-Language field
>

> How is this different from #1017? Shouldn't this be the same discussion?
...

The two proposals (required-prefix and macro-language) arose from the same
discussion.  I leave it to their advocates to say whether they should be linked.
To me they seemed to be presented as distinct concepts, although motivated
by a common underlying philosophy.

Randy

---

From: John Cowan <[email-masked]>
Date: Wed, 1 Jun 2005 17:14:32 -0400

> by a common underlying philosophy.

I understood that they were exactly the same except for the actual fieldname.
I am quite happy to switch from Required-Prefix to Macrolanguage.

-- 
After fixing the Y2K bug in an application:     John Cowan
        WELCOME TO <censored>                   [email-masked]
        DATE: MONDAK, JANUARK 1, 1900           http://www.ccil.org/~cowan

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 1 Jun 2005 14:29:09 -0700

Hi -

> From: "John Cowan" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Wednesday, June 01, 2005 2:14 PM
> Subject: Re: [Ltru] [psg.com #1018] Add Macro-Language field
...
...

I understood "Required-Prefix" as being more general than
"Macro-Language", but I could have completely missed the point.

Randy

---

From: John Cowan <[email-masked]>
Date: Wed, 1 Jun 2005 17:32:59 -0400

> "Macro-Language", but I could have completely missed the point.

No, I introduced it in order to talk about extlang subtags and macrolanguages.
Note that it's "macrolanguage" in ISO 639-3, not "macro-language".  In any
case, this issue can be and should be deferred until we are doing RFC 3066ter.

-- 
John Cowan  www.reutershealth.com  www.ccil.org/~cowan  [email-masked]
'Tis the Linux rebellion / Let coders take their place,
The Linux-nationale / Shall Microsoft outpace,
We can write better programs / Our CPUs won't stall,
So raise the penguin banner of / The Linux-nationale.  --Greg Baker

---

From: "Debbie Garside" <[email-masked]>
Date: Thu, 2 Jun 2005 15:43:16 +0100

Hi

Just a little info...

The term "Macro-language" MAY be up for discussion in the ISO meeting in
August.

Best regards

Debbie

> Behalf Of John Cowan
> Sent: 01 June 2005 22:15
> To: Randy Presuhn
> Cc: [email-masked]