Subject: RE: [Ltru] [psg.com #1034] Add region subtags 034 and 143, delete 062

From: "Addison Phillips" <[email-masked]>
Date: Fri, 24 Jun 2005 12:20:35 -0700

It would be possible to do so. The question is whether it would be appropriate to do so. The point of incorporating the various standards into the registry ab initio is to avoid the need to painstakingly review all of the potential items later.

Notice that there is a review period for the initial registry built into the registry-draft and this allows for community review.

I favor being conservative about the codes we incorporate (on the theory that ietf-languages is perfectly capable of resolving whether to add any omissions, but that no one is permitted to remove badly chosen inclusions), but not to the point of leaving out all of the macro-regions.

On that basis I would:

1. Follow the Date A/Date B rules to create a list of potential candidates (i.e. what Doug has already done)
2. Remove any that are questionable or controversial.
3. Document in the initial-registry draft which ones those are (that is, codes that are valid to register but were not initially registered)
4. Let ietf-languages and the process be used to incorporate those few that are needed from that list (or later assignments) at a later date.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: 2005?6?24? 12:14
> To: LTRU Working Group
> Subject: Re: [Ltru] [psg.com #1034] Add region subtags 034 and 143, delete
> 062
> 
> Hi -
> 
> As a technical contributor...
> 
> Since the registry draft (section 2.2.4 of -06) gives the rules specifying
> whether a given UN M.49 code may be added to the registry, wouldn't
> it be sufficient for the purposes of the initial registry to just
> supply the one such code (419) that is currently needed, leaving
> requests for the addition of others up to those who find a use for
> them?  This would allow us to sidestep all this discussion of the
> merits of individual codes on this list, moving it to ietf-languages
> when our work is approved, where such discussion properly belongs.
> 
> Randy
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 24 Jun 2005 12:41:56 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Friday, June 24, 2005 12:20 PM
> Subject: RE: [Ltru] [psg.com #1034] Add region subtags 034 and 143, delete 062
...
> 3. Document in the initial-registry draft which ones those are
> (that is, codes that are valid to register but were not initially registered)
> 4. Let ietf-languages and the process be used to incorporate those few
> that are needed from that list (or later assignments) at a later date.
...

This would address my concerns about any so-called "deletions".

Randy