Subject: RE: [Ltru] Re: draft-ietf-ltru-matching-02

From: "Addison Phillips" <[email-masked]>
Date: Mon, 13 Jun 2005 20:14:46 -0700

Your programs aren't actually required to. Only your registry compiler is required to actually follow the chain. Since this is a one-time, off-line process, it can be as ugly and inefficient as necessary.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: 2005年6月13日 19:59
> To: LTRU Working Group
> Subject: [Ltru] Re: draft-ietf-ltru-matching-02
> 
> Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:
> 
> > Doug apparently agreed that "frozen" Preferred-Values aren't
> > optimal, and he found various minor nits around this issue.
> 
> I don't like having to follow the daisy chain from TP to TL to TE to
> whatever, or having to make my programs do so.  But I'm not going to
> fight to the death over it.
> 
> --
> Doug Ewell
> Fullerton, California
> http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 13 Jun 2005 23:07:46 -0700

Addison Phillips <addison dot phillips at quest dot com> wrote:

> Your programs aren't actually required to. Only your registry compiler
> is required to actually follow the chain. Since this is a one-time,
> off-line process, it can be as ugly and inefficient as necessary.

That's good, because I had assumed that the validator would have to
report on the whole chain.  Just TP to TE is a lot nicer, and what the
user expects anyway.

My registry-to-header converter is already ugly and inefficient, so it
should fit the bill nicely.