Subject: RE: [Ltru] Re: [psg.com #1018] Add Macro-Language field

From: "Addison Phillips" <[email-masked]>
Date: Thu, 2 Jun 2005 10:33:18 -0700

I have posted another editor's copy incorporating a limit of extlang to three plus the changes necessary to make 'Recommended-Prefix' into 'Prefix' with normative powers.

Pay particular attention to the section on variants (in which Prefix field matching is described) and section 3.1 (where the Prefix field itself is described).

I followed John Cowan's suggestion that extlang should have exactly one Prefix field. I allow variant to have more than one (and the reason is in the text!!)

All other changes should be in the document at this point. Are we ready for another official draft?

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: jeudi 2 juin 2005 00:07
> To: LTRU Working Group
> Subject: [Ltru] Re: [psg.com #1018] Add Macro-Language field
> 
> Addison Phillips <addison dot phillips at quest dot com> wrote:
> 
> > For me the substantive issue that must be dealt with is whether a
> > limit of three, as opposed to five, extlangs can be sufficient (and
> > avoid having a weird "minimum" required buffer size) [yes, Randy,
> > issue #965]. Is there any reasonable likelihood that a five-fold
> > macrolanguage "enclosing" would ever exist (requiring four extlangs
> > and a primary language)?
> 
> I would be fine with reducing 5 to 3.  Frank seems to want to reduce it
> to 1, and I am not fine with that; the scenario for 2 has been
> demonstrated adequately, and allowing 3 as a safety net is just a simple
> as 2.
> 
> > The other point is: if we agree to change the term 'recommended-
> > prefix' to 'required-prefix', this adds a small new requirement to
> > validating processors (i.e. those that have a copy of the registry),
> > while giving us a general purpose mechanism for handling prefixes?that
> > will be understood "out of the box" when extlangs are assigned. I
> > would submit that the effect of this is small now, since there are
> > exactly two validating processors today that I'm aware of: Doug's and
> > mine. And the benefit of it later is potentially large (since by then
> > we hope there are many such processors).
> 
> I would have no problem whatsoever with changing my validating processor
> to (1) turn Recommended-Prefix into Required-Prefix, with the semantic
> changes implied thereby, and (2) allow a maximum of 3 (or 5 or whatever)
> extended-language subtags.
> 
> --
> Doug Ewell
> Fullerton, California
> http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Thu, 2 Jun 2005 14:43:02 -0400

Addison Phillips scripsit:

> I followed John Cowan's suggestion that extlang should have exactly
> one Prefix field. I allow variant to have more than one (and the reason
> is in the text!!)

2.2.2 says:

# Extended language subtag records, once they appear in the registry,
# must include one or more 'Prefix' fields indicating an appropriate
# language tag or tags that should always appear as a prefix to the
# extended language subtag.

But what I intended was:

# Extended language subtag records, once they appear in the registry,
# MUST include exactly one 'Prefix' field indicating an appropriate
# language subtag (or sequence of subtags) that MUST always appear as a prefix to the
# extended language subtag.

-- 
LEAR: Dost thou call me fool, boy?      John Cowan
FOOL: All thy other titles              http://www.ccil.org/~cowan
             thou hast given away:      [email-masked]
      That thou wast born with.         http://www.reutershealth.com

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 2 Jun 2005 21:11:58 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "LTRU Working Group" <[email-masked]>
> Sent: Thursday, June 02, 2005 10:33 AM
> Subject: RE: [Ltru] Re: [psg.com #1018] Add Macro-Language field
...
> All other changes should be in the document at this point. Are we ready for another official draft?
...

Yes, please submit the i-d.

Randy, ltru co-chair