Subject: RE: [Ltru] [psg.com #1018] Add Macro-Language field

From: "Addison Phillips" <[email-masked]>
Date: Wed, 1 Jun 2005 20:16:11 -0700

Which is why Required/Recommended-Prefix may be repeated for variants. 

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: John Cowan [mailto:[email-masked]]
> Sent: mercredi 1 juin 2005 19:15
> To: Addison Phillips
> Cc: [email-masked]
> Subject: Re: [Ltru] [psg.com #1018] Add Macro-Language field
> 
> Addison Phillips scripsit:
> 
> > Or, to say it simply, can't we solve this by replacing the field name
> > Recommended-Prefix with Required-Prefix? 3066ter can document that
> > extlangs use this to indicate their enclosing macrolanguage (3066bis
> > can document this as an intention).
> 
> I'm afraid not.  A variant subtag may be sensible with different prefixes.
> An extlang subtag isn't: it goes with exactly one language subtag, period.
> 
> --
> Where the wombat has walked,            John Cowan <[email-masked]>
> it will inevitably walk again.          http://www.ccil.org/~cowan

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Thu, 2 Jun 2005 07:52:02 -0400

> Which is why Required/Recommended-Prefix may be repeated for variants. 

If there are alternatives, it's semantically bizarre to label each of them
as "required".

-- 
John Cowan  www.ccil.org/~cowan  [email-masked]  www.reutershealth.com
[P]olice in many lands are now complaining that local arrestees are insisting
on having their Miranda rights read to them, just like perps in American TV
cop shows.  When it's explained to them that they are in a different country,
where those rights do not exist, they become outraged.  --Neal Stephenson

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 02 Jun 2005 14:15:46 +0200

> If there are alternatives, it's semantically bizarre to label
> each of them as "required".

Just saying "Prefix" could do the trick.  10 characters saved
per prefix in the registry.
                           Bye, Frank