Subject: RE: [Ltru] Re: status? last call?

From: "Addison Phillips" <[email-masked]>
Date: Tue, 28 Jun 2005 16:07:09 -0700

Replies below...

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: Dienstag, 28. Juni 2005 14:50
> To: [email-masked]
> Subject: [Ltru] Re: status? last call?
> 
> Addison Phillips wrote:
> 
> > #1026 "Guernsey and Jersey"
> [...]
> > which no longer affect the registry draft (they
> > affect the initial draft now)
> [...]
> > let us know where we stand regarding a Last Call.
> 
> I'm not yet sure that there's really no registration
> rule in Doug's initial registry.  All registration
> rules would belong to the registry draft.
[Addison Phillips] 

Agreed.
> 
> NOW (timestamp of this article) the initial registry
> still says:
> 
> | The UN numeric codes for countries or areas not associated
> | with an assigned ISO 3166 alpha-2 code MUST NOT be added to
> | the initial version of the registry.  These values MAY be
> | requested for registration by individuals using the process
> | defined in [I-D.ietf-ltru-registry] and according to the
> | rules described therein.
> 
> The MUST NOT is an editorial issue, the MAY is a rule,
> it affects the potential registration of 830, 831, 832,
> and 833, and it's incompatible with 2.2.4 clause 3.E:
> 
> | E. All other UN numeric codes for countries or areas which do
> |    not have an associated ISO 3166 alpha-2 code MUST NOT be
> |    entered into the registry and MUST NOT be used to form
> |    language tags.  For more information about these codes,
> |    see Section 3.3.
[Addison Phillips] 

I'll make a special exception for listed codes that are valid for registration in Section 2.2.4 clause 3.E., but note that Issue 1026 was closed by adding the following explicit text that makes these items ineligible for registration:

<t>Codes assigned by UN M.49 to countries or areas (as opposed to geographical regions and sub-regions) for which there is no corresponding ISO 3166 code MUST NOT be registered, except under the previous provision. If it is necessary to identify a region for which only a UN M.49 code exists in language tags, then the registration authority for ISO 3166 SHOULD be petitioned to assign a code, which can then be registered for use in language tags. At the time this document was written, there were only four such codes: 830 (Channel Islands), 831 (Guernsey), 832 (Jersey), and 833 (Isle of Man). This rule exists so that UN M.49 codes remain available as the value of last resort in cases where ISO 3166 reassigns a deprecated value in the registry.</t>
> 
> Draft -07 section 3.3 bullet 10 (conflict) star 6 (no alpha-2)
> states again that 830..833 cannot be registered.  BTW, that is
> no "conflict", maybe extract the 6th "no alpha-2" item from
> "bullet 10" and add it after bullet 10 before the last bullet.
[Addison Phillips] 

Agreed.
> 
> Counting bullets and stars is a PITA.  Is there really no way
> to initialize the counter for a <list style="numbers"> or for
> a <list style="letters"> ?  Wilbur's <OL> already had a START=,
> that's not exactly a new idea.

[Addison Phillips] 

Sure there is. I just didn't make the change previously. I'll change it to letters or numbers once I've looked at which is more appropriate.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 29 Jun 2005 01:36:04 +0200

Addison Phillips wrote:

> I'll make a special exception for listed codes that are valid
> for registration in Section 2.2.4 clause 3.E

Sorry, I'm completely confused.  IIRC we agreed that 830..833
and similar future cases of "UN region number without alpha-2"
are _not_ registered, never, no exception.

Maybe I got it wrong, but I didn't ask for exceptional rules,
if that's what you thought.  If Doug removes your old MAY in
his -01 it's fine, that's compatible with your -07 2.2.4 (3.E)

> Agreed.

No serious problem of course, moving one sublist item to the
parent list shouldn't delay Randy / Martin / Scott with their
"last call" business.

>> Is there really no way to initialize the counter for a
>> <list style="numbers"> or for a <list style="letters"> ?
[...]

> Sure there is. I just didn't make the change previously.

Oops, how does it work ?  My experiments with a list nested
within a <list style="format Changes in version 0%d"> failed
miserably, and a negative hangIndent= value had no effect.

> I'll change it to letters or numbers once I've looked at
> which is more appropriate.

For 2.2.4 (3E) you have letters within numbers.  Bye, Frank