Subject: RE: [Ltru] Re: Language in XML Schema 1.1 Datatypes

From: Misha Wolf <[email-masked]>
Date: Wed, 18 Jan 2006 17:09:49 +0000

What I was referring to is the text:

[Definition:] language represents formal natural language 
identifiers, as defined by [RFC 3066]or its successor(s) in the 
IETF Standards Track.

Is that correct?
 
Misha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Frank Ellermann
Sent: 18 January 2006 16:47
To: [email-masked]
Subject: [Ltru] Re: Language in XML Schema 1.1 Datatypes

Misha Wolf wrote:

> http://www.w3.org/TR/2006/WD-xmlschema11-2-20060116/#language

About 1 MB, sigh.

> Is that correct?

It's the general 3066 syntax, which is a superset of the more
elaborated 3066bis syntax.  Ignoring all details for certain
kinds of subtags it's still fine for all 3066bis language tags.

                            Bye, Frank

To find out more about Reuters visit www.about.reuters.com

Any views expressed in this message are those of the individual sender, except where the sender specifically states them to be the views of Reuters Ltd.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Wed, 18 Jan 2006 15:43:25 -0500

> identifiers, as defined by [RFC 3066]or its successor(s) in the 

Technically, no.  But the intent is clear enough.  I myself introduced
this "standards track" language into the XML Recommendation (from which
this language is taken) when I didn't understand the IETF process that well.
I think, however, that it is of no real importance; whatever the official
status, in practice 1766 > 3066 > 3066bis.

What troubles me more is that the draft says that the WXS datatype "language"
is case-sensitive, and says that it's up to applications to provide case
sensitivity.  It seems that this is the result of a misunderstanding:
mn is one thing (language subtag) and MN is another (country subtag),
but of course "MN" as a tag means the same as "mn", since country subtags
cannot appear in initial position.

-- 
And it was said that ever after, if any                 John Cowan
man looked in that Stone, unless he had a               [email-masked]
great strength of will to turn it to other              www.ccil.org/~cowan
purpose, he saw only two aged hands withering           www.reutershealth.com
in flame.   --"The Pyre of Denethor"