Subject: [Ltru] Charter update proposal (updated)

From: Martin Duerst <[email-masked]>
Date: Fri, 04 Aug 2006 18:24:00 +0900

Dear LTRU WG,

Below please find an updated proposal for our charter update
(rechartering). Details of changes are discussed in responses
to the commenters. The main change is the addition of a paragraph
discussing signed languages, transliterations, transcriptions,
and 639-6.

I look forward to send our proposal for rechartering to
Ted Hardie (Area Director) within the next few days. But
in case you find any additional problems in the current
draft charter, please tell me (and the WG).

Regards,    Martin.

-------------------------------------------------------------

Description of the Working Group:

The primary language subtags allowed by the current IANA Language
Subtag Registry are limited to ISO 639-1 and ISO 639-2 in the same
way as they were limited by RFC 3066. This covers approximately 500
possible language subtags. ISO 639-3, scheduled for approval towards
the end of 2006, will make available around 7000 more code elements
for identifying languages.

The working group will prepare an update to the Language Subtag
Registry procedures to allow the use of 3-letter code elements
from ISO 639-3 as primary language subtags or extended language
subtags as appropriate. The working group will also deliver means
to update the current IANA Language Subtag Registry with the newly
available subtags.

The working group will examine, and if necessary clarify or adjust,
procedures and guidelines with respect to extended language subtags
and variant subtags. Use cases include the identification of
signed languages, transliterations, and transcriptions.
The working group will also consider how the draft work on
ISO 639-6 may relate to the future development of language tags.

The working group will clarify text where necessary. It may also
make adjustments to the registration process and the form of the
registry if this is deemed appropriate based on ongoing registration
and operational experience. These adjustments and clarifications
are not expected to delay the progress of the work.

Work on the drafts is planned to start before ISO 639-3 is fully
approved and published. However, the WG will not finalize the
drafts before ISO 639-3 is fully approved.

Goals and Milestones:

September 2006   Submit first WG draft of registry procedure update
September 2006   Submit first WG draft of registry data update

January   2007   Submit registry procedure update draft for IETF Last Call
January   2007   Submit registry data update draft for IETF Last Call

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]     

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Peter Constable" <[email-masked]>
Date: Fri, 4 Aug 2006 08:22:22 -0700

> From: Martin Duerst [mailto:[email-masked]]

> (rechartering)...

This looks good to me.

I have one minor suggested addition, which you can ignore if it means a

> for identifying languages.

Add: 

"These additional code elements provide coverage for all known human
languages in use today."

That would pre-empt questions as to (1) why we would be getting such a
large increase in subtags and (2) whether this is a one-time bulk
increase or if there are going to be repeated order-of-magnitude
increases.

Peter Constable

---

From: "Debbie Garside" <[email-masked]>
Date: Fri, 4 Aug 2006 18:18:32 +0100

Peter wrote:

>> "These additional code elements provide coverage for all 
> known human languages in use today."

I think this could form quite a contentious statement and should not be
added as is. There are many cases where a linguistic entity can be treated
as a dialect by some and a language by others and vice versa.  

Perhaps a better statement would be:

----

These additional code elements provide coverage for the majority of known
human languages in use today.

----

"the majority" could be replaced with "significant proportions".

Best regards

Debbie 

> -----Original Message-----
> From: Peter Constable [mailto:[email-masked]] 
> Sent: 04 August 2006 16:22
> To: LTRU Working Group
> Subject: RE: [Ltru] Charter update proposal (updated)
> 
> I have one minor suggested addition, which you can ignore if 
> it means a significant delay for you:
> 
> > Subtag Registry are limited to ISO 639-1 and ISO 639-2 in 
> the same way 
> > as they were limited by RFC 3066. This covers approximately 500 
> "These additional code elements provide coverage for all 
> known human languages in use today."
> 
> That would pre-empt questions as to (1) why we would be 
> getting such a large increase in subtags and (2) whether this 
> is a one-time bulk increase or if there are going to be 
> repeated order-of-magnitude increases.
> 
> 
> 
> Peter Constable
>

---

From: "Peter Constable" <[email-masked]>
Date: Fri, 4 Aug 2006 11:19:12 -0700

> From: Debbie Garside [mailto:[email-masked]]

> human languages in use today.

Fine with me, but I'd go for "vast majority". But as I said, I'm also OK with the text that Martin had drafted.

Peter Constable

---

From: John Cowan <[email-masked]>
Date: Fri, 4 Aug 2006 14:25:48 -0400

> as a dialect by some and a language by others and vice versa.  

I think this comment misses the significance of the word "coverage".
There are indeed disputes about whether the 639-3 codes match up
one-for-one with the world's languages.  But nevertheless, for every
variety of language, there is a 639-3 code that describes it, if less
precisely than some would prefer.  This is not the case in 639-2, except
insofar as every language might be brought under some collective-language
code element or other.

So whereas there is simply no sensible way to code, say, Sac content
using 639-2 except to blanket it as 'nai', tagging it only as "some
North American Indian language", all instances of such content are now
covered by the 639-3 code element 'sac', even though that code element
also includes Fox and Mesquakie.  And so on for all known instances of
linguistic content.

-- 
John Cowan  [email-masked]  http://ccil.org/~cowan
In the sciences, we are now uniquely privileged to sit side by side
with the giants on whose shoulders we stand.
        --Gerald Holton

---

From: "Mark Davis" <[email-masked]>
Date: Fri, 4 Aug 2006 11:28:34 -0700

As with many other taxonomies, there are varying degrees of granularity; by
'language' one could mean anything down to ideolects. For the purposes of
BCP 47, we have no desire to have indefinitely fine distinctions, so I don't
have any problem with Peter's original formulation, perhaps with a minor
qualification indicating the degree of granularity being applied.

Mark

---

From: "Debbie Garside" <[email-masked]>
Date: Fri, 4 Aug 2006 19:41:10 +0100

Addison wrote:

> "These additional code elements are intended to provide 
> coverage for all known human languages in use today."

+1

Debbie 

> From: Addison Phillips [mailto:[email-masked]] 
> Sent: 04 August 2006 19:33
> To: John Cowan
> Cc: Debbie Garside; [email-masked]
> Subject: Re: [Ltru] Charter update proposal (updated)
> 
>  >
>  > There are indeed disputes about whether the 639-3 codes 
> match up  > one-for-one with the world's languages.  But 
> nevertheless, for every  > variety of language, there is a 
> 639-3 code that describes it, if less  > precisely than some 
> would prefer.  This is not the case in 639-2, except  > 
> insofar as every language might be brought under some 
> collective-language  > code element or other.
> 
> The easiest way out of this conundrum would be:
> 
> "These additional code elements are intended to provide 
> coverage for all known human languages in use today."
> 
> This covers the reason why without addressing whether the 
> effort has been a success or not.
> 
> Addison
> --
> Addison Phillips
> Globalization Architect -- Yahoo! Inc.
> 
> Internationalization is an architecture.
> It is not a feature.

---

From: "Debbie Garside" <[email-masked]>
Date: Fri, 4 Aug 2006 19:46:51 +0100

I would also be happy with "Vast majority"... 

Debbie 

> Sent: 04 August 2006 19:19
> To: LTRU Working Group
> > I think this could form quite a contentious statement and 
> should not 
> > be added as is. There are many cases where a linguistic 
> entity can be 
> > treated as a dialect by some and a language by others and 
> vice versa.
> > 
> > These additional code elements provide coverage for the majority of 
> > known human languages in use today.
> > 
> > ----
> 
> Fine with me, but I'd go for "vast majority". But as I said, 
> I'm also OK with the text that Martin had drafted.
> 
> 
> 
> 
> Peter Constable
>

---

From: Addison Phillips <[email-masked]>
Date: Fri, 04 Aug 2006 11:33:23 -0700

"These additional code elements are intended to provide coverage for all 
known human languages in use today."

This covers the reason why without addressing whether the effort has 
been a success or not.

Addison

---

From: John Cowan <[email-masked]>
Date: Fri, 4 Aug 2006 14:52:54 -0400

> January   2007   Submit registry data update draft for IETF Last Call

Hmm.  Are we likely to end up with an RFC that is superseded *before*
it is published?  And has that ever happened before?

-- 
John Cowan                              <[email-masked]>
            http://www.ccil.org/~cowan
                .e'osai ko sarji la lojban.
                Please support Lojban!          http://www.lojban.org

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 4 Aug 2006 15:42:33 -0700

Hi -

As a technical contributor ...

> From: "Addison Phillips" <[email-masked]>
> To: "John Cowan" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Friday, August 04, 2006 11:33 AM
...
> This covers the reason why without addressing whether the effort has 
...

No.  The easiest fix is to not add the text at all.  A WG charter is not
the place to give a tutorial.  A WG charter, according to RFC 2418,

|   1. Lists relevant administrative information for the working group;
|   2. Specifies the direction or objectives of the working group and
|      describes the approach that will be taken to achieve the goals;
|      and
|   3. Enumerates a set of milestones together with time frames for their
|      completion.

So, we should identity the standards we propose to use or consider,
but there's no point to further elaboration.

Randy

---

From: "Peter Constable" <[email-masked]>
Date: Fri, 4 Aug 2006 19:47:51 -0700

> From: Randy Presuhn [mailto:[email-masked]]

> No.  The easiest fix is to not add the text at all...

OK with me.

Peter Constable

---

From: Martin Duerst <[email-masked]>
Date: Sat, 05 Aug 2006 11:34:40 +0900

>it is published?  And has that ever happened before?

It's up to us, and the RFC Editor. If it happens, it would reflect
good on us, but bad on the RFC Editor. What we have to think about
now is whether these milestones are realistic for us, independent
of what the RFC Editor might do or not do.

Regards,    Martin.

---

From: Martin Duerst <[email-masked]>
Date: Sat, 05 Aug 2006 11:36:18 +0900

Regards,    Martin.

---

From: Martin Duerst <[email-masked]>
Date: Sat, 05 Aug 2006 11:36:18 +0900

Regards,    Martin.

---

From: Martin Duerst <[email-masked]>
Date: Sat, 05 Aug 2006 11:36:18 +0900

On this, I have to agree with Randy, and as Peter has said that
not adding an additional sentence would also be fine, I hope this
will be okay with everybody.

Regards,     Martin.

[email-masked]>
	<[email-masked]> <[email-masked]>
	<005e01c6b817$4772c3e0$6501a8c0@oemcomputer>
Cc: 

On this, I have to agree with Randy, and as Peter has said that
not adding an additional sentence would also be fine, I hope this
will be okay with everybody.

Regards,     Martin.

[email-masked]>
	<[email-masked]> <[email-masked]>
	<005e01c6b817$4772c3e0$6501a8c0@oemcomputer>
Cc: 

On this, I have to agree with Randy, and as Peter has said that
not adding an additional sentence would also be fine, I hope this
will be okay with everybody.

Regards,     Martin.

---

From: Martin Duerst <[email-masked]>
Date: Mon, 07 Aug 2006 11:18:14 +0900

After looking at the comments I have received for the update to
the recharter draft, I decided to forward this to Ted Hardie, our
Area Director. Just in case you find anything else that you think
really needs to be fixed, please feel free to write to the WG list,
to the chairs or to the AD, or to comment on the IETF list when
this recharter comes up there.

Regards,     Martin.