Subject: Re: [Ltru] Charter update proposal

From: Martin Duerst <[email-masked]>
Date: Fri, 04 Aug 2006 17:09:13 +0900

At 23:02 06/07/28, Mark Davis wrote:
>Something along these lines looks good. A couple wording items:
>
>The working group may make adjustments to the registration process
>and the form of the registry if this is deemed appropriate based
>on ongoing registration and operational experience and such 
>adjustments are not expected to delay the progress of the work.
>=>
>The working group may make adjustments to the registration process
>and the form of the registry if this is deemed appropriate based
>on ongoing registration and operational experience. It may also clarify 
>some of the text. Such
>adjustments are not expected to delay the progress of the work.

I have taken this into account, but slightly reworded:

The working group will clarify text where necessary. It may also
make adjustments to the registration process and the form of the
registry if this is deemed appropriate based on ongoing registration
and operational experience. These adjustments and clarifications
are not expected to delay the progress of the work.

Regards,     Martin.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]     

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Martin Duerst <[email-masked]>
Date: Fri, 04 Aug 2006 18:00:29 +0900

Hello Addison,

At 05:44 06/07/29, Addison Phillips wrote:
>Hello Martin,
>
>Thank you for doing this. Unless notes, I am "+1" to everything you said in
>your message.
>
>Specific comments follow.

same here.

>Addison
>
>Addison Phillips
>Internationalization Architect - Yahoo! Inc.
>
>Internationalization is an architecture.
>It is not a feature.  
>
>> -----Original Message-----
>> From: Martin Duerst [mailto:[email-masked]] 
>> Sent: vendredi 28 juillet 2006 01:41
>
>
>> ISO 639-3, scheduled for approval towards the end of 2006,
>> will make available around 6000 (??) more primary language codes
>> and language variant codes.
>
>As noted by others, this sentence should say something else. However, I'm
>convinced that the comments so far go in the wrong direction. In our jargon,
>the term "codes" refers to codes in ISO 639, not to subtags. I would thus
>propose we say:
>
>--
>ISO 639-3, scheduled for approval towards the end of 2006, will make
>available around 7000 additional codes for identifying languages.

I have decided that when speaking about ISO, I'm using their
terminology (code elements), and when speaking about our stuff,
I'm using our terminology. I hope this will come out reasonably
well.

>--
>> 
>> The working group will work on an update to the language subtag
>
>(Editorial) I would replace the phrase "work on" with "prepare" or "create".

Done.

>> registry procedures to allow the use of 3-letter codes from
>> ISO 639-3 as primary subtags or variant subtags as appropriate.
>
>As noted by others, replace 'variant' with 'extended language'.

Yes, my bad, done, mostly with text from Doug.

>> The working group will also deliver means to update the current
>> IANA language subtag registry with the newly available codes.
>
>I would change this to be slightly more expansive:
>
>--
>The working group will also deliver a means to update the current
>IANA language subtag registry with the newly available codes, as well
>as procedures for maintaining the registry as codes are assigned 
>or modified in the future.

My understanding is that we already have the procedures for
updating. Or do we miss something?

>--
>
>Or you might consider using a separate sentence, such as the one I proposed
>yesterday:
>
>--
>The working group must decide how ISO 639-3 codes are entered into the
>registry, what rules apply to associating a code with the language and/or
=>extlang subtag types, and any additional rules or guidance on their adoption
>and use.
>--

I don't see what's substantially different here from the existing
text:

The working group will prepare an update to the Language Subtag
Registry procedures to allow the use of 3-letter codes from
ISO 639-3 as primary subtags or extended language subtags as
appropriate. 

In short, we have to update the procedures so that we can use
IOS 639-3. I don't think that we need more details here.
How codes are entered, what types they are given, and so on,
should all be covered under Language Subtag Registry
procedures.

>(Editorial) This is a bit of a run-on sentence. Please break it into two
>setences between
>'experience' and 'such'.

I adopted a split from Mark, with some changes of my own.

>I wouldn't oppose including some version of (Mark's version of) my ISO 639-6
>text here ;-).
>
>> 
>> Work on the drafts is planned to start before ISO 639-3 is fully
>> approved and published. However, the WG will not finalize the drafts
>> before ISO 639-3 is fully approved.
>
>I'm not sure that's correct. It would be more appropriate to say
>"Publication of the draft(s) as an RFC will depend on final approval of ISO
>639-3." There is ample space in the RFC Editor process for awaiting specific
>external events (as we've already discovered). We might well finalize an
>update to draft-registry quite quickly, but not the actual registry update
>("draft-initial").

Peter said that he would have the approval by the third week of September.
Do you think we'll be finished with our drafts before that?

Regards,    Martin.

---

From: Addison Phillips <[email-masked]>
Date: Fri, 04 Aug 2006 08:10:20 -0700

> I'm using our terminology. I hope this will come out reasonably

That's fine.
> updating. Or do we miss something?

We do. The "means of updating" would probably be some form of new 
"draft-initial". The "procedures for maintaining" are instructions on 
how to handle future ISO 639-3 registrations. The reason this is 
different is that these registrations will need to be evaluated for 
"lang-or-extlang-ness", which is something we do not have today.
> should all be covered under Language Subtag Registry

Yes, but the things I mention are requirements that the Working Group 
must address. I favor listing requirements explicitly and treating other 
items as "potentially out of scope". We might, for example, decide that 
the best thing to do about, say, transliterations is "nothing". But we 
must decide in this iteration what to do about extlangs.
> Do you think we'll be finished with our drafts before that?

No, but your text was not correct. I'm allergic to artificial 
dependencies, based on our experience with 3066bis. ISO 639-3 might 
(unlikely as it probably is) take longer than Peter imagines. Our 
drafts, meanwhile, might go very quickly [if we can avoid the tar pits 
surrounding issues I personally would prefer to see remain off-topic].

Regards,

Addison

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.

---

From: Martin Duerst <[email-masked]>
Date: Sat, 05 Aug 2006 16:37:49 +0900

At 00:10 06/08/05, Addison Phillips wrote:

>>> as procedures for maintaining the registry as codes are assigned or modified in the future.
>We do. The "means of updating" would probably be some form of new "draft-initial".

Yes. This is worded as "means of updating" on purpose, because it gives
us some leeway to choose some other means than an internet-draft if we
think an internet draft really doesn't work (e.g. because of the volume).

>The "procedures for maintaining" are instructions on how to handle future ISO 639-3 registrations. The reason this is different is that these registrations will need to be evaluated for "lang-or-extlang-ness", which is something we do not have today.

I understand that we need these. And they are not covered by the "deliver a
means" sentence. However, they are covered by the following sentence before:

--------
The working group will prepare an update to the Language Subtag
Registry procedures to allow the use of 3-letter code elements
from ISO 639-3 as primary language subtags or extended language
subtags as appropriate.
--------

In my understanding, "procedures" here include the procedures for
updates to the registry at later points in time when new code
elements are added to ISO 639-3.

>>> --
>>>
>>> Or you mighFrom [email-masked] Sat Aug 05 03:38:46 2006
Date: Sat, 05 Aug 2006 16:37:49 +0900
To: Addison Phillips <[email-masked]>
From: Martin Duerst <[email-masked]>
Subject: Re: [Ltru] Charter update proposal
Cc: 'LTRU Working Group' <[email-masked]>

At 00:10 06/08/05, Addison Phillips wrote:

>>> as procedures for maintaining the registry as codes are assigned or modified in the future.
>We do. The "means of updating" would probably be some form of new "draft-initial".

Yes. This is worded as "means of updating" on purpose, because it gives
us some leeway to choose some other means than an internet-draft if we
think an internet draft really doesn't work (e.g. because of the volume).

>The "procedures for maintaining" are instructions on how to handle future ISO 639-3 registrations. The reason this is different is that these registrations will need to be evaluated for "lang-or-extlang-ness", which is something we do not have today.

I understand that we need these. And they are not covered by the "deliver a
means" sentence. However, they are covered by the following sentence before:

--------
The working group will prepare an update to the Language Subtag
Registry procedures to allow the use of 3-letter code elements
from ISO 639-3 as primary language subtags or extended language
subtags as appropriate.
--------

In my understanding, "procedures" here include the procedures for
updates to the registry at later points in time when new code
elements are added to ISO 639-3.

>>> --
>>>
>>> Or you mighFrom [email-masked] Sat Aug 05 03:38:46 2006
Date: Sat, 05 Aug 2006 16:37:49 +0900
To: Addison Phillips <[email-masked]>
From: Martin Duerst <[email-masked]>
Subject: Re: [Ltru] Charter update proposal
Cc: 'LTRU Working Group' <[email-masked]>

At 00:10 06/08/05, Addison Phillips wrote:

>>> as procedures for maintaining the registry as codes are assigned or modified in the future.
>We do. The "means of updating" would probably be some form of new "draft-initial".

Yes. This is worded as "means of updating" on purpose, because it gives
us some leeway to choose some other means than an internet-draft if we
think an internet draft really doesn't work (e.g. because of the volume).

>The "procedures for maintaining" are instructions on how to handle future ISO 639-3 registrations. The reason this is different is that these registrations will need to be evaluated for "lang-or-extlang-ness", which is something we do not have today.

I understand that we need these. And they are not covered by the "deliver a
means" sentence. However, they are covered by the following sentence before:

--------
The working group will prepare an update to the Language Subtag
Registry procedures to allow the use of 3-letter code elements
from ISO 639-3 as primary language subtags or extended language
subtags as appropriate.
--------

In my understanding, "procedures" here include the procedures for
updates to the registry at later points in time when new code
elements are added to ISO 639-3.

>Yes, but the things I mention are requirements that the Working Group must address. I favor listing requirements explicitly and treating other items as "potentially out of scope". We might, for example, decide that the best thing to do about, say, transliterations is "nothing". But we must decide in this iteration what to do about extlangs.

I don't see any reason why we wouldn't. The things that you mention
to me are obvious details, not things that need to be called out
because otherwise there would be major misunderstandings.

>No, but your text was not correct.

Is it still not correct? If yes, how?

>I'm allergic to artificial dependencies, based on our experience with 3066bis. ISO 639-3 might (unlikely as it probably is) take longer than Peter imagines. Our drafts, meanwhile, might go very quickly [if we can avoid the tar pits surrounding issues I personally would prefer to see remain off-topic].

I understand that you want things to be done as quickly as possible.
And I agree. However, I don't think it would be appropriate for
the WG to finalize the new draft and send it to the IESG before
we know that ISO 639-3 is really approved, because the fact that
it is not fully approved may mean that there are some more
changes, in which case we have to go back and make some
changes, too. As ISO 639-3 is the major reason for our new
work, I wouldn't call this an "artificial" dependency.

Regards,    Martin.

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 05 Aug 2006 16:48:38 +0200

Martin Duerst wrote:

> I don't think it would be appropriate for the WG to finalize
> the new draft and send it to the IESG before we know that
> ISO 639-3 is really approved, because the fact that it is not
> fully approved may mean that there are some more changes, in
> which case we have to go back and make some changes, too. As
> ISO 639-3 is the major reason for our new work, I wouldn't
> call this an "artificial" dependency.

We also need more procedural experience with the rules as they
are.  State of the art would be "dump review list as complete
failure wrt Suppress-Script".

If published today 3066ter should be different from 3066bis wrt
list and review management.  E.g. we now need a "MUST" for the
expert reviewer to read the rules (s)he's supposed to follow.

Frank

---

From: Martin Duerst <[email-masked]>
Date: Sun, 06 Aug 2006 18:21:31 +0900

At 23:48 06/08/05, Frank Ellermann wrote:
>are.

The idea of the current recharter proposal is to use whatever
procedural experience we have, and make whatever adjustments
we think are necessary based on this, rather than to wait
until we have enough experience so that we can create the
final, perfect procedures. Are you trying to say that this
should be changed?

>State of the art would be "dump review list as complete

I don't think we need to discuss specific adjustments to
procedures now, because we don't plan to mention them in
the charter. Are you disagreeing with this?

Regards,    Martin.

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 06 Aug 2006 13:44:09 +0200

Martin Duerst wrote:

>> We also need more procedural experience with the rules as
>> they are.
 
> final, perfect procedures. Are you trying to say that this

If there will be some months with pure 3066bis rules (after
it got its number), and no doubt about it, that will be good
enough to see how it works.  No 3066ter "last call" this year,
let alone before 3066bis got its number.

> the charter. Are you disagreeing with this?

No - just no overzealous milestones and timetable please,

Frank

---

From: John Cowan <[email-masked]>
Date: Sun, 6 Aug 2006 10:41:19 -0400

Frank Ellermann scripsit:

> No 3066ter "last call" this year, let alone before 3066bis got its
> number.

I hope you are right, but how do you know?  Perhaps our stuff
will still be hanging in the RFC Editor queue in 2008.

-- 
Verbogeny is one of the pleasurettes    John Cowan <[email-masked]>
of a creatific thinkerizer.             http://www.ccil.org/~cowan
   -- Peter da Silva

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 06 Aug 2006 17:15:19 +0200

John Cowan wrote:

> I hope you are right, but how do you know?

IIRC Bill published statistics, and the average time in the
queue was about / almost six months.  Including cases where
RFCs are blocked (= normative references not yet available),
or authors MIA.

> Perhaps our stuff will still be hanging in the RFC Editor
> queue in 2008.

Looking at it from the other side it's "unblocked" for less
than 14 days.  Addison, Doug, and Mark are ready if they get
their AUTH48 info, no "interesting" pending issues, one typo
covered by an RFC editor note.

I hope that it gets its number before its first "birthday"
(approval of initial + registry).  Together with matching.

But of course my crystal ball isn't better than yours... :-)