Subject: [Ltru] Erratum ?

From: Frank Ellermann <[email-masked]>
Date: Mon, 19 Feb 2007 23:03:39 +0100

Hi, thinking about John's I-D.klensin-unicode-escapes-02 my idea was
to simply copy <UNICHAR> from RFC 4646:

   UNICHAR    = "&#x" 2*6HEXDIG ";"

BUT, it's wrong, isn't it ?  I've now proposed this beast:

   UNICHAR    = %x26.23.78 2*6HEXDIG ";"

IOW &#x123; is fine, but &#X123; (X instead of x) is not, or is it ?
See http://www.w3.org/TR/REC-xml/#sec-references

Frank

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Martin Duerst <[email-masked]>
Date: Tue, 20 Feb 2007 11:38:33 +0900

What Frank is saying is that our current ABNF allows an upper-case
'X' in numeric character references, but that this isn't allowed
in XML.

My understanding is that this is only relevant for the registry
itself, that there are extremely few cases of numeric character
references currently (I counted 14, all of them with a lower-case x).

I don't think we need a formal erratum, because we have other
means to make sure no upper-case X gets into the registry.

But I definitely support fixing this in RFC 4646bis. Others,
please express your preferences.

>   UNICHAR    = %x26.23.78 2*6HEXDIG ";"

Just a detail: What about

   UNICHAR    = "&#" %x78 2*6HEXDIG ";"

Maybe just a tiny bit more readable, but I don't care too much.

Regards,    Martin.

>See http://www.w3.org/TR/REC-xml/#sec-references

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]

---

From: Martin Duerst <[email-masked]>
Date: Tue, 20 Feb 2007 11:38:33 +0900

Regards,    Martin.

---

From: John Cowan <[email-masked]>
Date: Mon, 19 Feb 2007 22:24:57 -0500

> please express your preferences.

+1

-- 
I am expressing my opinion.  When my            John Cowan
honorable and gallant friend is called,         [email-masked]
he will express his opinion.  This is           http://www.ccil.org/~cowan
the process which we call Debate.                   --Winston Churchill

---

From: Addison Phillips <[email-masked]>
Date: Mon, 19 Feb 2007 20:16:06 -0800

Could we please just bag entities and use UTF-8 in the registry? The 
entities are ugly, unreadable, and unnecessary in this modern era of 
Unicode. Some folks on the ietf-languages list have even had trouble 
submitting them (using a Web mail system appears to cause interference 
between the entities and the mail system's Web pages).

Addison

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.

Internationalization is an architecture.
It is not a feature.

---

From: Martin Duerst <[email-masked]>
Date: Tue, 20 Feb 2007 13:26:04 +0900

At 13:16 07/02/20, Addison Phillips wrote:
>Could we please just bag entities and use UTF-8 in the registry? The entities are ugly, unreadable, and unnecessary in this modern era of Unicode. Some folks on the ietf-languages list have even had trouble submitting them (using a Web mail system appears to cause interference between the entities and the mail system's Web pages).

I would be happy to support this, too.

Regards,    Martin.

---

From: "Erkki I. Kolehmainen" <[email-masked]>
Date: Tue, 20 Feb 2007 07:25:27 +0200

+1

Erkki I. Kolehmainen
Tilkankatu 12 A 3, FI-00300 Helsinki, Finland
Puh. (09) 4368 2643, 0400 825 943; Tel. +358 9 4368 2643, +358 400 825 943  

-----Alkuperainen viesti-----
Lahettaja: Martin Duerst [mailto:[email-masked]] 
Lahetetty: 20. helmikuuta 2007 6:26
Vastaanottaja: Addison Phillips
Kopio: Frank Ellermann; [email-masked]
Aihe: Re: [Ltru] Erratum ? (upper-case X in numeric character references)

Regards,    Martin.

---

From: Peter Constable <[email-masked]>
Date: Mon, 19 Feb 2007 22:42:25 -0800

+1

Peter Constable

-----Original Message-----
From: Erkki I. Kolehmainen [mailto:[email-masked]]
Sent: Monday, February 19, 2007 9:25 PM
To: 'Martin Duerst'; 'Addison Phillips'
Cc: 'Frank Ellermann'; [email-masked]
Subject: Re: [Ltru] Erratum ? (upper-case X in numeric character references)

+1

Erkki I. Kolehmainen

-----Alkuperainen viesti-----
Lahettaja: Martin Duerst [mailto:[email-masked]]
Lahetetty: 20. helmikuuta 2007 6:26
Vastaanottaja: Addison Phillips
Kopio: Frank Ellermann; [email-masked]
Aihe: Re: [Ltru] Erratum ? (upper-case X in numeric character references)

Regards,    Martin.

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 20 Feb 2007 15:58:45 +0100

Martin Duerst wrote:

>> I've now proposed this beast:

> Maybe just a tiny bit more readable, but I don't care too much.

Nor me.  For John's draft I proposed a comment 'starts with "&#x"'
for the readability, and kept the %x26 because it then implicitly
explains why "&" has to be expressed as "&#x26;".

In RFC 4646 we have an explicit explanation "ampersand is 26" or
similar.  Somewhere and somehow it has to be mentioned, but once
is of course good enough.

Frank

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 20 Feb 2007 16:07:38 +0100

Addison Phillips wrote:

> Unicode

Unicode is a nice reference charset.  Using it directly in plain text
OTOH strikes me as bad idea for this decade.  Users of the registry
need to know what something _should_ be, they're not interested to
learn which codepoints their system doesn't support.

As far as we know they use PC DOS 3.30 behind a web2mail gateway in a
remote area of the Sahara.  The registry has still to work for them.

Folks would scream when we use a signature as start of the registry.

Frank