Subject: [Ltru] Last Call: draft-mcwalter-langtag-mib (Language Tag MIB) to Proposed Standard

From: The IESG <[email-masked]>
Date: Thu, 08 Feb 2007 18:01:16 -0500

The IESG has received a request from an individual submitter to consider
the following document:

- 'Language Tag MIB '
   <draft-mcwalter-langtag-mib-01.txt> as a Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send substantive comments to the
[email-masked] mailing lists by 2007-03-08. Exceptionally, 
comments may be sent to [email-masked] instead. In either case, please 
retain the beginning of the Subject line to allow automated sorting.

The file can be obtained via
http://www.ietf.org/internet-drafts/draft-mcwalter-langtag-mib-01.txt

IESG discussion can be tracked via
https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=15469&rfc_flag=0

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Randy Presuhn <[email-masked]>
Date: Thu, 15 Feb 2007 13:57:43 +0700 (GMT+07:00)

Hi -

>From: "McDonald, Ira" <[email-masked]>
>Sent: Feb 11, 2007 4:15 AM
>To: 'John Cowan' <[email-masked]>, Doug Ewell <[email-masked]>
>Cc: [email-masked], LTRU Working Group <[email-masked]>, [email-masked]
>Subject: RE: [Ltru] Re: Last Call: draft-mcwalter-langtag-mib (Language Ta	g MIB) to Proposed Standard
>
>Hi,
>
>Right - ASN.1 doesn't allow discontinuous integer ranges.
...

No.  In a SIZE qualifier, a discontiguous range is perfectly
legal ASN.1   There are examples of this in RFC 2579,
among others.  In this particular case, something like

SYNTAX      OCTET STRING (SIZE (0 | 2..60))

(replacing 60 with whatever the consensus upper bound
should be) would seem appropriate.

Randy