Subject: [Ltru] Comorian and other issues

From: Nicolas Krebs <[email-masked]>
Date: Fri, 16 Feb 2007 00:38:48 +0100

After partial review of urn:ietf:id:draft-ietf-ltru-4645bis-01
( http://tools.ietf.org/html/draft-ietf-ltru-4645bis-01 ), i found some issue, 
a question and our old friend -western. 

1 Persian
What are the differences between fa-pes (Western Farsi) and fa-ir? between 
fa-prs (Eastern Farsi) and fa-af? 

2 western variant
For "western" generic variant previously discuted 
( http://www.alvestrand.no/pipermail/ietf-languages/2006-August/004899.html 
etc. ), you can see 
fa-pes (Western Farsi)
fa-prs (Eastern Farsi)
hy-arevmda (Western Armenian)
hy-arevela (Eastern Armenian)

3 Comorian
%
Type: language
Subtag: swb
Description: Comorian
Added: 2008-01-01
%%
Type: language
Subtag: wlc
Description: Mwali Comorian
Description: Comorian, Mwali
Added: 2008-01-01
%%
Type: language
Subtag: wni
Description: Ndzwani Comorian
Description: Comorian, Ndzwani
Added: 2008-01-01
%%
Type: language
Subtag: zdj
Description: Ngazidja Comorian
Description: Comorian, Ngazidja
Added: 2008-01-01
%%

If i understand correctly, swb is the encompass language, and the other are dialect. Then: 

%%
Type: extlang
Subtag: wlc
Description: Mwali Comorian
Description: Comorian, Mwali
Added: 2008-01-01
Prefix: swb
%%
Type: extlang
Subtag: wni
Description: Ndzwani Comorian
Description: Comorian, Ndzwani
Added: 2008-01-01
Prefix: swb
%%
Type: extlang
Subtag: zdj
Description: Ngazidja Comorian
Description: Comorian, Ngazidja
Added: 2008-01-01
Prefix: swb
%%

4 "specific" 
Are the follwing subtag enough unambiguous and defined? 
Should their Description be modified such Goanese Konkani 
or Cocos Islands Malay? 

%%
Type: language
Subtag: zne
Description: Zande (specific)
Added: 2008-01-01
%%
Type: extlang
Subtag: dgo
Description: Dogri (specific)
Added: 2008-01-01
Prefix: doi
%%
Type: extlang
Subtag: knn
Description: Konkani (specific)
Added: 2008-01-01
Prefix: kok
%%
Type: extlang
Subtag: mly
Description: Malay (specific)
Added: 2008-01-01
Prefix: ms
%%
Type: extlang
Subtag: swh
Description: Swahili (specific)
Added: 2008-01-01
Prefix: sw
%%

It would done
%%
Type: extlang
Subtag: swh
Description: Swahili (specific)
Description: Swahili, Tanzania
Added: 2008-01-01
Prefix: sw
%%

5 modified Description 
For the following sutag, the Description: was modified, and so the meaning too. 

%%
Type: language
Subtag: fy
Description: Western Frisian
Description: Frisian, Western
Added: 2005-10-16
%%
Type: language
Subtag: km
Description: Central Khmer
Description: Khmer, Central
Added: 2005-10-16
Suppress-Script: Khmr
%%
Type: language
Subtag: rm
Description: Romansh
Added: 2005-10-16
%%

IMHO, should be supercedes by 

%%
Type: language
Subtag: fy
Description: Frisian
Added: 2005-10-16
Deprecated: 2005-11-16
%%
Type: language
Subtag: km
Description: Khmer
Added: 2005-10-16
Deprecated: 2006-10-27
Suppress-Script: Khmr
%%
Type: language
Subtag: rm
Description: Raeto-Romance
Added: 2005-10-16
Deprecated: 2006-10-25
%%
Type: language
Subtag: fy
Description: Western Frisian
Description: Frisian, Western
Added: 2005-11-16
%%
Type: language
Subtag: km
Description: Central Khmer
Description: Khmer, Central
Added: 2006-10-27
Suppress-Script: Khmr
%%
Type: language
Subtag: rm
Description: Romansh
Added: 2006-10-25
%%

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Fri, 16 Feb 2007 02:19:19 -0500

Nicolas Krebs scripsit:

> After partial review of urn:ietf:id:draft-ietf-ltru-4645bis-01 (
> http://tools.ietf.org/html/draft-ietf-ltru-4645bis-01 ), i found some
> issue, a question and our old friend -western.

Generic note:  These considerations are appropriate for the ISO 693-3
Registration Authority, not for ietf-languages; we just clone what
they provide.  My comments are not authoritative.

> fa-prs (Eastern Farsi) and fa-af? 

By what I understand, the written forms in Iran and Afghanistan are
very similar, the spoken versions (Farsi and Dari) not so much.
So fa-ir and fa-af would suggest the slightly different written
forms, whereas fa-prs and fa-pes would suggest the rather more
divergent spoken varieties.  This is not a necessary implication,
just what a bit of desultory research suggests to me.

> hy-arevela (Eastern Armenian)

In 639-3, the two varieties of Farsi are different enough to count
as separate languages, whereas the two varieties of Armenian are not.

> 3 Comorian

[snip]

> If i understand correctly, swb is the encompass language, and the

That's not the view of 639-3, which treats the four as separate and
distinct languages.  Comorian (swb) is the largest, but it's not
considered to encompass the others.

> Are the follwing subtag enough unambiguous and defined? 

Again, we are tracking the names chosen by 639-3.  The point of
"(specific)" is to deal with cases where a macrolanguage and
one of the encompassed languages have the same name.

> Description: Frisian, Western

[snip]

> Description: Frisian, Western

Descriptions are non-normative for us (though we get them from ISO
standards where they are normative), so we don't deprecate and then
reinstate a subtag for the sake of a description.  Indeed, once a subtag
is deprecated, it stays deprecated forever.

-- 
John Cowan    [email-masked]    http://ccil.org/~cowan
If a traveler were informed that such a man [as Lord John Russell] was
leader of the House of Commons, he may well begin to comprehend how the
Egyptians worshiped an insect.  --Benjamin Disraeli