Subject: [Ltru] variants and ordering

From: Martin Hosken <[email-masked]>
Date: Thu, 01 Mar 2007 09:30:56 +0700

Dear All,

Herewith my humble attempt to bring some order to a small area of chaos:
variants.

There are 3 major components to a language tag: language, script,
region, each of which may take variants. In addition there may be
variants to combinations of components. Regional information is used for
locale information, and while I can see there may possibly be a need for
regional variants, there is no evidence of their existence yet and
certainly not of their interaction with the other components. So I will
ignore them for the moment and perhaps return to them once a basic model
is established. This leaves 2 components and therefore 3 types of
variants: language variants, script variants and language+script
variants which I will call orthography variants. The key concept I am
proposing here is that variants are categorised, based on their prefix,
as to what kind they are and then may be ordered in the tag based on
that categorisation.

A language variant takes a language only prefix. A script variant
currently takes no prefix, but I propose that they take a script prefix.
An orthography variant would take a language-script prefix (requiring both).

Mark Davis has proposed a canonical ordering of variants within a tag:

Any sequence of variant tags MUST be reordered such that for each variant subtags A and B, A comes before B if

   1. A has no prefix and B has a prefix
   2. or A and B are not ordered by #1, and A is part of a prefix (given
      the previous non-variant subtags) for B
   3. or A and B are not ordered by #1 or #2, and A is alphabetically
      before B

But this has been challenged with the example of en-scouse-fonipa. I.e. what people are saying is that language takes precedence over script, which makes perfect sense to me. I think the argument that one can say wider over narrower is unhelpful here since the two variants are from different categories.

Based on this preamble, I propose the following:

Any sequence of variant tags MUST be reordered such that for each variant subtag A and B, B comes before A unless any of the following are true:

  1. A is a language variant and B is one of a script, orthography or regional variant or has no prefix
  2. A is a script variant and B is one of an orthography or regional variant or has no prefix
  3. A is an orthography variant and B is a regional variant or has no prefix
  4. A is a regional variant and B has no prefix
  5. A is part of a prefix for B
  6. A is alphabetically before B

Where a variant is considered:

  1. A language variant if its prefix(es) or ancestoral prefix(es) consist only of language subtags
  2. A script variant if its prefix(es) or ancestoral prefix(es) consist only of script subtags
  3. An orthography variant if its prefix(es) or ancestoral prefix(es) consist only of language+script tags
  4. A regional variant if its prefix(es) or ancestoral prefix(es) consist only of regional subtags

Where the ancestoral prefixes are the prefixes of the ancestoral prefixes or the variant in question.

The effect of this on the subtag registry is that a variant may only be of one kind and may not, for example, have a prefix list consisting of a language tag and then a script tag. Also script variants MUST take a script prefix rather than taking a blank prefix.

In my analysis, I have treated orthography variants as being constrained script variants, local to a particular language and script. What makes script/orthography variants interesting is that, as has been stated in other discussion, their prefix script is implied and therefore is suppressed.

Does this help?

Yours,
Martin Hosken

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Wed, 28 Feb 2007 22:03:41 -0500

Martin Hosken scripsit:

> But this has been challenged with the example of
> en-scouse-fonipa. I.e. what people are saying is that language takes
> precedence over script, which makes perfect sense to me. I think the
> argument that one can say wider over narrower is unhelpful here since
> the two variants are from different categories.

Well, maybe it does and maybe it doesn't.  A language variant may be
less of a barrier than a script variant: as an American, I can understand
Scouse fairly well either in spoken form or in more or less conventional
orthography, but deciphering it in IPA (even though I know IPA) would
be much more difficult.

For that matter, the language-before-script rule doesn't even always apply
correctly when non-variants are involved.  For example, the standard
language line in the Scandinavian Peninsula runs north and south, but
the dialect isoglosses mostly run east and west.  So a Norwegian can
probably understand the speech of a Swede who lives at about the same
latitude; but in written form, Danish is for historical reasons much
more accessible than Swedish.

> Any sequence of variant tags MUST be reordered such that for each
> variant subtag A and B, B comes before A unless any of the following
> are true:

[detailed rules snipped]

This is a set of rules for *creating* tags from existing subtags rather
than for *canonicalizing* them, as Mark's proposals are.  These are
separate matters that shouldn't be confused.

My take is as follows:

1) It's clear that en-scouse-fonipa and en-fonipa-scouse have different
*matching* behaviors based on the RFC 4647 algorithms.

2) It's also clear, at least to me, that "en-scouce-fonipa" and
"en-fonipa-scouse" *mean* the same thing, the Scouse dialect of English
as recorded in IPA.

3) Canonicalization of tags is meant to eliminate non-semantic
differences; therefore, it is sensible to have some set of
canonicalization rules, even imperfect ones, to apply when multiple
variant subtags are present.  That does *not* mean that it's sensible
to have restrictions on the order in which subtags are used to construct
tags.

-- 
In my last lifetime,                            John Cowan
I believed in reincarnation;                    http://www.ccil.org/~cowan
in this lifetime,                               [email-masked]
I don't.  --Thiagi