Subject: RE: [Ltru] Re: Last Call: draft-mcwalter-langtag-mib (Language Ta g MIB) to Proposed Standard

From: "McDonald, Ira" <[email-masked]>
Date: Sat, 10 Feb 2007 13:15:58 -0800

Hi,

Right - ASN.1 doesn't allow discontinuous integer ranges.
The DESCRIPTION clause of this textual convention could
disallow the length of '1', but it's not important to do,
I think.

With respect to max length of 60, the public MIBs that
I'm aware of often use 63 octets and the rest use a
longer max length (except for the admittedly flawed
legacy objects in Printer MIB v2, RFC 3805 - I tried
to fix them before we published RFC 3805, but got shot
down by my co-editors).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-----Original Message-----
From: John Cowan [mailto:[email-masked]]
Sent: Saturday, February 10, 2007 1:16 PM
To: Doug Ewell
Cc: [email-masked]; LTRU Working Group; [email-masked]
Subject: [Ltru] Re: Last Call: draft-mcwalter-langtag-mib (Language Tag
MIB) to Proposed Standard

Doug Ewell scripsit:

> Since tags of 1 character are never well-formed, I suggest that the 
> definition:
> 
>   SYNTAX      OCTET STRING (SIZE (0..60))
> 
> be amended to exclude the 1-character case.  I assume that a zero-length 
> tag, while also not defined in RFC 4646, was included in the I-D to 
> allow the special case of "no tag."

AFAIK, ASN.1 does not allow sizes like (0, 2..60).  I wouldn't even
bother with this change.

-- 
John Cowan    [email-masked]    http://ccil.org/~cowan
Rather than making ill-conceived suggestions for improvement based on
uninformed guesses about established conventions in a field of study with
which familiarity is limited, it is sometimes better to stick to merely
observing the usage and listening to the explanations offered, inserting
only questions as needed to fill in gaps in understanding. --Peter Constable

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.441 / Virus Database: 268.17.33/678 - Release Date: 2/9/2007
4:06 PM

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Bill Fenner" <[email-masked]>
Date: Mon, 26 Feb 2007 19:29:24 -0500

On 2/10/07, McDonald, Ira <[email-masked]> wrote:
> I'm aware of often use 63 octets

Do you have any pointers?  I searched my MIB object database for
objects named "*Language*" or with DESCRIPTIONS with "Language"
inside, and only got the IP-MROUTE-MIB and MALLOC-MIB ones.  The
MALLOC-MIB one was interesting, since it uses
IPMROUTE-STD-MIB::LanguageTag(1..94).

Thanks,
  Bill