Subject: [Ltru] Re: Proposal for a subtag registration (fr-2004-ORTOGRAF)

From: "Mark Davis" <[email-masked]>
Date: Tue, 11 Dec 2007 07:49:44 -0800

It might be worth putting that text (wordsmithed a bit) into 4646bis:

One purpose of the registration process is to exclude idiosyncratic subtags:
those that do not have any usage beyond a handful of individuals for a brief
period of time.

On Dec 11, 2007 7:10 AM, Peter Constable <[email-masked]> wrote:

> > From: [email-masked] [mailto:ietf-languages-
> > [email-masked]] On Behalf Of Stephane Bortzmeyer
>
>
> > To put things into perspective, what problem do we try to solve by
> > limiting registrations to variants that have a sizable user base,
> > "well-enough attested"?
>
> [snip]
>
> > I candidly ask this because RFC 4646 never mentions the criteria of
> > "well-enough attested use". It just says "This requirement is not
> > intended to exclude particular languages or dialects due to the size
> > of the speaker population or lack of a standardized orthography.
> > Minority languages will be considered equally on their own merits."
>
> I don't think the request for established usage is in contradiction with
> what the RFC says, and I don't think it needs to be explicitly stated to be
> an operational principle here. I think what problem is being solved -- or,
> rather, what problem is being avoided -- is to prevent registration of
> subtags that will need to be widely supported indefinitely but which never
> had any potential value beyond a handful of individuals for a brief period
> of time.
>
>
> Peter
> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> http://www.alvestrand.no/mailman/listinfo/ietf-languages
>

-- 
Mark
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 11 Dec 2007 17:17:55 +0100

On Tue, Dec 11, 2007 at 07:49:44AM -0800,
 Mark Davis <[email-masked]> wrote 
 a message of 86 lines which said:

> One purpose of the registration process is to exclude idiosyncratic
> subtags: those that do not have any usage beyond a handful of
> individuals for a brief period of time.

Why? What does it buy us? Or which disease it protects us against?

---

From: "Mark Davis" <[email-masked]>
Date: Tue, 11 Dec 2007 08:24:32 -0800

In general, the more guidance we can provide reviewers, the more defensible
their actions become. We don't want to process to have the appearance of
being subject to favoritism, so where it does make sense to provide better
wording on what kinds of things are intended for registration and what not,
the better off we are.

Mark

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 11 Dec 2007 17:27:59 +0100

On Tue, Dec 11, 2007 at 08:24:32AM -0800,
 Mark Davis <[email-masked]> wrote 
 a message of 43 lines which said:

> In general, the more guidance we can provide reviewers, the more
> defensible their actions become.

We should ask the current Language Subtag Reviewer but I was under the
impression that he does not want to have too much micro-management of
its actions?

> where it does make sense to provide better wording on what kinds of
> things are intended for registration and what not, the better off we
> are.

I agree with the general goal (being precise and transparent) but I
dispute the fact that "vanity subtags" are a serious problem, worth of
an addition to the RFC.

---

From: "Frank Ellermann" <[email-masked]>
Date: Tue, 11 Dec 2007 18:03:07 +0100

Stephane Bortzmeyer wrote:

> I agree with the general goal (being precise and transparent)
> but I dispute the fact that "vanity subtags" are a serious
> problem, worth of an addition to the RFC.

Serious enough for the reviewer to mention it in conjunction
with the "ortograf" proposal.  He didn't ask for an addition
of a rule to the RFC, but he dislikes "vanity tags".

For some months in spring 2006 I watched the "Sealand" and the
"list of micronations" articles in en.wikipedia, and it was a
tough job for several editors to keep these two articles free
of nonsense for a single day.  And <pun> microlanguages </pun>
weren't much better.  Let alone all those "alternative roots"
such as the "Cesidian root" of an "Indigo child", president
(or whatever) of a micronation.  Won't surprise me if they'd
also claim to have their own language.  Certainly able to
write a set of Wikipedia articles linking to each other. :-(

 Frank

---

From: Addison Phillips <[email-masked]>
Date: Tue, 11 Dec 2007 11:33:29 -0800

> impression that he does not want to have too much micro-management of

It isn't just the LSR's actions that need defense. We need to provide 
clarity to registrants and set their expectations. Ultimately, the IESG 
may be appealed to and they need guidance that non-linguistic experts 
can understand about what is valid or not for registration.

Frankly, the current LSR should have rejected in a clear and unambiguous 
manner the request from the outset, citing the specific problems in RFC 
4646 (it's not a well-formed request).

> dispute the fact that "vanity subtags" are a serious problem, worth of

+1 to both of you.

I think that obvious vanity requests would not be tolerated by the list. 
But idiosyncratic registrations ought not be ruled out. "Idiosyncratic" 
is in the eye of the beholder. Even small linguistic communities may 
find valid uses for a variant.

What we need to provide is guidance on when to register a variant versus 
when to use a private use subtag. The more clarity we provide, the 
better this will be. That, I believe, is what Mark is trying to accomplish.

Addison

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.
Chair -- W3C Internationalization Core WG

Internationalization is an architecture.
It is not a feature.

---

From: Marion Gunn <[email-masked]>
Date: Tue, 11 Dec 2007 21:31:00 +0000

Suggest simplifying that somewhat, thus: "One purpose of the  
registration process is to exclude idiosyncratic and ephemeral subtags."
mg

> individuals for a brief period of time.

- -
Marion Gunn * EGTeo (Estab.1991)
27 Páirc an Fhéithlinn, Baile an
Bhóthair, Co. Átha Cliath, Éire.
* [email-masked] * [email-masked] *

---

From: Peter Constable <[email-masked]>
Date: Tue, 11 Dec 2007 19:04:28 -0800

> From: Stephane Bortzmeyer [mailto:[email-masked]]

> Why? What does it buy us? Or which disease it protects us against?

It protects lots of implementers from having to support subtags that don't really get used.

Peter

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 12 Dec 2007 12:02:38 -0800

Hi -

As a technical contributor...

> From: "Peter Constable" <[email-masked]>
> To: "LTRU Working Group" <[email-masked]>
> Sent: Tuesday, December 11, 2007 7:04 PM
> Subject: [Ltru] RE: Proposal for a subtag registration (fr-2004-ORTOGRAF)
>
...
> It protects lots of implementers from having to support subtags that don't really get used.
...

I don't find this persuasive.  After all, what does it mean to "support" a subtag,
and is this any different from the situtation with respect to the thousands of
language subtags referring to languages for which typical software will have
absolutely no special support?  As far as I can tell, the impact of encountering
an unknown subtag is no greater than running into (or needing to generate)
an unknown x-whatever.

<rhetorical>
Which are we more likely to see deployed in, say, a public information kiosk -
a browser with localization options for Gothic, for Klingon, or for something
like a simplified  French being discussed on the [email-masked]
list?  (To me it appears to be more than merely a simplified orthography,
if the pages I've read are any indication, since the writing I've seen was
also characterized by extreme clarity and simplicity.)
</rhetorical>

Randy

---

From: Peter Constable <[email-masked]>
Date: Wed, 12 Dec 2007 14:50:30 -0800

Please understand: I'm not among those opposed to this registration; I think it's a valid request, it looks like there probably is a user community, and so the main issue in my mind is how it relates to other things called 'ortograf'.

But I still think on ietf-languages we want some operational bar, whether formalized or not. Granted, since RFC 1766 we have provided a very large number of tags that need to be supported but which would not get used. Those are made from a limited set of subtags, though, and there are implementations that need to provide certain support for each subtag (e.g. providing UI strings). Each added variant subtag adds to those support requirements. I think it's reasonable to ask that those be things that really are going to get used, and to protect ourselves from supporting junk. If I were to request a subtag "flibtgit" for some idiosyncratic form of expression I just invented, I'd hope it would get rejected. Maybe the rationale I gave below isn't the basis you'd want to use for rejecting it -- fine, come up with a different statement. At the end of the day, I'd hope you'd reject it.

Peter.

> -----Original Message-----
> From: Randy Presuhn [mailto:[email-masked]]
> Sent: Wednesday, December 12, 2007 12:03 PM
> To: LTRU Working Group
> Subject: Re: [Ltru] RE: Proposal for a subtag registration (fr-2004-
> ORTOGRAF)
>
> Hi -
>

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 13 Dec 2007 15:43:52 +0100

On Tue, Dec 11, 2007 at 07:04:28PM -0800,
 Peter Constable <[email-masked]> wrote 

> It protects lots of implementers from having to support subtags that

No implementer will "support" all the languages (not to mention the
other subtags) of 4646bis/4645bis. They will recognize them (parse
them correctly) but I do not imagine a program whose authors will
commit to do something useful with *every* language in the LSR?