Subject: [Ltru] Re: John Cowan throws in the towel on extlangs

From: "Frank Ellermann" <[email-masked]>
Date: Sat, 1 Dec 2007 14:45:37 +0100

Addison Phillips wrote:

> if John's towel stays thrown, it wouldn't impact RFC 4646bis.

The extlang-ABNF and the "longest tag" discussion are affected,
or are you talking about 4645bis ?

 Frank

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Addison Phillips <[email-masked]>
Date: Sat, 01 Dec 2007 10:31:07 -0800

> or are you talking about 4645bis ?

Context is everything :-). The "it" in my sentence above refers to the 
impact of new Macrolanguage assignments by ISO 639. New Macrolanguage 
assignments, assuming no extlangs (i.e. a fully thrown, unretrieved 
towel), would have no impact on 4646bis.

The ABNF, longest tag, and other things, of course, are affected by the 
demise of extlangs.

Addison

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.
Chair -- W3C Internationalization Core WG

Internationalization is an architecture.
It is not a feature.

---

From: "Frank Ellermann" <[email-masked]>
Date: Sat, 1 Dec 2007 23:36:03 +0100

Addison Phillips wrote:
 
> New Macrolanguage assignments, assuming no extlangs (i.e.
> a fully thrown, unretrieved towel), would have no impact
> on 4646bis.

Is the Macrolanguage: header field proposal also dead,
as far as the Teleconference design team is concerned ?

Apparently I didn't get the purpose of Peter's list, if
it's unrelated to the deprecation of grandfathered zh-*
and similar constructs, was it about this header field ?

 Frank

---

From: Addison Phillips <[email-masked]>
Date: Sat, 01 Dec 2007 14:44:15 -0800

> as far as the Teleconference design team is concerned ?

Uh... no. And, yes, of course there would be some impact on 4646bis from 
having such a field. (header??? where'd that come from?)

Just not the impact you suggested in your previous note, as the impact 
will be limited to a few sentences describing the (informative) field. 
Procedurally there will be no impact on subtag assignment, deprecation, etc.

Addison

---

From: "Frank Ellermann" <[email-masked]>
Date: Sun, 2 Dec 2007 00:08:20 +0100

> Uh... no. And, yes, of course there would be some impact
> on 4646bis from having such a field. (header??? where'd
> that come from?)

Too many flamewars of replacing "header" by "header field"
in drafts related to message header fields, sorry.  It's a
"field" here, with a syntax like "header fields" elsewhere.

Needless to say that I liked the old (albeit sloppy) header
terminology where it was unambiguous, but I lost those wars.

 Frank