Subject: [Ltru] Re: Review of 4646bis-10, sections 3.5 to App. B

From: "Doug Ewell" <[email-masked]>
Date: Sat, 8 Dec 2007 10:24:43 -0800

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

> | Non-ASCII characters can be sent to IANA by attaching
> | the registration form to the email message or by
> | using various encodings in the mail message body
> | (UTF-8 is recommended).  IANA will verify any unclear
> | or corrupted characters with the Language Subtag
> | Reviewer prior to posting the updated registry.
>
> Can we please at least consider that neither IANA nor
> expert are idiots ?  It's no business of 4646bis to
> discuss technical details of the MUAs used by IANA and
> expert, as far as I'm concerned the expert can send
> IANA an URL where to find the complete registration,
> if IANA accepts this.  He could fax it, who cares ?

One of the big objections that people had to switching to UTF-8 was that 
the non-ASCII characters might get munged in transit.  This passage was 
added specifically to calm those nerves.

> | from
> | "http://www.iana.org/assignments/lang-subtags-templates/".
>
> What next, tell their Web master what software they have
> to use, or how to run backups ?  They told us that they
> intend to reorganize their Web site, and everybody knows
> that "cool" URIs are persistent.

People criticized the fact that 4646 didn't specify where the completed 
forms could be found.

> BTW, I vaguely recall that we didn't want chains:
>
> | Note: In rare cases, the mapped value will also have
> | a Preferred-Value.
>
> If a subtag Y gets a new Preferred-Value Z, then all X
> with Preferred-Value Y should be updated to say Z.
>
> IMO a clear case where getting it right in the registry
> once is better than asking obscure implementations to
> follow chained mappings.  Let alone erroneous cycles,
> such cycles could be related to "un-deprecated" codes.

We didn't want chains, but even more so, we didn't want to break the 
stability of the Preferred-Value field.

Regarding cycles, I think if you want to rely on IANA and the LSR to get 
things right rather than adding MUSTard, you surely ought to give them 
(or at least me, as Co-Designated Expert) credit for detecting and 
avoiding cycles.

>> Private use subtags, like all other subtags, MUST
>> conform to the format and content constraints in the
>> ABNF.  They have no meaning outside the private
>> agreement between the parties that intend to use or
>> exchange language tags that employ them, and so are
>> are simply useless for information exchange without
>> prior arrangement.
>
> Delete the whole paragraph, if folks don't know what
> "private" means then I'm pretty sure that they don't
> _want_ to know what it means, and adding text doesn't
> help.  Your wording is already shorter than the draft,
> but I think it's still too convoluted.

This was added in direct response to fears expressed during LTRU 1.0 
(which I did not share) that people would abuse private subtags.

Most of the text in the draft is there for a reason, because the WG 
wanted it there or agreed to have it put there.  Addison and Mark (like 
me) are editors, not authors; our job is to write drafts that reflect 
the will of the group.  It's always fair to ask why something is there 
or how it got there, but the answer might well be "because everyone 
insisted on it N months or years ago."

--
Doug Ewell  *  Fullerton, California, USA  *  RFC 4645  *  UTN #14
http://home.roadrunner.com/~dewell
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Frank Ellermann" <[email-masked]>
Date: Sat, 8 Dec 2007 21:21:48 +0100

Doug Ewell wrote:

> One of the big objections that people had to switching
> to UTF-8 was that the non-ASCII characters might get
> munged in transit.  This passage was added specifically
> to calm those nerves.

I'm aware of these "people", you're talking about John
and me, and John cried "doom".  While I hate UTF-8 for
the registry I never doubted that IANA and reviewer will
figure it out.  IIRC John's "doom" was also about folks
discussing on a mailing list, and for that part I still
support it.  

Even Martin is sometimes annoyed with his own MUA, I hope
I finally convinced my W2K that nothing is wrong with his
encoding.

> People criticized the fact that 4646 didn't specify 
> where the completed forms could be found.

Yes, because IANA didn't collect and publish them.  You
fixed that, and I found the pages on their site without
looking into 4646bis.  IANA is free to reorganize their
Web site, and then old URIs in an RFC are a royal PIT*
(Just an example, I try to post on [email-masked] )

> We didn't want chains, but even more so, we didn't
> want to break the stability of the Preferred-Value
> field.

IOW we got it wrong, let's fix it while we're at it.
"Stability of Preferred-Value" makes no sense, the
X -> Z shortcut for X -> Y -> Z can't cause harm.

> Regarding cycles, I think if you want to rely on 
> IANA and the LSR to get things right rather than
> adding MUSTard, you surely ought to give them (or
> at least me, as Co-Designated Expert) credit for
> detecting and avoiding cycles.

But it was you who said that "un-drepecating" isn't
allowed.  Maybe you'd also say that adding Y -> X
to a given X -> Y is at is, because the X can't be
"un-drepecated".  For the hypothetical FX example
if we'd end up with FX deprecated in favour of FX
it's obvious, but longer cycles are harder to spot.

> This was added in direct response to fears expressed
> during LTRU 1.0 (which I did not share) that people
> would abuse private subtags.

He-who-must-not-be-named will do what he likes, it's
a waste of time to tell the world how it has to judge
such inventions.

> Addison and Mark (like me) are editors, not authors

You *insist* on being an editor, for Addison that's a 
bit fictitious, isn't it ?  Inventing countries isn't
what I consider as editorial freedom.  For 4646 we had
Randy's list of tracked issues with his decisions, but
that was his list, it's quite possible that I hit an
old issue because I forgot it / changed my mind / was
never happy with his decision / whatever.

> It's always fair to ask why something is there or how
> it got there, but the answer might well be "because 
> everyone insisted on it N months or years ago."

If I wanted X months ago, and now want "not X" without
saying that and why I changed my mind, it's sad, but
not intentionally bad, just point it out.  In cases 
such as "UTF-8 instead of NCRs" I want tons of "not X"
because the former X was designed to work with NCRs.

 Frank