Subject: [Ltru] Update on draft-4645bis

From: "Doug Ewell" <[email-masked]>
Date: Wed, 16 Jan 2008 07:09:08 -0800

ISO 639-3 has announced the results of their latest round of change 
requests, on time.  There were a whopping 258 change requests during the 
past 6 months, which might indicate that the expected level of churn 
within 639-3, while not continuing at this pace, will still be quite a 
bit higher than what ietf-languages is accustomed to.

The remaining 10 changes are only promised to be announced "in the 
coming weeks," so draft-4645bis-04 will probably not be submitted to the 
RFC Editor until that point.  However, I'll post a revision soon that 
captures the other 248 changes.

Can I ask list members to review the text portion of draft-4645bis at 
least?  That part is unlikely to change as the result of future changes 
to ISO standards.  We need to agree (knowledgeably) on the procedure for 
filling the Registry before presenting it for WG Last Call and IETF Last 
Call.

http://www.ietf.org/internet-drafts/draft-ietf-ltru-4645bis-03.txt

I'll make special text-only and data-only copies available, for those 
who have requested them.

--
Doug Ewell  *  Fullerton, California, USA  *  RFC 4645  *  UTN #14
http://www.ewellic.org
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Peter Constable <[email-masked]>
Date: Wed, 16 Jan 2008 09:00:52 -0800

> From: Doug Ewell
> Sent: Wednesday, January 16, 2008 7:09 AM

> requests...

There is one change that I'm questioning: removal of a macrolanguage mapping.

The entry zha "Zhuang" is a macrolanguage; it formerly had two encompassed languages, ccx "Northern Zhuang" and ccy "Southern Zhuang". This was the state at initial publication of ISO 639-3. Now, researchers have determined (not at all surprisingly) that the Zhuang family is really made up of more than two individual languages. Thus, one of this round of changes has been to split Northern Zhuang into ten languages -- i.e., to deprecate ccx recommending the use of ten new IDs instead. These ten new entries are given macrolanguage mappings to zha. All of that is fine. However, in deprecating ccx, the ISO 639-3/RA has also removed its macrolanguage mapping to zha.

I hadn't realized (or don't recall noticing) that a similar change was made during 2006 wrt Southern Zhuang, with its macrolanguage mapping to zha also removed.

For our purposes (thinking in terms of on-going operational procedures, so speaking here for sake of discussion as though 4646bis were already approved), we can certainly deprecate ccx and ccy, but I would think we would not want to remove the Macrolanguage field from those entries.

Or do we care?

Peter

---

From: John Cowan <[email-masked]>
Date: Wed, 16 Jan 2008 12:23:33 -0500

Peter Constable scripsit:

> For our purposes (thinking in terms of on-going operational procedures,
> so speaking here for sake of discussion as though 4646bis were already
> approved), we can certainly deprecate ccx and ccy, but I would think
> we would not want to remove the Macrolanguage field from those entries.

I think the general principle is that we don't remove anything, because
of backward compatibility.  The exception would be an old name that is
a trivial variant of the new name (typo, or added hyphen, or some such)
or is offensive.  We already provide for the former case, but we may
need new language for the latter.  (Addison?)

> Or do we care?

Nobody knows if we care or not, because nobody knows what uptake the
Macrolanguage: header will have, if any.

I wish that SIL had made Northern and Southern Zhang into nested
macrolanguages instead of just deprecating them, since they are pretty
well recognized terms.

-- 
There are three kinds of people in the world:   John Cowan
those who can count,                            [email-masked]
and those who can't.

---

From: Addison Phillips <[email-masked]>
Date: Wed, 16 Jan 2008 09:24:28 -0800

> For our purposes (thinking in terms of on-going operational procedures, so speaking here for sake of discussion as though 4646bis were already approved), we can certainly deprecate ccx and ccy, but…

One thing this suggests: perhaps we should provide a mechanism for doing 
smaller "bulk" updates from ISO 639-3 (etc.) in which more than a single 
record can be updated/inserted.

Addison

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.
Chair -- W3C Internationalization Core WG

Internationalization is an architecture.
It is not a feature.

---

From: "Frank Ellermann" <[email-masked]>
Date: Wed, 16 Jan 2008 21:34:47 +0100

> Or do we care?

Yes.  I think it's the idea of the Macrolanguage field that 
the registry can reflect the state of the art in 639-3, and
isn't forced to preserve an old state in the form of extlang.

 Frank

---

From: "Doug Ewell" <[email-masked]>
Date: Sat, 19 Jan 2008 10:19:14 -0800

> macrolanguages instead of just deprecating them, since they are pretty 

Is there any indication that ISO 639-3 (the standard or the RA) 
recognizes the concept of nested macrolanguages?  I haven't seen any.  I 
know the rejected extlang mechanism would have allowed for up to three 
levels, just in case they did exist.

---

From: John Cowan <[email-masked]>
Date: Sat, 19 Jan 2008 13:39:19 -0500

Doug Ewell scripsit:

> recognizes the concept of nested macrolanguages?  I haven't seen any.  

No, but nor is there any indication that they accept or even understand
the concept, either.

-- 
When I'm stuck in something boring              John Cowan
where reading would be impossible or            (who loves Asimov too)
rude, I often set up math problems for          [email-masked]
myself and solve them as a way to pass          http://www.ccil.org/~cowan
the time.      --John Jenkins

---

From: Peter Constable <[email-masked]>
Date: Sun, 20 Jan 2008 00:27:51 -0800

> From: John Cowan

> No, but nor is there any indication that they accept or even understand

At the moment, "Guibei Zhuang" (zgb) et al have macrolanguage mappings to "Zhuang" (zha). Suppose these were given macrolanguage mappings to "Northern" (ccx) or "Southern Zhuang" (ccy): since ccx and ccy are now deprecated, the relationship that is probably of most interest is that between zgb and zha. So, to capture that, one of two things would have to be done:

- allow an entry like zgb to have multiple macrolanguage mappings, mapping to both ccx and zha; or

- define some kind of transitive relationship -- for sake of discussion, call it _derived macrolanguage mapping_ == such that if MacrolanguageOf(zgb) = ccx and MacrolanguageOf (ccx) = zha than DerivedMacrolanguageOf(zgb) = zha.

Since macrolanguage is a normatively-defined relationship in 639-3, then derived macrolanguage should also be defined normatively in 639-3. We could amend the standard for something like this, though it's not clear to me if it would be worth it. Note a couple of things:

- if we can have multiple levels of macrolanguage embedding, then it's not clear to me how the derived macrolanguage mapping should work. E.g., support a three level embedding involving languages W, X, Y and Z with MacrolanguageOf(W) = X, MacrolanguageOf(X) = Y and MacrolanguageOf(Y) = Z, then what?

DerivedMacrolanguageOf(W) = Z?
DerivedMacrolanguageOf(W) = {X, Y, Z}?

And if the latter, just how much formal, mathematical machinery do we really want to use in building up ISO 639?

- What's the practical application for these additional relationships? If ccx is deprecated, do we expect people to create new uses that will also make use of a zgb-ccx macrolanguage relationship?

It seems like hierarchical macrlanguage mappings would entail a bunch of new work when there's no indication of any application for using it. The main point of the macrolanguage was to provide a way to deal with exceptional 639-2 cases like zha. By saying that zha is a macrolanguage that encompasses (now) zgb et al, then the zha is handled equally well as when we said (before) that zha encompasses ccx and ccy. We did not previously have a dichotomous quandary as to how to handle ccx and ccy: they were deemed individual languages.

I suppose now we might say that a dichotomy for ccx has been introduced in that it has been used as an individual language but now we consider its denotation range to be multiple individual languages -- which was the issue for entries like zha. I guess the alternative path getting adopted is to say that ccx is "retired" rather than say its scope has changed from individual language to macrolanguage.

I kind of wished that 639-2 had from the outset defined zha as "Zhuang languages", or that in the course of adopting 639-3 we had changed it to that (and never defined macrolanguage mappings). With recent research determining that Zhuang is better analyzed as sixteen different languages rather than two, it seems like considering zha to be a collection makes more sense. But, the macrolanguage mappings to zha got defined, hence making it a macrolanguage, and it seems to me that just getting rid of those macrolanguage mappings could potentially be a problem for some existing implementations. No matter how we handle these kinds of things, we're taxonomists of human behaviour, which is not inherently amenable to taxonomies of sharp-boundary categories, so can never be said to be "perfect". So, I'm content to say that what's being done is "good enough".

Peter