Subject: RE: [Ltru] Re: action item: "other" collections in 639

From: Peter Constable <[email-masked]>
Date: Mon, 7 Jan 2008 15:46:43 -0800

Update on this: I’ve got agreement in principle from LOC to change entries of the form “Foo (Other)” to “Foo languages” in ISO 639-2. In doing this, they want to provide some info as to which individual-language entries in 639-2 are encompassed within each collection so that applications can derive “other” groups if that’s how they want to use them. So, I’m not sure just how quickly that change will appear in the code tables on the 639-2 site. (I wouldn’t expect to see a change on the 639-3 site until that has changed on the 639-2 site.)

Peter

From: Peter Constable [mailto:[email-masked]]
Sent: Thursday, November 29, 2007 8:13 AM
To: [email-masked]
Subject: RE: [Ltru] Re: action item: "other" collections in 639

Let me clarify this sub-thread: I have questioned in the past whether language collection ID of any kind are useful in IETF language tags. Whenever I made that suggestion, there were others here insisting that they wanted them kept.

I am not proposing any change in this regard at this time. This only came up because I had poorly worded my statement about getting rid of “(Other)” from language-collection names, and Doug thought I was suggesting that ISO 639 “withdraw” those entries – I was not suggesting that.

Let me clarify what change I am pursuing: I am asking the JAC to remove “(Other)” from the names of language-collection entries that currently contain that string. That is *all* this thread was intended to be about.

Peter

From: Mark Davis [mailto:[email-masked]]
Sent: Thursday, November 29, 2007 7:53 AM
To: Frank Ellermann
Cc: [email-masked]
Subject: Re: [Ltru] Re: action item: "other" collections in 639

Nobody is calling for removing. Peter's action was to take "(Other)" out of the names, that's all.

Mark
On Nov 29, 2007 7:25 AM, Frank Ellermann < [email-masked]<mailto:[email-masked]>> wrote:
Peter Constable wrote:

> I've suggested in the past that removing collection IDs from
> BCP47 might not be a bad idea, but on several occasions people
> have indicated that they wish to have the collections kept.
"Removing" can't fly.  Do you mean "not add new" (in the 4645bis
bulk update), "deprecate old", or both ?

 Frank

_______________________________________________
Ltru mailing list
[email-masked]<mailto:[email-masked]>
https://www1.ietf.org/mailman/listinfo/ltru

--
Mark
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Mon, 7 Jan 2008 15:53:23 -0800

Great news, thanks for managing this!

Mark

On Jan 7, 2008 3:46 PM, Peter Constable <[email-masked]> wrote:

>  Update on this: I've got agreement in principle from LOC to change
> entries of the form "Foo (Other)" to "Foo languages" in ISO 639-2. In doing
> this, they want to provide some info as to which individual-language entries
> in 639-2 are encompassed within each collection so that applications can
> derive "other" groups if that's how they want to use them. So, I'm not sure
> just how quickly that change will appear in the code tables on the 639-2
> site. (I wouldn't expect to see a change on the 639-3 site until that has
> changed on the 639-2 site.)
>
>
>
>
>
> Peter
>
>
>
> *From:* Peter Constable [mailto:[email-masked]]
> *Sent:* Thursday, November 29, 2007 8:13 AM
> *To:* [email-masked]
> *Subject:* RE: [Ltru] Re: action item: "other" collections in 639
>
>
>
> Let me clarify this sub-thread: I have questioned in the past whether
> language collection ID of any kind are useful in IETF language tags.
> Whenever I made that suggestion, there were others here insisting that they
> wanted them kept.
>
>
>
> I am not proposing any change in this regard at this time. This only came
> up because I had poorly worded my statement about getting rid of "(Other)"
> from language-collection names, and Doug thought I was suggesting that ISO
> 639 "withdraw" those entries – I was not suggesting that.
>
>
>
> Let me clarify what change I am pursuing: I am asking the JAC to remove
> "(Other)" from the names of language-collection entries that currently
> contain that string. That is **all** this thread was intended to be about.
>
>
>
>
>
> Peter
>
>
>
> *From:* Mark Davis [mailto:[email-masked]]
> *Sent:* Thursday, November 29, 2007 7:53 AM
> *To:* Frank Ellermann
> *Cc:* [email-masked]
> *Subject:* Re: [Ltru] Re: action item: "other" collections in 639
>
>
>
> On Nov 29, 2007 7:25 AM, Frank Ellermann < [email-masked]>
> wrote:
>
> Peter Constable wrote:
>

---

From: John Cowan <[email-masked]>
Date: Mon, 7 Jan 2008 19:27:44 -0500

> changed on the 639-2 site.)

Pulling together the Ethnologue 14 data, we find the following, which
is probably out of date in some places -- someone needs to go through
the 639-2 registrations since 2002 (Doug?)

Afro-Asiatic (Other) [afa] includes:
        ber     Berber (Other)   [collective]
        cop     Coptic
        cus     Cushitic (Other)         [collective]
        hau     Hausa
        sem     Semitic (Other)          [collective]
        wal     Walamo

Altaic (Other) [tut] includes:
        aze     Azerbaijani
        bak     Bashkir
        bua     Buriat
        chg     Chagatai
        chv     Chuvash
        kaa     Kara-Kalpak
        kaz     Kazakh
        kir     Kirghiz
        kum     Kumyk
        mnc     Manchu
        mon     Mongolian
        tat     Tatar
        tur     Turkish
        ota     Turkish, Ottoman (1500-1928)
        tuk     Turkmen
        tyv     Tuvinian
        uig     Uighur
        uzb     Uzbek
        sah     Yakut

Austronesian (Other) [map] includes:
        ace     Achinese
        ban     Balinese
        btk     Batak (Indonesia)
        bug     Buginese
        cmc     Chamic languages         [collective]
        cha     Chamorro
        chk     Chuukese
        day     Dayak
        fij     Fijian
        gay     Gayo
        gil     Gilbertese
        gor     Gorontalo
        haw     Hawaiian
        iba     Iban
        ind     Indonesian
        jav     Javanese
        kos     Kosraean
        mad     Madurese
        mak     Makasar
        mlg     Malagasy
        may     Malay
        mdr     Mandar
        mao     Maori
        mah     Marshall
        min     Minangkabau
        nau     Nauru
        nia     Nias
        niu     Niuean
        pau     Palauan
        phi     Philippine (Other)       [collective]
        pon     Pohnpeian
        rap     Rapanui
        rar     Rarotongan
        smo     Samoan
        sas     Sasak
        sun     Sundanese
        tah     Tahitian
        tet     Tetum
        tkl     Tokelau
        ton     Tonga (Tonga Islands)
        tvl     Tuvalu
        yap     Yapese

Baltic (Other) [bal] includes:
        lav     Latvian
        lit     Lithuanian

Bantu (Other) [bnt] includes:
        bai     Bamileke languages       [collective]
        bas     Basa
        bem     Bemba
        nya     Chichewa; Nyanja
        dua     Duala
        eka     Ekajuk
        ewo     Ewondo
        fan     Fang
        lug     Ganda
        her     Herero
        kam     Kamba
        kik     Kikuyu
        kmb     Kimbundu
        kin     Kinyarwanda
        kon     Kongo
        kua     Kuanyama
        lam     Lamba
        lin     Lingala
        loz     Lozi
        lub     Luba-Katanga
        lua     Luba-Lulua
        lun     Lunda
        lol     Mongo
        nde     Ndebele, North
        nbl     Ndebele, South
        ndo     Ndonga
        nym     Nyamwezi
        nyn     Nyankole
        nyo     Nyoro
        run     Rundi
        sna     Shona
        nso     Sotho, Northern
        sot     Sotho, Southern
        suk     Sukuma
        swa     Swahili
        ssw     Swati
        tiv     Tiv
        tog     Tonga (Nyasa)
        tso     Tsonga
        tsn     Tswana
        tum     Tumbuka
        umb     Umbundu
        ven     Venda
        xho     Xhosa
        yao     Yao
        zul     Zulu

Berber (Other) [ber] includes:
        kab     Kabyle
        tmh     Tamashek
        zen     Zenaga

Celtic (Other) [cel] includes:
        bre     Breton
        cor     Cornish
        gla     Gaelic (Scots)
        gle     Irish
        glv     Manx
        wel     Welsh

Creoles and Pidgins (Other) [crp] includes:
        chn     Chinook jargon
        cpe     Creoles and pidgins, English based (Other)       [collective]
        cpf     Creoles and pidgins, French-based (Other)        [collective]
        cpp     Creoles and pidgins, Portuguese-based (Other)    [collective]
        hmo     Hiri Motu
        pap     Papiamento
        sag     Sango

Creoles and pidgins, English based (Other) [cpe] includes:
        bis     Bislama
        tpi     Tok Pisin

Creoles and pidgins, French-based (Other) [cpf] includes:
        nothing

Creoles and pidgins, Portuguese-based (Other) [cpp] includes:
        nothing

Cushitic (Other) [cus] includes:
        aar     Afar
        bej     Beja
        orm     Oromo
        sid     Sidamo
        som     Somali

Dravidian (Other) [dra] includes:
        gon     Gondi
        kan     Kannada
        kru     Kurukh
        mal     Malayalam
        tam     Tamil
        tel     Telugu

Finno-Ugrian (Other) [fiu] includes:
        est     Estonian
        fin     Finnish
        hun     Hungarian
        kom     Komi
        chm     Mari
        smi     Sami languages (Other)   [collective]
        vot     Votic

Germanic (Other) [gem] includes:
        afr     Afrikaans
        dan     Danish
        dut     Dutch
        eng     English
        fao     Faroese
        fry     Frisian
        ger     German
        got     Gothic
        ice     Icelandic
        ltz     Letzeburgesch
        nds     Low German; Low Saxon
        nor     Norwegian
        sco     Scots
        swe     Swedish

Indic (Other) [inc] includes:
        asm     Assamese
        awa     Awadhi
        ben     Bengali
        bho     Bhojpuri
        bih     Bihari
        bra     Braj
        div     Divehi
        doi     Dogri
        guj     Gujarati
        him     Himachali
        hin     Hindi
        kas     Kashmiri
        kok     Konkani
        lah     Lahnda
        mag     Magahi
        mai     Maithili
        mar     Marathi
        mwr     Marwari
        nep     Nepali
        ori     Oriya
        pli     Pali
        pan     Panjabi
        raj     Rajasthani
        rom     Romany
        san     Sanskrit
        snd     Sindhi
        sin     Sinhalese
        urd     Urdu

Indo-European (Other) [ine] includes:
        alb     Albanian
        arm     Armenian
        bat     Baltic (Other)   [collective]
        cel     Celtic (Other)   [collective]
        gem     Germanic (Other)         [collective]
        grc     Greek, Ancient (to 1453)
        gre     Greek, Modern (1453-)
        inc     Indic (Other)    [collective]
        ira     Iranian (Other)          [collective]
        lat     Latin
        roa     Romance (Other)          [collective]
        sla     Slavic (Other)   [collective]

Iranian (Other) [ira] includes:
        ave     Avestan
        bal     Baluchi
        jpr     Judeo-Persian
        kur     Kurdish
        oss     Ossetian; Ossetic
        per     Persian
        pus     Pushto
        tgk     Tajik

Khoisan (Other) [khi] includes:
        sad     Sandawe

Mon-Khmer (Other) includes:
        kha     Khasi
        khm     Khmer
        vie     Vietnamese

Niger-Kordofanian (Other) [nic] includes:
        ada     Adangme
        aka     Akan
        bam     Bambara
        bad     Banda
        bnt     Bantu (Other)    [collective]
        bin     Bini
        dyu     Dyula
        efi     Efik
        ewe     Ewe
        fat     Fanti
        fon     Fon
        ful     Fulah
        gaa     Ga
        gba     Gbaya
        ibo     Igbo
        ijo     Ijo
        kpe     Kpelle
        kro     Kru
        man     Mandingo
        men     Mende
        mos     Mossi
        nzi     Nzima
        srr     Serer
        snk     Soninke
        sus     Susu
        tem     Timne
        twi     Twi
        vai     Vai
        wol     Wolof
        yor     Yoruba
        znd     Zande

Nilo-Saharan (Other) [ssa] includes:
        ach     Acoli
        din     Dinka
        kau     Kanuri
        luo     Luo (Kenya and Tanzania)
        mas     Masai
        nub     Nubian languages         [collective]
        son     Songhai

Romance (Other) [roa] includes:
        ast     Asturian; Bable
        cat     Catalan
        cos     Corsican
        fre     French
        fur     Friulian
        glg     Gallegan
        ita     Italian
        lad     Ladino
        mol     Moldavian
        oci     Occitan (post 1500); Proven�al
        por     Portuguese
        roh     Raeto-Romance
        rum     Romanian
        srd     Sardinian
        spa     Spanish

Sami languages (Other) [smi] includes:
        sme     Northern Sami

Semitic (Other) [sem] includes:
        amh     Amharic
        ara     Arabic
        arc     Aramaic
        gez     Geez
        heb     Hebrew
        jrb     Judeo-Arabic
        mlt     Maltese
        sam     Samaritan Aramaic
        syr     Syriac
        tig     Tigre
        tir     Tigrinya

Sino-Tibetan (Other) [sit] includes:
        bur     Burmese
        chi     Chinese
        dzo     Dzongkha
        kac     Kachin
        kar     Karen
        lus     Lushai
        mni     Manipuri
        new     Newari
        tib     Tibetan

Slavic (Other) [sla] includes:
        bel     Belarusian
        bos     Bosnian
        bul     Bulgarian
        chu     Church Slavic
        scr     Croatian
        cze     Czech
        mac     Macedonian
        pol     Polish
        rus     Russian
        scc     Serbian
        slo     Slovak
        slv     Slovenian
        wen     Sorbian languages        [collective]
        ukr     Ukrainian

Tai (Other) [tai] includes:
        lao     Lao
        shn     Shan
        tha     Thai
        zha     Zhuang

-- 
A witness cannot give evidence of his           John Cowan
age unless he can remember being born.          [email-masked]
--Judge Blagden                               http://www.ccil.org/~cowan

---

From: Peter Constable <[email-masked]>
Date: Mon, 7 Jan 2008 18:04:59 -0800

> From: John Cowan

> > In doing
> the 639-2 registrations since 2002

Joan Spanne (SIL, 639-3 RA) has been working on relationships between collections, macrolanguages and individual languages, and will be following up with LOC to help get this done.

Peter