Subject: [Ltru] Inconsistency in descriptions in BCP 47.

From: "Mark Davis" <[email-masked]>
Date: Wed, 30 Apr 2008 17:40:16 -0700

BCP 47 says:

o Added

* Added's field-value contains the date the record was added to
the registry.

...

o Deprecated

* Deprecated's field-value contains the date the record was
deprecated.

The normal reading of this would be the date that the record was added to
the language subtag registry, which is what is defined by BCP 47. That
registry did not exist, formally, until September 2006 (when BCP was
issued). That makes the following be inconsistent, since it has dates before
2006-09, and even before 2005-10-16:

%%
Type: grandfathered
Tag: no-nyn
Description: Norwegian Nynorsk
Added: 1995-08-23
Preferred-Value: nn
Deprecated: 2000-02-18
Comments: replaced by ISO code nn

Suggested fix is:

o Added

* Added's field-value contains the date the record was added to
the IANA language subtag registry or, if grandfathered, the
date the corresponding entry was added to the RFC3066 IANA
language tag registry.

...

o Deprecated

* Deprecated's field-value contains the date the record was
deprecated in the IANA language subtag registry or, if grandfathered, the
date the corresponding entry was deprecated in the RFC3066 IANA
language tag registry.

(Note that this also makes the text consistent with the 4645 description
2.9.)

-- 
Mark
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 30 Apr 2008 18:16:39 -0700

Good catch, but with a few minor edits needed. Primarily: it is not just grandfathered tags have this problem. Redundant tags do too. Also, a few subtags have “Date A”/”Date B” problems (cf. ‘id’). Note also that I say ‘registered’ rather than ‘added’. I also made the text more consistent with other field types (avoiding the whole “field-body” locution).

I made the one on Added read:

--
<t>'Added' contains the date the record was registered or, in the case of grandfathered or redundant tags, the
date the corresponding tag was registered under the rules of <xref target="RFC1766"></xref> and/or <xref target="RFC3066"></xref>.</t>
--

And Deprecated’s reads:

--
<t>'Deprecated' contains the date the record was deprecated. Note that some registry entries, including both a few subtags and some of the grandfathered or redundant tags were deprecated prior to adoption of <xref target="RFC4646"></xref>.</t>
--

This will, of course, appear in draft-14.

Addison

Addison Phillips
Globalization Architect -- Lab126
Chair -- W3C Internationalization Core WG

Internationalization is not a feature.
It is an architecture.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Davis
Sent: Wednesday, April 30, 2008 5:40 PM
To: LTRU Working Group
Subject: [Ltru] Inconsistency in descriptions in BCP 47.

BCP 47 says:
o Added

...

o Deprecated

The normal reading of this would be the date that the record was added to the language subtag registry, which is what is defined by BCP 47. That registry did not exist, formally, until September 2006 (when BCP was issued). That makes the following be inconsistent, since it has dates before 2006-09, and even before 2005-10-16:

%%
Type: grandfathered
Tag: no-nyn

Suggested fix is:
o Added

...

o Deprecated

(Note that this also makes the text consistent with the 4645 description 2.9.)

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 30 Apr 2008 19:40:04 -0700

Those are good changes; I have one further suggestion below.

I assume that all subtags with deprecation dates were either after the
subtag registry was formed or were in the tag registry. If that is not true,
can we discuss those cases?

On Wed, Apr 30, 2008 at 6:16 PM, Phillips, Addison <[email-masked]>
wrote:

>  Good catch, but with a few minor edits needed. Primarily: it is not just
> grandfathered tags have this problem. Redundant tags do too. Also, a few
> subtags have "Date A"/"Date B" problems (cf. 'id'). Note also that I say
> 'registered' rather than 'added'. I also made the text more consistent with
> other field types (avoiding the whole "field-body" locution).
>
>
>
> date the corresponding tag was registered under the rules of <xref
> target="RFC1766"></xref> and/or <xref target="RFC3066"></xref>.</t>
>
> --
>
>
>
> And Deprecated's reads:
>
>
>
> --
>
> <t>'Deprecated' contains the date the record was deprecated. Note that
> some registry entries, including both a few subtags and some of the
> grandfathered or redundant tags were deprecated prior to adoption of <xref
> target="RFC4646"></xref>.</t>
>
=>
<t>'Deprecated' contains the date the record was deprecated, or in the case
of some registry entries (including a few subtags and some of the
grandfathered or redundant tags), the date the corresponding tag was
registered under the rules of <xref target="RFC1766"></xref> and/or <xref
target="RFC3066"></xref>.</t>

[to be more parallel and have the first sentence be less misleading.]

> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *Mark Davis
> *Sent:* Wednesday, April 30, 2008 5:40 PM
> *To:* LTRU Working Group
> *Subject:* [Ltru] Inconsistency in descriptions in BCP 47.
>
>
>
> BCP 47 says:
>
> o Added
>

---

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 30 Apr 2008 21:31:55 -0700

The cases where subtags were deprecated “before the subtag registry” all focus on “dead on arrival” items like il/he or id/in, AFAIK. Those were NOT in the tag registry but have to do with ISO 639 or ISO 3166  changes. Cf:

%%
Type: region
Subtag: DD
Description: German Democratic Republic
Added: 2005-10-16
Preferred-Value: DE
Deprecated: 1990-10-30
%%

Addison

Addison

Addison Phillips

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Davis
Sent: Wednesday, April 30, 2008 7:40 PM
To: Phillips, Addison
Cc: LTRU Working Group
Subject: Re: [Ltru] Inconsistency in descriptions in BCP 47.

I assume that all subtags with deprecation dates were either after the subtag registry was formed or were in the tag registry. If that is not true, can we discuss those cases?
On Wed, Apr 30, 2008 at 6:16 PM, Phillips, Addison <[email-masked]<mailto:[email-masked]>> wrote:

Good catch, but with a few minor edits needed. Primarily: it is not just grandfathered tags have this problem. Redundant tags do too. Also, a few subtags have "Date A"/"Date B" problems (cf. 'id'). Note also that I say 'registered' rather than 'added'. I also made the text more consistent with other field types (avoiding the whole "field-body" locution).

--

--

And Deprecated's reads:

--

<t>'Deprecated' contains the date the record was deprecated. Note that some registry entries, including both a few subtags and some of the grandfathered or redundant tags were deprecated prior to adoption of <xref target="RFC4646"></xref>.</t>
=>
<t>'Deprecated' contains the date the record was deprecated, or in the case of some registry entries (including a few subtags and some of the grandfathered or redundant tags), the date the corresponding tag was registered under the rules of <xref target="RFC1766"></xref> and/or <xref target="RFC3066"></xref>.</t>

--

Addison

Addison Phillips

It is an architecture.

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Mark Davis
Sent: Wednesday, April 30, 2008 5:40 PM
To: LTRU Working Group
Subject: [Ltru] Inconsistency in descriptions in BCP 47.

BCP 47 says:

o Added

...

o Deprecated

%%
Type: grandfathered
Tag: no-nyn

Suggested fix is:

o Added

...

o Deprecated

--
Mark