Subject: [Ltru] 2.2.6: extensions within overall tag syntax

From: Peter Constable <[email-masked]>
Date: Mon, 7 Jul 2008 13:13:44 -0700

Draft 16 currently has this text in Section 2.2.6:

--------------
Extension subtags MUST follow all language, script, region, and variant subtags in a tag.
--------------

I suggest a revision to the following:

--------------
Extension subtags MUST follow all language, script, region, and variant subtags in a tag, but MUST precede any private-use subtag sequences.
--------------

Peter

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Mon, 7 Jul 2008 14:50:10 -0700

It goes without saying that they precede private-use sequences.

But I made the change anyway.

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Peter Constable
> Sent: Monday, July 07, 2008 1:14 PM
> To: LTRU Working Group
> Subject: [Ltru] 2.2.6: extensions within overall tag syntax
>
> Extension subtags MUST follow all language, script, region, and
> variant subtags in a tag, but MUST precede any private-use subtag
> sequences.
> --------------
>
>
> Peter
>

---

From: "Broome, Karen" <[email-masked]>
Date: Mon, 7 Jul 2008 15:42:58 -0700

I support this clarification based on the misinterpretations I've seen of this text in the wild.

Karen

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Peter Constable [[email-masked]]
Sent: Monday, July 07, 2008 1:13 PM
To: LTRU Working Group
Subject: [Ltru] 2.2.6: extensions within overall tag syntax

--------------

--------------

Peter