Subject: [Ltru] 2.1: casing

From: Peter Constable <[email-masked]>
Date: Mon, 7 Jul 2008 08:01:55 -0700

This paragraph doesn't make complete sense to me:

---------------------
Although case distinctions do not carry meaning in language tags, consistent formatting and presentation of the tags will aid users. The format of the tags and subtags in the registry is RECOMMENDED. In this format, all subtags, including all those following singletons (that is, in extension or private-use sequences) are in lowercase. The exceptions to this are: all other non-initial two-letter subtags are uppercase and all other non-initial four-letter subtags are titlecase.
---------------------

The format of subtags in the registry uses case as recommended by the various ISO standards. Thus, why does this suggest that for the format in the registry "all subtags... are in lowercase"?

Also, "...all other non-initial two-letter subtags..." - other than what?

I can't suggest alternate wording since it's not at all clear to me what was intended.

Peter
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Mon, 7 Jul 2008 08:18:57 -0700

What was intended by that text is that (a) if you see non-initial xxxx, it
should be Xxxx, and non-initial xx should be XX, and everything else should
be lowercase. The alternative is (b) the script code be Xxxx and the region
code be XX, and everything else should be lowercase. The difference is
illustrated by en-US-x-AB vs en-US-x-ab.

Option (b) would require slightly more smarts in parsing (you have to shift
modes when you hit a singleton), so some people wanted (a). I have a slight
preference for (b) but can live with (a).

Mark

On Mon, Jul 7, 2008 at 8:01 AM, Peter Constable <[email-masked]>
wrote:

> Although case distinctions do not carry meaning in language tags,
> consistent formatting and presentation of the tags will aid users. The
> format of the tags and subtags in the registry is RECOMMENDED. In this
> format, all subtags, including all those following singletons (that is, in
> extension or private-use sequences) are in lowercase. The exceptions to this
> are: all other non-initial two-letter subtags are uppercase and all other
> non-initial four-letter subtags are titlecase.
> ---------------------
>
> The format of subtags in the registry uses case as recommended by the
> various ISO standards. Thus, why does this suggest that for the format in
> the registry "all subtags... are in lowercase"?
>

---

From: John Cowan <[email-masked]>
Date: Mon, 7 Jul 2008 11:29:19 -0400

Peter Constable scripsit:

> format of the tags and subtags in the registry is RECOMMENDED. In
> this format, all subtags, including all those following singletons
> (that is, in extension or private-use sequences) are in lowercase. The
> exceptions to this are: all other non-initial two-letter subtags are
> uppercase and all other non-initial four-letter subtags are titlecase.

I think striking the two instances of "other" deals with the problem:
all subtags are lowercase, except for non-initial two-letter tags, which
are uppercase, and non-initial four-letter tags, which are titlecase.

(Come to think of it, that's probably a clearer wording; I hereby
propose it.)

Note that the "non-initial two-letter subtags need not be region subtags:
we write sgn-BE-FR, for example.

-- 
That you can cover for the plentiful            John Cowan
and often gaping errors, misconstruals,         http://www.ccil.org/~cowan
and disinformation in your posts                [email-masked]
through sheer volume --that is another
misconception.  --Mike to Peter
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Mon, 7 Jul 2008 08:39:57 -0700

> consistent formatting and presentation of the tags will aid users.
> The format of the tags and subtags in the registry is RECOMMENDED.
> In this format, all subtags, including all those following
> singletons (that is, in extension or private-use sequences) are in
> lowercase. The exceptions to this are: all other non-initial two-
> letter subtags are uppercase and all other non-initial four-letter
> subtags are titlecase.
> ---------------------
>
> The format of subtags in the registry uses case as recommended by
> the various ISO standards. Thus, why does this suggest that for the
> format in the registry "all subtags... are in lowercase"?

The registered variants are all lowercase. Private use and extension sequences normalize to lower case. If you read the paragraph again you'll see that it describes simple rules for implementing a casing algorithm for language tags that doesn't rely on the registry.

> Also, "...all other non-initial two-letter subtags..." - other than

Other than the ISO 3166 codes, which are upper case, plus the grandfathered sgn-* cruft. But the words "other" and "non-initial" should not modify one-another. We should probably omit one of them.

Addison

---

From: Peter Constable <[email-masked]>
Date: Mon, 7 Jul 2008 10:24:07 -0700

> From: Phillips, Addison [mailto:[email-masked]]

> The registered variants are all lowercase. Private use and extension
> sequences normalize to lower case. If you read the paragraph again
> you'll see that it describes simple rules for implementing a casing
> algorithm for language tags that doesn't rely on the registry.

Perhaps that's the intent, but that's not at all clear from that wording. The wording says that *all* subtags are in lowercase.

Peter

---

From: "Mark Davis" <[email-masked]>
Date: Mon, 7 Jul 2008 10:35:22 -0700

+1 I think that'd be clearer wording.

Mark

On Mon, Jul 7, 2008 at 8:29 AM, John Cowan <[email-masked]> wrote:

> and often gaping errors, misconstruals,         http://www.ccil.org/~cowan<http://www.ccil.org/%7Ecowan>

---

From: Peter Constable <[email-masked]>
Date: Mon, 7 Jul 2008 10:48:28 -0700

That helps clear up the last sentence. But I still see a problem with “In this format, all subtags… are in lowercase”, which doesn’t appear to be what is really intended.

Peter

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Davis
Sent: Monday, July 07, 2008 10:35 AM
To: John Cowan
Cc: Peter Constable; LTRU Working Group
Subject: Re: [Ltru] 2.1: casing

Mark
On Mon, Jul 7, 2008 at 8:29 AM, John Cowan <[email-masked]<mailto:[email-masked]>> wrote:

--
That you can cover for the plentiful            John Cowan
and often gaping errors, misconstruals,         http://www.ccil.org/~cowan<http://www.ccil.org/%7Ecowan>
and disinformation in your posts                [email-masked]<mailto:[email-masked]>
through sheer volume --that is another
misconception.  --Mike to Peter
_______________________________________________
Ltru mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Mon, 7 Jul 2008 10:50:52 -0700

It *IS* what we intend: all subtags are lowercase, except for the exceptions.

I disagree that we should make all alpha2 and alpha4 subtags follow the same pattern, although that is what the text says at present. I think it is weird to make extension/private use subtags have any case other than lowercase.

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter Constable
Sent: Monday, July 07, 2008 10:48 AM
To: Mark Davis; John Cowan
Cc: LTRU Working Group
Subject: Re: [Ltru] 2.1: casing

Peter

Mark

---

From: "Mark Davis" <[email-masked]>
Date: Mon, 7 Jul 2008 10:58:55 -0700

I had misread the text also. Looking at what Addison said and John did, I
think we could make it clearer with:

In this format, all subtags, including all those following singletons (that
is, in extension or private-use sequences) are in lowercase. The exceptions
to this are: all other non-initial two-letter subtags are uppercase and all
other non-initial four-letter subtags are titlecase.

=>

In this format, all subtags are in lowercase except for two possibilities:
those two-letter tags and four-letter subtags that are neither initial nor
occur after singletons. Such two-letter tags are all uppercase (eg, en-CA)
and four-letter subtags are titlecase (eg, az-Latn).

Mark

On Mon, Jul 7, 2008 at 10:48 AM, Peter Constable <[email-masked]>
wrote:

>  That helps clear up the last sentence. But I still see a problem with "In
> this format, all subtags… are in lowercase", which doesn't appear to be what
> is really intended.
>
>
>
> Peter
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Mark Davis
> *Sent:* Monday, July 07, 2008 10:35 AM
> *To:* John Cowan
> *Cc:* Peter Constable; LTRU Working Group
> *Subject:* Re: [Ltru] 2.1: casing
>
>
>

---

From: Peter Constable <[email-masked]>
Date: Mon, 7 Jul 2008 11:08:07 -0700

Well, I find the flow really confusing, then:

A.      Use the format in the registry. [That shows variations in casing.]

B.      That format is all lowercase. [That clearly is not a valid statement, given what is in the registry.]

C.      There are exceptions [Exceptions to what? Sorry, but I’m lost after the non-sequitor in B.]

Mark’s suggested wording (separate msg) makes things much clearer.

Peter

From: Phillips, Addison [mailto:[email-masked]]
Sent: Monday, July 07, 2008 10:51 AM
To: Peter Constable; Mark Davis; John Cowan
Cc: LTRU Working Group
Subject: RE: [Ltru] 2.1: casing

Addison

Addison Phillips

Peter

Mark

---

From: "Phillips, Addison" <[email-masked]>
Date: Mon, 7 Jul 2008 11:17:48 -0700

Done, with some minor modifications:

<t>Although case distinctions do not carry meaning in language tags, consistent formatting and presentation of the tags will aid users. The format of the tags and subtags in the registry is RECOMMENDED. In this format, all subtags are lowercase, with two exceptions: those two-letter tags and four-letter subtags that are neither initial nor occur after singletons. Such two-letter tags are all uppercase (as in the tag "en-CA-x-ca") and four-letter subtags are titlecase (as in the tag "az-Latn-x-latn").</t>

Addison Phillips

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Davis
Sent: Monday, July 07, 2008 10:59 AM
To: Peter Constable
Cc: LTRU Working Group
Subject: Re: [Ltru] 2.1: casing

I had misread the text also. Looking at what Addison said and John did, I think we could make it clearer with:

In this format, all subtags, including all those following singletons (that is, in extension or private-use sequences) are in lowercase. The exceptions to this are: all other non-initial two-letter subtags are uppercase and all other non-initial four-letter subtags are titlecase.

=>

In this format, all subtags are in lowercase except for two possibilities: those two-letter tags and four-letter subtags that are neither initial nor occur after singletons. Such two-letter tags are all uppercase (eg, en-CA) and four-letter subtags are titlecase (eg, az-Latn).

Mark
On Mon, Jul 7, 2008 at 10:48 AM, Peter Constable <[email-masked]<mailto:[email-masked]>> wrote:

That helps clear up the last sentence. But I still see a problem with "In this format, all subtags… are in lowercase", which doesn't appear to be what is really intended.

Peter

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Mark Davis
Sent: Monday, July 07, 2008 10:35 AM
To: John Cowan
Cc: Peter Constable; LTRU Working Group
Subject: Re: [Ltru] 2.1: casing

Mark

---

From: Peter Constable <[email-masked]>
Date: Mon, 7 Jul 2008 11:31:09 -0700

That works.

Peter

From: Phillips, Addison [mailto:[email-masked]]
Sent: Monday, July 07, 2008 11:18 AM
To: Mark Davis; Peter Constable
Cc: LTRU Working Group
Subject: RE: [Ltru] 2.1: casing

Addison Phillips

=>

Mark

Peter

Mark

---

From: "Mark Davis" <[email-masked]>
Date: Mon, 7 Jul 2008 13:17:13 -0700

Yup.

Mark

On Mon, Jul 7, 2008 at 11:31 AM, Peter Constable <[email-masked]>
wrote:

>  That works.
>
>
>
> Peter
>
>
>
> *From:* Phillips, Addison [mailto:[email-masked]]
> *Sent:* Monday, July 07, 2008 11:18 AM
> *To:* Mark Davis; Peter Constable
> *Cc:* LTRU Working Group
> *Subject:* RE: [Ltru] 2.1: casing
>
>
>
> <t>Although case distinctions do not carry meaning in language tags,
> format, all subtags are lowercase, with two exceptions: those two-letter
> tags and four-letter subtags that are neither initial nor occur after
> singletons. Such two-letter tags are all uppercase (as in the tag
> "en-CA-x-ca") and four-letter subtags are titlecase (as in the tag
> "az-Latn-x-latn").</t>
>
>
>
> Addison Phillips
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *Mark Davis
> *Sent:* Monday, July 07, 2008 10:59 AM
> *To:* Peter Constable
> *Cc:* LTRU Working Group

---

From: Peter Constable <[email-masked]>
Date: Mon, 7 Jul 2008 20:40:37 -0700

Btw, I note that 3.1.3 discusses casing in registry records, and it expresses the exceptions directly in terms of script and region. I suppose that is fine for the registry but doesn’t work quite as well for tags in cases like sgn-BE-FR.

Also, btw, I note that the current registry doesn’t strictly follow the rule for the exception that you gave. In particular, it lists grandfathered tags “sgn-BE-fr”, “sgn-BE-nl” and “sgn-CH-de”.

Peter

From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter Constable
Sent: Monday, July 07, 2008 11:31 AM
To: Phillips, Addison; Mark Davis
Cc: LTRU Working Group
Subject: Re: [Ltru] 2.1: casing

That works.

Peter

Addison Phillips

=>

Mark

Peter

Mark

---

From: "Phillips, Addison" <[email-masked]>
Date: Tue, 8 Jul 2008 11:49:35 -0700

A bit more on casing.

First, as part of a edit round, I redid the para on casing again to make it (I hope) clearer, including spelling out the fact that it includes an algorithm:

<t>Although case distinctions do not carry meaning in language tags, consistent formatting and presentation of the tags will aid users. The format of subtags in the registry is RECOMMENDED as the form to use in language tags. This format generally corresponds to the common conventions for the various ISO standards from which the subtags are derived as listed above. An implementation can reproduce this format without accessing the registry as follows: All subtags, including extension and private use subtags, use lowercase letters, with two exceptions: two-letter and four-letter subtags that neither appear at the start of the tag nor occur after singletons. Such two-letter subtags are all uppercase (as in the tags "en-CA-x-ca" or "sgn-BE-FR") and four-letter subtags are titlecase (as in the tag "az-Latn-x-latn").</t>

Peter then commented:

---

It turns out that this is sort-of okay, in that this achieves the correct result. However, the lack of linkage isn’t very helpful and the ‘Tag’ description is hopeless. To counteract this, I split out the casing rules into a new subsection of Section 2 and then refer to that in section 3.1.3. I think this is a lot cleaner and clearer.

Addison

---

From: "Mark Davis" <[email-masked]>
Date: Tue, 8 Jul 2008 13:38:52 -0700

Works for me.

Mark

On Tue, Jul 8, 2008 at 11:49 AM, Phillips, Addison <[email-masked]>
wrote:

>  A bit more on casing.
>
>
>
> First, as part of a edit round, I redid the para on casing again to make it
> (I hope) clearer, including spelling out the fact that it includes an
> algorithm:
>
>
>
> format of subtags in the registry is RECOMMENDED as the form to use in
> language tags. This format generally corresponds to the common conventions
> for the various ISO standards from which the subtags are derived as listed
> above. An implementation can reproduce this format without accessing the
> registry as follows: All subtags, including extension and private use
> subtags, use lowercase letters, with two exceptions: two-letter and
> four-letter subtags that neither appear at the start of the tag nor occur
> after singletons. Such two-letter subtags are all uppercase (as in the tags
> "en-CA-x-ca" or "sgn-BE-FR") and four-letter subtags are titlecase (as in
> the tag "az-Latn-x-latn").</t>
>
>
>
> Peter then commented:
>
>
>
> ---
>
>
>
> Btw, I note that 3.1.3 discusses casing in registry records, and it
> expresses the exceptions directly in terms of script and region. I suppose
> that is fine for the registry but doesn't work quite as well for tags in
> cases like sgn-BE-FR.
>
>
>
>
>
> It turns out that this is sort-of okay, in that this achieves the correct
> result. However, the lack of linkage isn't very helpful and the 'Tag'
> description is hopeless. To counteract this, I split out the casing rules
> into a new subsection of Section 2 and then refer to that in section
> 3.1.3. I think this is a lot cleaner and clearer.
>
>
>
> Addison
>

---

From: Peter Constable <[email-masked]>
Date: Tue, 8 Jul 2008 18:02:05 -0700

I think a fix is needed in 4.5 to make the following paragraph consistent with 2.1:

--------------
When performing canonicalization of language tags, processors MAY regularize the case of the subtags (that is, this process is OPTIONAL), following the case used in the registry. Note that this corresponds to the following casing rules: uppercase all non-initial two-letter subtags; titlecase all non-initial four-letter subtags; lowercase everything else.
--------------

While we’re there, I’d move the parenthetic comment in the first sentence:

--------------
When performing canonicalization of language tags, processors MAY regularize the case of the subtags following the case used in the registry (that is, this process is OPTIONAL). Note that this corresponds to the following casing rules: uppercase all non-initial two-letter subtags; titlecase all non-initial four-letter subtags; lowercase everything else.
--------------

Or perhaps you can delete the parenthetic comment and use instead, “… processors MAY optionally regularize…”

Peter

From: Phillips, Addison [mailto:[email-masked]]
Sent: Tuesday, July 08, 2008 11:50 AM
To: Peter Constable; LTRU Working Group
Subject: RE: [Ltru] 2.1: casing

A bit more on casing.

Peter then commented:

---

Addison

---

From: "Mark Davis" <[email-masked]>
Date: Tue, 8 Jul 2008 18:09:33 -0700

That doesn't quite work, since it doesn't account for the extensions. What
we could do is just point to the text that describes the normal casing
format (that we just tweaked).

Mark

On Tue, Jul 8, 2008 at 6:02 PM, Peter Constable <[email-masked]>
wrote:

> When performing canonicalization of language tags, processors MAY
> regularize the case of the subtags (that is, this process is OPTIONAL),
> following the case used in the registry. Note that this corresponds to the
> following casing rules: uppercase all non-initial two-letter subtags;
> titlecase all non-initial four-letter subtags; lowercase everything else.
>
> --------------
>
>
>
> While we're there, I'd move the parenthetic comment in the first sentence:
>
>
>
> --------------
>
> When performing canonicalization of language tags, processors MAY
> regularize the case of the subtags following the case used in the registry
> (that is, this process is OPTIONAL). Note that this corresponds to the
> following casing rules: uppercase all non-initial two-letter subtags;
> titlecase all non-initial four-letter subtags; lowercase everything else.
>
> --------------
>
>
>
> Or perhaps you can delete the parenthetic comment and use instead, "…
> processors MAY optionally regularize…"
>
>
>
>
>
> Peter
>
>
>
> *Sent:* Tuesday, July 08, 2008 11:50 AM
> *To:* Peter Constable; LTRU Working Group

---

From: Peter Constable <[email-masked]>
Date: Tue, 8 Jul 2008 18:11:39 -0700

> That doesn't quite work, since it doesn't account for
> the extensions.

Precisely.

Peter

---

From: "Phillips, Addison" <[email-masked]>
Date: Tue, 8 Jul 2008 21:58:45 -0700

I removed the now redundant instructions here and just pointed to the new subsection.

Addison Phillips

From: Peter Constable [mailto:[email-masked]]
Sent: Tuesday, July 08, 2008 6:02 PM
To: Phillips, Addison; LTRU Working Group
Subject: RE: [Ltru] 2.1: casing

--------------

--------------

Peter

A bit more on casing.

Peter then commented:

---

Addison