Subject: Re: [Ltru] Latn and fonipa

From: "Doug Ewell" <[email-masked]>
Date: Thu, 10 Jul 2008 22:06:49 -0600

"Phillips, Addison" <addison at amazon dot com> wrote:

> We allow many unwise tags. For example, "tlh-Cyrl-AQ-fonupa" is 
> well-formed, valid, and canonical. It's also laughable, bringing to 
> mind, as it does, freezing mythical Star Trek aliens typing on cast 
> off Soviet typewriters.

In IPA, no less, which is pretty hard to do on a Cyrillic typewriter.

Nevertheless, Addison's point is well taken: the tag is ridiculous but 
valid, and it isn't worth it to try to prohibit every possible 
ridiculous, or even inappropriate, tag.

> Given that variants are rare and tend to be very highly specialized, 
> supplying lots of formal requirements for their use and implementation 
> will make them even less appealing.

True; that's what killed extensions.

--
Doug Ewell  *  Arvada, Colorado, USA  *  RFC 4645  *  UTN #14
http://www.ewellic.org
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Thu, 10 Jul 2008 22:10:13 -0600

"Phillips, Addison" <addison at amazon dot com> wrote:

> Well... it might actually be a Good Thing to have the deprecated ISO 
> 639-1 junk have a description like "Hebrew (deprecated subtag)" so 
> that people actually look at the Preferred-Value and Deprecated fields 
> and find the more correct value. In this case, 'he' comes before 'iw' 
> in the registry.

I think it's a Bad Thing to ask the Description field to carry this 
meta-information.  People should look at the Preferred-Value and 
Deprecated fields without this hint.

---

From: "Doug Ewell" <[email-masked]>
Date: Thu, 10 Jul 2008 22:32:35 -0600

"Phillips, Addison" <addison at amazon dot com> wrote:

> Hmm... Doug, I notice this is inconsistent in 4645bis:
>
> %%
> Type: language
> Subtag: iw
> Description: Hebrew
> Added: 2005-10-16
> Preferred-Value: he
> Deprecated: 1989-01-01
> Suppress-Script: Hebr
> %%
>
> ...
>
> %%
> Type: language
> Subtag: jw
> Description: Javanese
> Added: 2005-10-16
> Preferred-Value: jv
> Deprecated: 2001-08-13
> Comments: published by error in Table 1 of ISO 639:1988
>
> Only one has a comment; the other deprecated values don't.

Someone (no names, but still an active participant in LTRU) suggested 
adding that comment to 'jw' back in January 2005.

There is no requirement that deprecated subtags have a comment 
explaining why they were deprecated.  I agree that we and ietf-languages 
have been inconsistent in adding some and not others, but when talking 
about one-at-a-time comments in the LSR, we should not expect 
consistency.  The only time we had any consistency in comments was with 
those horrid little content-free remarks we attached to deprecated 
grandfathered tags in the 3066bis days:

%%
Type: grandfathered
Tag: art-lojban
Description: Lojban
Added: 2001-11-11
Preferred-Value: jbo
Deprecated: 2003-09-02
Comments: replaced by ISO code jbo
%%

I'm glad to have led the effort to get rid of those.