Subject: [Ltru] obsolete grandfathered values...

From: "Phillips, Addison" <[email-masked]>
Date: Sat, 12 Jul 2008 13:26:58 -0700

We have a bit of leftover text in the section on stability relating to grandfathered tags. It says:

--
RFC 3066 tags that were deprecated prior to the adoption of [RFC4646] (Phillips, A. and M. Davis, “Tags for Identifying Languages,” September 2006.) are part of the list of grandfathered tags, and their component subtags were not included as registered variants (although they remain eligible for registration). For example, the tag "art-lojban" was deprecated in favor of the language subtag 'jbo'.
--

This no longer makes sense to me, as we previously say that the grandfathered list is now closed and immutable. I replaced it with:

--
Many of the grandfathered tags are deprecated, indeed, they were deprecated even before <xref target="RFC4646"></xref>. For example, the tag "art-lojban" was deprecated in favor of the primary language subtag 'jbo'. These tags could have been made 'redundant' by registering some of their subtags as 'variants'. The 'variant-like' subtags in the grandfathered registrations SHALL NOT be registered in the future, even with a similar or identical meaning.
--

Thoughts?

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Sat, 12 Jul 2008 13:38:43 -0700

Do we have a good reason for the last sentence?
Mark

On Sat, Jul 12, 2008 at 1:26 PM, Phillips, Addison <[email-masked]>
wrote:

> RFC 3066 tags that were deprecated prior to the adoption of [RFC4646]
> (Phillips, A. and M. Davis, "Tags for Identifying Languages," September
> 2006.) are part of the list of grandfathered tags, and their component
> subtags were not included as registered variants (although they remain
> eligible for registration). For example, the tag "art-lojban" was deprecated
> in favor of the language subtag 'jbo'.
> --
>
> This no longer makes sense to me, as we previously say that the
> grandfathered list is now closed and immutable. I replaced it with:
>
> --
> Many of the grandfathered tags are deprecated, indeed, they were deprecated
> even before <xref target="RFC4646"></xref>. For example, the tag
> "art-lojban" was deprecated in favor of the primary language subtag 'jbo'.
> These tags could have been made 'redundant' by registering some of their
> subtags as 'variants'. The 'variant-like' subtags in the grandfathered
> registrations SHALL NOT be registered in the future, even with a similar or
> identical meaning.
> --
>
> Thoughts?
>
> Addison Phillips

---

From: "Phillips, Addison" <[email-masked]>
Date: Sat, 12 Jul 2008 13:44:50 -0700

It would lead to weird “meaning collisions” if one were registered. It’s a short list anyway: “lojban”, “gaulish”, “guoyu”, “hakka”, and “xiang” are the complete list.

You wouldn’t want something like “hak-hakka”, nor would you want a differently-nuanced “zh-hakka” floating about… let alone some random “de-hakka” or “tlh-hakka” with a different meaning for “hakka”.

If, by contrast, we registered them with their current meaning, making a grandfathered tag redundant (we already prohibited this, please note), then we’d have the problem of having made a deprecated grandfathered tag (these are all deprecated, save ‘cel-gaulish’) into a valid, non-deprecated generative tag. Ick.

Addison Phillips

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Davis
Sent: Saturday, July 12, 2008 1:39 PM
To: Phillips, Addison
Cc: [email-masked]
Subject: Re: [Ltru] obsolete grandfathered values...

Mark
On Sat, Jul 12, 2008 at 1:26 PM, Phillips, Addison <[email-masked]<mailto:[email-masked]>> wrote:
We have a bit of leftover text in the section on stability relating to grandfathered tags. It says:

--
RFC 3066 tags that were deprecated prior to the adoption of [RFC4646] (Phillips, A. and M. Davis, "Tags for Identifying Languages," September 2006.) are part of the list of grandfathered tags, and their component subtags were not included as registered variants (although they remain eligible for registration). For example, the tag "art-lojban" was deprecated in favor of the language subtag 'jbo'.
--

Thoughts?

Addison Phillips

_______________________________________________
Ltru mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Sat, 12 Jul 2008 13:47:29 -0700

Ok, makes sense.
Mark

On Sat, Jul 12, 2008 at 1:44 PM, Phillips, Addison <[email-masked]>
wrote:

>  It would lead to weird "meaning collisions" if one were registered. It's
> a short list anyway: "lojban", "gaulish", "guoyu", "hakka", and "xiang" are
> the complete list.
>
>
>
> You wouldn't want something like "hak-hakka", nor would you want a
> differently-nuanced "zh-hakka" floating about… let alone some random
> "de-hakka" or "tlh-hakka" with a different meaning for "hakka".
>
>
>
> If, by contrast, we registered them with their current meaning, making a
> grandfathered tag redundant (we already prohibited this, please note), then
> we'd have the problem of having made a deprecated grandfathered tag (these
> are all deprecated, save 'cel-gaulish') into a valid, non-deprecated
> generative tag. Ick.
>
>
>
> Addison Phillips
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Mark Davis
> *Sent:* Saturday, July 12, 2008 1:39 PM
> *To:* Phillips, Addison
> *Cc:* [email-masked]
> *Subject:* Re: [Ltru] obsolete grandfathered values...
>
>
>

---

From: Peter Constable <[email-masked]>
Date: Sat, 12 Jul 2008 15:43:50 -0700

I agree that the intent makes sense. On the other hand, we don’t have a constraint prohibiting someone from registering variant subtag like “italian” (cp “it-italian” vs. “hak-hakka”). Perhaps a generalized requirement is in order: no variant subtag may be registered that has a semantic equivalent to existing language, script or region subtags.

Peter

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Davis
Sent: Saturday, July 12, 2008 1:47 PM
To: Phillips, Addison
Cc: [email-masked]
Subject: Re: [Ltru] obsolete grandfathered values...

Ok, makes sense.

Mark
On Sat, Jul 12, 2008 at 1:44 PM, Phillips, Addison <[email-masked]<mailto:[email-masked]>> wrote:

It would lead to weird "meaning collisions" if one were registered. It's a short list anyway: "lojban", "gaulish", "guoyu", "hakka", and "xiang" are the complete list.

You wouldn't want something like "hak-hakka", nor would you want a differently-nuanced "zh-hakka" floating about… let alone some random "de-hakka" or "tlh-hakka" with a different meaning for "hakka".

If, by contrast, we registered them with their current meaning, making a grandfathered tag redundant (we already prohibited this, please note), then we'd have the problem of having made a deprecated grandfathered tag (these are all deprecated, save 'cel-gaulish') into a valid, non-deprecated generative tag. Ick.

Addison Phillips

It is an architecture.

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Mark Davis
Sent: Saturday, July 12, 2008 1:39 PM
To: Phillips, Addison
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Ltru] obsolete grandfathered values...

Mark

Thoughts?

Addison Phillips

---

From: "Phillips, Addison" <[email-masked]>
Date: Sat, 12 Jul 2008 16:06:12 -0700

I think that might be overkill: ietf-languages wouldn’t likely register such a thing anyway. At least not as long as Grandpa Cowan is hanging out there :-). My real goal was to prevent any accidental-on-purpose grandfathered->redundant transitions in the future, especially since such a transition would introduce problematic collisions. That is, subtag ‘hakka’ probably doesn’t mean quite what subtag ‘hak’ means and there would be guessing as to whether “zh-hakka” is “zh-hakka” or “zh” + “hakka”.

Addison Phillips

From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter Constable
Sent: Saturday, July 12, 2008 3:44 PM
To: [email-masked]
Subject: Re: [Ltru] obsolete grandfathered values...

Peter

Ok, makes sense.

Mark

Addison Phillips

It is an architecture.

Mark

Thoughts?

Addison Phillips

---

From: Peter Constable <[email-masked]>
Date: Sat, 12 Jul 2008 16:50:40 -0700

Well, I’ve no particular objection to adding such language.

Peter

From: Phillips, Addison [mailto:[email-masked]]
Sent: Saturday, July 12, 2008 4:06 PM
To: Peter Constable; [email-masked]
Subject: RE: [Ltru] obsolete grandfathered values...

Addison Phillips

Peter

Ok, makes sense.

Mark

Addison Phillips

It is an architecture.

Mark

Thoughts?

Addison Phillips

---

From: John Cowan <[email-masked]>
Date: Sun, 13 Jul 2008 02:34:03 -0400

> Well, I’ve no particular objection to adding such language.

+1
-- 
John Cowan     http://ccil.org/~cowan    [email-masked]
Monday we watch-a Firefly's house, but he no come out.  He wasn't home.
Tuesday we go to the ball game, but he fool us.  He no show up.  Wednesday he
go to the ball game, and we fool him.  We no show up.  Thursday was a
double-header.  Nobody show up.  Friday it rained all day.  There was no ball
game, so we stayed home and we listened to it on-a the radio.  --Chicolini
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru