Subject: [Ltru] grandfathered to redundant?

From: "Phillips, Addison" <[email-masked]>
Date: Tue, 8 Jul 2008 11:58:14 -0700

In Section 3.4 (iana stability) we have rules for transitioning grandfathered tags to redundant. Recently there was a thread on the list suggesting that the remaining regular grandfathered list is basically closed and cannot become redundant because of various other rules we have in place. Should we modify the text to say this? (It would be nice to get rid of extraneous rules for a change).

The list of regular gf tags is:

regular       = "art-lojban"        ; these tags match the 'langtag'
              / "cel-gaulish"       ; production, but their subtags
              / "no-bok"            ; are not extended language
              / "no-nyn"            ; or variant subtags: their meaning
              / "zh-guoyu"          ; is defined by their registration
              / "zh-hakka"          ; and all of these are deprecated
              / "zh-min"            ; in favor of a more modern
              / "zh-min-nan"        ; subtag or sequence of subtags
              / "zh-xiang"

As I believe John Cowan pointed out, only 'lojban', 'gaulish', 'guoyu', 'hakka', and 'xiang' could ever become variants. Of these, only 'gaulish' has some semblance of residual meaning as a variant (and this one not much). The others are, without exception, deprecated in favor of something else.

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Tue, 8 Jul 2008 15:04:32 -0400

Phillips, Addison scripsit:
> In Section 3.4 (iana stability) we have rules for transitioning
> grandfathered tags to redundant. Recently there was a thread on the list
> suggesting that the remaining regular grandfathered list is basically
> closed and cannot become redundant because of various other rules we
> have in place. Should we modify the text to say this? (It would be
> nice to get rid of extraneous rules for a change).

+1

> As I believe John Cowan pointed out, only 'lojban', 'gaulish',
> 'guoyu', 'hakka', and 'xiang' could ever become variants. Of these,
> only 'gaulish' has some semblance of residual meaning as a variant
> (and this one not much). The others are, without exception, deprecated
> in favor of something else.

cel-gaulish would be semantically anomalous anyhow: a language collection
followed by a language variant, with no actual *language*.  I say it's
a dead duck.

-- 
In my last lifetime,                            John Cowan
I believed in reincarnation;                    http://www.ccil.org/~cowan
in this lifetime,                               [email-masked]
I don't.  --Thiagi
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru