Subject: [Ltru] 4.6: private use subtags convey... (nothing except by prior agreement)

From: Peter Constable <[email-masked]>
Date: Tue, 8 Jul 2008 22:14:43 -0700

The current draft has this in Section 4.6:

------------
Subtags defined in the IANA registry as having a specific private use meaning convey more information that a purely private use tag prefixed by the singleton subtag 'x'.
------------

Strictly speaking, that's not true: a private-use *subtag* conveys *no* information (except by private convention -- which is clearly not assumed in this statement), and so cannot convey more information than anything else.

Suggested revision:

------------
Tags created using subtags defined in the IANA registry as having a specific private use meaning can convey more information that a purely private use tag prefixed by the singleton subtag 'x'.
------------

Also, this wording is a bit problematic:

------------
However, in some cases content tagged with private use subtags MAY interact with other systems in a different and possibly unsuitable manner compared to tags that use opaque, privately defined subtags, so the choice of the best approach sometimes depends on the particular domain in question.
------------

Tags that use private-use subtags vs. tags that use opaque, privately-defined subtags? Those sound the same.

Suggested revision:

------------
However, in some cases content tagged with private-use subtags MAY interact with other systems in a different and possibly unsuitable manner compared to tags that use opaque, private-use subtag sequences prefixed by 'x', so the choice of the best approach sometimes depends on the particular domain in question.
------------

Peter
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 11 Jul 2008 10:18:23 -0700

(editor hat)

The suggested revision is "okay", but didn't convey exactly what we meant either, I think. I rewrote the paragraph and modified the example that followed (which Peter did not quote) as follows:

<t>In addition to private-use subtag sequences introduced by the singleton subtag 'x', the Language Subtag Registry provides private use subtags derived from the private use codes assigned by underlying standards. These subtags are valid for use in forming language tags and convey more information than the 'x-' private-use sequences because they are linked to the language tag's inherent structure.</t>

<t>For example, the region subtags 'AA', 'ZZ', and in the ranges 'QM'-'QZ' and 'XA'-'XZ' (derived from the ISO 3166-1 private use codes) can be used to form a language tag. A tag such as "zh-Hans-XQ" conveys a great deal of public, interchangeable information about the language material (that it is Chinese in the simplified Chinese script and is suitable for some geographic region 'XQ'). While the precise geographic region is not known outside of private agreement, the tag conveys far more information than an opaque tag such as "x-somelang" or even "zh-Hans-x-xq" (where the 'xq' subtag's meaning is entirely ambiguous).</t>

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Peter Constable
> Sent: Tuesday, July 08, 2008 10:15 PM
> To: LTRU Working Group
> Subject: [Ltru] 4.6: private use subtags convey... (nothing except
> by prior agreement)
>
> Subtags defined in the IANA registry as having a specific private
> use meaning convey more information that a purely private use tag
> prefixed by the singleton subtag 'x'.
> ------------
>
> Strictly speaking, that's not true: a private-use *subtag* conveys
> *no* information (except by private convention -- which is clearly
> not assumed in this statement), and so cannot convey more
> information than anything else.
>
> Suggested revision:
>
> ------------
> Tags created using subtags defined in the IANA registry as having a
> specific private use meaning can convey more information that a
> purely private use tag prefixed by the singleton subtag 'x'.
> ------------
>
>
>
> However, in some cases content tagged with private use subtags MAY
> interact with other systems in a different and possibly unsuitable
> manner compared to tags that use opaque, privately defined subtags,
> so the choice of the best approach sometimes depends on the
> particular domain in question.
> ------------
>
> Tags that use private-use subtags vs. tags that use opaque,
> privately-defined subtags? Those sound the same.
>
> Suggested revision:
>
> ------------
> However, in some cases content tagged with private-use subtags MAY
> interact with other systems in a different and possibly unsuitable
> manner compared to tags that use opaque, private-use subtag
> sequences prefixed by 'x', so the choice of the best approach
> sometimes depends on the particular domain in question.
> ------------
>
>
> Peter

---

From: "Mark Davis" <[email-masked]>
Date: Fri, 11 Jul 2008 10:35:15 -0700

A slight tweek, because you still have "..[private use] subtags ... convey
more information...". Peter was saying that it is the *tag* using them that
conveys more information. I think that both are true, just because
en-x-private conveys less info than en-AA (we know AA is meant to be a
region).

Here's a suggestion

Mark

On Fri, Jul 11, 2008 at 10:18 AM, Phillips, Addison <[email-masked]>
wrote:

> (editor hat)
>
> The suggested revision is "okay", but didn't convey exactly what we meant
> either, I think. I rewrote the paragraph and modified the example that
> followed (which Peter did not quote) as follows:
>
> <t>In addition to private-use subtag sequences introduced by the singleton
> subtag 'x', the Language Subtag Registry provides private use subtags
> derived from the private use codes assigned by underlying standards. These
> subtags are valid for use in forming language tags and convey more
> information than the 'x-' private-use sequences because they are linked to
> the language tag's inherent structure.</t>

=>
In addition to private-use subtag sequences introduced by the singleton
subtag 'x', the Language Subtag Registry provides private use subtags
derived from the private use codes assigned by underlying standards. These
subtags are valid for use in forming language tags; they are recommended
over the 'x-' private use subtag sequences:
1. tags incorporating private use subtags convey more publicly
interchangeable information than the 'x' sequences, because the subtags are
linked to the language tag's inherent structure, while the 'x' sequences are
completely opaque to those outside of the private-use agreement.
2. some implementations may not be able to handle 'x' sequences

> <t>For example, the region subtags 'AA', 'ZZ', and in the ranges 'QM'-'QZ'
> and 'XA'-'XZ' (derived from the ISO 3166-1 private use codes) can be used to
> form a language tag. A tag such as "zh-Hans-XQ" conveys a great deal of
> public, interchangeable information about the language material (that it is
> Chinese in the simplified Chinese script and is suitable for some geographic
> region 'XQ'). While the precise geographic region is not known outside of
> private agreement, the tag conveys far more information than an opaque tag
> such as "x-somelang" or even "zh-Hans-x-xq" (where the 'xq' subtag's meaning
> is entirely ambiguous).</t>

=> entirely opaque.

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 11 Jul 2008 10:53:05 -0700

I’m okay with this suggestion, only I don’t think we should say your item #2. An implementation that doesn’t handle ‘x’ sequences is horribly broken.

Addison

Addison Phillips

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Davis
Sent: Friday, July 11, 2008 10:35 AM
To: Phillips, Addison
Cc: Peter Constable; LTRU Working Group
Subject: Re: [Ltru] 4.6: private use subtags convey... (nothing except by prior agreement)

A slight tweek, because you still have "..[private use] subtags ... convey more information...". Peter was saying that it is the *tag* using them that conveys more information. I think that both are true, just because en-x-private conveys less info than en-AA (we know AA is meant to be a region).

Here's a suggestion

Mark
On Fri, Jul 11, 2008 at 10:18 AM, Phillips, Addison <[email-masked]<mailto:[email-masked]>> wrote:
(editor hat)

<t>In addition to private-use subtag sequences introduced by the singleton subtag 'x', the Language Subtag Registry provides private use subtags derived from the private use codes assigned by underlying standards. These subtags are valid for use in forming language tags and convey more information than the 'x-' private-use sequences because they are linked to the language tag's inherent structure.</t>
=>
In addition to private-use subtag sequences introduced by the singleton subtag 'x', the Language Subtag Registry provides private use subtags derived from the private use codes assigned by underlying standards. These subtags are valid for use in forming language tags; they are recommended over the 'x-' private use subtag sequences:
1. tags incorporating private use subtags convey more publicly interchangeable information than the 'x' sequences, because the subtags are linked to the language tag's inherent structure, while the 'x' sequences are completely opaque to those outside of the private-use agreement.
2. some implementations may not be able to handle 'x' sequences
DONE, but with a deeper recasting:
<t>Private use sequences introduced by the 'x' singleton are completely opaque to users or implementations outside of the private use agreement. So, in addition to private use subtag sequences introduced by the singleton subtag 'x', the Language Subtag Registry provides private use language, script, and region subtags derived from the private use codes assigned by the underlying standards. These subtags are valid for use in forming language tags; they are RECOMMENDED over the 'x' singleton private use subtag sequences because they convey more information via their linkage to the language tag's inherent structure.</t>

DONE

Addison Phillips

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On
> [email-masked]<mailto:[email-masked]>
_______________________________________________
Ltru mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Fri, 11 Jul 2008 11:09:17 -0700

I'm ok with removing the second sentence.

(BTW, I think we may be just using different senses of 'handle'. Because no
implementation is required to handle x sequences -- if it has no private
agreements, it can't give them any meaning anyway -- it would be perfectly
acceptable for an implementation on input to strip them before interpreting
the rest of the tag.)

Mark

On Fri, Jul 11, 2008 at 10:53 AM, Phillips, Addison <[email-masked]>
wrote:

>  I'm okay with this suggestion, only I don't think we should say your item
> #2. An implementation that doesn't handle 'x' sequences is horribly broken.
>
>
>
> Addison
>
>
>
> Addison Phillips
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Mark Davis
> *Sent:* Friday, July 11, 2008 10:35 AM
> *To:* Phillips, Addison
> *Cc:* Peter Constable; LTRU Working Group
> *Subject:* Re: [Ltru] 4.6: private use subtags convey... (nothing except
> by prior agreement)
>
>
>
> <t>Private use sequences introduced by the 'x' singleton are completely
> opaque to users or implementations outside of the private use agreement. So,
> in addition to private use subtag sequences introduced by the singleton
> subtag 'x', the Language Subtag Registry provides private use language,
> script, and region subtags derived from the private use codes assigned by
> the underlying standards. These subtags are valid for use in forming
> language tags; they are RECOMMENDED over the 'x' singleton private use
> subtag sequences because they convey more information via their linkage to

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 11 Jul 2008 11:11:38 -0700

(BTW, I think we may be just using different senses of 'handle'. Because no implementation is required to handle x sequences -- if it has no private agreements, it can't give them any meaning anyway -- it would be perfectly acceptable for an implementation on input to strip them before interpreting the rest of the tag.)
Manhandling the subtags is a form of handling :-).
Addison
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru