Subject: [Ltru] section 3.5 and descriptions...

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 9 Jul 2008 21:47:13 -0700

After editing the stuff about unique Description fields, I checked Section 3.5 (registration procedure) to ensure consistency. Some edits resulted.

1. The text about examples of completed registration forms was changed. The online list provided is not just examples: it is a complete list of approved forms. I said this.

<t>Examples of completed registration forms can be found in <xref target="regexamples"/>. A complete list of approved registration forms is online at <eref target="http://www.iana.org/assignments/lang-subtags-templates/">http://www.iana.org/assignments/lang-subtags-templates/</eref>.</t>

2. I added some text about prefixless variants, since we've never recognized them formally. The text is:

<t>Requests to add a 'Prefix' to a variant subtag that has no current prefix will also probably be rejected. Variants with no prefix are potentially useful with many or even all languages. Adding one or more Prefix fields would potentially harmful to the use of the variant. An example of such a variant is the subtag 'fonipa', which represents the International Phonetic Alphabet, a scheme which can be used to transcribe many languages.</t>

3. I modified text about Description, noting in passing John Cowan's previous observation that something was Very Wrong in this paragraph (it referred to registering tags for example). I made it read:

<t>The 'Description' fields provided in the request MUST contain at least one description written or transcribed into the Latin script; it MAY also include additional 'Description' fields in non-Latin scripts. The 'Description' field is used for identification purposes and doesn't necessarily represent the actual native name of the language or variation or to be in any particular language. Each 'Description' field MUST be unique for a given record type. For example, an attempt to register a 'Description' of "French" for a language subtag would be rejected because the subtag 'fr' is already using that description.</t>

4. Finally, in discussing "required registrations" (caused by ISO actions), I added the consensus requirement to:

The Language Subtag Reviewer MAY reject a specific version of the form, but MUST include in the rejection a suitable replacement, extending the review period as described above, until the form is in a format worthy of reviewer's approval and meets with rough consensus of the list.

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Thu, 10 Jul 2008 09:58:31 -0700

Looks good. A couple of comments below.

Mark

On Wed, Jul 9, 2008 at 9:47 PM, Phillips, Addison <[email-masked]>
wrote:

> After editing the stuff about unique Description fields, I checked Section
> 3.5 (registration procedure) to ensure consistency. Some edits resulted.
>
> 1. The text about examples of completed registration forms was changed. The
> online list provided is not just examples: it is a complete list of approved
> forms. I said this.
>
> <t>Examples of completed registration forms can be found in <xref
> target="regexamples"/>. A complete list of approved registration forms is
> online at <eref target="
> http://www.iana.org/assignments/lang-subtags-templates/">
> http://www.iana.org/assignments/lang-subtags-templates/</eref>.</t>
>
> <t>Requests to add a 'Prefix' to a variant subtag that has no current
> prefix will also probably be rejected.

This needs to be a MUST on the LSR and a "will be" here. Adding a prefix to
one that doesn't have one will narrow the range, which we don't allow.

> Variants with no prefix are potentially useful with many or even all
> languages. Adding one or more Prefix fields would potentially harmful to the
> use of the variant. An example of such a variant is the subtag 'fonipa',
> which represents the International Phonetic Alphabet, a scheme which can be
> used to transcribe many languages.</t>
>
> 3. I modified text about Description, noting in passing John Cowan's
> previous observation that something was Very Wrong in this paragraph (it
> referred to registering tags for example). I made it read:
>
> <t>The 'Description' fields provided in the request MUST contain at least
> one description written or transcribed into the Latin script; it MAY also
> include additional 'Description' fields in non-Latin scripts. The
> 'Description' field is used for identification purposes and doesn't
> necessarily represent the actual native name of the language or variation or
> to be in any particular language. Each 'Description' field MUST be unique
> for a given record type.

(uniqueness will probably be broadened pending other discussion)

> For example, an attempt to register a 'Description' of "French" for a
> language subtag would be rejected because the subtag 'fr' is already using
> that description.</t>
>
> The Language Subtag Reviewer MAY reject a specific version of the form, but
> MUST include in the rejection a suitable replacement, extending the review
> period as described above, until the form is in a format worthy of
> reviewer's approval and meets with rough consensus of the list.
>
> Addison
>
> Addison Phillips

---

From: "Phillips, Addison" <[email-masked]>
Date: Thu, 10 Jul 2008 10:10:31 -0700

Mark wrote:
--
<t>Requests to add a 'Prefix' to a variant subtag that has no current prefix will also probably be rejected.

This needs to be a MUST on the LSR and a "will be" here. Adding a prefix to one that doesn't have one will narrow the range, which we don't allow.
--

<AP> That's a good point. I'll make the change.

--
particular language. Each 'Description' field MUST be unique for a given record type.
(uniqueness will probably be broadened pending other discussion)
--

That does say "for a given record *type*". I can't see us broadening uniqueness to the whole registry.

For example, 'he', 'iw', and 'Hebr' all have the Description "Hebrew". Given our new rules, 'iw' would need to acquire a new Description, but I don't see forcing 'Hebr' to have a Description of "Hebrew (script)" as necessary. Ditto 'ar' and 'Arab'---and I'm sure more that I don't know off hand.

Addison

Addison Phillips

---

From: John Cowan <[email-masked]>
Date: Thu, 10 Jul 2008 13:32:48 -0400

Phillips, Addison scripsit:

> For example, 'he', 'iw', and 'Hebr' all have the Description
> "Hebrew". Given our new rules, 'iw' would need to acquire a new
> Description,

Ouch.  Can we exempt deprecated subtags from this requirement?  Otherwise
we will end up with parenthetical notes like "(new)" and "(old)" attached
to subtags in situations where ISO 639 has narrowed the denotation of a
language *name* and given it a new code element.

What's more, UIs shouldn't deal in deprecated subtags anyhow.

-- 
John Cowan   [email-masked]  http://www.ccil.org/~cowan
Most languages are dramatically underdescribed, and at least one is
dramatically overdescribed.  Still other languages are simultaneously
overdescribed and underdescribed.  Welsh pertains to the third category.
        --Alan King
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Thu, 10 Jul 2008 10:38:20 -0700

Well... it might actually be a Good Thing to have the deprecated ISO 639-1 junk have a description like "Hebrew (deprecated subtag)" so that people actually look at the Preferred-Value and Deprecated fields and find the more correct value. In this case, 'he' comes before 'iw' in the registry.

Addison

Addison Phillips

> -----Original Message-----
> From: John Cowan [mailto:[email-masked]]
> Sent: Thursday, July 10, 2008 10:33 AM
> To: Phillips, Addison
> Cc: Mark Davis; LTRU Working Group
> Subject: Re: [Ltru] section 3.5 and descriptions...
>

---

From: Peter Constable <[email-masked]>
Date: Thu, 10 Jul 2008 10:45:36 -0700

In comments on 3.1.4, I had suggested some wording:

----------------
Each 'Description' field MUST be unique within a given record. Also, each 'Description' field must be unique across the collection of records of the same type with the following exception: if a particular 'Description' field occurs in multiple records of a given type, then one of those records MUST be for a subtag listed in all the other records as Preferred-Value.
----------------

Some wording combining preferred value and deprecation seems sensible to me, rather than artificially changing descriptions in the case of two subtags that really are synonymous.

Peter

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> John Cowan
> Cc: LTRU Working Group

---

From: Martin Duerst <[email-masked]>
Date: Fri, 11 Jul 2008 13:29:23 +0900

>prefix will also probably be rejected. Variants with no prefix are 
>potentially useful with many or even all languages. Adding one or more 
>Prefix fields would potentially harmful to the use of the variant.

Please add a 'be' before or after 'potentially', thanks.

Regards,   Martin.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]