Subject: [Ltru] 3.1.6: Preferred-Value field for extlangs

From: Peter Constable <[email-masked]>
Date: Mon, 7 Jul 2008 21:36:59 -0700

The current draft has this text in Section 3.1.6:

-------------
The 'Preferred-Value' field in subtag records of type "extlang" use the same format as grandfathered or redundant tags. This allows the subtag to be deprecated in favor of either a single primary language subtag or a new language-extlang sequence.
-------------

It's not clear to me what's meant: in just what way is the format the same as for grandfathered or redundant tags? The requirements stated in 3.1.1 that apply to *all* fields would be one similarity, but obviously that's not what was in mind. Is it that the field "contains language ranges that are strongly RECOMMENDED for use in place of the record's value"? It's just not clear, but should be.

Peter
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Tue, 8 Jul 2008 08:19:19 -0700

>
> -------------
> The 'Preferred-Value' field in subtag records of type "extlang" use
> the same format as grandfathered or redundant tags. This allows the
> subtag to be deprecated in favor of either a single primary
> language subtag or a new language-extlang sequence.
> -------------
>
> It's not clear to me what's meant: in just what way is the format
> the same as for grandfathered or redundant tags? The requirements
> stated in 3.1.1 that apply to *all* fields would be one similarity,
> but obviously that's not what was in mind. Is it that the field
> "contains language ranges that are strongly RECOMMENDED for use in
> place of the record's value"? It's just not clear, but should be.

We already modified this in the editor's copy. Currently it reads:

<t>For fields of type 'extlang', 'grandfathered', or 'redundant', 'Preferred-Value' contains an extended language range that is preferred for forming the language tag. That is, each of the subtags that appears in the value MUST appear in the replacement tag; additional fields can be included in a language tag as described elsewhere in this document. For example, the replacement for the grandfathered tag "zh-min-nan" (Min Nan Chinese) is "nan", which can be used as the basis for tags such as "nan-Hant" or "nan-TW" (note that the extended language subtag form such as "zh-nan-Hant" or "zh-nan-TW" can also be used).</t>

Addison

---

From: "Phillips, Addison" <[email-masked]>
Date: Tue, 8 Jul 2008 10:40:44 -0700

(editor hat)

> The current draft has this text in Section 3.1.6:

... this text now reads...

<t>The 'Preferred-Value' field in subtag records of type "extlang" also contains an "extended language range". This allows the subtag to be deprecated in favor of either a single primary language subtag or a new language-extlang sequence.</t>
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru