Subject: Re: [Ltru] Canonical variants

From: "Doug Ewell" <[email-masked]>
Date: Wed, 9 Jul 2008 22:39:47 -0600

"Phillips, Addison" <addison at amazon dot com> wrote:

> Prefix: sl-rozaj
> Prefix: sl-rozaj-biske
> Prefix: sl-rozaj-njiva
> Prefix: sl-rozaj-osojs
> Prefix: sl-rozaj-solba
>
> 1994 is ordered after 'biske', 'njiva', 'osojs', and 'solba'. Note 
> that it is not recommended with 'lipaw' (which shares the sl-rozaj 
> prefix). In cases where all of the variants have prefixes, one can 
> determine the canonical order (provided one does not use prefixes that 
> are mutually exclusive together).

Right.

> What we don't say is where "no-prefix" variants go.

Right.  Logically, prefixes on variants exist to ensure that the variant 
has the correct modifiers, so we don't say "gu-biske" or 
"sl-biske-rozaj".  But we treat "no prefix" exceptionally, to mean "any 
prefix," so that variants can be used to indicate language-independent 
thingies like IPA and UPA.

The longer the prefix, the farther down the list the variant goes 
("sl-rozaj-biske-1994").  It seems to me that a variant with no 
prefix -- that is, one where any prefix is valid -- might reasonably go 
at the very end, thus: "de-1901-fonipa", "en-boont-fonipa", 
"sl-rozaj-biske-1994-fonupa", etc.

The only prefixless variants we currently have are 'fonipa' and 
'fonupa', and I can't get myself terribly worked up about how to 
canonicalize a tag that includes both 'fonipa' and 'fonupa'.  That's 
really unwise tagging.  I know it's theoretically possible to come up 
with other scenarios for prefixless variants besides phonetic alphabets, 
but neither LTRU or ietf-languages has come up with one yet.  Certainly 
if one does exist, it seems unlikely that they will interact with 
phonetic alphabets, so strict alpha order might work.

But as I said, we are really stretching the limits of brass handle 
polishing at this point.  Look at the scenario we have to dream up for 
this to be a problem: two or more prefixless variants in a single tag, 
where the meanings of the two variants interact in such a way that order 
is important, AND we need to make sure a search engine or other matching 
engine can match this tag properly when taking BOTH prefixless variants 
into account.  It's almost like we're trying to make work for ourselves.

--
Doug Ewell  *  Arvada, Colorado, USA  *  RFC 4645  *  UTN #14
http://www.ewellic.org
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 9 Jul 2008 21:48:19 -0700

+1

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: Wednesday, July 09, 2008 9:40 PM
> To: LTRU Working Group
> Subject: Re: [Ltru] Canonical variants
>

---

From: Martin Duerst <[email-masked]>
Date: Fri, 11 Jul 2008 14:12:28 +0900

>> On Behalf Of Doug Ewell

>> polishing at this point.

[chair hat on]
I agree that we should try to concentrate on our main issues.
Reading our charter at
http://www.ietf.org/html.charters/ltru-charter.html,

I see for example the following:
The working group will clarify text where necessary. It may also
make adjustments to the registration process and the form of the
registry if this is deemed appropriate based on ongoing registration
and operational experience. These adjustments and clarifications
are not expected to delay the progress of the work.

Please note in particular "not expected to delay" and
"based on ongoing registration and operational experience".

I suggest that if further operational experience after RFC 4646bis
shows that further tweaks may be needed, somebody can then propose
the creation of a new LTRU WG.

Regards,    Martin.

>> Look at the scenario we have to dream up
>> for

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]

---

From: Peter Constable <[email-masked]>
Date: Fri, 11 Jul 2008 07:07:21 -0700

+1

I submitted a bunch of mostly-editorial comments this week, although there were a couple of technical discussions that resulted (descriptions, canonicalization). I hadn't read through a draft in a long while, and I did that now because I wanted to get a handle on which parts of the document are at issue in resolving the open issues around extlang, canonicalization, deprecation and preferred-value. I see that as the last key issue, as far as I recall, and I'd like to see us settle that and wrap up. This month. There will always be things that could be improved, but we need to accept that 4646bis will not be perfect and get it out so that people can start using it. However we resolve that last key issue, it will be good enough to be usable -- maybe a little awkward for some of us at times, but still workable.

Let's get this done. This month.

I'm hoping Addison will have draft 17 complete over the weekend with revisions from this week's comments incorporated, and that we can close those issues and work through the last elephant next week.

Peter

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Martin Duerst
> Sent: Thursday, July 10, 2008 10:12 PM
> To: Phillips, Addison; Doug Ewell; LTRU Working Group

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 11 Jul 2008 10:08:09 -0700

Hi,

I agree with getting this done. Soon.

I wish the co-chairs would help us resolve the big consensus issues ahead of a last call, if possible. We've had proposals galore. We need to achieve some closure on the approach and handling of extlangs in particular.

In practical terms, I will finish incorporating comments from the list as quickly as possible and complete a full review/edit of my own in order to submit draft-17 shortly (i.e. today or tomorrow). Following this, we should be able to close out any remaining issues.

Addison

Addison Phillips

> Behalf Of Peter Constable
> Sent: Friday, July 11, 2008 7:07 AM
> To: Martin Duerst; LTRU Working Group
> I submitted a bunch of mostly-editorial comments this week,
> although there were a couple of technical discussions that resulted
> (descriptions, canonicalization). I hadn't read through a draft in
> a long while, and I did that now because I wanted to get a handle
> on which parts of the document are at issue in resolving the open
> issues around extlang, canonicalization, deprecation and preferred-
> value. I see that as the last key issue, as far as I recall, and
> I'd like to see us settle that and wrap up. This month. There will
> always be things that could be improved, but we need to accept that
> 4646bis will not be perfect and get it out so that people can start
> using it. However we resolve that last key issue, it will be good
> enough to be usable -- maybe a little awkward for some of us at
> times, but still workable.
>
> I'm hoping Addison will have draft 17 complete over the weekend
> with revisions from this week's comments incorporated, and that we
> can close those issues and work through the last elephant next week.
>
>
> Peter
>
>
>
> Behalf Of
> > >> this to be a problem: two or more prefixless variants in a
> single
> > >> tag,
> > >> where the meanings of the two variants interact in such a way
> that
> > >> order
> > >> is important, AND we need to make sure a search engine or
> other
> > >> matching