Subject: [Ltru] 2.2.6: requirements on extensions

From: Peter Constable <[email-masked]>
Date: Mon, 7 Jul 2008 13:08:24 -0700

Draft 16 currently has this wording in Section 2.2.6:

--------------
5. Extension subtags MUST meet all of the requirements for the content and format of subtags defined in this document.
--------------

IMO, this is so vague as to be un-enforceable. E.g., does rule 2 for script subtags (alpha 4 come from ISO 15924) apply? (Surely not.) Thus, it's not clear to me what value this item adds. I think it could be dropped without loss.

Btw, item 3 in that same list is not a separate rule; it is a tangential note related to what is discussed in 2, and does not pertain directly to extensions. I suggest that the text in that paragraph should not be a separately-numbered item in that list, but should just be a parenthetic not appended to item 2. (I.e. the item currently numbered 4 would get renumbered to 3, etc.)

Peter
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Mon, 7 Jul 2008 15:01:15 -0700

This appears to be redundant, since we have this bullet item nearby that more-directly accomplishes the same thing. The only other addition that seems to be implied here is the one about case, so I added on to the end of the bullet so that it reads thusly:

        <t>Each extension subtag MUST be from two to eight characters long
        and consist solely of letters or digits, with each subtag separated by
        a single '-'. Case distinctions are ignored in extensions
        (as with any language subtag) and normalized subtags of this type
        are expected to be in lowercase.</t>

> Btw, item 3 in that same list is not a separate rule; it is a
> tangential note related to what is discussed in 2, and does not
> pertain directly to extensions. I suggest that the text in that
> paragraph should not be a separately-numbered item in that list,
> but should just be a parenthetic not appended to item 2. (I.e. the
> item currently numbered 4 would get renumbered to 3, etc.)

I merged the current item 3 with its preceding paragraph.

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Peter Constable
> Sent: Monday, July 07, 2008 1:08 PM
> To: LTRU Working Group
> Subject: [Ltru] 2.2.6: requirements on extensions
>
> 5. Extension subtags MUST meet all of the requirements for the
> content and format of subtags defined in this document.
> --------------
>
> IMO, this is so vague as to be un-enforceable. E.g., does rule 2
> for script subtags (alpha 4 come from ISO 15924) apply? (Surely
> not.) Thus, it's not clear to me what value this item adds. I think
> it could be dropped without loss.
>
>
>
>
> Peter