Subject: Re: [Ltru] Lowercase language names and the Registry

From: CE Whitehead <[email-masked]>
Date: Fri, 30 Jan 2009 12:54:21 -0500

Hi.  I think Leif and Doug get my vote here. In a list I'd feel comfortable 'title-casing' the first word in French (a language in which language names are also normally 'lower-cased').But I'm not a native speaker.   (NOTE:  I found different conventions regarding titles online:http://www.google.com/search?hl=en&q=histoire+du+francais&btnG=Search http://www.google.com/search?hl=en&q=francais&btnG=Search [these are not lists however, just titles].when a French title appears on a book in the U.S. market, every word on the book may be title-cased:http://shopping.msn.com/prices/allons-y-le-francais-par-etapes-with-audio-cd/itemid25043275/?itemtext=itemname:allons-y-le-francais-par-etapes-with-audio-cd Wikipedia has two conventions for lists in French it seems?:http://fr.wikipedia.org/wiki/Liste_de_langues_par_ordre_alphab%C3%A9tiquehttp://fr.wikipedia.org/wiki/Liste_des_langues_officiellesin one the first word, whether the language name or a definite article preceding the name, is 'upper cased'; in the other list the names are almost all 'lower cased') Thanks. --C. E. [email-masked]   
 From: Leif Halvard Silli <lhs at malform.no> To: Doug Ewell <doug at ewellic.org> Doug Ewell 2009-01-30 07.08:
So far so good, but then the January 26 revision came along and lowercased the Finnish and Swedish names, as the requestor originally suggested (see http://www.sil.org/iso639-3/cr_files/2008-028.pdf):    Finland-Swedish Sign Language
   finlandssvenskt teckenspråk
   suomenruotsalainen viittomakieli
   [...]

I propose that for draft-4645bis and the Language Subtag Registry generally, we introduce a rule that Description fields for language subtags be modified from the ISO-provided name if necessary to ensure they begin with a capital letter, unless the lowercase letter is considered necessary to spell the name correctly (as it is in "tlhIngan-Hol"). This is consistent with draft-4646bis, Section 3.1.5, which allows Description fields to be "edited or modified" from the ISO rendering. Unless someone objects on-list to this rather pedantic suggestion, it will be added to the next draft-4645bis. In my view it is defendable to let language names begin with upper-case letter even in Scandinavian languages, as long as the names appears in a list -aka "menu" - as opposed to in a comma separated line of words. Hence, I'm ok with it. --
leif halvard silli
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Gerard Meijssen <[email-masked]>
Date: Fri, 30 Jan 2009 19:06:43 +0100

Hoi,
If the list is ony to be used as a list with a local application, I agree.
When people want to use lists like this or the CLDR language list, they
depend on the information to be right. It is not and people do.
Thanks,
       Gerard

2009/1/30 CE Whitehead <[email-masked]>

>
> Hi.  I think Leif and Doug get my vote here.
>
>
> In a list I'd feel comfortable 'title-casing' the first word in French (a language in which language names are also normally 'lower-cased').
>
> But I'm not a native speaker.
>
>
>
> (NOTE:  I found different conventions regarding titles online:
>
> http://www.google.com/search?hl=en&q=histoire+du+francais&btnG=Search
>
> http://www.google.com/search?hl=en&q=francais&btnG=Search [these are not lists however, just titles].
>
> when a French title appears on a book in the U.S. market, every word on the book may be title-cased:
>
> http://shopping.msn.com/prices/allons-y-le-francais-par-etapes-with-audio-cd/itemid25043275/?itemtext=itemname:allons-y-le-francais-par-etapes-with-audio-cd
>
> Wikipedia has two conventions for lists in French it seems?:
>
> http://fr.wikipedia.org/wiki/Liste_de_langues_par_ordre_alphab%C3%A9tique
>
> http://fr.wikipedia.org/wiki/Liste_des_langues_officielles
>
> in one the first word, whether the language name or a definite article preceding the name, is 'upper cased'; in the other list the names are almost all 'lower cased')
>
>
>
> Thanks.
>
>
>
> --C. E. Whitehead
>
> [email-masked]
>
>
>
>
>  From: Leif Halvard Silli <lhs at malform.no <[email-masked]>>
> To: Doug Ewell <doug at ewellic.org <[email-masked]>>
>
> Doug Ewell 2009-01-30 07.08:
>
> So far so good, but then the January 26 revision came along and lowercased
> the Finnish and Swedish names, as the requestor originally suggested (see
> http://www.sil.org/iso639-3/cr_files/2008-028.pdf):
>
>    Finland-Swedish Sign Language
> I propose that for draft-4645bis and the Language Subtag Registry generally,
> we introduce a rule that Description fields for language subtags be
> modified from the ISO-provided name if necessary to ensure they begin with
> a capital letter, unless the lowercase letter is considered necessary to
> spell the name correctly (as it is in "tlhIngan-Hol"). This is consistent
> with draft-4646bis, Section 3.1.5, which allows Description fields to be
> "edited or modified" from the ISO rendering.
>
> Unless someone objects on-list to this rather pedantic suggestion, it will
> be added to the next draft-4645bis.
>
> In my view it is defendable to let language names begin with upper-case
> letter even in Scandinavian languages, as long as the names appears in a
> list -aka "menu" - as opposed to in a comma separated line of words.
> Hence, I'm ok with it.
>
> --
> leif halvard silli
>
>

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 30 Jan 2009 10:14:47 -0800

The RFC says quite clearly that the ‘Description’ fields in the registry exist only to provide for unambiguous identification of subtag meaning. They should not be taken to be the localized name or in any particular language. Mainly the registry mirrors whatever one of the ISO groups has put into their standards. 4646bis allows for some cleanup/editing by the LSR in cases where the name has some sort of formatting problem (hence Doug’s inquiry). This is different from the goals of CLDR. People can and should rely on CLDR to be correct in presentation. But we have already warned users NOT to rely on the description fields in the registry.

Note that the registration process exists to allow users of the registry to correct or add additional descriptive material. My tendency is to favor mirroring exactly what ISO 639 has in the “initial” registry. If someone feels strongly about it, they can petition ietf-languages@ to change it. That’s what the process is for and I would tend to support corrections that native language speakers feel strongly about.

So… to be clear, I favor putting *exactly* what ISO 639 has into the initial registry unless it conflicts with a specific provision of 4646bis.

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Gerard Meijssen
Sent: Friday, January 30, 2009 10:07 AM
To: CE Whitehead
Cc: [email-masked]
Subject: Re: [Ltru] Lowercase language names and the Registry

Hoi,
If the list is ony to be used as a list with a local application, I agree. When people want to use lists like this or the CLDR language list, they depend on the information to be right. It is not and people do.
Thanks,
       Gerard
2009/1/30 CE Whitehead <[email-masked]<mailto:[email-masked]>>

Thanks.

--C. E. Whitehead

[email-masked]<mailto:[email-masked]>

From: Leif Halvard Silli <lhs at malform.no<mailto:[email-masked]>>
To: Doug Ewell <doug at ewellic.org<mailto:[email-masked]>>

Doug Ewell 2009-01-30 07.08:
So far so good, but then the January 26 revision came along and lowercased the Finnish and Swedish names, as the requestor originally suggested (see http://www.sil.org/iso639-3/cr_files/2008-028.pdf):

   [...]

I propose that for draft-4645bis and the Language Subtag Registry generally, we introduce a rule that Description fields for language subtags be modified from the ISO-provided name if necessary to ensure they begin with a capital letter, unless the lowercase letter is considered necessary to spell the name correctly (as it is in "tlhIngan-Hol"). This is consistent with draft-4646bis, Section 3.1.5, which allows Description fields to be "edited or modified" from the ISO rendering.

Unless someone objects on-list to this rather pedantic suggestion, it will be added to the next draft-4645bis.
In my view it is defendable to let language names begin with upper-case letter even in Scandinavian languages, as long as the names appears in a list -aka "menu" - as opposed to in a comma separated line of words. Hence, I'm ok with it.

--

leif halvard silli

_______________________________________________
Ltru mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ltru