Subject: Re: [Ltru] RFC 3282: should we revise it?

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 4 Aug 2009 22:23:06 -0700

Hi -

As a technical contributor (returning from two blissful weeks without email) ...

> From: "Phillips, Addison" <[email-masked]>
> To: "LTRU Working Group" <[email-masked]>
> Sent: Friday, July 24, 2009 8:34 AM
> Subject: [Ltru] RFC 3282: should we revise it?
>
> The one bit of language tagging infrastructure that we have not revised
> since this whole body of work has started is RFC 3282, which defines
> Content-Language and Accept-Language.

That was outside the scope for which ltru was originally chartered.

> This morning I had cause to want to reference it, but a desire not to
> (since it depends on 3066 rather than the current-and-future BCP 47).
> I'm pretty sure that the whole machinery of a WG is not needed to
> revise this document--I'm thinking it would make a suitable individual
> submission.

I agree.

> But I thought I'd mention it here to see if anyone had thoughts about
> whether it were necessary, whether this list would make a suitable
> place to solicit comments,

(As co-chair) This seems reasonable for now.  If it turns out to require
significant discussion, or if a better WG "home" appears, we
can redirect the discussion at that time.

> and whether anyone thought a WG charter were necessary for
> same (this last I studiously hope is not the case).

(As technical contributor) I would not support adding this work
to the ltru charter.

Randy

---

From: "Phillips, Addison" <[email-masked]>
Date: Tue, 4 Aug 2009 22:32:39 -0700

> As a technical contributor (returning from two blissful weeks

Welcome back!

I agree, hence:

> > revise this document--I'm thinking it would make a suitable
> > individual submission.
> 
> I agree.
> 

Sounds reasonable. I doubt another WG would appear to make a home for this. Ever the optimist, I would hope that such a revision wouldn't require the level of effort needed for the BCP 47 work.

> (As technical contributor) I would not support adding this work

Absolutely not (shudders). Thanks for the note.

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 19 Aug 2009 12:57:15 +0200

Phillips, Addison wrote:
> The one bit of language tagging infrastructure that we have not revised since this whole body of work has started is RFC 3282, which defines Content-Language and Accept-Language. This morning I had cause to want to reference it, but a desire not to (since it depends on 3066 rather than the current-and-future BCP 47).
FWIW, the reference is:

  [TAGS]      Alvestrand, H., "Tags for the Identification of
               Languages", BCP 47, RFC 3066

At the time, it seemed obvious to me that references to a 
standards-track specification were intended to be "this one or any 
version that obsoletes it"; it was only later that I discovered that 
there could be multiple differences of opinion on this even in cases 
that seemed obvious to me.

If the document were to be revised, an obvious improvement would be to 
split the references into normative and informative, and remove the 
unused ones - none of the ISO references are in fact used; this was the 
result of a rather hasty split from 1766.

If YAM decides that it's ready to go to Standard status, I really don't 
see any need except for formalism and nitpicking to revise the document 
at all.

Over to YAM list....

                   Harald

>  I'm pretty sure that the whole machinery of a WG is not needed to revise this document--I'm thinking it would make a suitable individual submission. But I thought I'd mention it here to see if anyone had thoughts about whether it were necessary, whether this list would make a suitable place to solicit comments, and whether anyone thought a WG charter were necessary for same (this last I studiously hope is not the case).
>
> Addison
>
> Addison Phillips
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ltru
>
>

---

From: John Cowan <[email-masked]>
Date: Wed, 19 Aug 2009 12:07:21 -0400

> that seemed obvious to me.

Well, yes, except that BCP 47 isn't standards-track.

> see any need except for formalism and nitpicking to revise the document 

IMHO, the syntax of Content-Language should be tightened to require proper
4646/4646bis language tag syntax, and the laxer syntaxes should be moved to
obs-* productions.

-- 
John Cowan   [email-masked]    http://ccil.org/~cowan
Original line from The Warrior's Apprentice by Lois McMaster Bujold:
"Only on Barrayar would pulling a loaded needler start a stampede toward one."
English-to-Russian-to-English mangling thereof: "Only on Barrayar you risk to
lose support instead of finding it when you threat with the charged weapon."