Subject: [Lurk] BoF/Anti-BoF and chairiness...

From: Stephen Farrell <[email-masked]>
Date: Sun, 24 Jan 2016 00:37:02 +0000

Hiya,

So it seems there is enough meat here for discussion of this
topic. Based on that, I'll be arguing for there to be a BoF
on this topic at IETF95.

If anyone has a good argument against having a BoF on this
at IETF95, please respond here saying why.

If we do have a BoF, we'll need one or two folks to chair
that session and help with organising in the lead up to that.

If you're not associated with a proposal for what to do here
and willing to help chairing then please send an offlist mail
to Kathleen and I. Note that helping to chair a BoF does not
mean that one is on the hook for chairing a WG if one is formed
later. But that does happen in a lot of cases, so please also
say if you'd be ok with that or if you're only offering to
help out at BoF-time, which can be a fine thing in itself.

Thanks,
S.

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 24 Jan 2016 00:43:35 +0000

A bit of clarification...

Someone asked if a BoF at IETF95 would aim to be wg-forming
or not. "Not" is the answer. But if an IETF95 BoF went very
well, I could imagine forming a WG without a 2nd f2f BoF.

Cheers,
S.

On 24/01/16 00:37, Stephen Farrell wrote:
> _______________________________________________
> Lurk mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lurk
>

---

From: Yoav Nir <[email-masked]>
Date: Sun, 24 Jan 2016 09:14:00 +0200

Hi, Stephen

> On 24 Jan 2016, at 2:37 AM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 

I think there’s definitely meat for discussion here. I’m just not sure what it is that we are going to discuss. Are we “married” to SKI or an SKI-like solution where the original content owner signs for the handshakes, or are we entertaining other solutions?

Yoav

---

From: Yaron Sheffer <[email-masked]>
Date: Sun, 24 Jan 2016 09:27:07 +0200

On 01/24/2016 09:14 AM, Yoav Nir wrote:
> I think there’s definitely meat for discussion here. I’m just not sure 
> what it is that we are going to discuss. Are we “married” to SKI or an 
> SKI-like solution where the original content owner signs for the 
> handshakes, or are we entertaining other solutions? Yoav
IMHO, this should be left up to the BoF to decide.

Jumping the gun a little bit: If this was WG-forming, and we were 
working on a charter, I would recommend that the SKI draft be extended 
with an explanation why it's better than existing, widely deployed 
solutions to a similar problem, namely PKCS #11.

Thanks,
     Yaron

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 24 Jan 2016 11:47:57 +0000

Hiya,

> IMHO, this should be left up to the BoF to decide.

I think Yaron's correct here, esp. as we've not yet established
that TLS is the only use-case of interest. (I think we have
established that TLS is definitely of interest, if there's any
IETF work at all to be done here.)

I'd also note that one of the drafts [1] mentioned on this list
has what seems to be a 3rd party IPR disclosure [2] that'd cause
me, as an individual implementer, to pause. (And btw I have no
more info on that than anyone who reads [1,2] and as always the
details of [2] are not a thing for us to debate, but it's ok to
note its existence and state its affect on one's opinion.)

So, bottom line is that I at least don't think the approach to
be taken is fixed. (Mind you, so far, we're also not swimming in
alternative proposals;-)

S.

[1] https://tools.ietf.org/html/draft-cairns-tls-session-key-interface
[2] https://datatracker.ietf.org/ipr/2638/

---

From: Eric Burger <[email-masked]>
Date: Sun, 24 Jan 2016 07:52:52 -0500

I would offer that we are not talking about a BOF if the purpose is to figure out what we want to do. If we call it a BOF, then the usual BOF suspects will be looking for, asking for, and insisting that we focus on the WG formation questions. That means we will spin our wheels in IETF process and miss out on an opportunity to work towards a solution.

The call for a BOF seems to me to be more of an informal design team meeting to hammer out the problem statement, explore the solution space, and see if enough people are *really* interested in working on a solution.

IIF we can work through the problem statement and solution space on list in the next two months, then we have a shot at having a normal BOF in BA. However, if all goes normal, I would offer we grab a room to work through the problem statement and solution space. The ADs can arrange for that. The down side, which might be an upside, is we would most likely need to schedule it outside of meeting time, i.e., evening or breakfast.

Thoughts?

> On Jan 24, 2016, at 6:47 AM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
>

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 24 Jan 2016 13:03:30 +0000

Hi Eric,

On 24/01/16 12:52, Eric Burger wrote:
> I would offer that we are not talking about a BOF if the purpose is
> to figure out what we want to do. If we call it a BOF, then the usual
> BOF suspects will be looking for, asking for, and insisting that we
> focus on the WG formation questions. That means we will spin our
> wheels in IETF process and miss out on an opportunity to work towards
> a solution.

Eh? Non wg-forming BoFs happen all the time. There is no problem
with doing that and there is value in terms of opening up the issue
to broader input, which a DT approach won't provide. I also think
that some at least of those proposing stuff have in fact already done
the DT thing themselves (which is great) in smaller groups.

So I'm confused by the above.

S.

> 
> The call for a BOF seems to me to be more of an informal design team
> meeting to hammer out the problem statement, explore the solution
> space, and see if enough people are *really* interested in working on
> a solution.
> 
> IIF we can work through the problem statement and solution space on
> list in the next two months, then we have a shot at having a normal
> BOF in BA. However, if all goes normal, I would offer we grab a room
> to work through the problem statement and solution space. The ADs can
> arrange for that. The down side, which might be an upside, is we
> would most likely need to schedule it outside of meeting time, i.e.,
> evening or breakfast.
> 
> Thoughts?
> 
>>>> I think there’s definitely meat for discussion here. I’m just
>>>> not sure what it is that we are going to discuss. Are we
>>>> “married” to SKI or an SKI-like solution where the original
>>>> content owner signs for the handshakes, or are we entertaining
>>>> other solutions? Yoav
>> 
>> established that TLS is definitely of interest, if there's any IETF
>> work at all to be done here.)
>> 
>> I'd also note that one of the drafts [1] mentioned on this list has
>> what seems to be a 3rd party IPR disclosure [2] that'd cause me, as
>> an individual implementer, to pause. (And btw I have no more info
>> on that than anyone who reads [1,2] and as always the details of
>> [2] are not a thing for us to debate, but it's ok to note its
>> existence and state its affect on one's opinion.)
>> 
>> So, bottom line is that I at least don't think the approach to be
>> taken is fixed. (Mind you, so far, we're also not swimming in 
>> alternative proposals;-)
>> 
>> S.
>> 
>> [1]
>> https://tools.ietf.org/html/draft-cairns-tls-session-key-interface 
>> _______________________________________________ Lurk mailing list 
>> [email-masked] https://www.ietf.org/mailman/listinfo/lurk
> 
> 
> 
> _______________________________________________ Lurk mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/lurk
>