Subject: [Lurk] More on Protocols: KMIP, PKCS#11

From: Eric Burger <[email-masked]>
Date: Mon, 8 Feb 2016 19:38:10 -0500

As the clear neophyte here, I would like the group’s collective wisdom. What is missing from KMIP <https://www.oasis-open.org/committees/tc_home.php?wg_abbrev=kmip> that this work group, should it be chartered, needs to fill in?

---

From: Eric Burger <[email-masked]>
Date: Wed, 17 Feb 2016 12:00:48 -0500

Any thoughts, or are we already finished before we start?

> On Feb 8, 2016, at 7:38 PM, Eric Burger <[email-masked]> wrote:
>

---

From: "Joe Hildebrand (jhildebr)" <[email-masked]>
Date: Wed, 17 Feb 2016 17:34:48 +0000

I know a couple of people are looking at KMIP.  It's not conducive to a quick read.

-- 
Joe Hildebrand

---

From: Daniel Migault <[email-masked]>
Date: Wed, 17 Feb 2016 17:41:50 +0000

Hi Eric, 

My understanding is that OASIS is is a network protocol that enables key management operations as well as cryptographic operations such as encryption, decryption and siging. It may be used as an interface between the Content Provider and the HSM.

This does only partly address the use case of LURK as LURK defines an interface between the Edge Server and the Content Provider (Key holder) which means for example:
    - input provided by the Edge Server to the Content Provider are different and specific to TLS ( Client Hello randoms...)
    - output provided by the Content Provider to the Edge Server are different (master secret, premaster secret, signature, validation...)

BR, 
Daniel

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 17 Feb 2016 22:04:34 +0200

Hi Daniel,

Given that in typical use, the private key is *only* used for server 
identity, what's the benefit of the TLS-specific output compared to a 
simple "please sign this blob with your RSA key"?

Thanks,
     Yaron

On 02/17/2016 07:41 PM, Daniel Migault wrote:
> _______________________________________________
> Lurk mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lurk

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 17 Feb 2016 20:06:30 +0000

> Given that in typical use, the private key is *only* used for server identity,
> what's the benefit of the TLS-specific output compared to a simple "please
> sign this blob with your RSA key"?

To avoid becoming a signing oracle.

--  
Senior Architect, Akamai Technologies
IM: [email-masked] Twitter: RichSalz

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 17 Feb 2016 22:13:12 +0200

> To avoid becoming a signing oracle.
Fine, even if the reason is that we're using broken signature algorithms 
that are susceptible to such attacks. Sigh.

However this only means we need to constrain the input, without 
requiring the signer to compute all the TLS parameters.

Thanks,
     Yaron

---

From: Daniel Migault <[email-masked]>
Date: Wed, 17 Feb 2016 20:15:49 +0000

Hi, 

In addition, when PSK_RSA is used for example, the premaster contains the PSK in clear text. So a request for decryption would result in leaking secret information.

BR, 
Daniel