Subject: [Lurk] Which authentication methods to consider ?

From: Daniel Migault <[email-masked]>
Date: Fri, 19 Feb 2016 19:45:27 +0000

Hi,

Authentication methods that have been designed for TLS are:  rsa, dh_dss, dh_rsa, dh_dss, dh_rsa, ecdh_rsa, dh_anon, ecdh_anon, dhe_dss, dhe_rsa, ecdhe_ecdsa, ecdhe_rsa, psk, dhe_psk, rsa_psk

One possibility is that we reduce the number of authentication methods to dhe/ecdhe.

Anyone thinks we should extend / reduce authentication methods in scope of LURK?

BR,
Daniel

[Ericsson]<http://www.ericsson.com/>

DANIEL MIGAULT
Researcher
Research

Ericsson
8500 Boulevard Decarie
H4P 2N2 Montreal, Canada
Phone +1 514 345 7900 46628
Mobile +1 514 452 2160
[email-masked]
www.ericsson.com

[http://www.ericsson.com/current_campaign]<http://www.ericsson.com/current_campaign>

Legal entity: Ericsson Canada Inc., registered office in Montreal. This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer<http://www.ericsson.com/email_disclaimer>

---

From: Andrei Popov <[email-masked]>
Date: Fri, 19 Feb 2016 20:11:49 +0000

I think it's a bit too early to exclude RSA at this point. Can't comment on the usefulness of PSK for LURK purposes.

Cheers,

Andrei

From: Lurk [mailto:[email-masked]] On Behalf Of Daniel Migault
Sent: Friday, February 19, 2016 11:45 AM
To: LURK BoF <[email-masked]>
Subject: [Lurk] Which authentication methods to consider ?

Hi,

BR,
Daniel

[Ericsson]<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fwww.ericsson.com%2f&data=01%7c01%7cAndrei.Popov%40microsoft.com%7c1c53dce0128b484d087008d339653c92%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=Glei81sfNtyHpKgdKfxn5zApZKz35MO9eEq2XjlXEdg%3d>
DANIEL MIGAULT
Researcher
Research

Ericsson
8500 Boulevard Decarie
H4P 2N2 Montreal, Canada
Phone +1 514 345 7900 46628
Mobile +1 514 452 2160
[email-masked]<mailto:[email-masked]>
www.ericsson.com<http://www.ericsson.com>

[http://www.ericsson.com/current_campaign]<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fwww.ericsson.com%2fcurrent_campaign&data=01%7c01%7cAndrei.Popov%40microsoft.com%7c1c53dce0128b484d087008d339653c92%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=YkNkPqWfwU8sgAwgXLMdeXmisRxc6xGgJJCdjm6GMUI%3d>

Legal entity: Ericsson Canada Inc., registered office in Montreal. This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fwww.ericsson.com%2femail_disclaimer&data=01%7c01%7cAndrei.Popov%40microsoft.com%7c1c53dce0128b484d087008d339653c92%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=lQ4nsec%2bg8TdkcWTWjnIO5%2bN%2b2c5ndLTspPuZKRBC7s%3d>

---

From: Watson Ladd <[email-masked]>
Date: Fri, 19 Feb 2016 12:20:43 -0800

Given the usecase seems to be CDN authenticated using keys of content
provider RSA, RSA - ECDHE, ECDSA - ECDHE, seem like enough to me.

On Feb 19, 2016 12:12 PM, "Andrei Popov" <[email-masked]> wrote:
>
> I think it’s a bit too early to exclude RSA at this point. Can’t comment
on the usefulness of PSK for LURK purposes.
> Authentication methods that have been designed for TLS are:  rsa, dh_dss,
dh_rsa, dh_dss, dh_rsa, ecdh_rsa, dh_anon, ecdh_anon, dhe_dss, dhe_rsa,
ecdhe_ecdsa, ecdhe_rsa, psk, dhe_psk, rsa_psk
> Legal entity: Ericsson Canada Inc., registered office in Montreal. This
Communication is Confidential. We only send and receive email on the basis
of the terms set out at www.ericsson.com/email_disclaimer
>
>
> _______________________________________________
> Lurk mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lurk
>