Subject: [Lurk] FW: New Version Notification for draft-mglt-lurk-tls-00.txt

From: Daniel Migault <[email-masked]>
Date: Fri, 8 Jul 2016 15:37:24 +0000

Hi, 

Please find a first draft defining the interfaces between Edge Server and Key Server. I tried to summarize discussions and comments received during the virtual meeting.

Comments are as always welcome!

BR, 
Daniel 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, July 08, 2016 11:34 AM
To: Daniel Migault
Subject: New Version Notification for draft-mglt-lurk-tls-00.txt

A new version of I-D, draft-mglt-lurk-tls-00.txt has been successfully submitted by Daniel Migault and posted to the IETF repository.

Name:		draft-mglt-lurk-tls
Revision:	00
Title:		LURK Protocol for TLS/DTLS1.2 version 1.0
Document date:	2016-07-08
Group:		Individual Submission
Pages:		25
URL:            https://www.ietf.org/internet-drafts/draft-mglt-lurk-tls-00.txt
Status:         https://datatracker.ietf.org/doc/draft-mglt-lurk-tls/
Htmlized:       https://tools.ietf.org/html/draft-mglt-lurk-tls-00

Abstract:
   This document describes the LURK/TLS protocol between a Edge Server
   and a Key Server.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Dmitry Belyavsky <[email-masked]>
Date: Tue, 12 Jul 2016 12:29:41 +0300

Dear Daniel,

Thank you for your work!

We need also a possibility to check whether the Key Server has the
necessary Private Key. IRL we can meet misconfigurations so it is worth
checking in a special way.

I think it should be described either in the "Capability Discovery" section
or in the separate section.

On Fri, Jul 8, 2016 at 6:37 PM, Daniel Migault <[email-masked]>
wrote:

> Hi,
>
> Please find a first draft defining the interfaces between Edge Server and
> Key Server. I tried to summarize discussions and comments received during
> the virtual meeting.
>
> A new version of I-D, draft-mglt-lurk-tls-00.txt has been successfully
> submitted by Daniel Migault and posted to the IETF repository.
>
> URL:
> https://www.ietf.org/internet-drafts/draft-mglt-lurk-tls-00.txt
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>
> _______________________________________________
> Lurk mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lurk
>

-- 
SY, Dmitry Belyavsky

---

From: Daniel Migault <[email-masked]>
Date: Tue, 12 Jul 2016 17:57:29 +0000

Hi,

Thanks for reading the draft and providing feed backs. Currently, one way to check the server got the appropriated Private Key is to send a query. If there is no corresponding private key, an error is returned. This may not be convenient when the number of keys growth.

As you suggested, one way would be to have a specific keyids query that returns all key IDs served by the Key Server. In which case we may need to understand the associated risk of providing the list. Another way  would be to define capability structures and return all of them, in which case we have to evaluate how large the response could be.
Capability {

-          Qtype

-          PRF

-          Key ID

-          …
}

I am fine with either ways. I would be happy to have operational feed backs on what makes more sense.

BR,
Daniel

From: Dmitry Belyavsky [mailto:[email-masked]]
Sent: Tuesday, July 12, 2016 5:30 AM
To: Daniel Migault <[email-masked]>
Cc: [email-masked]
Subject: Re: [Lurk] FW: New Version Notification for draft-mglt-lurk-tls-00.txt

Dear Daniel,

Thank you for your work!

We need also a possibility to check whether the Key Server has the necessary Private Key. IRL we can meet misconfigurations so it is worth checking in a special way.

I think it should be described either in the "Capability Discovery" section or in the separate section.

On Fri, Jul 8, 2016 at 6:37 PM, Daniel Migault <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

BR,
Daniel

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Friday, July 08, 2016 11:34 AM
To: Daniel Migault
Subject: New Version Notification for draft-mglt-lurk-tls-00.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

_______________________________________________
Lurk mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lurk

--
SY, Dmitry Belyavsky