Subject: [Lurk] LURK @ Hackathon101

From: Daniel Migault <[email-masked]>
Date: Sun, 18 Mar 2018 14:50:50 +0000

Lurk met during the Hackathon 101 in London. Feel free to have a look at the presentation [1].

We worked on pyLurk to implement [2] and have it integrated with openssl to perform an rsa authentication. Our next step for Hackathon 102 is to have a complete implementation of pylurk integrated with openssl as well as to have clurk an implementation of lurk in C.

Yours,
Daniel

[1] https://github.com/IETF-Hackathon/ietf101-project-presentations/blob/master/LURK_Hackathon_IETF101.pdf
[2] https://datatracker.ietf.org/doc/draft-mglt-lurk-tls12/

---

From: [email-masked]
Date: Wed, 21 Mar 2018 11:01:41 +0000

For the hackathon here at IETF101, our focus was on a use case where an end-user session stays persistent over a longer period of time (video) so less exposure to volatile/short-lived connections and thus we expect a reduced usage of traffic between the LURK client and LURK server.

The use case is tightly focused on content delegated by an upstream CDN to a downstream CDN and we expect specific redirection towards dCDN for video sessions (VOD/LIVE streaming).

-Sanjay

From: CDNi [mailto:[email-masked]] On Behalf Of Daniel Migault
Sent: Sunday, March 18, 2018 2:51 PM
To: LURK IETF <[email-masked]>; [email-masked]
Subject: [E] [CDNi] LURK @ Hackathon101

Yours,
Daniel

[1] https://github.com/IETF-Hackathon/ietf101-project-presentations/blob/master/LURK_Hackathon_IETF101.pdf<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_IETF-2DHackathon_ietf101-2Dproject-2Dpresentations_blob_master_LURK-5FHackathon-5FIETF101.pdf&d=DwQFAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTVIWCi3T-x6GdHR4ZTgoM&m=g_c9yr08--8XCzLzrKg8tQ78DUq-qGT8bhz0deTUiwY&s=HmJk_AyIQH_otLj9TXTtkMXQ6PDABm8Y_pu6jkZ2ks4&e=>
[2] https://datatracker.ietf.org/doc/draft-mglt-lurk-tls12/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dmglt-2Dlurk-2Dtls12_&d=DwQFAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTVIWCi3T-x6GdHR4ZTgoM&m=g_c9yr08--8XCzLzrKg8tQ78DUq-qGT8bhz0deTUiwY&s=K0YAQ_lQGaadsHgXfqPV_4QUaqyLWdRokKrqq182cFo&e=>