Subject: Re: [Lwip] draft-ietf-lwig-terminology

From: <[email-masked]>
Date: Wed, 20 Feb 2013 12:56:46 +0000

Hi Peter,

The idea of describing the energy characteristics of devices seems of interest to me.
We had an attempt at it in RFC6551 (the RPL routing metrics), and I know it's far from being perfect.
Regarding your suggestion, I would think that most devices that are characterized by P1 also do what you describe for P2.
Therefore, I would not know whether to characterize them with P1 or with P2.
Actually, why did you think that P2 what an "interesting" aspect?
Best regards

Dominique

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de peter van der Stok
Envoyé : mercredi 20 février 2013 12:28
À : carsten bormann; [email-masked]; [email-masked]
Objet : [Lwip] draft-ietf-lwig-terminology

Hi Carsten and Mehmet,

thanks for the terminology draft which is quite useful; and is providing clarifying information.

I want to re-ask to add terminology on power usage (possibly
orthogonal) to the device classes C0-C2, as came forward from several persons on and off the wg-lists.
Power consumption is an important aspect and has quite "interesting"
consequences for protocols and deployment options.
<Suggestion:>

P0: battery-less devices. They have a capacitor which is charged by harvesting power delivered by a small movement or light. The stored energy is just sufficient to send or receive a limited number of (today
1-3) packets per processor wake-up.
It is important to realize that P0 devices are not limited by the number of packets they can send, but are limited as to the rate.

P1: battery-constrained devices. They have a battery. Whereas, P1 devices are limited by the total number of packets they can send.  Every packet they send today is a packet they cannot send tomorrow.

P2: green devices. Independent of the energy source (external, battery
capacitor) these devices continuously switch on and off parts of the electronics to reduce the power consumption as function of the external demands on its operation.

<end suggestion>

In the text under class 0 devices there is a phrase:
"Class 0 devices will participate in Internet communications with the help of larger devices acting as proxies or gateways".

I find it difficult to place the gateway. I have seen the term "server"
mentioned as providing web-services to the device not supporetd by the device itself.

Greetings,

Peter

--
Peter van der Stok
mailto: [email-masked]
www: www.vanderstok.org
tel NL: +31(0)492474673     F: +33(0)966015248
_______________________________________________
Lwip mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lwip

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: peter van der Stok <[email-masked]>
Date: Wed, 20 Feb 2013 15:30:49 +0100

Hi Dominique,

Nice to read that other people struggle with the same issues.
P2 is meant for household appliances connected to the mains, with a low 
stand-by current to reduce power consumption when "off" (e.g. TV set)
It was suggested by Pier-Paolo.
In contrast to P1 devices, P2 devices have access to unlimited energy, 
once they are switched on.
I agree that P1 and P2 devices share "interesting" aspects (such as 
wake-up), but the possible supporting services are completely different.

Hope this explains things a bit more.

Peter

[email-masked] schreef op 2013-02-20 13:56:
> Regarding your suggestion, I would think that most devices that are
> characterized by P1 also do what you describe for P2.
> P0: battery-less devices. They have a capacitor which is charged by
> harvesting power delivered by a small movement or light. The stored
> energy is just sufficient to send or receive a limited number of
> (today
> It is important to realize that P0 devices are not limited by the
> number of packets they can send, but are limited as to the rate.
> 
> P1: battery-constrained devices. They have a battery. Whereas, P1
> devices are limited by the total number of packets they can send.
> Every packet they send today is a packet they cannot send tomorrow.
> 
> capacitor) these devices continuously switch on and off parts of the
> electronics to reduce the power consumption as function of the
> external demands on its operation.
> 
> <end suggestion>
> 
> "Class 0 devices will participate in Internet communications with the
> help of larger devices acting as proxies or gateways".
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous
> avez recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les
> messages electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or
> privileged information that may be protected by law;
> If you have received this email in error, please notify the sender
> and delete this message and its attachments.
> As emails may be altered, France Telecom - Orange is not liable for
> messages that have been modified, changed or falsified.
> Thank you.