Subject: [Lwip] I-D Action: draft-ietf-lwig-terminology-01.txt

From: [email-masked]
Date: Mon, 25 Feb 2013 09:59:16 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Light-Weight Implementation Guidance Working Group of the IETF.

	Title           : Terminology for Constrained Node Networks
	Author(s)       : Carsten Bormann
                          Mehmet Ersue
	Filename        : draft-ietf-lwig-terminology-01.txt
	Pages           : 10
	Date            : 2013-02-25

Abstract:
   The Internet Protocol Suite is increasingly used on small devices
   with severe constraints, creating constrained node networks.  This
   document provides a number of basic terms that have turned out to be
   useful in the standardization work for constrained environments.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lwig-terminology

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-lwig-terminology-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-lwig-terminology-01

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 25 Feb 2013 19:18:10 +0100

> http://www.ietf.org/rfcdiff?url2=draft-ietf-lwig-terminology-01

I just fixed two editorial problems.
It looks like we didn't find the time to discuss the more interesting substantive comments.

E.g., I'd love to include some power terminology if we manage to converge quickly enough -- otherwise I'd like to ship this draft and do another one about power.

I think there are more than two interesting Booleans here.

One class system that has come up in offline discussions centered around sustained average power availability (which may also be bound by the ability to dissipate):

a) ~ Tens of Watts (desktops > laptops)
b) ~ Watts (tablets > phones)
c) tens to hundreds of milliwatts (other rechargable devices, some building infrastructure, line-powered devices in standby mode)
d) tens to hundreds of microwatts (living on an AA for a couple of years)

Somewhat orthogonal to the sustained power availability, some of these devices may come with primary batteries.  
If there is some assumption that the lifetime of the device is bound to the lifetime of the battery, that somewhat changes the situation (every packet sent now cannot be sent later).  
Finally, the scavenging class includes both parking meters with big solar cells and light switches feed from the energy of the button press.

Grüße, Carsten

---

From: peter van der Stok <[email-masked]>
Date: Tue, 26 Feb 2013 09:16:27 +0100

Hi Carsten,

As you may have inferred I am quite willing to provide text for the 
power section.
Let's assume the convergence is quick.

peter

Carsten Bormann schreef op 2013-02-25 19:18:
> E.g., I'd love to include some power terminology if we manage to
> converge quickly enough -- otherwise I'd like to ship this draft and
> do another one about power.
> 
> One class system that has come up in offline discussions centered
> around sustained average power availability (which may also be bound
> by the ability to dissipate):
> 
> c) tens to hundreds of milliwatts (other rechargable devices, some
> building infrastructure, line-powered devices in standby mode)
> Somewhat orthogonal to the sustained power availability, some of
> these devices may come with primary batteries.
> If there is some assumption that the lifetime of the device is bound
> to the lifetime of the battery, that somewhat changes the situation
> (every packet sent now cannot be sent later).
> Finally, the scavenging class includes both parking meters with big
> solar cells and light switches feed from the energy of the button
> press.
> 
> Grüße, Carsten
> 
> _______________________________________________
> Lwip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lwip