Subject: Re: [Lwip] [Gen-art] Genart last call review of draft-ietf-lwig-tcp-constrained-node-networks-10

From: Alissa Cooper <[email-masked]>
Date: Thu, 22 Oct 2020 09:40:26 -0400

Linda, thanks for your review. I think on both points you raise what the document proposes is well supported given the use case. I entered a No Objection ballot.

Alissa

> On Sep 24, 2020, at 1:34 PM, Linda Dunbar via Datatracker <[email-masked]> wrote:
> 
> Reviewer: Linda Dunbar
> Review result: Almost Ready
> 
> I am the assigned Gen-ART reviewer for this draft. The General Area
> Review Team (Gen-ART) reviews all IETF documents being processed
> by the IESG for the IETF Chair.  Please treat these comments just
> like any other last call comments.
> 
> For more information, please see the FAQ at
> 
> <https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.
> 
> Document: draft-ietf-lwig-tcp-constrained-node-networks-10
> Reviewer: Linda Dunbar
> Review Date: 2020-09-24
> IETF LC End Date: 2020-09-30
> IESG Telechat date: Not scheduled for a telechat
> 
> Summary:
> This document describes the guidance on how to configure TCP parameters in the
> Constrained-Node-Networks.
> 
> Major issues:
> 4.1.2. recommends ECN to be used  in the Constrained Node networks. In any
> network, especially when many IoT devices are attached , the congestion can be
> very short lived. Having Constrained node supporting ECN can cause traffic
> oscillation.  In addition, not many deployed internet supports ECN, it can be
> waste of processing of the CNN nodes.
> 
> Section 4.1.1 recommend packet size to be 1280 for IPv6 to avoid the need to
> support Path MTU Discovery. it is problematic.  There are many layers of
> tunneling and encapsulation in today's network, (let's not even assume SR), the
> actual packet size can be much larger.  Supporting Path MTU Discovery is far
> less processing intensive than supporting ECN.
> 
> Minor issues:
> 
> Nits/editorial comments:
> 
> Cheers,
> 
> Linda Dunbar
> 
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Fri, 30 Oct 2020 09:25:40 +0100

Hi Alissa, and Linda,

Thank you very much for your reviews!

Based on Alissa's message, we understand that no update is required
regarding Linda's comments.

Thanks,

Carles (on behalf of the authors)

> Linda, thanks for your review. I think on both points you raise what the
> document proposes is well supported given the use case. I entered a No
> Objection ballot.
>
> Alissa
>
> Lwip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lwip
>