Subject: Re: [Madinas] BoF preparation call - Minutes

From: Juan Carlos Zuniga <[email-masked]>
Date: Fri, 16 Apr 2021 18:07:09 +0000

Dear all,

Thanks for attending the call.

Below are the minutes.

Feel free to let us know if there is any required clarification or missing info.

Best,

Juan Carlos, Carlos & Yiu

MADINAS BoF Prep-call

Friday, 16 April, 14:00-15:00 UTC, Webex

Chairs:
Juan Carlos Zuniga (SIGFOX)
Carlos Bernardos (UC3M)

Note Taker: Yiu Lee (Comcast)

AGENDA

1. Intro & Agenda Bashing - Chairs                            5 minutes

2. Problem Statement                                                   15 minutes
              draft-henry-madinas-framework-01 - Jerome Henry (Cisco)

3. WBA                                                                               20 minutes

              WiFi Devices Identification Group and Paper - Bruno Tomas (WBA), Tim Twell (BT)

4. Proposed Charter & Next Steps                                   20 minutes

              Chairs w/ADs support

MINUTES - Participants (28)

1. Intro & Agenda Bashing - Chairs

JC gave a quick intro and the agenda.

2. Problem Statement

Jerome explained the draft updates. Jerome mentioned that we updated
Table 1 and removed the "Privacy" column because the authors agreed that
privacy is important across the board.

Eric Vycke suggested to replace "framework" to "Problem Statement"

Tim Cappalli has question for PS6. We replace "Define" to "Identify".

3. WBA

Bruno Tomas shared the current work happening in WBA

WBA sees device identity is an important issue. They have a project called
"OpenRoaming".

OpenRoaming is a framework to extend Passpoint to make roaming more user
friendly

Tim Twell is leading the effort in BT for device identity. Tim Twell gave
an overview of the WBA Liaison paper. He acknowledged that using mac-address
as device identity created some challenges moving forward. The White Paper
will provide inputs to the standard bodies. WBA plans to work on requirements
and recommendations pointing to other SDOs - new protocol developments is
last resort. Currently, Tim believes that there isn't an one-size-fit-all
solution for all environments.

WBA released a Liaison Paper that is being shared with IETF MADINAS (newer
version to be distributed on the list).
Section 1 discuss problems caused by mac randomization.
Section 2 looks at different network types and how they use device identity.
Section 3 looks at device distribution of using mac-address randomization.

At the network data plane layer, currently mac-address is being used for
many functions such as telemetry, QoS and Lawful Intercept.

CHAT

rom Eric Vyncke (Cisco) to everyone:    10:07 AM
Sorry for joining late, I had a link to a google meeting ;-)
from Jerome Henry (Cisco) (Cisco) to everyone:    10:08 AM
:0
to Behcet (Guest) (privately):    10:10 AM
Hi Behcet, would you mind muting your mic?
from Tim Cappalli - Microsoft (Guest) to everyone:    10:14 AM
User's personal privacy still matters on managed devices. Its just what level is there legal protection or corporation policies that allow the organization to ignore the user's concerns.
from Eric Vyncke (Cisco) to everyone:    10:14 AM
agreed, some countries are pretty clear on this
from Tim Cappalli - Microsoft (Guest) to everyone:    10:17 AM
This is more of a use case doc, no?
from Eric Vyncke (Cisco) to everyone:    10:17 AM
True
from Eric Vyncke (Cisco) to everyone:    10:19 AM
3.6 is indeed more about requirements
from Erik Kline (Guest) to everyone:    10:19 AM
PS5: s/define/identify/?
from Eric Vyncke (Cisco) to everyone:    10:21 AM
Good idea
from Erik Kline (Guest) to everyone:    10:27 AM
What's the relationship between Open Roaming and Passpoint?  (sorry for the naive question)
from Erik Kline (Guest) to everyone:    10:28 AM
ack; thx
from Behcet (Guest) to everyone:    10:29 AM
Passpoint is authentication protocol developed by WiFi Alliance. It basically does authentication based on email address not MAC address
from Tim Cappalli - Microsoft (Guest) to everyone:    10:30 AM
Passpoint is NOT an authentication protocol
from Tim Cappalli - Microsoft (Guest) to everyone:    10:30 AM
It is a discovery protocl
from Tim Cappalli - Microsoft (Guest) to everyone:    10:30 AM
Nor is email address used
from Behcet (Guest) to everyone:    10:32 AM
This is from WFA: Wi-Fi CERTIFIED Passpoint(r) is an industry-wide solution that streamlines Wi-Fi access and eliminates the need for users to find and authenticate a network each time they visit
from [V] Mark Hamilton Ruckus/CommScope (Guest) to everyone:    10:32 AM
It's both.  It defines discovery mechansisms, and also specifies EAP authentication to be used for access.  I optionally also adds methods to provision EAP identities into the client devices.
from Bruno Tomas WBA (Guest) to everyone:    10:32 AM
Indeed, Passpoint combines 802.11u, 802.11i and 802.1x (allow both EAP-SIM, AKA, TTLS, TLS) authentication. OpenRoaming leverages Passpoint to massively scale user onboarding and Identity Providers. It then adds the end to end perspective, with RadSec/IPSEC, AAA, Dynamic Discovery (optional) of Roaming end points
from Tim Cappalli - Microsoft (Guest) to everyone:    10:32 AM
It references EAP methods, does not define them
from Tim Cappalli - Microsoft (Guest) to everyone:    10:33 AM
and client provisioning != authentication
from Behcet (Guest) to everyone:    10:33 AM
Merci Bruno
from Carsten Bormann (Guest) to everyone:    10:34 AM
This is somewhat hard to follow while it uses identifiers and identities as if they were synonyms
from [V] Mark Hamilton Ruckus/CommScope (Guest) to everyone:    10:36 AM
We should note that EAP level of authentication is not appropriate for all networks.  Where the user and network want/need a mutual trust relationship, Passpoint and OpenRoaming can be leveraged.  But, where the network is "visited" and less (or not) trusted, privacy is still a concern.
from Eric Vyncke (Cisco) to everyone:    10:37 AM
is 'networ types' on slide 4 what the IETF names "use cases" ?
from Tim Cappalli - Microsoft (Guest) to everyone:    10:37 AM
It is not all about trust. It is also about UX
from Tim Cappalli - Microsoft (Guest) to everyone:    10:38 AM
So while Passpoint may seem like overkiill from a protocol standpoint, its UX is unmatched.
[LAST LINES MISSING]

---

From: "Lee, Yiu" <[email-masked]>
Date: Tue, 20 Apr 2021 00:36:20 +0000

@JC: Thanks for doing it. Looks good to me.

Yiu

From: Juan Carlos Zuniga <[email-masked]>
Date: Friday, April 16, 2021 at 14:07
To: "[email-masked]" <[email-masked]>
Cc: CARLOS JESUS BERNARDOS CANO <[email-masked]>, "Lee, Yiu" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [EXTERNAL] RE: BoF preparation call - Minutes

Dear all,

Below are the minutes.

Best,

MADINAS BoF Prep-call

Chairs:

AGENDA

1. Intro & Agenda Bashing – Chairs                            5 minutes

2. Problem Statement                                                   15 minutes
              draft-henry-madinas-framework-01 – Jerome Henry (Cisco)

3. WBA                                                                               20 minutes

              WiFi Devices Identification Group and Paper – Bruno Tomas (WBA), Tim Twell (BT)

              Chairs w/ADs support

1. Intro & Agenda Bashing – Chairs

2. Problem Statement

3. WBA

CHAT

This is from WFA: Wi-Fi CERTIFIED Passpoint® is an industry-wide solution that streamlines Wi-Fi access and eliminates the need for users to find and authenticate a network each time they visit