Subject: [Madinas] MAC address stickers on devices

From: Michael Richardson <[email-masked]>
Date: Thu, 13 May 2021 18:21:39 -0400

I find that many devices that have WIFI in them will have their MAC address
printed on the outside.
(I don't think I've seen this on smartphones of late through)

These stickers have a non-trivial expensive to produce and apply since they
have to be coordinated with what's in the "PROM", and uniquely printed.
(At this point though, it's a sunk cost for most assembly lines)
Is there a regulatory (FCC, CRTC, etc.) requirement for the device to
be identifiable like this because there is a radio inside?

If that is the case, then how will MAC address randomization square with
that?

(I am totally ignorant of this: I studied for, but never got a HAM radio
license. I remember stuff about station identification...)

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Tim Cappalli <[email-masked]>
Date: Thu, 13 May 2021 22:23:13 +0000

I have never come across an IoT/headless device that does MAC randomization.

Tim

________________________________
From: Madinas <[email-masked]> on behalf of Michael Richardson <[email-masked]>
Sent: Thursday, May 13, 2021 6:21:39 PM
To: [email-masked] <[email-masked]>
Subject: [Madinas] MAC address stickers on devices

---

From: Michael Richardson <[email-masked]>
Date: Thu, 13 May 2021 21:07:37 -0400

> I have never come across an IoT/headless device that does MAC

Yet.

Almost all digital signage (which is ironically, often not headless, but it is IoT)
is based upon a current Windows or Linux distribution, and they rarely
change many settings, so if the default is MAC randomization, in two years,
they will all be randomized.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Tim Cappalli <[email-masked]>
Date: Fri, 14 May 2021 01:10:15 +0000

Those devices aren't headless and support strong authentication, no it doesn't really matter if they randomize or not.

________________________________
From: Michael Richardson <[email-masked]>
Sent: Thursday, May 13, 2021 9:07:37 PM
To: Tim Cappalli <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Madinas] MAC address stickers on devices

Yet.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.sandelman.ca%2F&amp;data=04%7C01%7CTim.Cappalli%40microsoft.com%7C057ea1b0153d47948b9708d91674ab1b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637565512612473697%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=M2x0wRtZoUhpVhDR%2BiZNYqDw6fumeZNB1WEu96GvNvE%3D&amp;reserved=0        |   ruby on rails    [

---

From: Tim Cappalli <[email-masked]>
Date: Fri, 14 May 2021 01:13:44 +0000

*so, not no
________________________________
From: Madinas <[email-masked]> on behalf of Tim Cappalli <Tim.Cappalli=[email-masked]>
Sent: Thursday, May 13, 2021 21:10
To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Madinas] MAC address stickers on devices

Yet.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.sandelman.ca%2F&amp;data=04%7C01%7CTim.Cappalli%40microsoft.com%7C057ea1b0153d47948b9708d91674ab1b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637565512612473697%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=M2x0wRtZoUhpVhDR%2BiZNYqDw6fumeZNB1WEu96GvNvE%3D&amp;reserved=0<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.sandelman.ca%2F&data=04%7C01%7Ctim.cappalli%40microsoft.com%7C6088bcd20e8548e6152308d916750ef4%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637565514304891050%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Dg9rV28m0d57%2FyTVRAkORaI8Gi8TdCqMRB60AukBB8E%3D&reserved=0>        |   ruby on rails    [

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Thu, 13 May 2021 22:29:39 -0400

Coming back to the original question:

> ...
Most regulatory compliance requirements on electronic products refer to the
electromagnetic radiation. This has to do with safety as well as with
conformance to frequency spectrum rules.

Also, most stickers are optional and only identify the trade name and model
of the device. This means that there is no need to identify the specific
unit or lot (it is not like a whole batch of WiFi devices will go bad
because it was stored outside a freezer...).

In most cases when a serial # or a MAC address is printed outside it is
because it is used by the manufacturer or the administrator for
identification purposes, like guarantee, service, support, etc.

I don't think we have a protocol in IETF to print identifiers on labels,
but if someone is interested in writing a draft I would be curious about
the contents ;)

Jc

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 14 May 2021 11:22:45 -0500

I agree with Tim here.

Behcet

On Thu, May 13, 2021 at 9:30 PM Juan Carlos Zuniga <[email-masked]>
wrote:

> Most regulatory compliance requirements on electronic products refer to
> the electromagnetic radiation. This has to do with safety as well as with
> Also, most stickers are optional and only identify the trade name and
> model of the device. This means that there is no need to identify the
> specific unit or lot (it is not like a whole batch of WiFi devices will go
> bad because it was stored outside a freezer...).
>
> Madinas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/madinas
>

---

From: Bob Hinden <[email-masked]>
Date: Fri, 14 May 2021 09:40:17 -0700

Hi,

> On May 13, 2021, at 7:29 PM, Juan Carlos Zuniga <[email-masked]> wrote:
> 
> 
> Most regulatory compliance requirements on electronic products refer to the electromagnetic radiation. This has to do with safety as well as with conformance to frequency spectrum rules.
> 
> Also, most stickers are optional and only identify the trade name and model of the device. This means that there is no need to identify the specific unit or lot (it is not like a whole batch of WiFi devices will go bad because it was stored outside a freezer...).
> 
> In most cases when a serial # or a MAC address is printed outside it is because it is used by the manufacturer or the administrator for identification purposes, like guarantee, service, support, etc.
> 
> I don't think we have a protocol in IETF to print identifiers on labels, but if someone is interested in writing a draft I would be curious about the contents ;)
> 

Just to be clear, I don’t think what to put on product labels has anything to do with the IETF.

Bob

---

From: Michael Richardson <[email-masked]>
Date: Fri, 14 May 2021 14:57:11 -0400

Juan Carlos Zuniga <[email-masked]> wrote:
    > I don't think we have a protocol in IETF to print identifiers on
    > labels, but if someone is interested in writing a draft I would be
    > curious about the contents ;)

We don't.

WiFi Alliance's DPP is such a protocol, and the CHIP/MATTER is also proposing
such a thing.  Is the MAC address critical there?  In DPP it is provided, and
I'm unclear about CHIP/MATTER at this point.

---

From: Tim Cappalli <[email-masked]>
Date: Fri, 14 May 2021 18:58:19 +0000

It is optional in DPP.

tim
________________________________
From: Madinas <[email-masked]> on behalf of Michael Richardson <[email-masked]>
Sent: Friday, May 14, 2021 14:57
To: Juan Carlos Zuniga <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [Madinas] MAC address stickers on devices

We don't.