Subject: [Madinas] Call for adoption: draft-zuniga-madinas-mac-address-randomization-01

From: Mathieu Cunche <[email-masked]>
Date: Wed, 10 Nov 2021 17:22:46 +0100

Dear all,

I've been appointed to run the Call for Adoption of 
draft-zuniga-madinas-mac-address-randomization-01

Confirming what was said at the meeting, we are starting a Call for 
Adoption of 
https://datatracker.ietf.org/doc/html/draft-zuniga-madinas-mac-address-randomization-01

Please let us know if you support or oppose the adoption. Likewise, 
please let us know if you have any comments or suggestions.

The Call for Adoption will close 2 weeks after the end of the IETF 
meeting, on the 28th of November.

Regards,

Mathieu Cunche

---

From: Michael Richardson <[email-masked]>
Date: Wed, 10 Nov 2021 14:45:06 -0500

I am in favour of adopting this document as a nomenclature document.
I'm not sure that this document needs to be distinct from the "framework"
document.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Lee, Yiu" <[email-masked]>
Date: Wed, 10 Nov 2021 19:48:01 +0000

Sorry for the confusion in the name of the draft. It started with the "framework". We just continue using it. I agree that there is not really about framework. I think it makes sense to change the name to a proper one when it becomes a WG draft.

On 11/10/21, 14:45, "Madinas on behalf of Michael Richardson" <[email-masked] on behalf of [email-masked]> wrote:

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 10 Nov 2021 14:38:20 -0600

Hi Mathieu, WG,

I think it is too early to start calling for adoptions for madinas.
Today's was the very first meeting. We have seen the drafts only a few days
ago.
What is the hurry?

I would stop all the CFAs.

Behcet

On Wed, Nov 10, 2021 at 10:23 AM Mathieu Cunche <[email-masked]>
wrote:

> Madinas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/madinas
>

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Wed, 10 Nov 2021 21:49:24 +0100

Hi Behcet,

The drafts have been presented and discussed already in previous BoFs
(IETF109, IETF111), side meetings (IETF110) and BoF preparation (April
2021) meetings. We have deadlines to meet for the charter deliverables:

- Sep 2022: Use Cases and Identity Requirements (informational) document
submitted to the IESG for publication
- Jun 2022: MAC Address Randomization current state-of-affairs
(informational) document submitted to the IESG for publication

And the charter also indicates that "MADINAS is expected to be a short
timeframe (12-18 months) Working Group".

Based on all of these, we believe that there is no hurry. We are just
working towards achieving the milestones for which the WG has been
chartered in due form and time.

Thanks,

Carlos

On Wed, Nov 10, 2021 at 9:38 PM Behcet Sarikaya <[email-masked]>
wrote:

> Today's was the very first meeting. We have seen the drafts only a few
> days ago.
> What is the hurry?
>
> On Wed, Nov 10, 2021 at 10:23 AM Mathieu Cunche <
> [email-masked]> wrote:
>
>> Dear all,
>>

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 10 Nov 2021 14:56:07 -0600

Hi Carlos,

> 2021) meetings. We have deadlines to meet for the charter deliverables:
I attended the BOFs. I must admit that during the BOFs, frankly I don't
remember that these drafts were discussed as if in a WG meeting.
BOFs were struggling to make the case for the problem and that's what they
should be for.

Behcet

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 10 Nov 2021 21:07:57 +0000

In my view, a call for adoption can be started at any time as it is only a check whether the WG wants to work on the topic (and that the topic fits the charter).

In this case, if the WG thinks that the topic is worthless or too undefined, then indeed the document should not be adopted.

But if the WG thinks that the topic is worth working on it and the I-D scope is well defined and workable, then let's adopt it. It is not a matter a time but more a matter of content. Of course, we can expect multiple revisions before the WGLC ;-)

Regards

-éric

From: Behcet Sarikaya <[email-masked]>
Reply to: "[email-masked]" <[email-masked]>
Date: Wednesday, 10 November 2021 at 21:38
To: Mathieu Cunche <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Juan Carlos Zuniga <[email-masked]>, CARLOS JESUS BERNARDOS CANO <[email-masked]>, Eric Vyncke <[email-masked]>
Subject: Re: [Madinas] Call for adoption: draft-zuniga-madinas-mac-address-randomization-01

Hi Mathieu, WG,

I think it is too early to start calling for adoptions for madinas.
Today's was the very first meeting. We have seen the drafts only a few days ago.
What is the hurry?

Behcet

On Wed, Nov 10, 2021 at 10:23 AM Mathieu Cunche <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Regards,

Mathieu Cunche

--
Madinas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/madinas

---

From: <[email-masked]>
Date: Thu, 11 Nov 2021 10:15:32 +0000

Hi Mathieu, all, 

I'm afraid that the I-D falls under (https://www.ietf.org/about/groups/iesg/statements/support-documents/). 

The document includes interesting information, but I don't think it is worth publishing as an RFC.

Cheers,
Med

> -----Message d'origine-----
> De : Madinas <[email-masked]> De la part de Mathieu Cunche
> Envoyé : mercredi 10 novembre 2021 17:23
> À : [email-masked]
> Cc : Juan Zuniga <[email-masked]>; CARLOS JESUS BERNARDOS CANO
> <[email-masked]>
> Objet : [Madinas] Call for adoption: draft-zuniga-madinas-mac-address-
> randomization-01
> 
> Dear all,
> 
> Please let us know if you support or oppose the adoption. Likewise, please
> let us know if you have any comments or suggestions.
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Thu, 11 Nov 2021 11:48:58 -0500

(chair hat off)

Hi Med,

I understand the concept of Support Documents when the WG is chartered to
define a solution.
However, in this case MADINAS is chartered to be the point of contact to
discuss to other SDOs about this topic, and also to inform the IETF about
the current state-of-affairs in other SDOs. This is something that keeps
coming back, so having an informative reference provides value to the
discussions. The charter has deliverables to go along these lines.

The draft may be seen as a Support Document if ever the need for new
solutions is identified in the future, but at the moment and with the
current charter we (authors) believe the draft responds to a clear need and
there is value in publishing it - perhaps with references to information on
a git page as suggested during the meeting.

Best,

Juan-Carlos

On Thu, Nov 11, 2021 at 5:15 AM <[email-masked]> wrote:

> Hi Mathieu, all,
>
> I'm afraid that the I-D falls under (
> https://www.ietf.org/about/groups/iesg/statements/support-documents/).
>
> please
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: <[email-masked]>
Date: Thu, 11 Nov 2021 18:05:05 +0000

Re-,

I hear that, Carlos.

The deliverable does not need to be an RFC. The information in this I-D can be put in a wiki or something similar.

Cheers,
Med

De : Juan Carlos Zuniga <[email-masked]>
Envoyé : jeudi 11 novembre 2021 17:49
À : BOUCADAIR Mohamed INNOV/NET <[email-masked]>
Cc : Mathieu Cunche <[email-masked]>; [email-masked]; CARLOS JESUS BERNARDOS CANO <[email-masked]>
Objet : Re: [Madinas] Call for adoption: draft-zuniga-madinas-mac-address-randomization-01

  (chair hat off)

Hi Med,

I understand the concept of Support Documents when the WG is chartered to define a solution.
However, in this case MADINAS is chartered to be the point of contact to discuss to other SDOs about this topic, and also to inform the IETF about the current state-of-affairs in other SDOs. This is something that keeps coming back, so having an informative reference provides value to the discussions. The charter has deliverables to go along these lines.

The draft may be seen as a Support Document if ever the need for new solutions is identified in the future, but at the moment and with the current charter we (authors) believe the draft responds to a clear need and there is value in publishing it - perhaps with references to information on a git page as suggested during the meeting.

Best,

Juan-Carlos

On Thu, Nov 11, 2021 at 5:15 AM <[email-masked]<mailto:[email-masked]>> wrote:
Hi Mathieu, all,

Cheers,
Med

> De : Madinas <[email-masked]<mailto:[email-masked]>> De la part de Mathieu Cunche
> À : [email-masked]<mailto:[email-masked]>
> Cc : Juan Zuniga <[email-masked]<mailto:[email-masked]>>; CARLOS JESUS BERNARDOS CANO
> <[email-masked]<mailto:[email-masked]>>

---

From: "Jerome Henry (jerhenry)" <[email-masked]>
Date: Thu, 11 Nov 2021 19:13:39 +0000

I am in support of adopting this document for our group. I think that it provides critical context around the problem space where the group operates.
The idea of storing on Github the latest observed behavior is also a great way to increase the shelf life of the document.

Regards

Jerome Henry 

On 11/10/21, 11:23 AM, "Madinas on behalf of Mathieu Cunche" <[email-masked] on behalf of [email-masked]> wrote:

    Dear all,

    Regards,

    Mathieu Cunche

---

From: Luther Smith <[email-masked]>
Date: Fri, 12 Nov 2021 14:01:50 +0000

I agree for adoption

Luther

-----Original Message-----
From: Madinas <[email-masked]> On Behalf Of Mathieu Cunche
Sent: Wednesday, November 10, 2021 9:23 AM
To: [email-masked]
Cc: Juan Zuniga <[email-masked]>; CARLOS JESUS BERNARDOS CANO <[email-masked]>
Subject: [Madinas] Call for adoption: draft-zuniga-madinas-mac-address-randomization-01

Dear all,

Confirming what was said at the meeting, we are starting a Call for Adoption of
https://datatracker.ietf.org/doc/html/draft-zuniga-madinas-mac-address-randomization-01

Please let us know if you support or oppose the adoption. Likewise, please let us know if you have any comments or suggestions.

The Call for Adoption will close 2 weeks after the end of the IETF meeting, on the 28th of November.

Regards,

Mathieu Cunche

---

From: Michael Richardson <[email-masked]>
Date: Sat, 13 Nov 2021 18:44:15 -0500

Juan Carlos Zuniga <j.c.zuniga=[email-masked]> wrote:
    > I understand the concept of Support Documents when the WG is chartered
    > to define a solution.  However, in this case MADINAS is chartered to be
    > the point of contact to discuss to other SDOs about this topic, and
    > also to inform the IETF about the current state-of-affairs in other
    > SDOs. This is something that keeps coming back, so having an
    > informative reference provides value to the discussions. The charter
    > has deliverables to go along these lines.

I agree that the internet-draft does this.
The documents were very good in collecting the right information in the right
place so that we could establish the WG.

    > current charter we (authors) believe the draft responds to a clear need
    > and there is value in publishing it - perhaps with references to
    > information on a git page as suggested during the meeting.

It would have value as an RFC only if it can be used by a junior engineer to
explain to their manager why they can't use MAC addresses as primary keys.

To do that, if it details places in IETF specifications where this has
happened, and which were a mistake, then good.

Otherwise, I agree with Med.

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Wed, 24 Nov 2021 00:27:35 +0000

I support the adoption of draft-zuniga-madinas-mac-address-randomization as a WG document, on information track. The document has useful information on the a.) current industry trends around closing privacy gaps in protocol interfaces, b.) privacy support in device eco-system and implementation variations c.) efforts in IETF/WBA/IEEE on the related activities.

Given the scale of impact of MAC randomization to current network architectures, various backend systems, impact to operator services, there is value in documenting the end point behaviors operating in privacy mode, to understand the areas where further standardization is required. The document is a good starting point but requires some good amount of work. Also, I am not sure what the title should be for this document, but it can be restructured to be bit more focused on documenting end point behaviors of different OS implementations in various scenarios, and that by itself can be a useful write-up.

Sri

---------- Forwarded message ---------
From: Mathieu Cunche <[email-masked]<mailto:[email-masked]>>
Date: Wed, Nov 10, 2021 at 5:22 PM
Subject: Call for adoption: draft-zuniga-madinas-mac-address-randomization-01
To: <[email-masked]<mailto:[email-masked]>>
Cc: Juan Zuniga <[email-masked]<mailto:[email-masked]>>, CARLOS JESUS BERNARDOS CANO <[email-masked]<mailto:[email-masked]>>

Dear all,

Regards,

Mathieu Cunche

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 24 Nov 2021 10:16:27 -0600

I read this draft.

+1 to Med.

Behcet