Subject: [Madinas] What device type is affected by RCM?

From: Qin Wu <[email-masked]>
Date: Thu, 4 Nov 2021 05:05:25 +0000

I have read v-03 of draft-henry-madinas-framework. One thing I want to understand is
what device type is affected by RCM? I am scared it cover all device types.
In Section 2, two type of devices are discussed,
one is shared device, the other is personal device. Examples of shared device provided
in the draft include switches in a dense network, 802.11 (WLAN) access points in a crowded airport,
task-specific (e.g. barcode scanners) devices.

I am thinking in these examples actually the shared devices are further broke down into terminal device such as
barcode scanners, which connects to the network and network device in the network such as switch, I am not
sure barcode scanners is a good example, since it may need to connect PC maybe it should be changed into smoke
detector or other sensor without operation system, so the question is whether dumb terminal such as smoke detector
will be considered? for dumb terminal, it may not have operating system.

Also I am wondering whether any Iot device vendor make their IoT device to support MAC Randomization?
do we consider some other terminal device such as printer or camera? or we just consider mobile device?
I can image a guest taking his mobile device or laptop roams around in the campus network, MAC Randomization
has its value to protect user privacy. But there is alternative solution, e.g, SIM based subscriber authentication.

So the question if the terminal device doesn't move and is well trusted in the network and managed by its owner's
IT department, do we have MAC Randomization requirements?

-Qin

---

From: "Jerome Henry (jerhenry)" <[email-masked]>
Date: Thu, 4 Nov 2021 19:53:58 +0000

Hi Qin,

Thanks a lot for this feedback. Please see some answers inline.

Best

Jerome

From: Madinas <[email-masked]> on behalf of Qin Wu <[email-masked]>
Date: Thursday, November 4, 2021 at 1:05 AM
To: "[email-masked]" <[email-masked]>
Subject: [Madinas] What device type is affected by RCM?

I have read v-03 of draft-henry-madinas-framework. One thing I want to understand is
what device type is affected by RCM? I am scared it cover all device types.
[jh] Conceptually, we (the authors of the document) do not want to decide which vendor will decide to implement RCM< and which will not. So conceptually indeed, any device that has a MAC address may implement RCM. However, we think that the primary candidates (those that we care about in this phase) are the ones in your question just below (personal devices).

[jh] Yes indeed. Please note that we did not invent this terminology. It is found in many other texts, for example in 802E, we merely reuse the terms because they have become commonly accepted. From the IEEE dictionary for example:

personal device: A device associated with a user or a group of users, such that identification of the device also allows identification of its user or group of users.

shared service device: A device associated with a large enough group of users, such that identification of the device does not easily allow identification of individual users or groups of users.

[jh] If the barcode scanner does not have a MAC entity on its own, then it is likely not concerned with RCM. Likewise, the smoke detector may be wired (in which case RCM may not be implemented). If it is a dumb terminal without operating system, I doubt that it would have a MAC address to rotate. The main point is that there is an incentive to implement RCM on a device which is associated to a user (or small group) as per the definition above, because the device activity can be equivalent to the user activity. There is less incentive to implement RCM on a device that is not associated to a user. It does not seem to me that the role of the device is especially meaningful. Any traffic going through my home AP (and the switch behind it) is going to be related to me. That same AP/switch in a busy airport is unlikely to expose PII specific to me. But glad to discuss this point further.

Also I am wondering whether any Iot device vendor make their IoT device to support MAC Randomization?
[jh] The choice to implement RCM or not of course belongs to the device vendor, so I do not think that MADINAS can decide who will and will not do it, but my experience is that IoT vendors often use default / of the shelves network stack implementations, and those very commonly implement RCM as an option (that may be on or off by default).

So the question if the terminal device doesn't move and is well trusted in the network and managed by its owner’s
IT department, do we have MAC Randomization requirements?
[jh] I want to be cautious here, and note that MADINAS is not defining who should implement RCM (we are not defining the requirements). Then vendors implement RCM based on if they think that their users will be exposing PII through these devices or not. The device may be mobile or not (I do not think that there is a requirement in that direction, for example my home AP usually does not move). If the device is a printer, then the vendor would decide if PII exposure is likely or not. My thinking is that if it is  a home wireless printer, its traffic can be detected from outside the home and there may be PII exposure. At the same time, if the traffic to the printer is encrypted, and the printer is also not a scanner (so the traffic is only ‘to’ the printer and never ‘from’), then the vendor may decide that the exposure is small and RCM is not needed (RCM may in fact make the printer management more complicated, possibly). As we do not know what individual vendors will think, I believe that it is safe to assume that mobility is not a requirement for RCM to be implemented, but also that we can study the effect of RCM on this or that type of device, but we cannot say if the device should/not or will/not implement RCM.

-Qin

---

From: Qin Wu <[email-masked]>
Date: Fri, 26 Nov 2021 09:26:35 +0000

>[jh] I want to be cautious here, and note that MADINAS is not defining who should implement RCM (we are not defining the requirements). Then vendors implement RCM based on if they think that
>their users will be exposing PII through these devices or not. The device may be mobile or not (I do not think that there is a requirement in that direction, for example my home AP usually does not
 >move). If the device is a printer, then the vendor would decide if PII exposure is likely or not. My thinking is that if it is  a home wireless printer, its traffic can be detected from outside the home and
>there may be PII exposure. At the same time, if the traffic to the printer is encrypted, and the printer is also not a scanner (so the traffic is only ‘to’ the printer and never ‘from’), then the vendor may
>decide that the exposure is small and RCM is not needed (RCM may in fact make the printer management more complicated, possibly). As we do not know what individual vendors will think, I believe
>that it is safe to assume that mobility is not a requirement for RCM to be implemented, but also that we can study the effect of RCM on this or that type of device, but we cannot say if the device
>should/not or will/not implement RCM.
[Qin] Thank Henry for clarification, I agree some of devices in the home network need to consider implement RCM scheme such as smart lock, but I am thinking whether Playstations, lightbulbs, Echos, Google ChromeCast will do MAC address randomization. Even in some public wifi senarios, enterprise scenario such as kisoks (which doesn’t move), loaner laptops may consider to implement RCM schemes. Happy to see how these get evolved.