Subject: Re: [magma] question on igmp snooping

From: Anouk Rocher <[email-masked]>
Date: Thu, 12 Jun 2003 10:12:00 -0400

Hello Saravana,

This definitely helps. I had missed that somehow. A follow
up question : Are the rules currently specified, sufficient
for operation when the multiocast router in the diagram
below is not present. Ie there are on IGMP snooping switches
in the network  and hosts send IGMP join/leave messages.

My take is it would, but the switch-2 to switch-1 and 
switch-1 to switch-2 ports would have to be manually
configured to forward IGMP reports.

Thank you,
Anouk

________________________________________________
Get your own "800" number
Voicemail, fax, email, and a lot more
http://www.ureach.com/reg/tag

---- On Thu, 12 Jun 2003, SARAVANAP ([email-masked])
wrote:

> Hello Anouk,
> 
>    IGMP reports should be forwarded upstream. Though this
configuration is not explicitly mentioned,
> it is taken care in the draft in section 2.1.1, points a,b,c
in page 4. If you follow these rules,
> It'll automatically take care of the configuration you are
talking about. The router will be sending
> the query messages and the reports will be forwarded to the
interface on which the queries were
> received.
> 
>   Quey Flow : Router - Switch 2 - Switch 1 - Host 1
>   Report    : Host 1 - Switch 1 - Switch 2 - Router
> 
> Hope this helps,
> Saravana
> ---
> 
> Subject: [magma] question on igmp snooping
>    Date: Wed, 11 Jun 2003 16:56:44 -0400
>    From: Anouk Rocher <[email-masked]>
>      To: [email-masked]
> 
> 
> Section 2.1.1 of draft-ietf-magma-snoop-07.txt lays down the
> rules for forwarding IGMP packets. However, it does not
> explicitly indicate if an IGMP Membership Reports should be
> forwarded on interfaces connected to other IGMP snooping
> switches.
> 
> It seems like one would need to forward IGMP packets to other
> IGMP snooping switches to make a network of Snooping switches
> connected to a multicast router at one end, work. Or else
> how will IGMP Snooping work in the network below :
> 
>                [multicast router]
>                   /         \
>               [switch2]    [host3]
>                /     \
>            [switch1] [host2]
>              |
>           [host1]
> 
> 
> Comments?
> Anouk

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Karen Kimball <[email-masked]>
Date: Thu, 12 Jun 2003 09:03:35 -0700 (PDT)

Saravana,
	
Thanks for posting the reply.
	
> configured to forward IGMP reports.
	
All of this is outside of the IGMP snooping-switch document.
It is instead part of the IGMP standard(s) itself.
	
To summarize, for proper IGMP operation,
	* Reports and multicast traffic must be forwarded
		in the direction of the Querier and out all
		multicast router ports
	* There must always be an IGMP Querier present. That
		means that there must always be one, 
		preferrably more, IGMP-Querier-capable 
		device.
	
Some IGMP snooping-switches can perform limited Querier
capabilities, enough to make IGMP work properly. BUT, in the
absence of a multicast router, you must be sure that at 
least some of the IGMP switches you are using are IGMP 
Querier-capable.
	
Best regards,
	Karen Kimball

---

From: Karen Kimball <[email-masked]>
Date: Thu, 12 Jun 2003 09:03:35 -0700 (PDT)

Saravana,

	

	
Best regards,
	Karen Kimball