Subject: Re: [magma] AD comments on magma-mrdssm-02

From: Isidor Kouvelas <[email-masked]>
Date: Thu, 05 Jun 2003 11:59:55 -0700

Erik,

Sorry for the long delay in resopnding to your comments. More inline.

Erik Nordmark writes:
>
>Draft-ietf-ssm-arch-00.txt is listed as a normative reference.
>When is that document likely to become a proposed standard?
>The RFC editor would not publish this as an RFC until all normative
>references have been published.
>
>So perhaps ssm-arch was intended to be a non-normative reference?

I will move the reference to an informative section.

>In section 1 it would be quite useful to include the motivation for
>needing local ssm range for IPv4 (and not for IPv6).
>As I understand it, but I could be off base, a single /8 is not
>believed to be sufficient for IPv4 SSM (and in IPv6 there is a whole
>/32).

I think the reason for extending the v4 range is the ability to define
admin-scoped SSM ranges outside 232/8. There has been discussion on
the list for using admin scoped SSM ranges within 232/8 but I think
that in practice most people define additional ranges. 
V6 has well defined admin-scoped SSM ranges.
I will add text to the spec to reflect these points.

>Section 1 could benefit from a reference where it says "the SSM range for
>IPv6 is well defined ..." to the actual definition.

I will add an informative reference to RFC3306.

>Section 2:
>Length
>     The length of the SSM Range Discovery option is variable and
>     depends on the number of destination ranges present in the option
>     as well as the sizes of the ranges.
>In what unit? (octets I assume)
>Does the length include the type and length fields?
>(pretty basic to have missed this IMHO.)

Right.

>Mask-Len-n
>     The mask length for the nth address range.
>In what unit? (bits I assume)
>What is the relationship between this and the number of octets used for 
>the prefix-N field?
>(pretty basic to have missed that as well.)

Yes bits, sorry for the omission. The relationship to the prefix
length is given in the prefix field description. Do you feel I should
also say something here?

>Prefix-n
>     The multicast destination address prefix for the nth range present
>     in this option. The size of the prefix field is variable and
>     depends on the number of significant bits in the prefix (specified
>     in the corresponding Mask-Len field). The field is padded by enough
>     trailing bits to make the end of the field fall on an octet
>     boundary. Note that the value of the trailing bits is irrelevant.
>s/irrelevant/must be sent as zero and ignored on receipt/ ??

Will use your text.. I copied "irrelevant" from the BGP base spec.
Guess I should have fixed that.

>This section could benefit from examples e.g with a /16 prefix and a /17
>prefix.

I can add a sentence about /16 needing two bytes for the prefix and
/17 3 bytes. Do you think this is sufficient or were you thinking
about including a diagram of the actual packet format?

>Nits:
>The document seems to call the option "SSM Range option" but in many
>places it has an added "Discovery" to make it "SSM Range Discovery option".
>Pick one of them.

Updated all occurences to include "Discovery".

>> 8.  Normative
>Missing "References".

Groff mistake. Fixed it.

thanks
Isidor
_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Isidor Kouvelas <[email-masked]>
Date: Thu, 05 Jun 2003 11:59:55 -0700

Erik,

Right.

Groff mistake. Fixed it.

thanks
Isidor

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 6 Jun 2003 15:39:25 +0200 (CEST)

> I will add text to the spec to reflect these points.

Good - that discussion must have occured when I was not around.

> length is given in the prefix field description. Do you feel I should

As long as the relationship is clear you can keep thigs in the prefix-n
description.

> about including a diagram of the actual packet format?

Perhaps text is sufficient. But make sure that you explicitly refer
to the value of the prefix-len field in the text.
 
   Erik

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 6 Jun 2003 15:39:25 +0200 (CEST)

Erik