Subject: [magma] IGMP snooping switch connected to multiple routers

From: Anouk Rocher <[email-masked]>
Date: Wed, 25 Jun 2003 13:51:48 -0400

Hi,

I had a few questions regarding an IGMP snooping switch
(not acting as a proxy) which connects muliple routers. 
I was hoping somebody here could answere these. I have
the following topology in mind :

            [R1]    [R2]
                \   /
                 [S]
                 /  \
              [H1]  [H2]

R1, R2 : Multicast routers
H1, H2 : Multicasting hosts
S      : IGMP Snooping switch

Questions
---------
o Are IGMP membership reports coming in from H1 and H2 are 
  sent to both R1 and R2?
o Are all IGMP messages coming from R1 sent R2 and vice-versa
  by S?

Thanks in advance for your help,
Anouk

________________________________________________
Get your own "800" number
Voicemail, fax, email, and a lot more
http://www.ureach.com/reg/tag

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Anouk Rocher <[email-masked]>
Date: Fri, 27 Jun 2003 19:59:23 -0400

Sorry this went to the wrong alias by mistake.
Anouk

> >>>>>   Re: RE: [magma] IGMP snooping switch connected to
multiple ...
> Command? Hello Srivatsan,
> Command? Even if the switch is intelligent and one router is
the
> Command? primary and the other backup, shouldn't the switch
forward
> Command? queries from one router to the orther? B'cos from
the
> >>>>> 
> >>>>> Too many errors encountered; the rest of the message is
ignored:
> > routers perspective, the switch represents a broadcast 
> > medium. No?
> > 
> > Actually that brings up another poiny : over the switch,
> > only one of the routers will be elected as the Querier.
> > So as long as the switch forwards the routers messages
> > to each other, the Querier election process looks like
> > it will do the right thing.
> > 
> > Regards,
> > Anouk
> > 
> > 
> > 
> > ---- On Fri, 27 Jun 2003, Srivatsan S
([email-masked])
> > wrote:
> > 
> > > Hi Anouk,
> > > 
> > > The behaviour depends on the features on the switch.
> > > 
> > > a. If the switch is provided with some sort of
intelligence,
> > one router port
> > > may be 
> > >    configured as a primary port while other as backup.
The
> > duration between
> > > queries will be 
> > >    monitored on the primary port by the switch and if a
query
> > has not been
> > > received after a 
> > >    significant amount of time (eg: 3 query periods), then,
the
> > switch can use
> > > the backup 
> > >    port to access the router, assuming that the router
through
> > the primary
> > > port is down.
> > > 
> > > b. If no such intelligence is there in the switch, then,
> > switch has to
> > > forward all the IGMP
> > >    reports on both the router ports. But, this may lead
to
> > duplicate
> > > multicast packets on 
> > >    the switch. One has to be careful about this.
> > > 
> > > Hope this helps.
> > > 
> > > Thanks,
> > > Srivatsan
> > > 
> > > 
> > > Srivatsan S
> > > Senior Engineer
> > > MindTree Consulting, Bangalore
> > 
> > 
> > 
> 
>

---

From: Anouk Rocher <[email-masked]>
Date: Fri, 27 Jun 2003 19:59:23 -0400

multiple ...
the
forward
the
intelligence,
The
query
the
through
to