Subject: Re: Re: [magma] question on igmp snooping

From: Anouk Rocher <[email-masked]>
Date: Thu, 12 Jun 2003 17:52:49 -0400

Hello Karen,

Thank you for a comprehensive reply. I see how it works
now. The only confusion on this topic that I have left
is from draft-ietf-magma-igmp-proxy-02.txt which
at the beginning of section 3 states :

   A proxy device performing IGMP/MLD-based forwarding has 
   a single upstream interface and one or more downstream
   interfaces.  These designations are explicitly configured;
   there is no protocol to determine what type each interface 
   is.

So I guess what I am not seeing is when is the manual (explicit)

configuration applicable at all.

Warm regards,
Anouk

---- On Thu, 12 Jun 2003, Karen Kimball
([email-masked]) wrote:

> Hi, Anouk,
> 	
> > Thank you for the summary. It leads one to a model
> > where if an IGMP snooping network does not have a multicast
> > router, one or more of the IGMP snooping switches behave
> > like one and send out IGMP queries. This certainly gets
> > rid of configuring switch-to-switch ports manually for
> > IGMP report forwarding. However, the IGMP queriers will 
> > need to be configured with the list of multicast groups 
> > they are supposed to query for. So there is still some
> > manual intervention required.
> 	
> This actually isn't true. The IGMP Querier sends out a 
> General Query on a fixed interval, which prompts hosts to
> Join any groups they are interested in.
> 	
> You may be thinking instead of the Group-Specific Query.
> This is sent out in response to an IGMP Leave message from
> a host-- it is used to see if any other interested hosts
> remain off of that downstream connection. So, the group to
> Query for in this case was indicated by the Leaving host.
> 	
> 		
> > Regardless, I think even without an IGMP querier the
> > IGMP snooping will work if switch-to-switch ports are
> > configured to forward IGMP reports - just not as robustly 
> > as with a querier. This is kinda cool as for small networks
> > one can get by without the complexities of PIM.
> 	
> You really don't want to configure the switch-to-switch ports
> as forward ports. It is unnecessary, and defeats the purpose
> of the IGMP protocol (which is to SELECTIVELY forward 
> multicast groups). You will instead be forwarding IGMP
traffic
> where, in some cases, you do not want it to go.
> 	
> As I stated previously, the IGMP protocol rules for
forwarding
> toward the Querier/multicast routers and for requiring the
> presence of a Querier on the network already take care of
this.
> 	
> For some snooping IGMP switches, such as the one I work on
(is
> it OK to mention this?), the configuration required is
basically,
> "Turn IGMP on." That's it. I believe that is true for most
other
> vendors, and it is certainly the goal of the draft for 
> recommendations for IGMP snooping switches. 
> 	
> I hope this clears things up. Best Regards,
> 	Karen Kimball	

________________________________________________
Get your own "800" number
Voicemail, fax, email, and a lot more
http://www.ureach.com/reg/tag
_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Karen Kimball <[email-masked]>
Date: Thu, 12 Jun 2003 15:43:08 -0700 (PDT)

Hi, Anouk,
	
> configuration applicable at all.
	
The function of IGMP-Proxy is different from that of IGMP-snooping.
	
The user must configure upstream/downstream for IGMP-Proxy (the
Proxy function may also be done by a router, not just a switch).
	
However, for IGMP in general, as in for an IGMP router or an IGMP
snooping-switch, this configuration is not necessary. The upstream/
downstream is determined solely by where the Querier is located
and also the specification that IGMP protocol packets and/or multicasts
are forwarded in the direction of the Querier and/or mcast routers.
	
The IGMP-Proxy is an enhancement function that is separate from IGMP 
itself, and from IGMP-snooping.
	
More clear now?
	
Best regards,
	Karen Kimball

---

From: Karen Kimball <[email-masked]>
Date: Thu, 12 Jun 2003 15:43:08 -0700 (PDT)

Hi, Anouk,

	

	
More clear now?
	
Best regards,
	Karen Kimball