Subject: [magma] question on igmp snooping

From: Anouk Rocher <[email-masked]>
Date: Wed, 11 Jun 2003 16:56:44 -0400

Section 2.1.1 of draft-ietf-magma-snoop-07.txt lays down the
rules for forwarding IGMP packets. However, it does not
explicitly indicate if an IGMP Membership Reports should be
forwarded on interfaces connected to other IGMP snooping
switches.

It seems like one would need to forward IGMP packets to other
IGMP snooping switches to make a network of Snooping switches
connected to a multicast router at one end, work. Or else
how will IGMP Snooping work in the network below :

               [multicast router]
                  /         \
              [switch2]    [host3]
               /     \
           [switch1] [host2]
             |
          [host1]

Comments?
Anouk

________________________________________________
Get your own "800" number
Voicemail, fax, email, and a lot more
http://www.ureach.com/reg/tag
_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Anouk Rocher <[email-masked]>
Date: Thu, 12 Jun 2003 10:12:00 -0400

Hello Saravana,

This definitely helps. I had missed that somehow. A follow
up question : Are the rules currently specified, sufficient
for operation when the multiocast router in the diagram
below is not present. Ie there are on IGMP snooping switches
in the network  and hosts send IGMP join/leave messages.

My take is it would, but the switch-2 to switch-1 and 
switch-1 to switch-2 ports would have to be manually
configured to forward IGMP reports.

Thank you,
Anouk

---- On Thu, 12 Jun 2003, SARAVANAP ([email-masked])
wrote:

> Hello Anouk,
> 
>    IGMP reports should be forwarded upstream. Though this
configuration is not explicitly mentioned,
> it is taken care in the draft in section 2.1.1, points a,b,c
in page 4. If you follow these rules,
> It'll automatically take care of the configuration you are
talking about. The router will be sending
> the query messages and the reports will be forwarded to the
interface on which the queries were
> received.
> 
>   Quey Flow : Router - Switch 2 - Switch 1 - Host 1
>   Report    : Host 1 - Switch 1 - Switch 2 - Router
> 
> Hope this helps,
> Saravana
> ---
> 
> Subject: [magma] question on igmp snooping
>    Date: Wed, 11 Jun 2003 16:56:44 -0400
>    From: Anouk Rocher <[email-masked]>
>      To: [email-masked]
> 
>

---

From: Anouk Rocher <[email-masked]>
Date: Thu, 12 Jun 2003 16:07:06 -0400

Hello Karen,

Thank you for the summary. It leads one to a model
where if an IGMP snooping network does not have a multicast
router, one or more of the IGMP snooping switches behave
like one and send out IGMP queries. This certainly gets
rid of configuring switch-to-switch ports manually for
IGMP report forwarding. However, the IGMP queriers will 
need to be configured with the list of multicast groups 
they are supposed to query for. So there is still some
manual intervention required.

Regardless, I think even without an IGMP querier the
IGMP snooping will work if switch-to-switch ports are
configured to forward IGMP reports - just not as robustly 
as witha querier. This is kinda cool as for small networks
one can get by without the complexities of PIM.

Sorry if my questions sound dumb - I used to work with DVMRP
a long time ago and am pickung up on IGMP or anything
multicast after a long hiatus.

Anouk.

---- On Thu, 12 Jun 2003, Karen Kimball
([email-masked]) wrote:
> All of this is outside of the IGMP snooping-switch document.
> It is instead part of the IGMP standard(s) itself.
> 	
> To summarize, for proper IGMP operation,
> 	* Reports and multicast traffic must be forwarded
> 		in the direction of the Querier and out all
> 		multicast router ports
> 	* There must always be an IGMP Querier present. That
> 		means that there must always be one, 
> 		preferrably more, IGMP-Querier-capable 
> 		device.
> 	
> Some IGMP snooping-switches can perform limited Querier
> capabilities, enough to make IGMP work properly. BUT, in the
> absence of a multicast router, you must be sure that at 
> least some of the IGMP switches you are using are IGMP 
> Querier-capable.
> 	
> Best regards,
> 	Karen Kimball

---

From: Anouk Rocher <[email-masked]>
Date: Thu, 12 Jun 2003 17:52:49 -0400

Hello Karen,

Thank you for a comprehensive reply. I see how it works
now. The only confusion on this topic that I have left
is from draft-ietf-magma-igmp-proxy-02.txt which
at the beginning of section 3 states :

   A proxy device performing IGMP/MLD-based forwarding has 
   a single upstream interface and one or more downstream
   interfaces.  These designations are explicitly configured;
   there is no protocol to determine what type each interface 
   is.

So I guess what I am not seeing is when is the manual (explicit)

configuration applicable at all.

Warm regards,
Anouk

---- On Thu, 12 Jun 2003, Karen Kimball
([email-masked]) wrote:

> Hi, Anouk,
> This actually isn't true. The IGMP Querier sends out a 
> General Query on a fixed interval, which prompts hosts to
> Join any groups they are interested in.
> 	
> You may be thinking instead of the Group-Specific Query.
> This is sent out in response to an IGMP Leave message from
> a host-- it is used to see if any other interested hosts
> remain off of that downstream connection. So, the group to
> Query for in this case was indicated by the Leaving host.
> 	
> 		
> > as with a querier. This is kinda cool as for small networks
> You really don't want to configure the switch-to-switch ports
> as forward ports. It is unnecessary, and defeats the purpose
> of the IGMP protocol (which is to SELECTIVELY forward 
> multicast groups). You will instead be forwarding IGMP
traffic
> where, in some cases, you do not want it to go.
> 	
> As I stated previously, the IGMP protocol rules for
forwarding
> toward the Querier/multicast routers and for requiring the
> presence of a Querier on the network already take care of
this.
> 	
> For some snooping IGMP switches, such as the one I work on
(is
> it OK to mention this?), the configuration required is
basically,
> "Turn IGMP on." That's it. I believe that is true for most
other
> vendors, and it is certainly the goal of the draft for 
> recommendations for IGMP snooping switches. 
> 	
> I hope this clears things up. Best Regards,
> 	Karen Kimball

---

From: Anouk Rocher <[email-masked]>
Date: Fri, 13 Jun 2003 09:34:03 -0400

Hello Karen,

Thanks for your patient explanataions. I am 
definitely more clear now. 

(Re) reading your mails and the two drafts, it is clear
that the IGMP proxy functionality is optional for IGMP
snooping networks. IGMP proxying does serve the very
useful purpose of summarizing downstream membership to
upstream switches.

I am wondering, as a default, when IGMP proxying is
used in an IGMP Snooping network and there is only
one querier in the switched network, it should make 
sense to have the upstream/downstream definitions 
the same as and automatically determined by the 
location of the querier (ie by the underlying 
IGMP message flow). It seems to me that this
would naturally aggregate membership reports in
the direction of the querier which would be
very desirable.

Warmly,
Anouk

---- On Thu, 12 Jun 2003, Karen Kimball
([email-masked]) wrote:

> The function of IGMP-Proxy is different from that of
IGMP-snooping.
> 	
> The user must configure upstream/downstream for IGMP-Proxy
(the
> Proxy function may also be done by a router, not just a
switch).
> 	
> However, for IGMP in general, as in for an IGMP router or an
IGMP
> snooping-switch, this configuration is not necessary. The
upstream/
> downstream is determined solely by where the Querier is
located
> and also the specification that IGMP protocol packets and/or
multicasts
> are forwarded in the direction of the Querier and/or mcast
routers.
> 	
> The IGMP-Proxy is an enhancement function that is separate
from IGMP 
> itself, and from IGMP-snooping.
> 	
> More clear now?
> 	
> Best regards,
> 	Karen Kimball

---

From: Anouk Rocher <[email-masked]>
Date: Fri, 13 Jun 2003 09:34:03 -0400

Hello Karen,

Warmly,
Anouk

IGMP-snooping.
(the
switch).
IGMP
upstream/
located
multicasts
routers.
from IGMP

---

From: "Srivatsan S" <[email-masked]>
Date: Fri, 13 Jun 2003 15:23:56 +0530

Hi Anouk,

When the system comes up, you may know what interfaces are connected
to multicast routers and hosts. You may want to configure one as the
main upstream interface and others as backup. Having more than one upstream
interface may lead to duplicate packets in the network.

Thanks,
Srivatsan

Srivatsan S
MindTree Consulting, Bangalore
Ph: 91-80-6711777 Extn: 1428

-----Original Message-----
From: Anouk Rocher [mailto:[email-masked]]
Sent: Friday, June 13, 2003 3:23 AM
To: Karen Kimball
Cc: [email-masked]
Subject: Re: [magma] question on igmp snooping

Hello Karen,

Warm regards,
Anouk

traffic
forwarding
this.
(is
basically,
other

DISCLAIMER:
This message (including attachment if any) is confidential and may be privileged. Before opening attachments please check them for viruses and defects. MindTree Consulting Private Limited (MindTree) will not be responsible for any viruses or defects or any forwarded attachments emanating either from within MindTree or outside. If you have received this message by mistake please notify the sender by return  e-mail and delete this message from your system. Any unauthorized use or dissemination of this message in whole or in part is strictly prohibited.  Please note that e-mails are susceptible to change and MindTree shall not be liable for any improper, untimely or incomplete transmission.
_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: "Srivatsan S" <[email-masked]>
Date: Fri, 13 Jun 2003 15:23:56 +0530

Hi Anouk,

Thanks,
Srivatsan

Srivatsan S

-----Original Message-----
From: Anouk Rocher [mailto:[email-masked]]
Sent: Friday, June 13, 2003 3:23 AM
To: Karen Kimball
Cc: [email-masked]
Subject: Re: [magma] question on igmp snooping

Hello Karen,

Warm regards,
Anouk

traffic
forwarding
this.
(is
basically,
other

DISCLAIMER: