Subject: FW: [magma] Proxy querier uses 0.0.0.0 ip address

From: "KIMBALL,KAREN (HP-Roseville,ex1)" <[email-masked]>
Date: Wed, 4 Feb 2004 13:25:02 -0500

Hello, Koen,

We would have to ask Haixiang (IGMP Proxy Draft) author to
be sure, but my impression is that the Proxy Switch does NOT
use the   0.0.0.0 address in sending out any queries.

The Proxy device (possibly a switch) is being used to place
"stubs" in the network, where it interprets all requests for IGMP
forwarding from below and makes any necessary translations
for the larger LAN. Similarly, it sends out its own queries to
(ONLY) its downstream network-- using, I would assume, its 
own IP address.

The devices below the Proxy Switch/Router are innocent of 
any larger LAN beyond it, and would not be confused by
receiving packets with the Proxy Device's real IP address.

Furthermore, we have received some feedback in the MAGMA
mailing list that some hosts will ignore any Queries that 
contain the   0.0.0.0    IP Source Address. Hence, it isn't
recommended that a Device use that address anyway.

Because the Proxy Device would use its own IP address,
your issue does not come up. Any snooping switches down
below believe it to be the real Querier, and will forward all
reports toward it (reports are always forwared toward the
Querier, any routers, and any ports the user has explicitly
configured in "IGMP-forward" mode).

At one time, the IGMP Snooping Switch Draft had 
recommended that the  0.0.0.0 address be used to
send out spoofed Queries to end-nodes if the network
topology changed (to force faster network convergence by
having hosts resubmit reports immediately). However, it 
was decided that this behavior could cause more problems
than it solved, and again, some hosts would ignore such
Queries anyway. The language on not forwarding the Null
Address Query remains.

Thanks,
	Karen Kimball

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Koen Vermeulen
> Sent: Monday, January 26, 2004 4:58 AM
> To: [email-masked]'
> Subject: [magma] Proxy querier uses 0.0.0.0 ip address
> 
> 
> Hello all,
> 
> I have again a question concerning the 'IGMP snooping 
> recommendations' 
> document.
> 
> In part 2.2.1. (IGMP Forwarding Rules) 1), is stated the the 
> multicast 
> router list can be constructed via any combination of 3 ways. 
> However, I 
> have a problem in understanding way b):
> 
> 'The arrival port for IGMP Queries (sent by multicast 
> routers) where the 
> source address is not 0.0.0.0.'
> 
> I am unable to understand why we wouldn't use this type of queries to 
> build our list of multicast routers. 0.0.0.0 means that we 
> are dealing 
> with a 'proxy querier'. In my opinion, this type of switch is 
> very much 
> interested in receiving reports. How else is this proxy able 
> to build an 
> internal membership database?
> 
> Suppose following network:
> 
>    +------------------+
>    | multicast router |
>    +------------------+
>             |
>     +--------------+
>     |IGMP proxy (A)|
>     +--------------+
>        |         \
>        |          \
>  +-----+-----+     \
>  |     |     |      \
> host1 host2 host3    \
>                       \
>                   +-------------------+
>                   | IGMP snooping (B) |
>                   +-------------------+
>                        |         |
>                      host4     host5
> 
> where A is performing 'proxy' functionality (is regularly sending 
> queries downstream to hosts 1-3 and snooping device B)
>   and B is a 'regular non-proxy snooping' switch.
> 
> If B is not taking the upstream interface towards A into account 
> (because of the fact that A is sending its queries with ip address 
> 0.0.0.0), how can A build its membership database allowing multicast 
> traffic to be flooded towards hosts 4 and 5?
> 
> Or am I missing something here?
> 
> Thanks in advance,
> Koen
> 
> 
> _______________________________________________
> magma mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/magma
> 

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: "KIMBALL,KAREN (HP-Roseville,ex1)" <[email-masked]>
Date: Wed, 4 Feb 2004 13:25:02 -0500

Hello, Koen,

Thanks,
	Karen Kimball