Subject: Re: [magma] Proxy querier uses 0.0.0.0 ip address

From: Frank Solensky <[email-masked]>
Date: Wed, 04 Feb 2004 08:55:38 -0500

On Mon, 2004-01-26 at 13:57 +0100, Koen Vermeulen wrote:
> In part 2.2.1. (IGMP Forwarding Rules) 1), is stated the the multicast 
> router list can be constructed via any combination of 3 ways. However, I 
> have a problem in understanding way b):
> 
> 'The arrival port for IGMP Queries (sent by multicast routers) where the 
> source address is not 0.0.0.0.'
> 
> I am unable to understand why we wouldn't use this type of queries to 
> build our list of multicast routers. 0.0.0.0 means that we are dealing 
> with a 'proxy querier'.

Sorry for the delay..  The list in that section describes how to figure
out where the multicast routers are.  A packet with a source address of
0.0.0.0 is not likely to be coming from a router since their interfaces
will usually have a specific host address assigned.

>  In my opinion, this type of switch is very much 
> interested in receiving reports. How else is this proxy able to build an 
> internal membership database?
> 
> Suppose following network:
> 
>    +------------------+
>    | multicast router |
>    +------------------+
>             |
>     +--------------+
>     |IGMP proxy (A)|
>     +--------------+
>        |         \
>        |          \
>  +-----+-----+     \
>  |     |     |      \
> host1 host2 host3    \
>                       \
>                   +-------------------+
>                   | IGMP snooping (B) |
>                   +-------------------+
>                        |         |
>                      host4     host5
> 
> where A is performing 'proxy' functionality (is regularly sending 
> queries downstream to hosts 1-3 and snooping device B)
>   and B is a 'regular non-proxy snooping' switch.
> 
> If B is not taking the upstream interface towards A into account 
> (because of the fact that A is sending its queries with ip address 
> 0.0.0.0), how can A build its membership database allowing multicast 
> traffic to be flooded towards hosts 4 and 5?

The text above doesn't prevent A from using the information in the
packets coming from B; it's suggesting that B shouldn't identify A as
being a multicast router when it sees packets with a source address of
0.0.0.0.  B will know that there's a multicast router in that general
direction as a result of its seeing the queries coming the router
itself, flooded out all of A's other interfaces, but the source address
on those will be the router's address.

			-- Frank

---

From: Frank Solensky <[email-masked]>
Date: Wed, 04 Feb 2004 08:55:38 -0500

-- Frank