Subject: RE: [magma] I-D ACTION:draft-ietf-magma-igmp-proxy-06.txt

From: "Manfredi, Albert E" <[email-masked]>
Date: Wed, 7 Apr 2004 13:43:25 -0400

Not sure I understand the motivation behind:

4.3.
   ...

   An interface can be configured to perform IGMPv1 or IGMPv2. In this
   scenario, the SSM semantic will not be maintained for that interface.
   However, a proxy device that supports this document should ignore
   those IGMPv1 or IGMPv2 subscriptions sent to SSM addresses. And more
   importantly, the packets with source-specific addresses SHOULD NOT be
   forwarded to interfaces with IGMPv2 or IGMPv1 subscriptions for these
   addresses.

What would be wrong in principle with saying that packets belonging to SSM group addresses are forwarded to interfaces with IGMPv1, IGMPv2, or MLDv1 membership to those multicast groups, from any source device providing such multicasts from upstream?

Is the SHOULD NOT there to only discourage use of the SSM address block by non-SSM-capable membership? I can come up with disadvantages either way, so I'm curious why the SHOULD NOT.

Bert

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, April 07, 2004 10:36 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [magma] I-D ACTION:draft-ietf-magma-igmp-proxy-06.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> This draft is a work item of the Multicast & Anycast Group 
> Membership Working Group of the IETF.
> 
> 	Title		: IGMP/MLD-based Multicast Forwarding 
> ('IGMP/MLD Proxying')
> 	Author(s)	: B. Fenner, et al
> 	Filename	: draft-ietf-magma-igmp-proxy-06.txt
> 	Pages		: 11
> 	Date		: 2004-4-6
> 	
> In certain topologies, it is not necessary to run a multicast routing
>    protocol. It is sufficient for a device to learn and proxy group
>    membership information and simply forward multicast packets based
>    upon that information.  This draft describes a mechanism for
>    forwarding based solely upon Internet Group Management Protocol
>    (IGMP) or Multicast Listener Discovery (MLD) membership 
> information.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-magma-igmp-proxy-06.txt

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Haixiang He <[email-masked]>
Date: Wed, 07 Apr 2004 18:44:10 -0400

Bert,

Comments inline.

>What would be wrong in principle with saying that packets belonging to SSM group addresses are forwarded to interfaces with IGMPv1, IGMPv2, or MLDv1 membership to those multicast groups, from any so…
There is nothing wrong in principle.

>Is the SHOULD NOT there to only discourage use of the SSM address block by non-SSM-capable membership? I can come up with disadvantages either way, so I'm curious why the SHOULD NOT.
You are right about the intention. This rule follows the suggestions 
described in IGMPv3/MLDv2 for SSM draft.

regards,
haixiang

---

From: Haixiang He <[email-masked]>
Date: Wed, 07 Apr 2004 18:44:10 -0400

Bert,

Comments inline.

regards,
haixiang