Subject: [magma] IGMP Snooping

From: [email-masked]
Date: Mon, 17 Jan 2005 19:04:46 +0530

Hi,
I have a question with respect to IGMP Snooping switches.

If Layer 2 switch builds an "Include" List as per the Reports it has
received from the Hosts, and if the switch receives data from a
particular source which is part of this "Include" list, will the switch
forward the data to all the Host which are part of the group or will it
send it to only those Hosts which are interested in the source? If it
has to send it to only those hosts which are interested how will this be
sent?
regards
Keerthi

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: "Bharani" <[email-masked]>
Date: Tue, 18 Jan 2005 10:30:04 +0530

Hi

This scenario of forwarding data based on both Group and Source information
is possible
only in case of IP address based IGMPv3 snooping.
Here the membership information is stored in format where the
Group IP address and Source IP addresses are the indices for the
forwarding table built.
So data should be forwarded to the hosts based on groups they are interested
and when the source of that data is from the list of intended sources for
this group.
i.e. the host is able to say the list of sources from which it wants data in
addition
to the interested group(in IGMP v3 snooping).

Regards
Bharani

***************************************

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Monday, 17 January 2005 7:05 PM
To: [email-masked]
Subject: [magma] IGMP Snooping

Hi,

***************************************************************************
This message is proprietary to Future Software Limited (FSL)
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information
and should not be circulated or used for any purpose other than for
what it is intended.

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message.
FSL accepts no responsibility for loss or damage arising from
the use of the information transmitted by this email including
damage from virus.
***************************************************************************

---

From: Jean-Jacques Pansiot <[email-masked]>
Date: Tue, 18 Jan 2005 11:13:10 +0100

>to the interested group(in IGMP v3 snooping).
HI,
note that all packets from  non local sources may have the same layer 2 
source address :
the address of the multicast router. Therefore source management for an 
IGMPv3 snooping
switch would imply to look at the IP header of all multicast data packets.

regards

Jean-Jacques

---

From: "Bharanidharan I" <[email-masked]>
Date: Tue, 18 Jan 2005 16:25:34 +0530

Hi

Pl go thru my mail clearly.
I have mentioned that the forwarding table built by snooping IGMPv3 reports
is
IP addreses based,    i.e the forwarding entry would be like
-----------------
-----------------

Group IPAddress     Source IPAddress     PortList
________________    ________________     ________

This information is built by snooping IGMPv3 reports.
The v3 reports give the following info :
Group IP address and the list of sources from which data is required for
this group.
In case of v3 reports the source IPs is obtained from the report itself and
not from
the source IP of the report.

So it is implied that the look up in the database for data forwarding is
based on
the Group destination address and Source address in the IP header of the IP
Multicast(Data).

Regards
Bharani

-----Original Message-----
From: Jean-Jacques Pansiot [mailto:[email-masked]]
Sent: Tuesday, 18 January 2005 3:43 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [magma] IGMP Snooping

HI,

regards

Jean-Jacques