Subject: Re: [magma] Should a snooping switch proxy or forward IGMP queries?

From: [email-masked]
Date: Mon, 21 Feb 2005 10:32:37 -0500

> On Tue, 2005-01-18 at 11:08 -0500, [email-masked] wrote:
> > Consider an IGMP snooping switch with static routers configured on
> > ports 1 and 2 which receives a general Query on port 5.  Should that
> > query be forwarded (intact) or proxied (with a source address of
> > 0.0.0.0) to ports 3, 4, 6, etc.?  It seems intuitive that it 
> should or
> > the router out port 5 will never know about members that may be out
> > port 3, etc. but "Considerations" doesn't seem to say so.
> 
> (Sorry for delay in responding..)
> 
> It depends on what you mean by "static routers configured..".
> ...

Most snooping switches I've seen have a configuration option to say, "Trust me, there's an IBMP router connected to port N" which directs the switch to send IGMP messages to that port, even if no Query is received from it.

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Frank Solensky <[email-masked]>
Date: Mon, 21 Feb 2005 13:27:20 -0500

On Mon, 2005-02-21 at 10:32 -0500, [email-masked] wrote:
> >..
> Most snooping switches I've seen have a configuration option to say,
> "Trust me, there's an IBMP router connected to port N" which directs
> the switch to send IGMP messages to that port, even if no Query is
> received from it.

But if it's doing that to _all_ IGMP message then the option is
_overriding_ the functionality that snooping would provide.

In short, yes, you're correct: the switch should forward it out all
ports.