Subject: Re: [magma] local loops in IGMP/MLD-based Multicast Forwarding

From: Brian Haberman <[email-masked]>
Date: Tue, 1 Nov 2005 13:10:48 -0500

The proxy draft only specifies the forwarding rules for IGMP messages.
What IGMP messages other than Queries would be sent from A to LAN
2?  Data forwarding rules are driven by the IGMP state maintained at
A & B.

Regards,
Brian

On Oct 31, 2005, at 7:32, ahlem elhaj wrote:

> In draft-ietf-magma-igmp-proxy-06.txt, an “upstream loop” happens when 
> we have this configuration where A and B are IGMP/MLD-proxies:
>  
>            LAN 1  --------------------------------------
>                   Upstream |              | Downstream
>                            A              B
>                 Downstream |              | Upstream
>            LAN 2  --------------------------------------
>  
> This loop is due to unconditional sending of multicast traffic from a 
> downstream interface of a proxy to its upstream interface.
>  
> I think we have also a local loop with the following configuration 
> (both A and B are configured as IGMP/MLD-proxies):
>  
>            LAN 1  --------------------------------------
>                   Upstream |              | Upstream
>                            A              B
>                 Downstream |              | Downstream
>            LAN 2  --------------------------------------
>  
> For this reason: if A forwards packets destined for a multicast group 
> G mentioned in its Membership Database from LAN 1 to LAN 2, this 
> packets will be automatically retransmitted by B from LAN 1 to LAN 2 
> and etc …
> Am I making any confusion?
> Thanks for help,
>
> Yahoo! FareChase - Search multiple travel sites in one click. 
> _______________________________________________
> magma mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/magma
_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: ahlem elhaj <[email-masked]>
Date: Sat, 5 Nov 2005 04:20:58 -0800 (PST)

It is true that IGMP rules are used to forward packets, but there is an exception: a proxy automatically forwards the packets it receives on a downstream interface to its upstream interface.

(The draft has invoked the problem of “Upstream loop” as a result of this unconditional forwarding).

Regards,

Ahlem

Brian Haberman <[email-masked]> wrote:
The proxy draft only specifies the forwarding rules for IGMP messages.
What IGMP messages other than Queries would be sent from A to LAN
2? Data forwarding rules are driven by the IGMP state maintained at
A & B.

Regards,
Brian

> Yahoo! FareChase - Search multiple travel sites in one click. 

---------------------------------
 Yahoo! FareChase - Search multiple travel sites in one click.