Subject: [magma] igmp leave group message

From: AJAY THAKUR <[email-masked]>
Date: Sat, 26 Aug 2006 10:36:56 +0530

HI,
I could not understand how leave group message is changed in igmpv3.
Is it like use message type=0x17 (igmpv2 leave) and add number of
sources from which host doesn't want to receive any multicast packets ?

Thanks
Ajay

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: John Zwiebel <[email-masked]>
Date: Mon, 28 Aug 2006 08:18:29 -0700

There is no "leave group".
There is "include <NULL>" which means the host doesn't want to listen  
to anything.
Normally you wouldn't send such a message (I can't think of any  
reason you would)
So if you are listening to a group you are "Exclude NULL" or do not  
exclude anything.
To leave you change your interface filter state with a "TO_IN<NULL"

The TO_* messages tell the querier to check the other hosts on the  
network to
see if they are still interested in the specific group.