Subject: [magma] IGMP report messages..

From: AJAY THAKUR <[email-masked]>
Date: Thu, 12 Oct 2006 19:47:20 +0530

Hi,
I have doubt about IGMP report messages.
IGMP report messages are sent to group-address.
Is there any reason why we don't send messages to
ALL_IGMP_HOSTS ? (at least once in 100 sec.). So
that routers can learn groups dynamically.

As of now most router implementations does not accept
packet from any UNKNOWN group. So it can accept packet
only if router has configuration about possible groups
in its network.
Many implementation does not support Router Alert Option as
well. So what is the soultion for this ?

with regards,
Ajay Thakur

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: John Zwiebel <[email-masked]>
Date: Thu, 12 Oct 2006 08:44:32 -0700

> that routers can learn groups dynamically.

How about because that was the way IGMPv1/v2 were defined?
It created a lot of problems which is why it was changed in IGMPv3

> only if router has configuration about possible groups

"Most"  I doubt it.  If so, those router implementations are broken.

> well. So what is the soultion for this ?

Many what implementations?
Routers certainly do.  Hosts may or may not.
Routers just have to deal with it.

---

From: Hitoshi Asaeda <[email-masked]>
Date: Fri, 13 Oct 2006 01:21:48 +0900 (JST)

> ALL_IGMP_HOSTS ? (at least once in 100 sec.). So

Because a host that does not join a multicast session does not want to
listen the non-membership report. It is fine only the group member
hosts (and routers) listen the corresponding report.
(In fact, if a host speaks IGMPv3, it does not need to listen the
report at all, because of elimination of a report surpression
mechanism. This is not your question I guess, but would be nice to
know.)

> that routers can learn groups dynamically.

A multicast router captures all IGMP reports, even though it is not
the corresponding group member.

> only if router has configuration about possible groups

What UNKNOWN means? Multicast routers listen all IGMP reports.

> well. So what is the soultion for this ?

I think many routers support it.
If I talk about a BSD's host-side implementation, RA option for IPv6
was implemented years ago and the one for IPv4 is included in the
IGMPv3 implementation of KAME.
--
Hitoshi Asaeda