Subject: [magma] source specific multicast

From: "K T" <[email-masked]>
Date: Wed, 08 Nov 2006 23:31:16 +0000

Hi,

I am little new to multicast/igmp code here.  I am looking for some info on 
following issues.

1) In Linux, How do we initialize variable "ipv4_devconf.force_igmp_version" 
to version 3.  by default it is inialized to 2 in old kernel.  I need to 
find a place where this variable is initialized.

2) Is there any multimedia player for windows XP through which you can send 
a source specific multicast (SSM)/IGMPv3 request to the network from XP 
machine by selecting a particular source.?

Thank you
BC

_________________________________________________________________
Use your PC to make calls at very low rates 
https://voiceoam.pcs.v2s.live.com/partnerredirect.aspx

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Matthias Waehlisch <[email-masked]>
Date: Thu, 9 Nov 2006 04:34:42 +0100 (CET)

Hi,

> find a place where this variable is initialized.
  in general you use the "sysctl" command or editing /etc/sysctl.conf.

> machine by selecting a particular source.?
  I don't know ... But there is a ssmping tool by Stig Venaas running also
under Windows XP: http://www.venaas.no/multicast/ssmping/.

best regards
  matthias

--
Matthias Waehlisch
:. HRZ - FHTW Berlin                     :. link-lab
:. Treskowallee 8, 10318 Berlin, Germany :. Hoenower Str. 35/PF16, 10318 Berlin
:. mailto:[email-masked]              :. mailto:[email-masked]
:. http://home.fhtw-berlin.de/~mw        :. http://www.link-lab.net

---

From: John Zwiebel <[email-masked]>
Date: Thu, 9 Nov 2006 09:31:32 -0800

On Nov 8, 2006, at 3:31 PM, K T wrote:

>
> 2) Is there any multimedia player for windows XP through which you  
> can send a source specific multicast (SSM)/IGMPv3 request to the  
> network from XP machine by selecting a particular source.?
>

Absolutely:  VLC

videolan.org

You can source just about anything and send it out via IPv4 or IPv6
unicast and/or multicast.  even multiple streams at the same time.
You can even receive a unicast stream and convert it to a multicast  
stream

On those hosts (windows) that support IGMPv3 the manual says:

    To receive a SSM (source specific multicast) stream, you can use:
    % vlc udp:server_address@multicast_address[:server_port]

This is a very nice application and it is free.