Subject: [magma] IP Router alert option in IGMP messages

From: Princy Elizabeth <[email-masked]>
Date: Fri, 3 Nov 2006 00:19:39 -0800 (PST)

Hi all,
   
  I had a query on the usage of the IP Router alert option in IGMP messages. I do not understand what exactly is the significance of this option. What does a non-multicast enabled router do on receiving an IGMP 'Join' or a 'Query' with the IP Router alert option set? Does a multicast enabled router actually require this option for recognising IGMP packets in its fast path? Don't most routers look at the IGMP protocol field for identifying IGMP packets?
   
  Thanks and regards,
  Princy

 __________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: John Zwiebel <[email-masked]>
Date: Fri, 3 Nov 2006 17:01:11 -0800

On Nov 3, 2006, at 12:19 AM, Princy Elizabeth wrote:

> Hi all,
>
> I had a query on the usage of the IP Router alert option in IGMP  
> messages. I do not understand what exactly is the significance of  
> this option. What does a non-multicast enabled router do on  
> receiving an IGMP 'Join' or a 'Query' with the IP Router alert  
> option set? Does a multicast enabled router actually require this  
> option for recognising IGMP packets in its fast path? Don't most  
> routers look at the IGMP protocol field for identifying IGMP packets?

Most routers have implemented it. (The RA option)
It should be configurable since some hosts have not.
Its most useful for igmpv2 because IGMP host reports are sent to the  
multicast group address
	not a specific address (as in IGMPv3) which the router is a member of.
Yes if the RA is not configured the router looks at the IP protocol  
field, but the
	problem is that the router must listen to the complete multicast  
group range
	just to see if there might be an IGMP packet.  Using RA, the router  
doesn't have to work so hard.