Subject: [magma] calculating inherited_olist(S,G)

From: ajay thakur <[email-masked]>
Date: Thu, 14 Dec 2006 21:17:01 +0000 (GMT)

Hi,
I have doubt about inherited_olist(S,G) calculation. 

inherited_olist(S,G) is the olist that is relevant for 
forwarding a packet from S to G using both source-
specific and group-specific state. 

My doubt is if RPF_INTERFACE(S) is found in the
inherited_olist(S,G) then do we remove RPF_INTERFACE(S)
from inherited_olist(S,G) ? Is it implemenation dependent?

Thanks,
Ajay 

---------------------------------
 Find out what India is talking about on  - Yahoo! Answers India 
 Send FREE SMS to your friend's mobile from Yahoo! Messenger Version 8. Get it NOW

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: ajay thakur <[email-masked]>
Date: Fri, 15 Dec 2006 13:09:59 +0000 (GMT)

HI,
Thanks for your reply. But I have seen some problem
b'cos of this sort behaviour. Whatever you said makes
sense  while forwarding packets. 

But in some macros we use inherited_olist(S,G) (e.g.
RP uses this macro to decide whether to send register
stop message or not). 

I have seen some miss behaviour of routers because of
this type of usage. 

Ajay

--- Jean-Jacques Pansiot
<[email-masked]> wrote:

> ajay thakur wrote:
> if you look at the full description, you can see
> 
> oiflist = inherited_olist(S,G)
> 
> and then
> 
> oiflist = oiflist (-) iif
> 
> so the incoming interface iif (which must be the
> RPF(S) interface if you use (S,G) tree)
> is removed from oiflist
> 
> Jean-Jacques
> 
> 
> 
> > Thanks,
> > Ajay 
> >   
> >
> >
>
------------------------------------------------------------------------
> > Find out what India is talking about on - Yahoo!
<http://us.rd.yahoo.com/mail/in/yanswers/*http://in.answers.yahoo.com/>
> > Send FREE SMS to your friend's mobile from Yahoo!
> Messenger Version 8. 
> > Get it NOW 
> >
>
<http://us.rd.yahoo.com/mail/in/messengertagline/*http://in.messenger.yahoo.com>
------------------------------------------------------------------------

Send free SMS to your Friends on Mobile from your Yahoo! Messenger. Download Now! http://messenger.yahoo.com/download.php