Subject: [MAGMA]How to distinct the V2 and V3 IGMP query for a snooping switch?

From: [email-masked]
Date: Tue, 9 Jan 2007 21:32:49 +0800 (CST)

According to the 7.1 of RFC3376 (IGMP V3)
7.1. Query Version Distinctions
   The IGMP version of a Membership Query message is determined as
   follows:
      IGMPv1 Query: length = 8 octets AND Max Resp Code field is zero
      IGMPv2 Query: length = 8 octets AND Max Resp Code field is
                    non-zero
      IGMPv3 Query: length >= 12 octets
I have a question about that. For Ethernet the IGMP V2 Query is always encapsulated in a 64 
bytes packet.  da+sa+tpid+ip header+IGMP query+padding+fcs=64 bytes,that means after 8 bytes 
Query fields,there are some padding "zeros".For this packet the TOTAL LENGTH filed of IP 
header is 46.  So it seems that it's impossible for a snooping switch to tell the IGMP QUERY 
version from the IP header length. any other method?
Somebody told me use the Checksum of IGMP to verify whether the Query is V2 OR V3. But i 
think it's not effient for a L2 switch to do that. For the switch which only support V2 
snooping ,it just need let V3 query flood to all ports. Then how can the switch recognize 
the version of the Query?
I have an idea,let the switch just read the QQIC field,if QQIC !=0,it is V3,otherwise it's 
V1 or V2.Can this method work well?  Thank you 
Klein

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: [email-masked]
Date: Tue, 09 Jan 2007 09:09:21 -0500

> I have a question about that. For Ethernet the IGMP V2 Query is 
> always encapsulated in a 64 bytes packet.  da+sa+tpid+ip header+IGMP
> query+padding+fcs=64 bytes,that means after 8 bytes Query fields,there 
> are some padding "zeros".For this packet the TOTAL LENGTH filed of IP 
> version from the IP header length. ...

In my experience, the length in the Ethernet header does not include the
padding bytes but I've found conflicting documentation on the web.

---

From: "Ashish Yadav" <[email-masked]>
Date: Wed, 10 Jan 2007 10:48:40 +0530

In my view, IP does not include the padding of Ethernet in the length.

Warm Regards,
Ashish

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, January 09, 2007 7:39 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [MAGMA]How to distinct the V2 and V3 IGMP query for a
snoopingswitch?

Conexant E-mail Firewall (Conexant.Com) made the following annotations---------------------------------------------------------------------
********************** Legal Disclaimer **************************** 

"This email may contain confidential and privileged material for the sole use of the intended recipient. Any unauthorized review, use or distribution by others is strictly prohibited. If you have received the message in error, please advise the sender by reply email and delete the message. Thank you." 

********************************************************************** 

---------------------------------------------------------------------

---

From: "Ashish Yadav" <[email-masked]>
Date: Wed, 10 Jan 2007 10:57:42 +0530

i.e In case of IGMP, the length is taken from length in IP header. It
does not matter if the Ethernet frame includes padding. In case of
IGMP/IP frames Ethernet length/type is type.

Warm Regards,
Ashish

-----Original Message-----
From: Ashish Yadav [mailto:[email-masked]] 
Sent: Wednesday, January 10, 2007 10:49 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [MAGMA]How to distinct the V2 and V3 IGMP query for
asnoopingswitch?

Warm Regards,
Ashish

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, January 09, 2007 7:39 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [MAGMA]How to distinct the V2 and V3 IGMP query for a
snoopingswitch?

Conexant E-mail Firewall (Conexant.Com) made the following
annotations-------------------------------------------------------------
--------
********************** Legal Disclaimer **************************** 

"This email may contain confidential and privileged material for the
sole use of the intended recipient. Any unauthorized review, use or
distribution by others is strictly prohibited. If you have received the
message in error, please advise the sender by reply email and delete the
message. Thank you."