Subject: Re: [magma] some questions about RFC4605 -- IGMP/MLD multicast proxy

From: Jayanth Chennamangalam <[email-masked]>
Date: Fri, 09 Feb 2007 19:11:00 +0530

Hi Yu-Jung,
 
Consider the following scenarios:
 
1. Querier election is implemented: If the proxy device receives an MLD
Query on a downstream, it should process it for finding out who the querier
should be.
 
---------       ---------
| Proxy |       | Proxy |
---------       ---------
    |               |
    |               |
    -----------------
            |
            |
     Downstream Tree
 
2. Querier election is not implemented: If the proxy device receives an MLD
Query on a downsream, it should not process it, as it should be the only
querier on the network, and no other device should send queries on the
downstream tree.
 
         ---------
         | Proxy |
         ---------
             |
             |
      Downstream Tree
 
In both these cases, MLD Reports received on the downstream should not be
forwared to any other downstream port, as this is not required for any
purpose. Consider the case of an MLD Report from one dowstream interface
(Interface 1) being forwarded on another downstream interface (Interface 2).
Any host on Interface 2 interested in that particular multicast group will
suppress its own MLD Report. So, when the group table is downloaded to the
hardware in the proxy device, it will not have Interface 2 in the forwarding
entry corresponding to that group. This will result in multicast data not
being forwarded to hosts connected to Interface 2.
 
MLD Reports are sent by the proxy device only on the upstream.
 
Regards,
 
Jayanth
 
This email and its attachments contain confidential information from HUAWEI,
which is intended only for the person or entity whose address is listed
above. Any use of the information contained herein in any way (including,
but not limited to, total or partial disclosure, reproduction, or
dissemination) by persons other than the intended recipient(s) is
prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

  _____  

From: Yu-Jung Lee [mailto:[email-masked]] 
Sent: Friday, February 09, 2007 11:02 AM
To: Jayanth Chennamangalam; [email-masked]
Subject: Re: [magma] some questions about RFC4605 -- IGMP/MLD multicast
proxy

Hi, Jayanth:
 
Thanks for your response.
Regarding the answer about (3), MLD Reports should not be sent in response
to MLD Queries received on the downstream. I suppose it means that the proxy
device does not forward received MLD reports on downstream interfaces.
However, the proxy does send out unsolicited reports on its downstream
interfaces whenever the interface itself has multicast address of interest,
and also send out solicited reports with group of interest in response to
MLD Queries received on the downstream interface. Is it right?

BR,
Yu-Jung
 
  _____  

----- Original Message ----- 
From:  <mailto:[email-masked]> Jayanth Chennamangalam 
To:  <mailto:[email-masked]> [email-masked] 
Sent: Thursday, February 08, 2007 9:32 PM
Subject: RE: [magma] some questions about RFC4605 -- IGMP/MLD multicast
proxy
 
Hi Yu-Jung,
 
I have given my answers to your questions inline in your mail attached
below. Hope you will find it useful.
 
Regards,
 
Jayanth Chennamangalam

  _____  

From: Yu-Jung Lee [mailto:[email-masked]] 
Sent: Thursday, February 08, 2007 5:57 PM
To: [email-masked]
Subject: [magma] some questions about RFC4605 -- IGMP/MLD multicast proxy

Hi,
 
I have a few questions regarding RFC 4605.
 
(1) In RFC 4605, it defines that a proxy device has a single upstream
interface and one or more downstream interfaces. What's the reason for the
restriction of only one upstream interface? 
>> If there are more than one upstream port, it would result in upstream
looping. For the proxy device to work, the network should be a tree, with
the upstream interface pointing towards the root of the tree.
 
(2) It is said in the RFC that the proxy device MUST NOT perform the router
portion of IGMP/MLD on its upstream interface. There's no restriction on
performing the host portion of IGMP/MLD on the downstream interfaces. Does
that mean it's okay to send out reports which are received from one
downstream interface to other downstream interfaces? Wouldn't it cause
problems if the hosts attached to downstream interfaces support report
suppression? 
>> The reason behind the lack of restriction on performing the host portion
of IGMP/MLD proxying on the dowstream is to support querier election. The
host functionality does not involve forwarding received MLD Reports.
Besides, if the proxy device sends Reports on the downstream, it might lead
to Report suppression.
 
(3) What should the proxy device do except for querier election if it
receives MLD query on downstream interfaces? Shuold it send out MLD report
on downstream interfaces? (This question is related to (2) though.)
>> If querier election is not implemented, the proxy device should discard
the MLD Query received on the downstream interface. Even if querier election
is implemented, MLD Reports should not be sent in response to MLD Queries
received on the downstream.
 
It's not clear about the protocol behaviors in RFC 4605 and I'm quite
confused. Thanks in advance if anybody have explanations.

BR,
Yu-Jung
 
_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: "Yu-Jung Lee" <[email-masked]>
Date: Fri, 9 Feb 2007 22:08:38 +0800

Hi, Jayanth:

You're right. I see why the proxy device should not forward MLD reports received from one downtream interface to another downstream interface. That's because of report suppression. Now my question is, could a proxy device send out MLD reports on downstream interface if the downstream interface itself is interested in a multicast group?

BR,
Yu-Jung

  ----- Original Message ----- 
  From: Jayanth Chennamangalam 
  To: [email-masked] 
  Sent: Friday, February 09, 2007 9:41 PM
  Subject: Re: [magma] some questions about RFC4605 -- IGMP/MLD multicast proxy

  Hi Yu-Jung,

  1. Querier election is implemented: If the proxy device receives an MLD Query on a downstream, it should process it for finding out who the querier should be.

  ---------       ---------
  | Proxy |       | Proxy |
  ---------       ---------
      |               |
      |               |
      -----------------
              |
              |
       Downstream Tree

  2. Querier election is not implemented: If the proxy device receives an MLD Query on a downsream, it should not process it, as it should be the only querier on the network, and no other device should send queries on the downstream tree.

           ---------
           | Proxy |
           ---------
               |
               |
        Downstream Tree

  In both these cases, MLD Reports received on the downstream should not be forwared to any other downstream port, as this is not required for any purpose. Consider the case of an MLD Report from one dowstream interface (Interface 1) being forwarded on another downstream interface (Interface 2). Any host on Interface 2 interested in that particular multicast group will suppress its own MLD Report. So, when the group table is downloaded to the hardware in the proxy device, it will not have Interface 2 in the forwarding entry corresponding to that group. This will result in multicast data not being forwarded to hosts connected to Interface 2.

  Regards,

  Jayanth

  This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!

------------------------------------------------------------------------------
  From: Yu-Jung Lee [mailto:[email-masked]] 
  Sent: Friday, February 09, 2007 11:02 AM
  To: Jayanth Chennamangalam; [email-masked]
  Subject: Re: [magma] some questions about RFC4605 -- IGMP/MLD multicast proxy

  Hi, Jayanth:

  Thanks for your response.
  Regarding the answer about (3), MLD Reports should not be sent in response to MLD Queries received on the downstream. I suppose it means that the proxy device does not forward received MLD reports on downstream interfaces. However, the proxy does send out unsolicited reports on its downstream interfaces whenever the interface itself has multicast address of interest, and also send out solicited reports with group of interest in response to MLD Queries received on the downstream interface. Is it right?

  BR,
  Yu-Jung

---

From: Jayanth Chennamangalam <[email-masked]>
Date: Thu, 15 Feb 2007 12:08:09 +0530

Hi Yu-Jung,
 
The downstream of the proxy device is an IGMP/MLD router, and it is not the
router which is interested in multicast groups - it is the IGMP/MLD host.
So, for a proxy device, only the upstream - which is the IGMP/MLD host - can
send MLD reports.
 
Regards,
 
Jayanth

  _____  

From: Yu-Jung Lee [mailto:[email-masked]] 
Sent: Friday, February 09, 2007 7:39 PM
To: Jayanth Chennamangalam; [email-masked]
Subject: Re: [magma] some questions about RFC4605 -- IGMP/MLD multicast
proxy

Hi, Jayanth:
 
You're right. I see why the proxy device should not forward MLD reports
received from one downtream interface to another downstream interface.
That's because of report suppression. Now my question is, could a proxy
device send out MLD reports on downstream interface if the downstream
interface itself is interested in a multicast group?
 
BR,
Yu-Jung

----- Original Message ----- 
From: Jayanth  <mailto:[email-masked]> Chennamangalam 
To: [email-masked] 
Sent: Friday, February 09, 2007 9:41 PM
Subject: Re: [magma] some questions about RFC4605 -- IGMP/MLD multicast
proxy

Hi Yu-Jung,

 
---------       ---------
| Proxy |       | Proxy |
---------       ---------
    |               |
    |               |
    -----------------
            |
            |
     Downstream Tree

         ---------
         | Proxy |
         ---------
             |
             |
      Downstream Tree

 
Regards,
 
Jayanth

  _____  

Hi, Jayanth:

BR,
Yu-Jung