Subject: [magma] multicast senders behind an IGMP Proxy

From: "Dan Wing" <[email-masked]>
Date: Thu, 21 Jun 2007 17:18:15 -0700

During WGLC, there was clear consensus from MAGMA and MBONED that supporting
multicast senders behind the IGMP Proxy device was desirable.  However,
while wrapping up draft-ietf-behave-multicast-07, Toerless pointed out a
problem with multicast senders behind an IGMP Proxy device (any IGMP Proxy
device -- not just an IGMP Proxy in a NAT).

The problem is that any multicast flows generated behind the IGMP proxy will
be forwarded up the access link towards the Internet -- even for flows that
you want to keep within your network.  Concrete examples of generating
multicast within a home network include:

 * sending audio to all of your IP-enabled speakers distributed 
   throughout your house,  
 * IP-enabled intercom system, 
 * HD video to multiple telvision sets (kitchen and living room).

In each case, you "could" do unicast, but especially for HD one might easily
envision not having sufficient bandwidth or not wanting to waste the
bandwidth (which might be used for other things).

Does anyone have suggestions on how this might be resolved?

-d

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Prashant Jhingran <[email-masked]>
Date: Fri, 22 Jun 2007 15:31:16 +0530

Hi,

I would like to suggest following methods to  resolve this
issue:

- TTL scoping can be used to control the distribution of
multicast traffic with the objective of easing stress on
scarce resources viz. bandwidth.

- Another way (and probably a preferred choice) would be to
use administratively scoped IP multicast [rfc2365]. 

Moreover, these methods can (to a certain extent) help in
achieving privacy.

PS: "sending audio to all of your IP-enabled speakers
distributed throughout your house" seems to be very
ambitious usage of multicast :-) 

Regards,
Prashant Jhingran

Huawei Technologies
+91-80-41117676 Ext -7175
+91-9448927814

"Sing, dance, serve, meditate and celebrate" 
 - www.artofliving.org  

-----Original Message-----
From: Dan Wing [mailto:[email-masked]] 
Sent: Friday, June 22, 2007 5:48 AM
To: [email-masked]; [email-masked]
Cc: Toerless Eckert
Subject: [magma] multicast senders behind an IGMP Proxy

During WGLC, there was clear consensus from MAGMA and MBONED
that supporting
multicast senders behind the IGMP Proxy device was
desirable.  However,
while wrapping up draft-ietf-behave-multicast-07, Toerless
pointed out a
problem with multicast senders behind an IGMP Proxy device
(any IGMP Proxy
device -- not just an IGMP Proxy in a NAT).

The problem is that any multicast flows generated behind the
IGMP proxy will
be forwarded up the access link towards the Internet -- even
for flows that
you want to keep within your network.  Concrete examples of
generating
multicast within a home network include:

 * sending audio to all of your IP-enabled speakers
distributed 
   throughout your house,  
 * IP-enabled intercom system, 
 * HD video to multiple telvision sets (kitchen and living
room).

In each case, you "could" do unicast, but especially for HD
one might easily
envision not having sufficient bandwidth or not wanting to
waste the
bandwidth (which might be used for other things).

-d

---

From: Brian Haberman <[email-masked]>
Date: Fri, 22 Jun 2007 08:02:21 -0400

In IPv6, the scoping can be accomplished simply with the existing scope
bits without having to rely on the Hop Count.

The home router simply acts as a scope border and does not forward
traffic to the Internet.

Regards,
Brian

---

From: Prashant Jhingran <[email-masked]>
Date: Fri, 22 Jun 2007 17:44:36 +0530

Oh yes, multicast link-local addressing scheme should be
good enough to tackle this issue for IPv6.

My suggestions were applicable for IPv4 alone.

Regards,
Prashant Jhingran

Huawei Technologies

-----Original Message-----
From: Brian Haberman [mailto:[email-masked]] 
Sent: Friday, June 22, 2007 5:32 PM
To: [email-masked]
Cc: 'Dan Wing'; [email-masked]; [email-masked]; 'Toerless
Eckert'
Subject: Re: [magma] multicast senders behind an IGMP Proxy

In IPv6, the scoping can be accomplished simply with the
existing scope
bits without having to rely on the Hop Count.

The home router simply acts as a scope border and does not
forward
traffic to the Internet.

Regards,
Brian

---

From: John Zwiebel <[email-masked]>
Date: Fri, 22 Jun 2007 20:59:37 -0700

On Jun 21, 2007, at 5:18 PM, Dan Wing wrote:

>  Concrete examples of generating

I have a difficult time imagining a home network that would have to
be subnetted.

And although I can imagine 2 HDTVs watching the same channel sometimes,
I don't believe it will happen often enough that there would be any
BW saving inside one's home.

---

From: "Dan Wing" <[email-masked]>
Date: Sun, 24 Jun 2007 21:48:08 -0700

> And although I can imagine 2 HDTVs watching the same channel 
> sometimes, I don't believe it will happen often enough that 
> there would be any BW saving inside one's home.

So you're saying nobody would use multicast within their own 
network?  Here is what we plan on adding to the next revision of
the NAT Multicast document:

<begin>
   As many NATs are located adjacent to bandwidth-constrained access
   links, it is important that multicast senders communicating with
   multicast receivers behind the NAT not have their flows consume
   bandwidth on the access link.  This is accomplished by applications
   using administratively scoped IP addresses.

   REQ-6:   A NAT MUST NOT forward administratively scoped multicast
            traffic (239/8) [RFC2365] from its 'inside' interface(s) to
            its 'outside' interface, unless the NAT has been configured
            to do so.
<end>

Please let me know if you object to that text.

-d