Subject: Re: [magma] Issues in Igmpv3 Snooping switch.

From: Vikaskakkar <[email-masked]>
Date: Fri, 8 Jun 2007 02:17:47 -0700 (PDT)

Hi Ramrao , 

In that case 
1) proxy will generate IGMPv3 report message for  Group address G1 and
forward it Router 
2) Before leaving Group address G2 from proxy , first it will send query to
host thereafter it will generate TO_IN{NONE} and send it to routher 
3) Third record will not be forwarded to routher but source timer / Group
timer will start for  Group address G3

Ramrao Deshpande wrote:
> 
> Hi All,
> 
> How to handle following scenarios in IGSv3 snooping switch
> 
> IGMPv3 Report message is received and contains three group record
> 
> GR1 igmp join to multicast address G1
> GR2 igmp leave to multicast address G2
> GR3 igmpv3 current state record for G3
> 
> In the above case whether report message should be sent router port or it 
> can be discarded?
> 
> 2. Interface is enabled with "Fast Leave"  but that interface contains 
> following hosts 
> 
> Host1-->IGMPv1 host joined to group G1
> Host2-->IGMPv2 host joined to group G1
> Host3-->IGMPv3 is sending leave message(state change record) to G1
> 
> Whether the interface to be pruned because there is a leave message 
> coming? or any other method to handle it.
> 
> Thanks and regards,
> 
> Ramrao G Deshpande
> 
> 
> 
> 
> ***********************  Aricent-Unclassified   ***********************
> "DISCLAIMER: This message is proprietary to Aricent and is intended solely
> for the use of 
> the individual to whom it is addressed. It may contain privileged or
> confidential information and should not be 
> circulated or used for any purpose other than for what it is intended. If
> you have received this message in error, 
> please notify the originator immediately. If you are not the intended
> recipient, you are notified that you are strictly
> prohibited from using, copying, altering, or disclosing the contents of
> this message. Aricent accepts no responsibility for 
> loss or damage arising from the use of the information transmitted by this
> email including damage from virus."
> 
> _______________________________________________
> magma mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/magma
> 
> 

-- 
View this message in context: http://www.nabble.com/Issues-in-Igmpv3-Snooping-switch.-tf3777630.html#a11023064
Sent from the IETF - magma mailing list archive at Nabble.com.

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: kulambi <[email-masked]>
Date: Mon, 11 Jun 2007 06:30:34 -0700 (PDT)

Hi,

For query1: Why do you want to drop the packet? In snooping case ideally you
should not be dropping the packet. I dont see any reason why this valid
packet should be dropped until and unless there are any implementation
constraints. If you drop this packet router may not forward the streams for
G1, it will not stop streaming for G2 and for G3 it may stop streaming if
its timers dont get refreshed. So ideally it should be forwarded.

For Query2: In this case the leave will be entertained and the other hosts
may not get the streams since you stop forwarding the streams. So how to
solve this one? If fastleave is enabled then only one host should be there
on that interface else dont configure fastleave.

-- 
View this message in context: http://www.nabble.com/Issues-in-Igmpv3-Snooping-switch.-tf3777630.html#a11060673
Sent from the IETF - magma mailing list archive at Nabble.com.