Subject: [magma] igmp snooping querier recommendations

From: Prashanth Badabagni <[email-masked]>
Date: Tue, 18 Aug 2009 05:18:35 -0600

Hi,

I've the following questions regarding igmp snooping querier implementation.
Please provide your thoughts on this.

1. Are there any recommendations for implementation igmp snooping querier.

2. what should be the ip address of the queries sent. Should it always be 0.0.0.0 or valid ip address should be allowed. There can be a problem if the general queries are sent with valid ip address, if an l3 router comes up in the vlan, by listening to the query message, it might assume that there is another querier present, which can potentially make the l3 querier a non-querier on that interface.

3. what kinds of queries should be sent, only general queries, or group specific queries should also be allowed.

4. what should be the behavior, if the switch listens to igmp activity in the vlan on which snooping querier is enabled.

Thanks

---

From: "Prashant Jhingran (pjhingra)" <[email-masked]>
Date: Tue, 18 Aug 2009 19:04:25 +0530

Hi Prashanth,

Refer rfc 4541 & 4605, these would clarify your doubts.
 
Regards,
Prashant Jhingran
 
Phone:   +91-80-442 61800
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Prashanth Badabagni
Sent: Tuesday, August 18, 2009 4:49 PM
To: [email-masked]
Subject: [magma] igmp snooping querier recommendations

Hi,

I've the following questions regarding igmp snooping querier
implementation.
Please provide your thoughts on this.

1. Are there any recommendations for implementation igmp snooping
querier.

2. what should be the ip address of the queries sent. Should it always
be 0.0.0.0 or valid ip address should be allowed. There can be a problem
if the general queries are sent with valid ip address, if an l3 router
comes up in the vlan, by listening to the query message, it might assume
that there is another querier present, which can potentially make the l3
querier a non-querier on that interface.

3. what kinds of queries should be sent, only general queries, or group
specific queries should also be allowed.

4. what should be the behavior, if the switch listens to igmp activity
in the vlan on which snooping querier is enabled.

Thanks

_______________________________________________
magma mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/magma

---

From: Prashanth Badabagni <[email-masked]>
Date: Wed, 19 Aug 2009 20:35:40 -0600

Are there any ways to avoid the problem mentioned in point 2 in the 
original post? The only way I see is using a source ip address 0.0.0.0;
But vendors like cisco generate the queries with a valid ip address
configured on the vlan on which snooping querier is enabled.

thanks

-----Original Message-----
From: Prashant Jhingran (pjhingra) [mailto:[email-masked]] 
Sent: Tuesday, August 18, 2009 7:04 PM
To: Prashanth Badabagni
Cc: [email-masked]
Subject: RE: [magma] igmp snooping querier recommendations

Hi Prashanth,

Regards,
Prashant Jhingran
 
Phone:   +91-80-442 61800
 
-----Original Message-----

Hi,

Thanks

---

From: "V, Magesh (Magesh)" <[email-masked]>
Date: Fri, 21 Aug 2009 16:21:26 +0530

The idea of sending GenQuery w/ valid srcIp is indeed to take care of the scenario mentioned in 2) below. That is, whenever a igmp interface in a router receives a general query from someone else then it MUST run querier election on that LAN to decide the ultimate querier.

Thanks,
Magesh.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Prashanth Badabagni
Sent: Thursday, August 20, 2009 8:06 AM
To: Prashant Jhingran (pjhingra)
Cc: [email-masked]
Subject: Re: [magma] igmp snooping querier recommendations

thanks

-----Original Message-----
From: Prashant Jhingran (pjhingra) [mailto:[email-masked]] 
Sent: Tuesday, August 18, 2009 7:04 PM
To: Prashanth Badabagni
Cc: [email-masked]
Subject: RE: [magma] igmp snooping querier recommendations

Hi Prashanth,

Regards,
Prashant Jhingran
 
Phone:   +91-80-442 61800
 
-----Original Message-----

Hi,

Thanks

---

From: "V, Magesh (Magesh)" <[email-masked]>
Date: Fri, 21 Aug 2009 17:32:55 +0530

Okay, wait a minute. I might be slightly out of context.
For Snooping querier; the way to avoid scenario 2) is to send queries w/ zero srcip. 
By default it can send w/ 0.0.0.0. It can also give a simple configuration option to specify an ip-address (a real ip interface w/ that address need not exist). If it is so, then it becomes the responsibility of the administrator to ensure the ip address he chooses is inferior to that of the IGMP router.

Thanks,
Magesh.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of V, Magesh (Magesh)
Sent: Friday, August 21, 2009 4:21 PM
To: Prashanth Badabagni; Prashant Jhingran (pjhingra)
Cc: [email-masked]
Subject: Re: [magma] igmp snooping querier recommendations

Thanks,
Magesh.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Prashanth Badabagni
Sent: Thursday, August 20, 2009 8:06 AM
To: Prashant Jhingran (pjhingra)
Cc: [email-masked]
Subject: Re: [magma] igmp snooping querier recommendations

thanks

-----Original Message-----
From: Prashant Jhingran (pjhingra) [mailto:[email-masked]] 
Sent: Tuesday, August 18, 2009 7:04 PM
To: Prashanth Badabagni
Cc: [email-masked]
Subject: RE: [magma] igmp snooping querier recommendations

Hi Prashanth,

Regards,
Prashant Jhingran
 
Phone:   +91-80-442 61800
 
-----Original Message-----

Hi,

Thanks

---

From: Prashanth Badabagni <[email-masked]>
Date: Fri, 21 Aug 2009 06:11:36 -0600

Is it not simple to use the source address 0.0.0.0 always?
Are there any other problems of using source ip as 0.0.0.0

thanks
-----Original Message-----
From: V, Magesh (Magesh) [mailto:[email-masked]] 
Sent: Friday, August 21, 2009 5:33 PM
To: V, Magesh (Magesh); Prashanth Badabagni; Prashant Jhingran (pjhingra)
Cc: [email-masked]
Subject: RE: [magma] igmp snooping querier recommendations

Thanks,
Magesh.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of V, Magesh (Magesh)
Sent: Friday, August 21, 2009 4:21 PM
To: Prashanth Badabagni; Prashant Jhingran (pjhingra)
Cc: [email-masked]
Subject: Re: [magma] igmp snooping querier recommendations

Thanks,
Magesh.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Prashanth Badabagni
Sent: Thursday, August 20, 2009 8:06 AM
To: Prashant Jhingran (pjhingra)
Cc: [email-masked]
Subject: Re: [magma] igmp snooping querier recommendations

thanks

-----Original Message-----
From: Prashant Jhingran (pjhingra) [mailto:[email-masked]] 
Sent: Tuesday, August 18, 2009 7:04 PM
To: Prashanth Badabagni
Cc: [email-masked]
Subject: RE: [magma] igmp snooping querier recommendations

Hi Prashanth,

Regards,
Prashant Jhingran
 
Phone:   +91-80-442 61800
 
-----Original Message-----

Hi,

Thanks