Subject: [magma] IGMP NonQuerier Adopted Robustness value

From: rajasekar bonthala <[email-masked]>
Date: Mon, 30 Nov 2009 11:58:21 +0530

Hi,

In the IGMP RFC it is mentioned that Non-Querier adopts the Robustness value
of the querier.
There are some IGMP Protocol parameters, where they depend on Robustness to
derive their value, for example non-querier timeout, start-up query
count etc... I think these should also change accordingly, after adopting
robustness.

In the case of start-up query count,  is it required that start-up query
count should also change ?

Thanks,
RajaSekhar

---

From: Bharat Joshi <[email-masked]>
Date: Mon, 30 Nov 2009 12:16:48 +0530

Rajsekhar,

    Yes. You are right. Adoption of the robustness value is done for such usage.

    Startup-query count need not be based on the learnt value. When IGMP is started on an interface, it does not know who is the present querier and what is the robustness value. It assumes itself to be the querier and start sending query with whatever it is configured with.

Thanks,
Bharat
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of rajasekar bonthala [[email-masked]]
Sent: Monday, November 30, 2009 11:58 AM
To: [email-masked]; [email-masked]
Subject: [magma] IGMP NonQuerier Adopted Robustness value

Hi,

In the IGMP RFC it is mentioned that Non-Querier adopts the Robustness value of the querier.
There are some IGMP Protocol parameters, where they depend on Robustness to derive their value, for example non-querier timeout, start-up query count etc... I think these should also change accordingly, after adopting robustness.

In the case of start-up query count,  is it required that start-up query count should also change ?

Thanks,
RajaSekhar

---

From: rajasekar bonthala <[email-masked]>
Date: Mon, 30 Nov 2009 12:56:36 +0530

Thanks a lot to Bharat and Kunal for replies.

~RajaSekhar

On Mon, Nov 30, 2009 at 12:25 PM, Kunal Shah <[email-masked]>wrote:

>  Hi,
>
>    IMO, start-up query count is used when IGMP has just come up on an
> interface and is not aware of who the querier is and hence, what values to
> use for robustness. So start-up query count should not be changed even when
> the querier's robust values are adopted.
>
> Kunal
>
>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *rajasekar bonthala
> *Sent:* Sunday, November 29, 2009 10:28 PM
>
> *To:* [email-masked]; [email-masked]
> *Subject:* [magma] IGMP NonQuerier Adopted Robustness value
>
>   Hi,
>

---

From: rajasekar bonthala <[email-masked]>
Date: Mon, 30 Nov 2009 12:56:36 +0530

~RajaSekhar

---

From: "K.Kawaguchi" <[email-masked]>
Date: Mon, 30 Nov 2009 16:26:57 +0900

Hi Rajsekhar,

Are that you want to ask a question the following cases?

   Before a router transmits Startup Query or retransmits
   Startup Query, a router receives General Query from Querier.

I think that it is not necessary to adopt to Startup-counter
immediately. (It is satisfactory even if it adopts, of course.)
This is a timing matter. If a router does not receive General
Query to this timing, this router will follow an own value.
This is not a problem. Rather, if it is important, the
administrator should set up a router correctly from the start.

Best Regards
--
Kiyoaki Kawaguchi

"rajasekar bonthala <[email-masked]>" wrote:

> _______________________________________________
> magma mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/magma
> 
> 
> 
> 
>

---

From: "K.Kawaguchi" <[email-masked]>
Date: Mon, 30 Nov 2009 16:26:57 +0900

Hi Rajsekhar,

Best Regards
--
Kiyoaki Kawaguchi